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Foreword

The Zen Cart Team met Goh Koon Hoek in late 2006 via an email asking if we would review the book he had
written about the program. As we each read our copy of the email the first question we all had was 'who?' Since those
first emails we have come to know and admire Koon Hoek ("KH" to his friends).

KH has been working in the IT industry for the last 7 years. His various roles as project leader, consultant,
programmer, software tester, and more have afforded him a broad range of knowledge and experience while enjoying
his own passion of using IT to help realize business objectives. He has now expanded his portfolio by becoming an
author as well.

He chanced upon Zen Cart (late 2005) while evaluating which shopping cart to install for a client. At that time, Zen
Cart was at v1.2.6d. He was impressed by  the clean code design and the number of features that came "out of the
box" in Zen Cart. Although there are other programs available in other languages, he felt it suited his client's
requirements best and set up the shop using it. As he became more familiar with it, he also fell in love with its
simplicity and power. KH had been 'Zenned' as we say on the support forum.

On New Year's Day 2006, his fiancée suggested he write a book on Zen Cart and use part of the proceeds to help the
Zen Cart Project. KH agreed it would be more effective than a single donation. Twenty percent of each book's profit
is donated to the Zen Cart Project. The ongoing income will help speed the code's progress and it will free some time
from answering the questions in the forums, but the biggest advantage to the Zen Cart community, is having a
comprehensive, written document that covers Zen Cart operations from start to finish.

A little over a year ago, this book was just an idea. It is now reality. We, the Zen Cart Development Team,
congratulate Goh Koon Hoek. The Zen Cart Team is proud of you and your "new baby". The book is everything we
hoped it would be. Clear, concise, easy to understand and most of all thorough. Thank you.

The Zen Cart Development Team
February 2007 
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Preface

Today, millions of people are already doing their shopping online. With the number of online shoppers set to explode
as Internet access becomes more affordable and Internet infrastructure more available to the masses, businesses
cannot afford not to have an online presence to cater to such demand.

Contrary to popular belief, you do not have to spend loads of money just to establish an online store. With this book,
you will learn how to use the free and open source Zen Cart software to start building and running your own online
store.

This practical book provides a step-by-step guide to on how to perform all the necessary tasks required to run an
online store. Many screen shots are also included to help reinforce your learning experience and help you visualize
the steps even when you are away from a computer.

Why This Book Was Written

This book serves to address two major concerns for store owners who are using Zen Cart to run their online stores.

Firstly, it goes into detail on how to set up a Zen Cart store on a reader's local computer. 

With this approach, store owners can familiarize themselves with the software before they start searching for a web
hosting provider and putting their store on the Internet.

Another advantage is that the local installation of Zen Cart is able to act as a test bed for store owners to try out
different ideas before they actually implement those ideas on their 'live' online store on the Internet. 

Secondly, this book acts as a form of structured documentation for Zen Cart. 

Now, anyone can start learning how to use this powerful piece of software in a structured manner and see how the
different pieces fit together. This “proactive” approach is in stark contrast to the “reactive” approach that current
users employ: asking questions in the forums, reading the Wiki or browsing the FAQs on Zen Cart's site.

Ultimately, store owners can save themselves the time, effort and headaches of sifting through the forums to look for
answers to most of their problems. The developers of Zen Cart can then have more time to continue enhancing this
wonderful software and not repeatedly answering the same questions that keep popping up ever so often on the
forums.

Audience

This book is aimed at anyone who wants to use Zen Cart to set up an online store to sell products or services. It is not
a book for programmers learning how to program Zen Cart!

It assumes you are comfortable with using a web browser (Internet Explorer, Mozilla Firefox, etc) and already
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familiar with your operating system (Windows XP, Mac OS X, etc). This would allow you to install and set up your
online store comfortably.

You should also be familiar with commonly used Internet terms like web server, web hosting provider, HTTP, FTP,
etc. Knowledge of programming languages like HTML, CSS and PHP is not strictly necessary but does allow you to
customize your store in greater detail. 

Finally, you need a large dose of patience and perseverance. Setting up an online store is relatively easy, but tailoring
it to suit your business requirements will require time and effort. 

How To Use This Book

This book covers Zen Cart version 1.3.7.1 which is the latest version at the time this book goes to print. 

This book is divided into 5 parts. If you are reading this book for the first time, you should go through the book in
sequence from Part 1 to Part 5. After that, you can jump around the different chapters to accomplish a specific task.

Part 1: Getting Started

Chapter 1, “Introduction to Zen Cart” - Introduces you to Zen Cart's history and features and why you should use
Zen Cart to set up your online store.

Chapter 2, “Installing Zen Cart on Your Local Machine” - Goes into details on how to install a Zen Cart store on
your local computer. All supporting software installation like Apache web server, MySQL database server, Mercury
mail server, etc, will also be covered.

Chapter 3, “Store Quick Tour” - Brings you on a quick tour of Zen Cart's Admin Console and Store Front interfaces.
Also covers the creation of sample data for use in later chapters.

Part 2: Setting Up Your Store

Chapter 4, “Email” - Shows you how to integrate Zen Cart to a mail server for sending emails. Also breaks down the
various email options into manageable sections for you to understand and configure.

Chapter 5, “Location” - Helps you understand and configure location-related information which will be used
throughout the online store.

Chapter 6, “Store Contact Information” - Shows you the different mediums in which your store contact information
will be displayed to customers; email, packing slips, invoices, etc.

Chapter 7, “Currency” - Covers how to setup multiple currencies and also how to update these currencies in real time
without you having to deal with exchange rates manually.

Chapter 8, “Weighting Unit” - Discusses how to change the unit of measure for weight.

Chapter 9, “Taxes” - Discusses the concepts behind sales tax configuration and then shows you how to set up sales
tax for any region. 

Chapter 10, “Shipping” - Discusses the various shipping concepts before going through the configuration of various
shipping options.
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Chapter 11, “Payment” - Goes through the configuration of various payment options.

Part 3: Managing Your Store Catalog

Chapter 12, “Categories, Product Types and Products” - Goes through the concepts of categories, product types and
products before using them to set up a proper online catalog for your goods.

Chapter 13, “Product Attributes” - Discusses how to add new attributes to your products and also how to tie pricing
and weighting information to these attributes.

Chapter 14, “Other Product Manipulation Techniques” - Shows you how to add multiple product images, make use
of sample clips for your goods, add downloadable products for sale, etc.

Chapter 15, “Order Totals, Surcharges and Discounts” - Discusses how order totals affect a customer's order pricing
during checkout. Also examines the different surcharges and discounts you can apply to specific goods, categories or
the entire store. 

Part 4: Customizing Your Store

Chapter 16, “Simple Customization” - Introduces you to the layout components in your Zen Cart store and shows you
how to customize your store's look mainly from your web browser.

Chapter 17, “Advanced Customization” - Explains how to use the Override System to make changes to your store.
You will also be shown how to change templates and add multiple language support to your store.

Part 5: Managing Your Store

Chapter 18, “Managing Customers” - Shows you how to manage common and individual customer information.

Chapter 19, “Managing Orders” - Covers how to deal with orders and understand the order statistics generated by
Zen Cart. Also shows you how to generate invoices and packing slips from the orders.

Chapter 20, “Managing Stock” - Discusses how to interpret and make use of stock-related information including
setting low-stock warnings and configuring low stock email alerts.

Chapter 21, “Marketing” - Discusses the use of various marketing techniques like discount vouchers, gift certificates,
newsletters, banners, etc, for attracting customers to your store and helping them with their purchasing decisions.

Chapter 22, “System Administration” - Covers the non-business related functions like backup, security, performance
and upgrades which ensure the smooth operation of your online store.

Appendixes

Appendix A, “Utility Software” - Covers the various computer programs like text editors, FTP programs and file
comparison programs that you will need to properly configure and customize Zen Cart.

Appendix B, “Setting Up Shop on the Internet” - Deals with the details of getting your Zen Cart store hosted on a
remote server on the Internet. 

Appendix C, “Test Account Information” - Consolidates all account information used throughout this book for easy
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reference.

Conventions Used

This book makes use of various typefaces and graphics to help you distinguish between regular text and what you see
on your screen.

Light Bold  type is used for words or objects on the screen that you are to do something with. For example, “Click on
Configuration > My Store to access general store settings.”.

Italic type is used for a word or phrase that is being defined or otherwise deserves special emphasis.

Monospaced Underline  type is used for text that you are to type from the keyboard. For example, enter false
into the Enable Images field.

Monospaced   type is used to illustrate directories or files on your OS. For example, the directory path
C:\apache\htdocs\store\docs holds documentation that comes with Zen Cart. 

File contents will be contained in blocks as shown below.

<html>
  <head><title>Greeting</title></head>
  <body><h1>Hello World</h1></body>
</html>

Examples are contained in blocks with shadows instead.

Area of Rectangle = Length x Breadth
Area of Triangle  = ½ x Length x Breadth

Furthermore, there are several graphic elements to bring your attention to specific items in the book.

Contacting Us

We want to know what we are doing right and how we can do better. So if you have any comments regarding this
book or wish to suggest other titles we should publish, please send an email to comments@cucumbermedia.com. 
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Part 1  Getting Started

This section introduces you to Zen Cart's history and features. Next, you will walk through how to
set up Zen Cart and all supporting software on your local machine. Finally, you will be
introduced to how a Zen Cart store functions and how to set up sample test data for use in the
later parts of the book.

This section covers the following topics:

● Introduction to Zen Cart

● Installing Zen Cart on Your Local Machine

● Store Quick Tour
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Chapter 1 Introduction to Zen Cart

What is Zen Cart?

Zen Cart (http://www.zen-cart.com) is a piece of shopping cart software that allows you to create an online, e-
commerce store for selling your goods and services. It is written in PHP and requires a MySQL database to work.
You can use Zen Cart to create an online store to sell physical goods like shoes, pianos or digital goods like gift
certificates, music downloads, etc. You can even sell services like insurance policies, IT support plans, etc.

The developers of Zen Cart have adopted the line, “The Art of E-Commerce”, as their goal when developing the
software. Hence, you will find that the software is designed to cater specifically to the requirements of store owners
and shoppers first. Store owners do not need an IT degree to set up and administer their web sites, and shoppers can
navigate the online store and check out their items easily. Programmers are also not forgotten, as the code for Zen
Cart is well-structured and well-designed for easy maintenance and custom logic.

Zen Cart comes absolutely free with many e-commerce features available out-of-the-box. Therefore, you do not have
to invest a lot of money to establish an online, robust and professional e-commerce presence. All you need is to pay
the web hosting fees and possibly some web design fees if you want to give your online store a more polished look.

The source code for Zen Cart is distributed under the GNU General Public License (GPL). In essence, this license
gives anyone the right to modify the source code to suit their needs. However, derivative works that modify the
source code have to adhere to certain restrictions if they are to be re-distributed. More information on the GNU GPL
can be found at http://www.fsf.org/licensing/licenses/gpl.html.

Features

Zen Cart has a wide user base and is currently deployed across many ‘live’ sites around the world. Due to input from
this user base and a very active forum, Zen Cart is able to offer many useful and robust e-commerce features out-of-
the-box. 

A list of the features that come with a default Zen Cart distribution is shown below.

Simple Web-Based Installation – Once you have the necessary supporting software (i.e. PHP and MySQL) ready,
installing Zen Cart is easily performed using a web browser. 

Supports Physical and Virtual Goods – Physical goods (computers, cars, flowers, etc) and virtual goods (digital
music, e-books, etc) can be sold. Product samples like brochures or music clips can also be provided together with
these goods.

Product Customization through Attributes – Product attributes can be added to further customize products. For
example, customers can specify the colors, size and wordings for T-shirts that are being sold.

Simple Checkout Process – Customer checkout is a simple three-step process which is designed to reduce the
occurrence of shopping cart abandonment. Customers only need to specify their shipping and billing information and
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26 e-Start Your Web Store with Zen Cart

then confirm their orders to complete the checkout.

Multiple Payment Options – Credit Card, Check/Money Orders, Cash-On-Delivery, PayPal and many other
payment options are supported by default. Payment options can also be enabled for customers based on their
locations.

Multiple Shipping Options – Flat Rate, Per Item, Free Shipping, UPS and many other shipping options are
supported by default. Shipping options can also be enabled for customers based on their locations.

Multiple Languages, Currencies and Taxes – To cater for customers from different geographical and cultural
backgrounds, additional currencies and languages can be defined to smoothen their shopping experience. Taxes are
calculated based on zone information and tax rates which store owners define.

Wide Array of Marketing Tools  – To help store owners promote their products and retain their customers, many
marketing tools like newsletters, product reviews, customer referrals, banners, etc  are available.

Advanced Pricing Options – Discounts based on store-wide, category-wide or product-specific selections are
possible. Surcharges can also be applied for customer orders below a certain amount, cash-on-delivery payment
options, etc.

Order Total Calculation  – Customers can choose to use discount coupons, gift certificates or their group discount
status to offset their order total amounts either partially or fully. 

Order Management – Store owners can easily manage orders by assigning order statuses to them. Customers can
then log in to their individual accounts to view the status of their orders. Invoices and delivery orders can also be
automatically generated by Zen Cart at the click of a button.

Custom Look-and-Feel – A store's look-and-feel can be dramatically modified just by modifying some CSS and
HTML. Maintenance efforts are also reduced with the use of the Override System in Zen Cart. Additional web pages
can also be easily added using the EZ-Pages feature.

The above features are only the tip of the iceberg when it comes to what Zen Cart can do for store owners. Additional
features that do not come bundled with the default Zen Cart distribution are easily downloaded from the Zen Cart site
and plugged-into an existing store. No programming experience is required to use these third-party downloads.

The list of third-party downloads can be accessed via the downloads area at Zen Cart's website.

History

Zen Cart was borne out of another shopping cart software known as osCommerce (http://www.oscommerce.com)
back in June 2003. Since then, it has undergone major code enhancements and several releases to make it stand out
from osCommerce and other e-commerce software.

Although anyone can contribute to Zen Cart's development, there is a group of core developers churning out the code
and ensuring the quality of the overall product. This team of developers include:

 Ian C Wilson (wilt) 
 Kim Elliott (Kim) 
 Steve Strassburg (Steve) 
 Linda McGrath (Ajeh) 
 Chris Brown (DrByte) 

Their nicknames are in brackets and you will usually encounter them in the forums where they can be seen answering
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 Chapter 1   Introduction to Zen Cart 27

questions on Zen Cart.

Support

If you are worried about the fact that Zen Cart does not offer any support because it is not commercial software, you
can put your mind at ease. The great number of Zen Cart users have given rise to a lively community of users who
include programmers, graphic designers and store owners. These people, and the developers of Zen Cart, provide an
excellent source of support for most of your queries. 

Before you consider seeking help from the community, do spend some time familiarizing yourself with Zen Cart's
site. If you are a non-English speaking user, you might even be able to locate a Zen Cart support site which is in your
native language. 

To help you seek help from the community more effectively, you might like to follow this approach when using Zen
Cart's site.

1. Check the tutorials/FAQ section to see if an answer already exists for a question you are about to ask.

2. Go to the Wiki section to find out if your area of concern has already been addressed in one of the write-ups.

3. Check the downloads section to see whether any of the third-party contributions like side-boxes, payment
and shipping modules serve your particular needs.

4. Finally, go to the Support Forum if you still do not find a satisfactory answer to your problems. Before you
post any queries, spend some time reading through other people's posts or simply do a search of the forums
to see if a question similar to yours might have been answered before. 

Finally, do consider donating to the project if the software has benefited you. It is a great way to give back to the
developers for all that they have done to build the software and to answer queries from users around the world.
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Chapter 2 Installing Zen Cart on

Your Local Machine

Overview

This chapter guides you through the process of installing Zen Cart on your local computer. This is not an easy
undertaking because Zen Cart is a web-based application which requires several other pieces of software to be
installed and configured properly beforehand.

If you already have a running Zen Cart installation either on your local machine or a remote server, you should still
quickly browse through this chapter. This is because some sample values created here will be used in our examples in
the following chapters.

Pre-Installation Requirements

Before you begin installing and configuring Zen Cart to run on your machine, you need to fulfill certain
requirements. These requirements are crucial to the success of your installation, so make sure you go through them.

Hardware Requirements

For your local machine, I would recommend at least 512MB of RAM to run all the server software (Apache,
MySQL, etc) and client applications (Web Browser, FTP application, etc). In addition, you may need to have a fast
CPU (at least 1GHz) since you will need all these applications to be running at the same time as well. 

If you are running Zen Cart on a remote server with a web hosting provider, you would need to gather some statistics
(server load at different times of the day, server hardware specifications, etc) before you decide on your hardware
requirements. 

Software Requirements

To install Zen Cart version 1.3.7.1, the following software is recommended:
 PHP (version 4.4.x or higher)
 Apache web server (version 1.3.x or 2.x)
 MySQL database server (version 3.2.x or 4.x.x)
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30 e-Start Your Web Store with Zen Cart

You will also need a Mail Server in order to send emails from within Zen Cart. 

For more information on the different server software versions that are compatible with different Zen Cart versions,
refer to http://www.zen-cart.com/wiki/index.php/Installation#Required.

Zen Cart is able to run on any operating system (OS) that supports the above software. The list of operating systems
would include Windows, Unix/Linux and Mac OS.

PHP

Web Address: http://www.php.net/

PHP is a programming language widely used for developing web-based applications. It is free and open source and is
one of the most popular computer languages with web developers because of its simplicity and power.

Zen Cart is written entirely in PHP but you do not need to know much about it to run your online store successfully.
All you need is some basic information (PHP version, PHP settings, etc) to help you troubleshoot any problems you
might face when running your online store.

Apache Web Server

Web Address: http://httpd.apache.org/

Because Zen Cart is a web-based application accessed via a web browser, you will need a web server to host your
application. Theoretically, you should be able to use any web server that supports PHP. However, most people run
PHP with Apache so I’d suggest you do the same. This will save you lots of time and frustration if you encounter set
up or performance problems because most people are familiar with Apache and should be able to answer any
questions you have relatively faster.

MySQL Database

Web Address: http://www.mysql.com/

Zen Cart uses a database to store all product, customer, order and configuration details. Currently, MySQL is the
only supported database. It is a robust and popular database; and is used to power high traffic sites like Yahoo
Finance and Google. 

The developers of Zen Cart have also begun work on supporting another open source database called PostgreSQL
(http://www.postgresql.org) although it is not supported at the moment. Do check with your web hosting provider on
whether they provide this database if you intend to use it as your Zen Cart database in future.

Mercury Mail Server (Optional)

Web Address: http://www.pmail.com/overviews/ovw_mercury.htm

A mail server (e.g. Microsoft Exchange) is used for sending and receiving emails. Many mail servers are available
for you to install and try out but we shall be using the Mercury Mail Server for this book. You can choose
not to install this mail server if you already have another mail server installed on your system or simply
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 Chapter 2   Installing Zen Cart on Your Local Machine 31

prefer another mail server you are more comfortable with. 

Other Installation Requirements

Before we begin, make sure you fulfill the following conditions:
 You have full administrative rights to your computer.
 You have control over your computer's firewall settings.
 You have a collection of software as outlined in Appendix A: “Utility Software”.

Understanding the Installation Setup

Before we begin the installation process, you need to understand how our local setup will be different from a remote
setup. This will help you understand the installation process better and allow you to picture how the different setup
elements fit together.

For simplicity's sake, we shall assume that all the necessary software required to run Zen Cart is bundled together on
a single machine. This is usually not the case in an actual deployment but you do not have to worry about it because
your web host will take care of that.

To show the different steps that take place when accessing a remote host versus a local machine, we shall use an
example of a customer trying to access a Zen Cart store via the Uniform Resource Locator (URL)  -
http://www.example.com/store.

Figure   2.1  : Zen Cart store located on the Internet  

In Figure 2.1, the Zen Cart store is located on a remote machine on the Internet. When the customer types the URL
into the web browser, the web browser has to fetch the IP address of the Zen Cart store from a Domain Name System
(DNS) server. Based on this address, the web browser will then access the online store which is running Zen Cart. 

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


32 e-Start Your Web Store with Zen Cart

Figure   2.2  : Zen Cart store located on a local PC  

In Figure 2.2, the Zen Cart store is located on a local machine. Instead of obtaining the IP address from the remote
DNS server, the web browser automatically looks for the Zen Cart store on our local machine. This is done by
specifying the IP address to point to our local machine via the use of a host file on your local machine. This little
trick makes use of the fact that computers will always look for an entry in the local host file before consulting the
DNS when looking up IP addresses. (Note: In computer networking, 127.0.0.1 is a standard IP address that a
computer uses to point to itself)

Once you understand the above differences between a local and remote setup, you can begin the installation process
in the following sections.

Using a Pre-Packaged Solution: XAMPP

Getting PHP, Apache and MySQL properly configured to work in harmony is no easy task. The different versions
and configuration possibilities can often cause problems during installation - even for seasoned developers.

To simplify our installation procedure, we shall be making use of a software package called XAMPP
(http://www.apachefriends.org/en/xampp.html) which is available for several operating systems. 

This package not only contains all the required software we need but has the added benefit that the different versions
of the software will work together. In addition, it also comes bundled with useful features like SSL support and a nice
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 Chapter 2   Installing Zen Cart on Your Local Machine 33

MySQL database management tool called phpMyAdmin (http://www.phpmyadmin.net/) which you might encounter
if you host your Zen Cart installation with a web hosting provider in future.

Currently, the highest version of XAMPP that is able to work with Zen Cart properly is version 1.4.16. This version
has a download size of 67.3 MB and when expanded will take up 163 MB of disk space. It contains the following
software:

 PHP 5.0.5
 Apache 2.0.54
 MySQL 4.1.14
 Mercury Mail Server 4.01a

Obtaining XAMPP

There are currently many versions of XAMPP available for download. Because Zen Cart officially works with
MySQL version 4.x, we will need to download an older copy of XAMPP instead of the latest one available.

Follow the steps below to download the correct version that will work with Zen Cart:

1. Go to the official site of XAMPP at http://www.apachefriends.org/en/xampp.html. 

2. Click on XAMPP for Windows , to access the page which provides all the information regarding the
windows version of XAMPP. 

3. Search for the Source Forge hyperlink and click on it to be redirected to another site which allows you to
download older XAMPP releases. 

4. Click on XAMPP Windows to access a page showing all the different release versions of XAMPP for the
Windows platform.

5. Click on 1.4.16 and a sub-menu of links should appear. This version of XAMPP contains the correct version
of software that can run Zen Cart.

6. Click on the xampp-win32-1.4.16-installer.exe hyperlink to begin downloading the software to your
machine.

Installing XAMPP

Before you begin installation:
 Make sure you do not have any previous copies of Apache, MySQL or Mercury Mail server installed on your

machine. Uninstall them if they are present. 
 The following ports in your computer's firewall may need to be enabled. Do not allow access to other

machines on the Internet unless you know what you are doing!
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34 e-Start Your Web Store with Zen Cart

Table 2.1: Ports used by various local server software

Port Protocol Software

80 HTTP Apache Web Server

3306 MySQL-specific MySQL Database Server

25 SMTP Mercury Mail Server

110 POP Mercury Mail Server

To begin installing XAMPP:

1. Double-click on xampp-win32-1.4.16-installer.exe to start the installation process.

2. In the Destination Folder field, choose a directory without any spaces or periods in its path (e.g.
C:\server\xampp) to install XAMPP before clicking Install .  

3. Click Yes if you are prompted to install XAMPP, Apache and MySQL as a Windows service. 

4. After installation completes, go to the directory where XAMPP is installed and you should see something
similar to the following directory structure.

5. Restart your computer. This step is optional but I usually do it to prevent any unexpected problems with
different versions of Windows.

To check whether XAMPP has been installed successfully:

1. From your Windows menu, click on Start > All Programs > apachefriends > xampp > CONTROL
XAMPP SERVER PANEL . This will bring up the XAMPP control panel as shown in the following screen
shot.
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 Chapter 2   Installing Zen Cart on Your Local Machine 35

2. Make sure all the services, except FileZilla, are running. If any of them are not running, click on the
respective Start buttons.  

If you are still unable to start the Apache service after several tries, make sure you shut down any other
application (e.g. Skype, Microsoft IIS, Windows Firewall) on your computer that is currently using or
blocking port 80.

3. Start your preferred web browser and type in the following URL - http://localhost. You should see something
similar to the following screen shot if everything goes well. 

4. Click on the English hyperlink and a screen similar to the following screen shot will be shown if XAMPP
has been successfully installed on your system.

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


36 e-Start Your Web Store with Zen Cart

Setting Up a Local Domain

Before we proceed any further, we need to first create a domain in your local machine. We need to do this because
when you experiment with Zen Cart later, you will not be allowed to specify email accounts with either “ localhost”
or an IP address as the domain. For example, “john@localhost” and “john@127.0.0.1” are not allowed as inputs into
Zen Cart.

Furthermore, a domain allows you to access your online store using a more realistic URL (e.g.
http:///www.example.com/store) instead of using the word “localhost” or an IP address (e.g. http://127.0.0.1/store or
http://localhost/store). It also adds a touch of realism to your mail server address. For example, using
“mail.example.com” instead of “localhost”.

For the rest of this book, we shall be making use of the domain “example.com”. This domain is actually used
specifically for documentation purposes and cannot be registered to anyone on the Internet.

If you type “http://www.example.com” into your web browser now, you will see something similar to the following
screen shot.
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 Chapter 2   Installing Zen Cart on Your Local Machine 37

To set up a domain in Windows XP:

1. Edit the file C:\WINDOWS\system32\dr ivers\etc\hosts with a text editor. Change the drive letter (C:)
to match your own computer setup. 

2. Add the following lines to the end of the file.

127.0.0.1       www.example.com     # For browser a ccess
127.0.0.1       mail.example.com    # For email acc ess
127.0.0.1       example.com         # For mercury m ail server

3. Remember to save the contents of the file.

You should now be able to use “localhost” and “www.example.com” interchangeably when accessing your web
server via a web browser. The “mail.example.com” domain will make more sense to you when you learn how to
configure Zen Cart to send emails in “Mail Server Settings” on page 72. The “example.com” domain will be used in
“Configuring Mercury” on page 38. 

Configuring Apache

We have to configure our local Apache to accept connections for any requests to the domain -
http://www.example.com, instead of allowing such connections to go through the Internet.

To configure Apache to use the new domain you created:

1. Edit the file <xampp-home>/apache/conf/httpd.conf with a text editor.

2. Delete and add the following line in the file.

ServerName   localhost:80     ServerName   www.example.com:80
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38 e-Start Your Web Store with Zen Cart

To test whether Apache has been configured properly:

1. Start your Apache service via the XAMPP Control Panel.

2. Use your web browser to point to http://www.example.com and you should be presented with the XAMPP
welcome screen if your configuration is successful.

Note that you are still able to access your server via the old URL of http://localhost.

Configuring Mercury

Now we have to make sure that all emails for the domain example.com will be handled by our mail server.

To configure your Mercury mail server to use the new domain:

1. Stop the Mercury mail server service via your XAMPP Control Panel.

2. Edit the file <xampp-home>/MercuryMail /MERCURY.INI with a text editor.

3. Delete and add the following lines in the file.

myname  localhost     # Canonical name for this server
myname  example.com   # Canonical name for this server

4. Add the following line just below the words “localhost.com : localhost.com” in the file.

example.com   :   example.com 

To test whether your Mercury mail server has been configured properly:

1. Start your Mercury service via your XAMPP Control Panel. Also make sure your Apache service is started.

2. Navigate to the URL http://www.example.com/xampp to open up your XAMPP page.

3. Click on the Mercury Mail  hyperlink on the left-panel. Your right-panel should refresh and appear
similar to the following screen shot.

4. Enter some values for the test email you want to send. You can make use of the following settings
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 Chapter 2   Installing Zen Cart on Your Local Machine 39

as an example.
 Sender – postmaster@example.com

 Recipient – admin@example.com

 Subject – Test Message

 Message – This is a test message .

5. Click on Abschicken to send your email. Note: “Abschicken” is the German translation for the English
word “Send”.

6. If all goes well, you should see a message telling you that the email has been successfully sent.

Preparing for Zen Cart Installation

Creating Your Store's Database

A database is used to store your configuration information during the installation process and also all your store's
settings, customer and product information, etc. Our database will be created in the MySQL database server which
we have installed when we installed XAMPP. 

To create a database:

1. Start up your XAMPP Control Panel and make sure all services are running. 

2. From your web browser, navigate to http://www.example.com/phpmyadmin. 

3. Type the name of the database you want to use for your Zen Cart installation into the Create new database
field. For example, type zencart . 

4. Leave the other settings at their default values and click on Create to create a new database.

5. After your installation completes, you should see a screen similar to the following screen shot. Notice that
your newly created database is shown on the drop-down list box on the left panel. 
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40 e-Start Your Web Store with Zen Cart

Keep in mind what you have specified for your database name in Step 3. You can refer to Appendix C “Database
Account” on page 390 for the default settings used in this book.

Enabling cURL support in PHP

cURL is a set of functions that allow programs to communicate with many different types of servers using different
types of protocols. We shall not go into the technical details of how cURL functions are used by PHP but you need to
know that cURL is used by certain shipping and payment modules in Zen Cart to connect to external sites to send or
retrieve information. 

If cURL is not enabled in your PHP configuration, Zen Cart will display a warning message complaining about the
fact. To enable cURL support in your PHP configuration for your local XAMPP server, edit the file <xampp-

home>/apache/bin/php.ini and remove the semicolon in front of the words “extension=php_curl.dll” as shown
in the following code snippet. Restart the Apache service in your XAMPP Control Panel after making your changes. 

;extension=php_curl.dll
extension=php_curl.dll

Creating Test Email Accounts

Several email accounts will now be created in our mail server. These email accounts will be used later for simulating
the store owner and test customers.

To add email accounts to your Mercury mail server:

1. Start up your XAMPP Control Panel and make sure the Mercury Mail Server service is started.

2. Click on the Admin  button next to the Mercury  field in your XAMPP Control Panel to bring up the Mercury
mail server management window. 

To arrange your windows nicely, click on the menu item Window > Tile. 
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 Chapter 2   Installing Zen Cart on Your Local Machine 41

3. Choose Configuration > Manage local users from the menu as shown in the preceding screen shot. You
should be presented with a dialog box showing the current users present in your mail server. 

4. Click on Add to bring up a dialog box for you to enter the details of the email accounts you wish to create.

5. Refer to “Email Accounts” on page 389 for a list of email accounts you need to use for the examples in this
book.

6. Enter information only for the fields: Username, Personal name and Mail password for each individual.

7. Click OK  after adding an email account and you will be presented with the same dialog box you encountered
in Step 3.
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42 e-Start Your Web Store with Zen Cart

8. Repeat the process from Step 4 onwards for the other email accounts.

9. After you have completed adding all the email accounts, you should have something similar to the following
screen shot. 

Configuring Your Email Client 

We need to configure an email client (or reader) to send and receive emails via the Mercury mail server we
configured. For our example, we shall be using the open source and freely available Mozilla Thunderbird as our
email client. It is available at http://www.mozilla.com/thunderbird.

The latest version of Thunderbird available at the time of printing of this book is Thunderbird 2.0.0.6. I'll assume you
have no problems downloading, installing and starting up Thunderbird so we'll start our configuration immediately.

Before you begin adding email accounts to Thunderbird, start your Mercury mail server via your XAMPP Control
Panel.

To add an email account to Thunderbird:

1. Start up Thunderbird and choose File > New > Account from the main menu to bring up the Account Wizard
dialog box.
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 Chapter 2   Installing Zen Cart on Your Local Machine 43

2. Choose Email account from the list of account types and click Next > to proceed to the next screen. You
should see a screen similar to the following screen shot.

3. Enter the values according to the email accounts you created in the previous section. For example:
 Your Name – Claud Blanc
 Email Address – storekeeper@example.com

Click on Next > to proceed to the next screen to enter your mail server information.

4. Leave the radio button set at POP although Mercury Mail Server is able to support IMAP as well. Enter
mail.example.com  for the Incoming Server field and un-check the field Use Global Inbox (store mail
in Local Folders). If this is the first time you are creating an account in your Thunderbird software, you will
notice an Outgoing Server field in the Account Wizard dialog box. You can choose to enter localhost  or
mail.example.com  for that field. Click on Next > to proceed to the next screen.
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44 e-Start Your Web Store with Zen Cart

5. Enter the Mercury email account user name into the Incoming User Name field. If this is the first time you
are creating an email account, you will also have to enter an email account for the Outgoing User Name
field. Click on Next > to proceed to the next screen.

6. Enter anything you would like to identify this email account in the Account Name field. I would recommend
you stick to the default offered by Thunderbird because it is easier to differentiate between the several email
accounts you will need to create as you begin adding more test customers to your store. Click on Next > to
proceed to the next screen.
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 Chapter 2   Installing Zen Cart on Your Local Machine 45

7. Check the box Download messages now and click Finish to complete the email account creation.
Thunderbird should prompt you to enter your password for the newly created email account as it needs to
connect to the Mercury mail server to retrieve all email messages for the account.

8. Once your account is created, you should be able to see it on the left-panel of Thunderbird.

Repeat the above process for all other email accounts you have created in your email server.

To test whether your email accounts are configured successfully, try sending some emails between the different
email accounts. 

Installing Zen Cart

Installation of Zen Cart will be performed via a web browser. 

Pre-Installation Activities

To download and prepare the Zen Cart directory for installation:

1. Go to Zen Cart’s home page at http://www.zen-cart.com.

2. Click on the Download NOW! hyperlink on the right-side of the screen and you will be redirected to another
website (SourceForge) to download your Zen Cart installation files.
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46 e-Start Your Web Store with Zen Cart

3. Click on zen-cart-v1.3.7.1-full-patched-07052007.zip. Follow the instructions to begin downloading the
copy of Zen Cart that is used with this book.

4. You should end up with the file, zen-cart-v1.3.7.1-ful l -patched-07052007.zip, on your machine.

5. Unpack the downloaded file to the <xampp-home>/htdocs  directory on your machine. You should end
up with the following directory <xampp-home>/htdocs/zen-cart-v1.3.7.1-ful l -

patched-07052007 . 

6. Rename the directory from zen-cart-v1.3.7.1-ful l -patched-07052007  to store or shop . In this
way, we can use the following URL to access our store http://www.example.com/store or
http://www.example.com/shop. Although you can rename the Zen Cart directory to anything, we shall
assume you have used store  for the rest of this book. You should have a directory structure similar to the
following screen shot.

Performing the Installation

Before you begin installation, make sure you have started all your services via the XAMPP Control Panel.

To begin installation of Zen Cart:

1. From your web browser, navigate to the URL you specified in the previous section. For example –
http://www.example.com/store. You should reach the Welcome screen of Zen Cart's installer.
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 Chapter 2   Installing Zen Cart on Your Local Machine 47

2. Click on Continue to proceed to the License screen.

Agree to the license by clicking on the relevant radio button.

3. Click on Continue to proceed to the Prerequisites screen.
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48 e-Start Your Web Store with Zen Cart

Make sure that the PHP cURL Support field shows up as ON. If this is not the case, refer to “Enabling cURL
support in PHP” on page 40 to turn on cURL support in your PHP setup.

4. Click on Install  to proceed to the System Setup screen.

Accept the default settings as they are automatically picked up by Zen Cart. 

5. Click on Save System Settings to proceed to the phpBB Setup screen.
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 Chapter 2   Installing Zen Cart on Your Local Machine 49

phpBB (http://www.phpbb.com) is a separate piece of software for running online bulletin boards. The
software is being developed separately by another group of developers unrelated to the Zen Cart project and
will not be covered in this book. Therefore, make sure the radio button is left at NO.

6. Click on Save phpBB Settings to proceed to the Database Setup screen.

Enter the name of the database you created in “Creating Your Store's Database” on page 39 in the Database
Name field. Leave the Database Username and Database Password field at their default values which will
coincide with that of XAMPP's MySQL settings. Optionally, specify a value for the Store Identifier (Table
Prefix) field as shown in the screen shot.

Warning: If you are installing Zen Cart on a remote server, never leave your Database Password field
empty! 

7. Click on Save Database Settings and a screen will appear showing the progress of data population in your
database.
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50 e-Start Your Web Store with Zen Cart

8. The Store Setup screen will automatically appear after database setup completes.

The examples in our book uses the following values for the respective fields on the screen.
 Store Name - Mega Store
 Store Owner – Claud Blanc  
 Store Owner Email – storekeeper@example.com  
 Store Demo - NO 

Leave the rest of the fields at their default values. 

Note: Do consider installing another store with the demo data populated (Store Demo – Yes) after going
through this book. The demo store contains many product/feature configuration possibilities, some of which
may not be covered in this book. 

To create another store, just rename the Zen Cart folder to something other than the one you used for creating
this store. For example, use “demo” instead of “store”. Another thing is to remember to use a unique value
for the Database Identifier (Table-Prefix) field you specified in Step 6.

9. Click on Save Store Settings to proceed to the Admin Setup screen.
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 Chapter 2   Installing Zen Cart on Your Local Machine 51

The values appearing in the Administrator Information section of the screen shot are taken from “Zen Cart
Administrator Account” on page 390. 

10. Click on Save Admin Settings to complete your installation.

You can click on either buttons at the bottom of the screen to visit your online store but you will receive an
error from Zen Cart complaining about file permissions. Continue on to the next section to solve this
problem.
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52 e-Start Your Web Store with Zen Cart

Post-Installation Activities

After installation completes, you will need to do some file system clean up for security purposes.

To prevent Zen Cart from complaining about file permissions when you access your online store, you need to set the
permission of the following files to read-only.

 <zc-home>/includes/configure.php
 <zc-home>/admin/ includes/configure.php

For Windows users, just right-click on the above-mentioned files to bring up a context menu. Select Properties from
the context menu and then click the Read-only check-box from the dialog box. 

You also need to rename or delete the <zc-home>/zc_instal l directory. To prevent hackers from wiping out your
store's database, delete the directory if your Zen Cart store is located on a “live” server. 

Checking Your Installation

From your web browser, navigate to the following web address – http://www.example.com/store. You should see
something similar to the following screen if your installation is successful.

Applying Bug Fixes

Some minor bugs have have been reported since the release of version 1.3.7.1 of Zen Cart. Make sure you subscribe
to the Bug Reports forum at Zen Cart's web site for more details on those bugs and the fixes you can apply.
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 Chapter 2   Installing Zen Cart on Your Local Machine 53

Summary

You should now be familiar with how Zen Cart can be installed on your local machine. This will help you to
troubleshoot problems when you decide to host your site on a remote server. We will be making use of the
information contained in this chapter, so do remember to take note of the following points:

 Know how to start all services via the XAMPP Control Panel.
 Remember the Zen Cart administrator account settings you have configured.
 Remember the URL you should use to access your store.
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Chapter 3 Store Quick Tour

Introduction

A Zen Cart store is segmented into two different access areas. Site visitors and customers access the Store Front to
do their shopping or manage their personal accounts. Store owners (also known as administrators) access the Admin
Console to add products to the store's catalog and configure other business rules.

The Store Front

The Store Front acts as the front-end to your store and is where your customers go to perform their shopping
activities. A sample customized Store Front is shown in the following screen shot.

55
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56 e-Start Your Web Store with Zen Cart

A Typical Shopping Flow

To help you understand how Zen Cart works, we shall go through a typical set of activities that customers perform
when doing their online shopping. This entire process constitutes a workflow and enables you to visualize which part
of your store will be affected when you start configuring your own online store. For simplicity's sake, the illustrated
workflow is shown in sequence. In actual fact, customers can opt to skip to certain pages without having to follow
the sequence. Store owners can also alter the standard shopping flow to suit their business needs as we will learn in
“Altering the Shopping Flow” on page 264.

An explanation of the different steps in the illustrated shopping flow is shown in the following table.

Table 3.1: Explanation of each step in the shopping flow   (continued)

Step Explanation

1 A customer learns about your site through a marketing campaign (Search Engine, Gift
Certificate, etc) you have implemented. She picks up your site's web address and types it into
her web browser to reach your Store Front. The first page she encounters is known as the Home
Page (which is also known as the Index Page or Main Page).

The customer browses through your store's products via the Categories side-box. If your store
sells documents, she may see a Documents side-box as well. Optionally, she can perform a
search for a product she is interested in.

An example of a Home Page was shown in the first screen shot in this chapter.

Figure   3.1  : A typical shopping flow  
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 Chapter 3   Store Quick Tour 57

Table 3.1: Explanation of each step in the shopping flow   (continued)

Step Explanation

2 As the customer clicks through the list of products, she will ultimately reach the Product Info
page which details the price, weight, discounts and any other information related to the product.

Once she decides to purchase the product, she enters the desired quantity into the “Add to Cart”
text box and then clicks the “add this to my cart” button to proceed to the Shopping Cart page.

3 On the Shopping Cart page, the number of items that the customer has purchased and the price
breakdown for all items will be displayed. Products can be removed and the quantity of items
changed by clicking the relevant icons on the screen. 

Once the customer is satisfied with her purchase, she can click the “go to checkout” button to
begin the checkout process.
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Table 3.1: Explanation of each step in the shopping flow   (continued)

Step Explanation

4 Before the customer enters the checkout process, she will be redirected to the Login page if she
has not logged in to her account. If she does not have an account, she will need to sign up for an
account at the same page. 

Zen Cart is smart enough to make sure that items in the customer's shopping cart will not be lost
even if she transitions from an anonymous visitor to a logged in customer.

5 Once the customer is logged in, she will automatically be redirected to the Delivery Information
page.

The customer will choose her desired shipping option and confirm her delivery addresses. After
making her selection, she will click on the “continue checkout” button to proceed to the
Payment Information page.
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Table 3.1: Explanation of each step in the shopping flow   (continued)

Step Explanation

6 At the Payment Information page, the customer will choose her desired payment option and
confirm her billing addresses. 

The customer can also use the monetary values contained in her discount coupons or gift
certificates to offset a portion of the order amount. After she is satisfied with her selection, she
will click on the “continue checkout” button to proceed to the Order Confirmation page.
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Table 3.1: Explanation of each step in the shopping flow   (continued)

Step Explanation

7 At the Order Confirmation page, all applicable costs (shipping charges, sales taxes, etc) for the
customer's order are tallied and displayed. Previously selected values for the Delivery
Information page and Payment Information page will also be displayed.

Once the customer is satisfied with the details of her order, she will click on the “confirm the
order” button. After the order is processed by Zen Cart (send out order confirmation emails, set
order status to Pending, save order in database, etc), the customer will be redirected to the
Checkout Success page. 
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Table 3.1: Explanation of each step in the shopping flow   (continued)

Step Explanation

8 At the Checkout Success Page,  the customer will be given an opportunity to opt-in to receive
any email updates for the products she just purchased. 

If the customer has purchased gift certificates from your store or received gift certificates from
her friends, the balance in her gift certificate account will also be displayed. This brings an end
to the shopping flow.

Optionally, if the customer wants to view her order history, she can click the My Account
hyperlink to proceed to the My Account Information page.

9 At the My Account Information page, the customer will be able to view her order history and
check on each order status.
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Setting Up a Test Customer

We shall now set up a test customer account in your online store. With this test customer, you will be able to
experience the impact of your store settings which we will learn to configure from the next chapter onwards.

1. Go to your Store Front and click on the Log In hyperlink at the top of the page.

2. You should be presented with a screen for you to log in or sign up for a new account. Concentrate on the
sign-up portion of the screen as shown in the following screen shot.

3. Enter the values for your test customer account. You can make use of the values in the following table and
leave the other fields at their default values.

Field Value

Mr. Ms. Mr.

First Name Jacques

Last Name Pires

Street Address 200, rue de Tolbiac 

City Paris

State/Province Paris

Post/Zip Code 75015 

Country France

Telephone (33)-01-40-80-82-11

Date of Birth 05/21/1970

Email Address jacques@example.com

Password abcdef

Confirm Password abcdef

4. Click on submit once all the relevant data has been entered. The test customer will be created and
automatically logged in to his account.
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5. Click on the Log Out hyperlink at the top of the page to log the test customer out of his account.

If you would like to set up other test customer accounts as we go through the book, you can refer to “Zen Cart
Customer Test Accounts” on page 390 for a list of account credentials which you can use.

The Admin Console

The Admin Console acts as the back-end to your store and is where you will spend most of your time looking
through orders, adding shipping and payment options, and configuring discounts, etc. 

The web address of your local Zen Cart store is http://www.example.com/store/admin. To log in to your Admin
Console, use the values you entered for the Administrator Username and Administrator's Password fields which
you entered in the Admin Setup screen on page 51.

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


64 e-Start Your Web Store with Zen Cart

Moving Around The Admin Console

To navigate around the different areas in the Admin Console, hover over the menu entries at the top of your screen
and click on a selected sub-menu entry. For example, to access the Currencies screen, click on Localization >
Currencies.

We shall cover the various areas in the Admin Console as we work through this book. For this chapter, we shall
concentrate only on the Categories/Products screen because we need to create some test products for use later.

To access the Categories/Products screen, click on Catalog > Categories/Products and you should see a screen
similar to the following screen shot if you have products defined in your store catalog. Pay attention to the different
areas highlighted as it helps you understand the screen elements better.

Icon buttons are used throughout the Admin Console. Red and green icon buttons that appear under a Status column
allow you to quickly enable or disable an entry. Clicking on other icons will direct you to other screens for you to
further customize the selected item. 

Setting Up Test Products

We shall now set up some test products in your online store. Although you may not understand some of the fields as
we start creating the products, do not worry as we will cover these fields in greater depth in a later chapter.

Before we can create any test products, we need to create a category to hold our test products. To create a test
category:

1. Click on Catalog > Categories/Products to access the Categories/Products screen. If you have no products
in your store, your screen should look like the following screen shot.

Current
Category

Screen
Name

Click to
toggle status
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2. Click on the new category button to bring up the next screen where you can specify your category details.
Enter the following values for the respective fields on the screen. Ignore all other fields.

Field Value

Category Name Test

Categories Description To hold all test products for our testing purposes.

Sort Order 0

3. Click save after you have entered the relevant fields. You will be redirected back to the Categories/Products
screen which will now contain your newly created category.

Now that we have created our category, we shall begin adding our test products.

Normal Test Product

This product shall be used for testing multiple scenarios (shipping modules, payment modules, sales taxes, etc) in our
store. 

To create a Normal Test Product:

1. Click on the “Test” folder icon in your Categories/Products screen and you should see the following screen.

2. Select Product  -  General   from the drop-down list box and then click on the new product button to bring
up the next screen where you can specify your product details. 

3. Enter the following values for the respective fields on the screen. Ignore all other fields.
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66 e-Start Your Web Store with Zen Cart

Field Value

Products Name Normal Test Product

Tax Class Taxable Goods

Products Price (Net) 200.00

Products Description A generic test product that can be used for many scenarios.

Products Quantity 1000

Products Shipping Weight 0.2

Sort Order 0

4. Click preview after you have entered the values for the relevant fields and you will see the following screen
which shows you all the data you have previously entered.

5. Click insert to create your product. You will be redirected back to the “Categories/Products – Test” screen
which will contain your newly created product.

Free Test Product with Free Shipping

This product is used to test a particular payment module which we will cover later. A free product in Zen Cart has to
be specifically marked as “Product is Free”. If you specify the product as $0.00, Zen Cart will not automatically
recognize the product as a free product although customers do not have to pay for the product in both instances.

To create a “Free Test Product with Free Shipping” product, follow the same steps when creating the “Normal Test
Product” but specify the following values instead when you reach Step 3.
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Field Value

Products Name Free Test Product with Free Shipping

Product is Free Yes

Tax Class -- none --

Always Free Shipping Yes, Always Free Shipping

Products Description For testing the Payment Module - The Zen Cart FREE CHARGE CARD.

Products Quantity 1000

Products Shipping Weight 0.2

Sort Order 1

Ignore all warning messages when previewing your product as they only serve to ensure that you have configured
your settings correctly. After your product is created, your “Categories/Products – Test” screen will contain the “Free
Test Product with Free Shipping” product as shown in the following screen shot.

Summary

You should now have a better picture of how customers perform their shopping activities and the various screens
involved. With this mental picture, you should find the configurations for your store much easier to understand. The
test customer account and test products that you have configured in this chapter will come in handy when you begin
testing out your store configurations.
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Part 2  Setting Up Your Store

This section shows you how to set up the business infrastructure for your online store. It helps
you define all the necessary settings you need to make before you can start adding products to
your catalog and welcoming customers to your store.

This section covers the following topics:

● Email

● Location

● Store Contact Information

● Currency

● Weighting Unit

● Taxes

● Payment

● Shipping
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Chapter 4 Email

Introduction

Email is the main communication channel used by your store. It can be configured to notify customers of  their order
statuses, to notify you of different conditions (e.g. low stock level) in your store, and also as part of your marketing
campaign (e.g. newsletters). 

In this chapter, we shall:
 Learn how to set up Zen Cart to send emails.
 Specify the recipients for different email notifications.
 Cover miscellaneous email options.
 Learn how to customize your email message templates.

The Email Options Screen

All email configurations in Zen Cart, except for email templates, are configured via the E-Mail Options screen. To
access the E-Mail Options screen, click on Configuration > E-Mail Options . A screen shot of an E-Mail Options
screen is shown on the following page.

The large number of settings in the E-Mail Options screen may make the screen overwhelming at first sight. Do not
worry about it as you will find that the settings can be broadly categorized as follows:

 Mail server settings.
 Message recipients.
 Other email settings. 

We will be using the above categorization to explain the different fields on the screen.

71
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72 e-Start Your Web Store with Zen Cart

Enabling Email Sending

Before Zen Cart can send emails, you need to enable this capability. Many people forget this important point and end
up wasting a lot of time troubleshooting why their emails are not sent even though all their settings are otherwise
correct. 

To enable Zen Cart to send emails, make sure that the Send E-Mails field in the E-Mail Options screen is set to
true .

Mail Server Settings

Besides enabling the sending of emails, Zen Cart needs to connect to a mail server in order to send emails. To specify
the connection settings to a mail server, concentrate on the following fields on the E-Mail Options screen.
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 Chapter 4   Email 73

Table 4.1: Explanation of mail server settings

Title Meaning

E-Mail Transport Method The method that is used to connect to a mail server. Check with your
web host if you are unsure which method to use.

On Windows/Mac platforms, this is usually smtp  or smtpauth .
On Unix/Linux platforms, this is usually sendmail ,  sendmail
-f  or Qmail . 

The default value PHP uses PHP's “mail()” function to send emails.
It allows Zen Cart to use whatever mail-sending method that is
already configured by your web hosting provider on the server
hosting your store. In many cases, this may be the best option.

SMTP Email Account Mailbox This is the user name that is used to log in to the email account on
the mail server. 

Required if E-Mail Transport Method  value is smtpauth . In
some cases, may also be required if using smtp .

SMTP Email Account Password This is the password that is used to log in to the email account on the
mail server. 

Required if E-Mail Transport Method  value is smtpauth . In
some cases, may also be required if using smtp .

SMTP Email Mail Host This is either the domain or IP address of the mail server. 

Required if E-Mail Transport Method  is set to smtp  or
smtpauth .

SMTP Email Mail Server Port This is the mail server port which Zen Cart will connect to when
sending out emails. The usual value is 25 .

Required if E-Mail Transport Method  is set to smtp  or
smtpauth .

Use the settings in the following table to specify the mail server settings for your local Zen Cart store to connect to
the local Mercury mail server you created in Chapter 2.
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Table 4.2: Local Mercury mail server settings

Title Value

E-Mail Transport Method smtp

SMTP Email Account Mailbox <leave blank>

SMTP Email Account Password <leave blank>

SMTP Email Mail Host mail.example.com

SMTP Email Mail Server Port 25

To test whether your mail server settings can work with Zen Cart, send an email to the test customer you created in
the previous chapter. To send an email from the Admin Console, click on Tools > Send Email and then fill in the
details in that screen to send your test email. After the test email is sent, use your mail client (e.g. Thunderbird) to
retrieve the test email from the test customer's email account.

If you encounter any problems sending emails, make sure you check that your mail server is already started before
checking the rest of your mail server settings. If the problem persists or is more complicated, refer to http://www.zen-
cart.com/wiki/index.php/Troubleshoot_-_Email_Problems for a discussion on the possible solutions before you post
on Zen Cart's forum.

Message Recipients

Zen Cart is able to automatically send carbon copy (cc) or low stock emails to your designated recipients whenever
an email is sent from your online store. Most emails are sent when a customer takes a specific action (e.g. signs up
for an account) or when the system detects an extraordinary condition (e.g. a low stock level). 

Note that you can set multiple recipients for each email notification by using a comma and a space as the separator
for multiple email addresses as shown in the following example:

Jacques <jacques@example.com>, Nicole <nicole@examp le.com>, Alan <alan@example.com>

To specify the recipients of different emails sent by Zen Cart, concentrate on the following fields in the E-Mail
Options screen. 

Table 4.3: Explanation of email notification settings   (continued)

Title Meaning

E-Mail Address (Displayed to Contact you) Displayed in email messages that customers receive.
Used as a means for customers to contact you if they
have any questions.

Refer to Figure 4.1 on page 77 to see the location of
this field in an email.
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Table 4.3: Explanation of email notification settings   (continued)

Title Meaning

E-Mail Address (sent FROM) Displayed in email messages that customers receive
so they know who sent them the relevant emails.

Refer to Figure 4.1 on page 77 to see the location of
this field in an email.

Send Copy of Order Confirmation Emails To Specifies the CC recipient(s) for the order
confirmation email that a customer receives after
completing the checkout process.

Send Copy of Create Accounts Emails To – Status Enables the sending of CC emails for the following
field.

Send Copy of Create Accounts Emails To Specifies the CC recipient(s) for the welcome email
which a customer receives on signing up with your
store.

Send Copy of Tell a Friend Emails To – Status Enables the sending of CC emails for the following
field.

Send Copy of Tell a Friend Emails To Specifies the CC recipient(s) for an email which a
customer sends to another person to comment about
your store.

Send Copy of Customer GV Send Emails To – Status Enables the sending of CC emails for the following
field.

Send Copy of Customer GV Send Emails To Specifies the CC recipient(s) for an email
(containing the Gift Certificate amount) which a
customer sends to another person.

Send Copy of Admin GV Mail Emails To – Status Enables the sending of CC emails for the following
field.

Send Copy of Customer Admin GV Mail Emails To Specifies the CC recipient(s) for an email
(containing the Gift Certificate amount) which the
store owner send to his/her customers.

Send Copy of Admin Discount Coupon Mail Emails To –
Status

Enables the sending of CC emails for the following
field.

Send Copy of Customer Admin Discount Coupon Mail
Emails To

Specifies the CC recipient(s) for an email
(containing the Discount Coupon amount) which the
store owner sends to his/her customers.
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Table 4.3: Explanation of email notification settings   (continued)

Title Meaning

Send Copy of Admin Orders Status Emails To - Status Enables the sending of CC emails for the following
field.

Send Copy of Admin Orders Status Emails To Specifies the CC recipient(s) that should receive a
copy of the updated order status emails sent to a
customer.

Send Notice of Pending Reviews Emails To - Status Enables the sending of emails for the following
field.

Send Notice of Pending Reviews Emails To Specifies the recipient(s) for an email which
indicates that a new product review by a customer is
ready for  moderation.

Send Low Stock Emails Enables the sending of emails for the following
field.

Send Low Stock Emails To Specifies the recipient(s) for an email which
indicates that a product's stock level has fallen below
a threshold level.

A sample email that a customer receives on signing up with your store is shown in the following screen shot. It
clarifies the difference between the Email Address (Sent FROM) field and the Email Address (Displayed to
Contact you) field. Although the email addresses are the same in the screen shot, they can be different for your
situation.
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Other Email Options

We shall now touch upon other email options that do not fall into the above two categories but are also contained in
the Email Options screen. Refer to the following table for explanations of these options.

Table 4.4: Explanation of other email settings   (continued)

Title Meaning

E-Mail Linefeeds Specifies what character(s) should be used to terminate a line in email
messages. On a Windows machine, a line feed is specified via a carriage return
(CR) followed by a line feed (LF) which results in a “CRLF”. For a Unix/Linux
machine, it is specified as a “LF”. You can set this to CRLF if your website is
running on a Windows server.

Figure   4.1  : Sample email message received by a customer  

Email Address 
(Displayed to 
Contact you)

Email Address 
(Sent FROM)
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Table 4.4: Explanation of other email settings   (continued)

Title Meaning

Use MIME HTML
When Sending Emails

If set to false , emails can only be composed in TEXT format. All customers
will receive TEXT emails regardless of the email format they choose to receive
from your store.

If set to true , emails can be composed in both TEXT and HTML formats and
is thus the recommended value.

Verify Email
Addresses Through
DNS

It checks whether the domain of outgoing email addresses actually exists before
sending out emails. For example, if someone signs up with an account of
“ tom@dinerdelights.com”, this setting will check whether “dinerdelights.com”
actually exists. 

This option may or may not appear in your screen as it is supposed to be hidden
as of Zen Cart version 1.3.6. Set this to false  if it appears because this feature
is currently not implemented in Zen Cart.

Email Archiving
Active?

Allows you to keep copies of sent emails in your store's database. You might
need to set this to true  to comply with your country’s laws. However, this can
take up a lot of disk space and become a performance problem. Recommended
value for testing purposes is true .

E-Mail Friendly-Errors If set to true , an easier to understand error message will be displayed when
sending of emails fail. If set to false , PHP errors which are not easily
understood will be shown instead.

Do not rely on this setting to determine whether email messages have been sent.
It is better that you CC yourself a copy of an email when you send out email
messages to your customers. 

Emails must send from
known domain? 

Some mail servers require that a valid email address from a known domain (e.g.
example.com) be used for the FROM field when sending out an email. If you
set this field to Yes, Zen Cart will disregard any other email address you use
which is not from the recognized domain (e.g. experiment.org). Instead, Zen
Cart will use the E-Mail Address (sent FROM) field to send the email.

Note: For store owners who choose to use Gmail for the E-Mail Address (sent
FROM)  field, it is recommended to set this field to No.

Email Admin Format? Indicates whether email messages carbon copied (cc) to store owners should be
in plain-text format or HTML format.
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Table 4.4: Explanation of other email settings   (continued)

Title Meaning

Set "Contact Us"
Email Dropdown List 

If this field is left blank, all emails sent via the Contact Us page will be sent to
the email address you configured in E-Mail Address (sent FROM) field.

If this field is not empty, customers can direct their emails to specific parties in
your store by choosing from a drop-down list box. Refer to “The Contact Us
Page” on page 92 to see a screen shot of how the list of email recipients will
appear if this field is not empty.

When adding email addresses to this field, make sure that the angle brackets are
included as well. An example value would be Store Owner
<storekeeper@example.com> .  Remember to use the format shown on
page 74 if you intend to specify multiple recipients for this field.

Allow Guest To Tell A
Friend 

Specifies whether visitors to your store are allowed to send emails to other
people commenting on what they see in your store. You should go through the
“Tell-a-Friend” section on page 341 if you intend to set this field to true .

Contact Us - Show
Store Name and
Address 

Toggles the display of your store's contact information in the Contact Us page.

Your store's contact information is taken from the Store Address and Phone
field found under Configuration > My Store. Refer to “The Contact Us Page”
on page 92 to see a screen shot of where this information is displayed. 

Display "Newsletter
Unsubscribe" Link? 

If enabled, the Information side-box in your Store Front will display a
Newsletter Unsubscribe hyperlink.

Audience-Select Count
Display 

This setting only affects the screens in the Admin Console. If enabled, the
number of email recipients in each mailing group will be displayed. To see an
example of the number of customers displayed in each mailing group, click on
Tools > Send Email and look at the Customer field.

If this setting is set to true , the display of admin email pages may slow down
on large or poorly tuned servers due to the extra database work to calculate the
relevant numbers.

Convert currencies for
Text emails 

When you compose TEXT emails, you are not able to specify certain currency
symbols properly. For example, the English Pound (£) or the Euro (€ ). Zen Cart
is able to help you overcome this problem by letting you use a replacement text
(e.g. &euro; ) that will automatically help you do the conversion to the
appropriate symbol (e.g. € ). 

Customizing Email Messages

To look at a sample email that customers receive when signing up for an account with your store, click on Tools >
Email Welcome. Besides the plain-text email shown in the following screen shot, you may see an HTML email if
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80 e-Start Your Web Store with Zen Cart

you have set the Use MIME HTML When Sending Emails field in the E-Mail Options screen to true .

You cannot make any changes to the sample email from the Admin Console. In fact, to customize the text in any
emails, you should go through the “The Template Override System” section on page 270 before returning to this
page because that section shows you how to utilize the Override System to edit files properly and also covers some of
the terminology we shall be using in this section.

Understanding How Email Messages Are Formed

Each email sent from Zen Cart is actually constructed from several components. These components include the
various “define( )” statements in the many possible language files in your store, the data stored in your database, the
email layout templates, etc. To visualize all these components, we shall use the preceding Welcome Email sample
screen shot together with the following explanations to give you a rough idea how an email is constructed before
being delivered.

The structure of an email is taken from one of the email template files located under the <zc-home>/emai l

directory. For the Welcome Email, it is the file <zc-home>/email /email_template_welcome.html. If you
open up that file and look at the contents, you will see something similar to the following snippet of code.

  <div class="content">
    <div class="content-line">$EMAIL_GREETING</div>
    <div class="content-line">$EMAIL_WELCOME</div>

Text preceded by a dollar sign are known as template tags. The HTML source code in the file gives HTML emails
their structure. The template tags are placeholders for static custom text taken from “define( )” statements contained
in various language files, database values for settings you configured for your store, and dynamic content generated
by Zen Cart.

To understand how template tags act as placeholders for content, open up the file <zc-
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 Chapter 4   Email 81

home>/includes/ languages/engl ish/create_account.php and you should see something similar to the
following snippet of code.

 
define('EMAIL_WELCOME', 'We wish to welcome you to <strong>' . STORE_NAME .
'</strong>.');
 

Notice that the words EMAIL_WELCOME  in the “define( )” statement actually corresponds to the template tag
$EMAIL_WELCOME  in the email template file. Another thing you will notice is that the words We wish to
welcome you to corresponds exactly with the third sentence in the sample Welcome Email screen shot. The word
STORE_NAME is a variable that holds the value for the Store Name field found under Configuration > My Store.
This value is taken from the database although it is configured in the Admin Console. 

We shall not talk about dynamic content generated from Zen Cart for template tags because it requires knowledge of
PHP's syntax to understand the logic behind how dynamic content is generated for a particular situation. In any case,
you will seldom need to change those dynamic content generation code.

So how do you get plain-text emails since only HTML email layout templates are available? Well, the answer is Zen
Cart retains all the values taken from template tags and just strips away all HTML and CSS codes from an email
layout template before sending out the relevant plain-text emails.

If you have Zen Cart installed on your local machine, you can learn more about email message templates by opening
up the file <zc-home>/docs/4.readme_html_emai l_templates.html .

Changing Text In Emails

From our discussion in the previous section, you can see that the only thing that you are likely to customize besides
the various store settings is the “define( )” text found in various language files. Store settings are covered throughout
the book so there is no point talking about them here. Instead, we will show you how to locate the necessary
language files holding the “define( )” text you want to change.

To locate and edit a “define( )” text:

1. Look at a copy of an email containing some text you want to change.

2. Look at the names and contents of the various files under the <zc-home>/emai l directory and you should
be able to identify the email layout template containing the “define( )” text you need to change.

3. Identify the template tag in the email layout template that is likely to contain the “define( )” text you need to
change. For example, $EMAIL_WELCOME .

4. Go to your Admin Console and click Tools > Developers Tool Kit to access the Developers Tool Kit screen.
This screen allows you to look for text appearing in certain files used by Zen Cart.
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82 e-Start Your Web Store with Zen Cart

5. Enter the template text (without the dollar sign) you identified in Step 3 into the first text box under the Key
or Name field on the screen. For example, enter EMAIL_WELCOME.

6. Experiment with the values in the adjacent drop-down list box to specify the search scope. For example,
choose All Current Selected Language Files .

7. Click search to begin the search. 

8. After some time, you screen should refresh with search results displayed on top of your screen. If something
is found, you will see something like the following screen shot. 

9. Based on the file name and line number of the file(s) found, use the Override System to change the custom
text accordingly.

Summary

Email is the communications lifeline for any e-commerce store. Thus, we have covered the meanings of every email
setting available in Zen Cart to allow you to troubleshoot most problems you might experience in your own online
store. Armed with this knowledge, you should be able to set up your email preferences confidently.
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Chapter 5 Location

Introduction

Location plays a very important role in the correct functioning of your store. It affects how your shipping, payment
and tax rules will be applied based on the supplied geographical information from your customers and your store.

In this chapter, we shall:
 Understand  how the different pieces of location information (i.e. Countries, Zones and Zone Definitions) are

used together to determine the taxes, shipping and payment charges that a customer incurs.
 Configure Countries information.
 Configure Zones information.
 Configure Zone Definitions information.
 Specify your Store Location.

Understanding the Use of Location Information

In Zen Cart, location information is divided into the following categories:
 Countries 
 Zones 
 Zone Definitions 

Countries is self-explanatory. Zones allow you to segregate a country into different areas. For example, you might
use zones to specify states for America, provinces for China, etc. Zone definitions, on the other hand, allow you to
segregate different geographical areas according to how you conduct business. Thus, you can have a zone definition
that spans several countries or several states.

To appreciate the relationship between Countries, Zones and Zone Definitions, consider the case where you run your
business in England and you have recently set up an online shop to sell vintage guitars. Since your shop is online and
caters to customers from all over the world, you will have to consider the impact of taxes, shipping and payment
charges that apply to each customer.

If you expect the bulk of your customers to come from the United States, you might want to provide overnight FedEx
delivery only to this set of customers to entice them to buy from you. In that case, you might want to use zones in
Zen Cart to represent the states in the United States. You would then set up a shipping zone definition which
encompasses all these zones of the United States. When you configure your Shipping options, you can then choose to
have the FedEx option show up only when customers are from the shipping zone definition you created. 

Similarly, you can set up a payment zone definition to support customers in certain regions where you want to offer a
specific Payment option. For example, you can offer a Credit Card payment option only to customers in the United
Kingdom and United States. Customers who belong to other geographic locations will not be able to see this option
as a result.

Finally, you can also set up a tax zone definition to encompass the different counties that make up the United

83
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84 e-Start Your Web Store with Zen Cart

Kingdom so that you can apply a suitable Value Added Tax to charge customers from this region.

The above example is rather complex but it does give you an idea of how Zen Cart provides the flexibility for you to
specify the settings you want. Don't worry if you do not get the full picture now because we will be going through
this topic again in later chapters. For the next few sections in this chapter, we shall look at how to configure these
individual pieces of location information.

Countries

By default, Zen Cart comes with a complete set of countries in your database. You will not need to add any more
countries unless there are major political upheavals in certain parts of the world. However, you might want to
consider removing some of the countries which you do not intend to or cannot support. 

For example, if your store location is in the United States and you sell hardware with strong encryption software, you
are unlikely to be allowed to export your hardware to certain countries which the United States deem to have terrorist
links. In that case, you might want to remove those countries from the list of countries available in Zen Cart.

To manage the countries in your online store, click on Location/Taxes > Countries to access the Countries screen. 

The options to add, update or remove countries in your store are very obvious from the screen and also quite self-
explanatory. However, you do need to take note of the following two points while making your changes.

 ISO Country Codes.
 Address Formats in Each Country.

When you click on the edit button next to a country in the Countries screen, you will see a side-panel similar to the
following screen shot. We shall use this screen shot to discuss the above two points.
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 Chapter 5   Location 85

ISO Country Codes 

Zen Cart uses both the ISO Code (2) and ISO Code (3) fields to represent different countries in its database as seen
in the preceding screen shot. These are internationally recognized abbreviations of country codes according to the
ISO-3166 standard. This standard defines both two-letter and three-letters codes for different countries in the world. 

The list of country codes can be found at http://www.unicode.org/onlinedat/countries.html. Make sure you refer to
this list when adding or updating country codes in Zen Cart.

Address Formats Used in Different Countries

Each country in the world defines a fixed format for the addresses in their respective countries. This address format is
available via the post office of each country. 

Zen Cart comes with a default of six address formats which are used to format the addresses contained in your
invoices, packing slips, etc, when you send goods to other countries. 

As seen in the preceding screen shot, only the Address Format field is shown but not the exact pattern of the address
format. Therefore, you will need to rely on the following table to understand which option to choose for the Address
Format field. Note that the example addresses shown are purely fictitious and used only for illustration purposes.

Table 5.1: Address format patterns used in Zen Cart    (continued)

Address
Format

Pattern Default Countries
Affected

Address Format Examples

1 $firstname $lastname
$streets
$city, $postcode
$statecomma$country

All other countries not
stated below.

James Logan
496 Victoria Street 
Sydney, 2010
New South Wales, Australia

2 $firstname $lastname
$streets
$city, $state   $postcode
$country

United States John Doe
123 Magnolia Street
Dallas, TX   55803-0034
United States
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86 e-Start Your Web Store with Zen Cart

Table 5.1: Address format patterns used in Zen Cart    (continued)

Address
Format

Pattern Default Countries
Affected

Address Format Examples

3 $firstname $lastname
$streets
$city
$postcode - $statecomma$country

Spain Martina Gonzalez
General Castanos, 86 
Barcelona
08003 – Barcelona, Spain

Note: Assumes both city and
state are “Barcelona”. Although
Spain uses the term “province”
instead of “state”.

4 $firstname $lastname
$streets
$city ($postcode)
$country

Singapore John Low
16 Whampoa Drive
Singapore (260042)
Singapore

5 $firstname $lastname
$streets
$postcode $city
$country

Austria, Germany Heidi Kohler
Lentzeallee 194 
14195 Berlin
Germany

6 $firstname $lastname
$streets
$city
$state
$postcode
$country

United Kingdom James Watson
1 St. Georges Business Centre
Portsmouth
Portsmouth
PO1 3AX
United Kingdom

Note: Assumes both city and
state are “Portsmouth”. 

Zones

In Zen Cart, Zones are defined as geographical regions within a country. Zen Cart comes with a default set of zones
configured for the following countries: Australia, Austria, Canada, Germany, Palau, Spain, Switzerland and United
States. 

Purpose of Zones

To understand the purpose of Zones, let us first look at what happens when a customer signs up for an account with
your store. We shall assume you have set the State/Province field to be displayed as a drop-down list box in your
Sign Up page. For more information on how to configure the look of the State/Province field on the Sign Up page in
your Store Front, refer to step 3 on page 290. 
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 Chapter 5   Location 87

If customers come from a country that does not have any Zones configured in Zen Cart, they will have to manually
enter a value in the State/Province field. On the other hand, customers who come from a country with Zones defined
in Zen Cart can choose the required information from the State/Province field's drop-down list box instead.

So why does Zen Cart want to enforce this rule of restricting the State/Province information for countries that have
Zones configured in Zen Cart's database? The answer is because Zen Cart may need to make use of this information
to allow you to fine-tune your shipping, payment and tax charges. For example, you can apply different sales tax
rates based on whether the shipping addresses of customers fall within certain Zones.

Adding a Zone

To add a zone to a country:

1. Click on Location/Taxes > Zones to access the Zones screen.

2. Click on new zone and concentrate on the side-panel.

3. Enter the name of a state or province in the relevant country into the Zone Name field. Alternatively, if your

State/Province is 
selected from a list

State/Province is 
entered manually
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88 e-Start Your Web Store with Zen Cart

country does not have a state or province defined, you can use any logical grouping you can think of that will
make sense to customers from that country.

4. Enter the code representing the state or province into the Zone Code field. For example, the United States
uses “TX” to represent the state of Texas in that country. If your country does not have such a definition or
you are using a logical grouping, you can use the same value as the one used for the Zone Name field.

5. Choose the country containing the zone you want to define from the Country  field.

6. Click insert to save the zone to the database. 

Zone Definitions

A Zone Definition is a logical grouping of zones. You may need to create separate zone definitions for payment,
shipping or tax purposes. Additionally, discount coupons usage can also be restricted based on which zones your
customers' billing addresses fall under.

Purpose of Zone Definitions

When you add a shipping option, payment option, sales tax rate or discount coupon in your store, you have the option
of selecting a Zone Definition to link to it. This Zone Definition allows you to restrict a shipping or payment option
only to customers from a specific area in the world. Similarly, you can use a Zone Definition to specify a specific tax
rate for customers from a specific location in the world.

A Zone Definition is a logical grouping of Zones. A Zone Definition can cover a small area such as a State in a
country (e.g. Paris) or several countries in a federation (e.g. European Union). It all depends on what you want to
achieve with the Zone Definition. 

For example, if your business operates in the European Union (EU) and your store is required to collect Value Added
Tax (VAT), you may want to create a Zone Definition for all countries in the EU. This is because VAT is collected
only for customers in the EU. You can then specify a tax rate that applies to all the EU countries uniformly.
Similarly, you can create a Zone Definition which contains your local state only. You can then offer free shipping to
those customers from your local state only.

Ultimately, you have to understand your own business needs before you can set up a zone definition.

Adding a Zone Definition

To add a zone definition:

1. Click on Location/Taxes > Zone Definitions to access the Zone Definitions screen.

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


 Chapter 5   Location 89

2. Click on insert and concentrate on the side-panel.

3. Enter the relevant information and click insert to save your changes to the database. You will be redirected
back to the Zone Definitions screen, but with your changes shown instead.

4. Select the zone definition you created in the above step and click details in the side-panel to proceed to the
next screen showing you all the sub-zones belonging to the selected zone definition.

5. Click on insert and concentrate on the side-panel with the heading “New Sub Zone”.

6. Choose the relevant information and then click insert to save your changes. Note that the Zone field is
dynamically populated with information after you have selected a particular country from the Country  field.

7. Repeat Steps 5 and 6 to continue adding more sub-zones.

8. Click back after you have finished specifying all your sub-zones.

Specifying Your Store Location

We have postponed the discussion of setting your store location until now because you need to have the proper
country and zone information set up in your store before you can configure this setting.
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90 e-Start Your Web Store with Zen Cart

Although you have a virtual online store, you still need to provide Zen Cart with details of where you are located.
This is because Zen Cart may need this information to determine how certain charges are to be calculated. For
example, you can specify that shipping tax and product tax be calculated based on your store location (see “Basis for
Tax Calculation” on page 108 for details). 

To specify your store location, click on Configuration > My Store to access the My Store screen and change the
following fields accordingly.

 Country  
 Zone 

Make sure that you specify the Country  field first then the Zone field. Values in the Zone drop-down list box are
populated based on the Country  specified.

Summary

Location information provides the basis for you to specify shipping, payment and tax rules. Although they are easy to
setup, they are not easy to understand. Therefore, you have to think through your business needs and plan properly
before specifying this information. 

A slight misconfiguration here and it could affect the charges that a customer should pay for your product or service;
ultimately it might hurt your revenue and possibly your reputation. Make sure you test your shipping, payment and
tax settings thoroughly, with test customers from different geographical regions.
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Chapter 6 Store Contact

Information

Introduction

Research has shown that customers prefer to deal with businesses that display their contact information prominently.
This gives them the impression that the business is legitimate and they will have a response if something goes wrong
with their orders.

In this chapter, we shall:
 Specify your store contact information.
 See how your store information is displayed in your online store.
 See how your store information is displayed in printable documents generated by your store.
 See how your store information is displayed in emails sent to customers.

Specifying Store Contact Information

To specify your store's contact information for online and printed documents: 

1. Click on Configuration > My Store to access the My Store screen. 

91
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92 e-Start Your Web Store with Zen Cart

2. Edit the Store Address and Phone field and concentrate on the side-panel.

The information displayed in the side-panel corresponds to the values you entered in the Store Address field
in Step 8 of Zen Cart's installation as shown in the screen shot on page 50. Any information entered here is
used purely for display purposes and has no effect on shipping options, payment options or tax calculations.
The default text (as shown above) gives you an idea of the information you might want to make available to
your customers. You should consider adding any pertinent information (fax numbers, pager numbers, etc) for
your business here as well.

Store Contact Information Displayed Online

Your store contact information is available in the following places online:
 Contact Us page.
 Order Confirmation page if Check/Money Order payment option chosen by customer.

The Contact Us Page

To view your store's contact information in the Contact Us page, go to your Store Front and click on Contact Us
from the Information side-box.

Store Contact Information

Appears only if the field,
Set “Contact Us” Email Dropdown List,
in Configuration > E-Mail Options
is not empty.
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 Chapter 6   Store Contact Information 93

If you do not see your store's contact information displayed on the top-left corner of the screen, click on
Configuration > E-Mail Options  and check that the Contact Us - Show Store Name and Address field is enabled. 

The Order Confirmation Page

If customers have chosen the Check/Money Order payment option when checking out their purchases, they will see
your store's contact information displayed under the Mail your payment to section in their Order Confirmation
screens. 

Store Contact Information Displayed in Printable Documents

Your store's contact information will also appear in the following printable documents – invoices and packing slips.
These documents can then be printed and sent together with your goods when preparing your orders. More
information on how to generate these documents will be covered in a later chapter . For now, just concentrate on the
display of your store's contact information.

Invoices

Your store contact information will be displayed on the top-left corner of an invoice.

Packing Slips

Similarly, your store contact information will also be displayed on the top-left corner of a packing slip.
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94 e-Start Your Web Store with Zen Cart

Store Information Appearing in Emails

Unlike the information displayed in online and printed documents, contact information presented in emails sent out
from your store will only contain the store name and store owner's name as shown in the following sample screen
shot.

To change the contact information displayed in emails, click on Configuration > My Store and edit the following
fields.

 Store Name
 Store Owner

Notice that the values for the preceding fields correspond to the values you entered in the Store Name and Store
Owner fields in Step 8 of Zen Cart's installation as shown in the screen shot on page 50.

Store Name

Store Owner Name
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 Chapter 6   Store Contact Information 95

Summary

Your contact information is available through several mediums: online store, printed documents and in emails.
Always keep your contact information updated as it is important for the image and credibility of your business. 
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Chapter 7 Currency

Introduction

Zen Cart provides you with the ability to configure your store to accept multiple currencies. Customers can then
switch to their desired currency when they view product prices via the Currencies side-box in your Store Front. 

By offering customers the ability to switch to their desired currencies when viewing product prices, you aid them in
their buying decisions since they do not need to perform any manual or mental exchange rate conversions. 

In this chapter, we shall:
 Add new currencies to your Zen Cart store.
 Update currency exchange rates in real-time.
 Specify the default currency for your store.

The Currencies Screen

All currency configurations in Zen Cart are configured via the Currencies screen. To access this screen, click on
Localization > Currencies. 

The default currency used in a store is the US dollar. The important point you need to take note is that the default
currency (US dollar) has a value of 1.00000000 . All other currencies will be relative to this currency when
specifying the exchange rate. 

Depending on your situation, you may not want to specify 1.00000000  as the value for your default currency. For
example, if your default currency is the Indonesian Rupiah, you might want to specify 100.00000000  as the value
instead.
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98 e-Start Your Web Store with Zen Cart

 Tip If you intend to accept online payments via a payment gateway  (e.g.
PayPal, 2CheckOut, etc), check whether these payment gateways are able
to accept the currency you specify in your Zen Cart store.

Adding a New Currency

To add a new currency:

1. Click on new currency in the Currencies screen to bring up the following side-panel.

2. An explanation of the different fields on the screen is shown in the following table. Go through them before
you start setting their values in your screen.

Property Meaning

Title You can assign any name you like to a currency. This should, however, be intuitive because
it is displayed in the Currencies side-box in your Store Front. 

Code This represents an abbreviated code assigned to a currency. You should use a currency code
that conforms to the ISO 4217 standard which is available from
http://www.iso.org/iso/en/prods-services/popstds/currencycodeslist.html.

If you use a currency code that is not in the ISO 4217 list, you might have problems doing a
real-time update of the exchange rate later.

Symbol Left The symbol that will appear on the left-side of a currency value. For example, in the case of
US dollars, the symbol will appear as a ($) sign on the left of the amount 17.99 as $17.99.

Symbol Right The symbol that appears on the right-side of a currency value. For example, in the case of
Euros, the symbol would appear as a (EUR) sign on the right of the amount 17.99 as
17.99EUR. 

Note: You can display a Euro sign (€) in your browser by specifying &euro;  for this field,
However, the symbol might not be displayed properly in all browsers because it is still
considered a relatively new currency and requires that the symbol exists on the customer's
operating system.
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 Chapter 7   Currency 99

Property Meaning

Decimal Point This is a separator to indicate hundredths of the currency. For example, $100.99 has a “.” as
a separator.

Thousands
Point

This is a separator before each thousand. For example, $1,000,000 has a “,” as a thousand
separator.

Decimal Places Specifies the number of decimals you want for a particular currency. For example, if a
product costs ten dollars and you specify 2 decimal places for this field, then the price of
that product will appear as $10.00.

Value Specifies the exchange rate relative to the default currency. If you are not sure, you can
leave this field blank. You can update exchange rates in real-time after a currency is
created.

3. Check the Set as default (requires a manual update of currency values) option if you intend to set your
new currency as the default currency.

4. Click insert to save your changes to the database.

Updating Exchange Rates in Real-Time

If you want your currencies to be updated with the latest exchange rates, you just need to click on the update
currencies button in the Currencies screen. Zen Cart will immediately fetch the latest exchange rates from
http://www.oanda.com. If this site is down or the exchange rates you specified is not available there, Zen Cart will
automatically switch to another currency exchange site (http://www.xe.com) to retrieve the required exchange rates.
Once the exchange rates are updated, messages will be displayed at the top of your screen.

Using the Currency Conversion Ratio to Achieve Realistic Exchange Rates

If you were to visit the aforementioned currency exchange sites and compare the rates displayed online with the
exchange rates displayed in Zen Cart, you may notice a discrepancy between the two sets of values. This discrepancy
is caused by the Currency Conversion Ratio field which is accessible via Configuration > My Store.
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100 e-Start Your Web Store with Zen Cart

Because the actual exchange rates retrieved from the currency exchange sites assume forex transactions in very large
amounts, they are not realistic for most businesses. To alleviate this situation, Zen Cart first multiplies a retrieved
exchange rate with the value of the Currency Conversion Ratio before updating the affected currency's exchange
rate in your store's database.

The default value for the Currency Conversion Ratio field is 1.05 . This ratio may not be appropriate for your area,
always check the exchange rates available at your local banks or money changers and adjust the field accordingly.

Configuring the Displayed Default Currency

Whenever visitors arrive at your site, the default currency will be displayed in the Currencies side-box. If your store
supports only English, the default currency displayed in the Currencies side-box in your Store Front, will be the
default currency you specified in the Currencies screen of the Admin Console. However, if your store supports
multiple languages, the default currency displayed in the Currencies side-box can either be the default currency
specified in the Currencies screen of the Admin Console or another currency associated with the language the visitor
is using to view your store. 

Before we discuss how to specify the default currency for a store that supports multiple languages, you need to know
what is the default currency associated with a language pack. We shall term the default currency associated with a
language pack as the native currency for that language. For example, the French language pack will have a file <zc-

home>/includes/ languages/french.php. If you view the contents of that file, you will find the following
piece of code.

define('LANGUAGE_CURRENCY', 'EUR');

This means the native currency for the French language is the Euro (EUR). This currency must be defined in the
Currencies screen of your Admin Console. Similarly, other language packs will have their native currency defined in
a file <zc-home>/includes/ languages/<language>.php .

A store that supports multiple languages can choose to have the default currency in the Currencies side-box  in your
Store Front displayed in the following ways:
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 Chapter 7   Currency 101

 Always use the default currency specified in the Currencies screen of the Admin Console regardless of the
language chosen by a customer in the Store Front.

To achieve this, click on Configuration > My Store and set the Switch to Default Language Currency
field to false .

 Switch to the native currency of the particular language that a customer has chosen in the Store Front.

To achieve this, click on Configuration > My Store and set the Switch to Default Language Currency
field to true .

Summary

You have seen how you can easily support multiple currencies in your store. Although exchange rates can easily be
updated in real-time, you need discipline to constantly update your currency exchange rates to reflect current market
conditions. You have also learned how to properly configure the default currency to be displayed to customers
viewing your store in different languages.
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Chapter 8 Weighting Unit

Introduction

An often overlooked point for most store owners when setting up their stores is the issue of which unit of measure to
use for weight. For simplicity's sake, we shall refer to the unit of measure for weight as “weighting unit” for the rest
of this book.

The default weighting unit in Zen Cart is the pound (lb). This weighting unit is used in countries that follow the
Imperial system of measurements. For countries that follow the Metric system, they would be more accustomed to
the kilogram (kg) instead. Whatever the case, Zen Cart offers much more flexibility than that to specify your
weighting unit. You can use anything to identify your weighting unit. For example, carat, stone, horse, rock, etc.
Why is that so? Because to Zen Cart, the weighting unit is just a “label”!

The weighting unit issue is an abstract concept for most new store owners so we will examine it closely. Whenever a
weight is specified, two things need to be mentioned: weighting unit and weightage. For example, 5 kgs of flour or
10 lbs of pork. When you learn to create products in your store, you will only be asked to key in the weightage.
When a product's weight is displayed, Zen Cart automatically puts the weighting unit and weightage information
together so the weight makes sense to customers. That is why you can customize the weighting unit to anything you
want in Zen Cart. 

Note that the weighting unit you decide to use is applied globally throughout the store. You cannot mix multiple
weighting units. For example, specifying the weighting unit of product X in kilograms and the weighting unit of
product Y in grams.

Implications of Changing the Weighting Unit

Although the weighting unit is used purely as a label for display in your store, when it comes to shipping your goods
you will most likely need to take into account the real weighting unit that needs to be used. Some shipping modules
expect the weight to be expressed in a certain weighting unit. For example, the United States Postal Service (USPS)
shipping module expect weight to be in pounds (lbs) and no other weighting unit. If you need to use the USPS or any
other shipping module that expects weight to be in pounds, my advice would be not to customize the weighting unit.

If you already have products in your store created with pounds as the weighting unit, then changing your weighting
unit may also be a concern. This is because when you specified the weightage (e.g. 20) for your products, you had
the intention of using pounds (lbs). If you change the weighting later to kilogram (kgs), your products will not
display weight correctly. For example, a product will now display “20 kgs” instead of  “20 lbs” previously. Making
the required manual changes is a simple task if you have very few products but it can be very tedious changing an
entire catalog with thousands of products.
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104 e-Start Your Web Store with Zen Cart

Changing the Weighting Unit

Changing the weighting unit to anything other than the default pound (lb) is not a trivial task. For readers who are
new to Zen Cart, you should skip this chapter and come back to it after you have gone through the rest of the book.
You would then be in a better position to decide whether you want to perform any weighting unit customizations;
and if you do, you can easily change the weightage for the few example products that are in your store and also edit
all affected files properly using the Override System.

There are two steps to perform in order to change the default weighting unit used in your store. 

1. Search for source files that have weighting unit information contained in them 

2. Apply the changes to these files.

Step 1 of 2: Search for Files to Change

As mentioned earlier, the default weighting unit in Zen Cart is the pound. This unit is represented as either “lb” or
“lbs”. Therefore to change the weight unit, you will have to search for these values and replace them with your own
weighting unit; e.g. “kg” or “kgs”.

To search for files containing the value “lb”, “lb(s)” or “lbs”:

1. Click on Tools > Developers Tool Kit to access the Developers Tool Kit screen. This screen is helpful in
locating any text contained within the physical files that make up your Zen Cart store.

2. Concentrate on the Look-up in all files portion of the screen.

3. Type the weighting unit which you would like to replace into the Key or Name field. For example, type lb .

4. Choose All Files – Catalog/Admin  from the All Files Look-ups field to maximize your search
scope.
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 Chapter 8   Weighting Unit 105

5. Click search and a list of files containing the keyword you typed in Step 3 will be displayed at the top of the
screen if the search was successful. 

6. Take down the names of the files and their line numbers as you will need to edit these files later. Ignore those
files that contain words that match your keyword but are not related to weighting unit. For example,
“callback” contains the keyword “lb” but is not related to weight.

7. Repeat your search for the weighting unit you want to change with other forms of the previous keyword you
typed in Step 3. For example, type lbs  or lb(s) . 

As you can see in Step 6, it can be very tedious to single out files that contain the weighting unit you want to change.
You need to be patient and thorough or else you may encounter strange problems later on. For example, a certain
screen may display weight in “kgs” but another screen in your store may display the same weight in “lbs”.

Step 2 of 2: Edit the Relevant Files

After you have consolidated all the file names containing the weighting unit you want to change, you need to edit the
relevant files and change the weighting unit contained in them. You have two options for changing the contents of
those affected files:

 Use Zen Cart’s Override System to edit the relevant files. This is the preferred way and is covered in “The
Template Override System” on page 270.

 Directly edit the relevant files. Back up those files which cannot be overridden using Zen Cart's Override
System.

Whatever option you choose, make sure you use a proper text editor when editing the contents of any file. Refer to
“Text Editors” on page 379 for more information on choosing a text editor.

Since the editing of file contents only involves a straightforward search and replace for the relevant keywords, we
will not discuss it further here. Just be careful not to accidentally replace keywords that may be embedded in other
words.

Summary

As you have just seen, it is not easy to change the unit of measure for weight without touching a lot of files. To
compound the problem, some shipping modules (e.g. USPS) require that a specific unit of measure for weight (e.g.
lb) is used. Thus, you should consider carefully whether you really need to change the unit of measure for weight.
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Chapter 9 Taxes

Introduction

Taxes are a part and parcel of everyday life. If you run a business, you would most likely have to deal with sales
taxes. Sales taxes are taxes levied on consumption of goods and/or services and are a form of indirect taxation which
is different from income tax. In Zen Cart, sales taxes can be applied to shipping as well as to goods and/or services. 

Sales taxes vary across different countries and sometimes even across states within a country. What's more, you
could have different tax rates apply to different classes of goods. Sales taxes can even be compounded. That means
you might have to charge an assortment of taxes on even a single item you will be selling in your store! 

Indeed, the topic of taxation is a complex and wide-ranging one. Since you are planning on setting up your online
store to conduct business, do check with your accountant on how taxation works for your line of business.

In this chapter, we shall:
 Understand how the different elements of Zen Cart are used to configure tax rates.
 Decide on the basis of your sales tax collection.
 See the impact of different settings on the display of tax-related prices.
 Add a tax class.
 Add a tax rate.
 Understand the impact of customer zone information on tax calculation.

Understanding How Taxes are Configured

Before you start configuring taxes in Zen Cart, you need to have an overall picture of how Zen Cart implements tax
calculations. Let us use an example of an online store that sells guitars and is located and registered in Australia. The
tax setup for the store is shown in the following illustration and will be used to explain the concept of tax
configuration in Zen Cart.
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108 e-Start Your Web Store with Zen Cart

Figure   9.1  : Tax configuration overview  

Looking at Figure 9.1, the different components of Zen Cart (i.e. Zone, Zone Definition, Tax Class, Tax Rate) used
to calculate the tax charged on goods sold by the store are shown in bold whereas example values for each
component are shown in italics.

Zone Definitions and Zones are used to identify the geographical regions where a tax rate should apply.

A Tax Class allows different products to be separated into different groups so that each group can be taxed at a
different rate. For example, if Item A is to be taxed at 5% while Item B is non-taxable, you can set up two different
tax classes (i.e. Taxable Goods and Non-Taxable Goods ) to hold each item. 

A Tax Rate defines the percentage of a product's retail price or shipping charges that should be collected as sales tax.
It ties together the information you have defined for a Zone Definition and a Tax Class to trigger the collection of a
sales tax.

After looking at the building blocks of tax calculation above, we can now interpret the tax setup in the preceding
illustration as follows: customers from the relevant Zones (i.e. Queensland, Victoria and New South Wales) in a
Zone Definition (i.e.the country of Australia) who purchase goods (of Tax Class “Taxable Goods”) will be liable to
pay sales taxes (at a rate of 10%) on those goods.

Zen Cart gives you a lot more flexibility than the simple illustration we have just seen. For example, you could
specify that the tax calculation be based on store location instead of shipping address. You can also specify whether
different tax rates should be added or compounded (Federal Taxes added to State Taxes, etc). We shall cover all
these different permutations in the rest of this chapter.

Basis for Tax Calculation

Usually, sales tax is collected based on a customer's shipping addresses when a purchase is made. However, there
may be times where a store owner would like to have the sales tax calculated based on the store address or a
customer's billing address instead.

Zone (New South Wales)

Zone (Victoria) Tax Class
(Taxable Goods)

Tax Rate

(Goods and 
Services Tax 

@ 10%)

Zone (Queensland)

Zone Definition
 (Australia)
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 Chapter 9   Taxes 109

To specify the basis for sales tax calculation:

1. Click on Configuration > My Store to access the My Store screen. 

2. Set the following fields to either Shipping , Billing  or Store . 
 Basis of Product Tax 
 Basis of Shipping Tax 

Shipping and Billing addresses are determined by a customer during the checkout process. Store address is based on
the following fields in the My Store screen. 

 Country
 Zone

Display of Tax Information

Before you configure your tax information, you need to take note of a few settings that might affect whether you get
to see tax calculations being displayed and how these tax calculations are derived.

All the relevant display settings can be found in the My Store screen available via clicking Configuration > My
Store. We shall go through each of those fields in the following table.

Table 9.1: Explanation of tax settings in My Store screen   (continued)

Title Explanation

Tax Decimal Places Specifies how many decimal places will be used to display a tax rate. Let us
use the following example screen shot to illustrate its use where we assume
we have already set this field to 0.

Notice that we have specified a Tax Rate of 17.5% for the EU zone. When
we try to delete this tax rate, the side-panel actually shows a tax rate of 18%! 

Do not worry because this setting only affects the display of tax rates. Actual
tax rates will still be used in any tax calculation. To avoid confusion, set this
value to use the same number of decimal places as your expected tax rate.
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110 e-Start Your Web Store with Zen Cart

Table 9.1: Explanation of tax settings in My Store screen   (continued)

Title Explanation

Display Prices with Tax If this field is true , your product prices will be displayed inclusive of tax.
For example, if your product price is $100 and a tax rate of 10% is applied.
The product price will be displayed as $110 instead of the usual $100. 

There are two cases where this setting will have an effect on the display of
prices in the Store Front:
 - Product Price
 - Order Total

When looking at product prices in the Store Front, even if you have enabled
this field, whether you will see the price of $110 or $100 will depend on what
you set for the Basis of Product Tax field. If the address for the Basis of
Product Tax field falls within a Zone defined in the tax rate you set up, then
you will see $110, if not, you will still see $100. Note that Zen Cart will not
know your location if you have not logged in so whether you see the price
with or without tax is also subjected to this scenario.

At the final step of the check out process, customers will be presented with
their order totals. Depending on the value of this field, the display of prices
with tax information is different, as shown in the following screen shots.

Display Prices with Tax: false .

Display Prices with Tax: true .

Note that the tax calculations in the above orders only apply to the product
price and not to the shipping charge (Flat Rate). 
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 Chapter 9   Taxes 111

Table 9.1: Explanation of tax settings in My Store screen   (continued)

Title Explanation

Display Prices with Tax
in Admin

This setting will affect the display of prices in customer orders and invoices
generated by Zen Cart in the Admin Console. To look at an invoice generated
by Zen Cart, click on Customers > Orders and choose an order. Click on
invoice to see a dynamically generated invoice.

Take note of the differences in the Price (inc) and Total (inc) columns for
the two sample invoices shown in the following screen shots.

Display Prices with Tax in Admin: false .

Display Prices with Tax in Admin: true .

Note that the tax calculations in the above orders only apply to the product
and not to the shipping (Flat Rate). The number of decimals displayed is
dependent on the number of decimal places you set for that particular
currency. 

Sales Tax Display Status If enabled, it will force the display of sales tax even if the amount is $0.00. It
is recommended that you set this value to 1 during testing so you can check
whether your tax calculations are in order.

Adding a Tax Class

A tax class allows you to classify your goods into a specific category so that tax rates can be applied. When you
configure a shipping module or create a new product (which you will learn about in a later chapter), you will be
given the option of specifying a tax class for that particular product or shipping module.

To add a tax class:
1. Click on Locations/Taxes > Tax Classes to access the Tax Classes screen.
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112 e-Start Your Web Store with Zen Cart

2. Click on new tax class to bring up the tax class detail panel.

3. Enter your desired values for the Tax Class Title and Description fields.

4. Click insert to save your changes into the database.

Adding a Tax Rate

A tax rate specifies a percentage of a product's sales price to be added as tax. A product can incur several tax rates at
once so Zen Cart gives you the option of adding or compounding the different tax rates together.

To add a tax rate:

1. Click on Locations/Taxes > Tax Rates to access the Tax Rates screen.

2. Click on new tax rate to bring up the New Tax Rate side-panel.
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 Chapter 9   Taxes 113

3. Choose the tax class which you want to apply a tax rate to by selecting from the Tax Class Title field.

4. Choose a zone definition to which the tax rate should apply from the Zone field. 

5. Specify the tax rate you want to charge in the Tax Rate (%) field.

6. Specify a meaningful description for the Description field. Preferably, state the tax rate since this field will
be displayed to the customer in the Order Confirmation screen during check out. For example, Value
Added Tax (VAT) @ 10% . 

7. Specify how you want different tax rates to apply by entering a number into the Priority  field. An
explanation of this field is found in the “Compounding or Adding Different Tax Rates” section below.

8. Click insert to save your changes.
 

Compounding or Adding Different Tax Rates

In some cases, different tax rates need to be applied to a product. The final tax rate that applies for the product will
depend on whether these tax rates are compounded or added. Zen Cart allows you to perform the compounding or
addition of tax rates by way of the Priority  field which you encountered in step 7 in the “Adding a Tax Rate” section
previously. Notice that the Priority  field states that “Tax rates at the same priority are added, others are
compounded”. 

We will use the following examples of a single product which has two tax rates (3% and 5%) applied to it to
understand the meaning of compounding versus addition.

Example 1: “Compounded” Tax Rate 

Net Price of Product = $100.00
Priority = 1, Tax Rate = 5%
Priority = 2, Tax Rate = 3%
Compounded Tax Rate = (1.05 x $100.00) x (1.03) = $108.15
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114 e-Start Your Web Store with Zen Cart

Example 2: “Added” Tax Rate

Net Price of Product = $100.00
Priority = 1, Tax Rate = 5%
Priority = 1, Tax Rate = 3%
Added Tax Rate = (1 + 0.05 + 0.03) x $100.00 = $108.00 

Impact of Customer Zone Information

One of the things that can cause problems when Zen Cart calculates taxes is when no State/Province information
exists for a customer. This happens when they are not required to enter the State/Province field when they sign up
for an account with your online store.

Zen Cart needs the State/Province information in order to determine which Zone a customer is located in so that it
can decide whether the customer is liable for sales tax. If your store chooses not to collect any zone information
during customer registration, then the only way to assess taxes on those customers would be to set the tax basis to
Store  (refer to “Basis for Tax Calculation” on page 108 for configuration details). Note that the Zone used when
using a store-based tax basis is taken from the Zone field under Configuration > My Store.

To make sure that customers specify a state or province when they sign up for an account:

1. Click on Configuration > Customer Details to access the Customer Details screen.

2. Make sure the State field is set to true .

Summary

Configuration of sales taxes needs to be carefully done as there are many steps to perform and also several
dependencies with other modules as well. The main thing before you start configuring your taxes is to have an
understanding of how your business is required to handle taxation issues. Since tax rules can change overnight, you
also need to stay abreast of current affairs and update your tax settings in a timely manner. 

Do contact your local tax authority or consult a tax accountant to review your business needs, including taxation
issues related to zones outside the jurisdiction of your local tax authority (since you can sell to anyone anywhere if
you are selling online).
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Chapter 10 Shipping

Introduction

Any store that deals with physical goods will likely need to ship those goods to their customers. Zen Cart provides
various shipping modules to cater to the different ways in which store owners ship their goods. Each shipping
module that is enabled will then appear as a shipping option to customers based on the delivery addresses they select
when they check out their items.

Zen Cart comes with quite a handful of default shipping modules. However, we will not be covering the United
Parcel Service (UPS) and United States Postal Service (USPS) shipping modules for the following reasons:

 If you are running Zen Cart on your home computer while reading this book, the external shipper will not be
able to send any information back to you since you are not listed on the Internet.

 Most external shippers require you to have an account with them before you can start testing and a lot of
technical expertise and time will usually be required to troubleshoot any problems. 

In this chapter, we shall:
 Understand important shipping considerations like tare weight, shipping boxes calculation and

shipping/packing details.
 Run through the common shipping screen and shipping settings.
 Go through each shipping option separately.

Default Shipping Modules Overview

Use the following table to help decide which shipping option you want to offer your customers. Shipping modules
are classified according to the methods they employ to calculate shipping charges, such as:

 Online – Shipping charges are calculated in real-time by an external shipping processor and sent back to your
store for display to customers.

 Offline – Shipping charges are calculated based on the rates a store owner sets for a particular shipping
module.

Table 10.1: Default shipping options   (continued)

Modules Method Comments

Flat Rate Offline Adds a fixed shipping cost to a customer's order regardless of how many
items were bought.

115
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Table 10.1: Default shipping options   (continued)

Modules Method Comments

Per Item Offline Adds a fixed shipping cost to each item in a customer's order. 

Per Unit Offline A different shipping cost is applied for each item based on the item's unit
weight and quantity. 

Note: The unit weight of an item is the weight you specified when
creating a product in the store's catalog.

Store Pickup Offline Charges a fixed shipping cost for customers who choose to collect their
goods from your store instead of having you deliver it to them.

Table Rate Offline Applies different shipping charges for items that fall within different
bands for weight, price or number of items. For example, charge $2 for
orders below 5 lbs and charge $5 for orders between 5 lbs to 10 lbs.

Zone Rates Offline Behaves similarly to Table Rate but has the added ability to define
different table rates for different countries in different zones.

FREE SHIPPING! Offline Allows you to specify extra charges that should apply although free
shipping is offered to customers. 

Note: If this module is active and shown to the customer during
checkout, all other modules automatically disappear. To enable free
shipping for customers and at the same time offer other shipping options
to customers, use the Free Shipping Options module instead.

Free Shipping Options Offline Allows you to specify different conditions for a customer to qualify for
free shipping. For example, when the total order exceeds a certain
amount or weight, or when the total number of items bought is above a
certain threshold value.

United Parcel Service Online Delivery information in Zen Cart is submitted to United Parcel Service
where shipping charges are calculated in real-time before being
displayed to customers.

You need an account with United Parcel Service if you intend to use this
option.

United States Postal
Service

Online Delivery information in Zen Cart is submitted to United States Postal
Service where shipping charges are calculated in real-time  before being
displayed to customers. Only works if you are shipping from the United
States.

You need an account with United States Postal Service if you intend to
use this option.
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 Chapter 10   Shipping 117

Enabling Network Access to Third-Party Sites

For some shipping modules which require access to third-party sites to acquire real-time shipping quotes, you will
need to ensure that your PHP settings are properly configured to work with cURL. cURL support in PHP allows Zen
Cart to communicate properly with external web sites.

To check whether cURL functionality is enabled in your server's PHP settings:

1. Click on Tools > Server/Version Info to access the Server Information screen. 

2. Make sure that the CURL support field is enabled.

If your store is hosted with a web hosting provider, you may need to specify additional proxy settings in Zen Cart in
order for cURL to work properly. Check with your web hosting provider if you encounter problems with network
access when configuring those shipping modules which require cURL access.

To enable proxy server access for cURL to work:

1. Click on Config > My Store to access the My Store screen.

2. Set the cURL Proxy Status field to True .

3. Specify the proxy address which your web hosting provider has given you in the cURL Proxy Address field.

Important Shipping Considerations

Before you can start configuring any shipping module, you need to take note of several factors that will affect your
shipping costs. 
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Tare Weight and Calculation of Shipping Boxes

What Is Tare Weight?

You might need to enclose your product within a box and maybe add some layers of foam for protection when
shipping your items. The additional weight (i.e. packing box, foam, etc) added to the actual weight of your item is
known as the tare weight. This variable should be the first thing you check when you find that the calculation for
your shipping charges do not add up.

Calculating the Number of Shipping Boxes Required

Whenever you ship items, you need to pack them nicely into suitable boxes, tubes, etc. Zen Cart can help you
determine the number of boxes you require based on the weight of your orders. However, the way the number of
shipping boxes is calculated can be wrong!

The formula for the calculation of the number of shipping boxes required is:

Number of shipping boxes = 
     (total weight of all items in an order) / (max imum package weight)

Note: maximum package weight is the maximum weight that each shipping box can h old.

We shall use the following two examples to show how this formula actually works. For simplicity, both examples
assume the tare weight is zero. Example 1 gives you an idea of how the formula works. Example 2  illustrates why
you have to be very careful if you decide to use this feature to determine your shipping boxes.

Example 1: Correct shipping boxes calculated

Assume the maximum package weight is 0.4 lbs and a customer buys several items of the same
product.

 Product A = 0.2 lbs
 Customer buys 4 units of Product A = 4 x 0.2 = 0.8  lbs

No. of Shipping Boxes required = (0.8) / (0.4) = 2

Note: Each box weighs 0.4 lbs, and contains 2 units  of Product A each.

Example 2: Impractical shipping boxes calculated

Assume the maximum package weight is 2.5 lbs and a customer buys the following three products
from your store.

 Product A – 2 lbs
 Product B – 1 lb
 Product C – 2 lbs
 
No. of Shipping Boxes required = (2 + 1 + 2) / (2.5 ) = 2

Note: You can’t ship your goods with only 2 boxes b ecause the maximum weight for each box is
2.5 lbs! You would need 3 boxes to ship the goods p roperly.

Due to the potential miscalculation of shipping boxes above, it is advisable that you do not show customers any
information on shipping boxes when they are checking out their items. You will see how to disable the display of this
information when we discuss “display-related information” in the next section.
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 Chapter 10   Shipping 119

Shipping and Packaging Details

Before you configure your shipping modules, you should set some general settings for all your shipping-related
activities. We will go through all the settings here to give you a firm grounding in how Zen Cart deals with these
issues.

Click on Configuration > Shipping/Packaging to access the Shipping/Packaging screen.

The information in this screen can be split up into several categories to help you appreciate how they impact your
shipping configuration. 

 Shipping Origin Information
 Weight-Related Information
 Display-Related Information

Shipping Origin

The following fields are required if you are shipping physical items anywhere in the world.
 Country of Origin  
 Postal Code 

The information collected may be used to determine your shipping rates. Online shipping modules (USPS,  UPS, etc)
which prepare shipping quotes in real-time will use this information to calculate the shipping charges based on the
distance between your shipping origin and the shipping destination.

Weight-Related Information

The following fields are related to weight information and will affect the calculation of your shipping weights when
you configure your shipping modules later.

 Enter the Maximum Package Weight you will ship 
 Package Tare Small to Medium - added percentage:weight 
 Larger packages - added packaging percentage:weight 
 Order Free Shipping 0 Weight Status 

Enter the Maximum Package Weight you will ship tells Zen Cart the maximum weight that you will allow in a
shipping package – box, tube, envelope, etc. This is the maximum package weight that will be used for calculating
the number of boxes to pack the items contained in a customer's order. Refer to “Calculating the Number of Shipping
Boxes Required” on page 118 for calculation details.

Package Tare Small to Medium - added percentage:weight and Larger packages - added packaging
percentage:weight both allow you to specify a tare weight in addition to the total weight of your orders. You need to
pay close attention to these two options because store owners tend to forget that they affect the order weight
calculations and spend a lot of time trying to figure out where the phantom weight came from.
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120 e-Start Your Web Store with Zen Cart

Order Free Shipping 0 Weight Status allows you to specify whether you want to allow customers to enjoy free
shipping when they purchase a product for which you did not specify a weight. If you enable this option by setting its
value to 1, you will need to enable the FREE SHIPPING! module under Modules > Shipping.

Display-Related Information

The two fields related to display information for shipping are shown below.
 Display Number of Boxes and Weight Status 
 Shipping Estimator Display Settings for Shopping Cart. 

Display Number of Boxes and Weight Status allows you to choose how you want to display the number of boxes
and weight when customers are prompted to choose a shipping option during the checkout process. The following
example screen shot shows what is displayed if you set this option to Both Boxes and Weight .

It is recommended that you set this value to off  to prevent customers from witnessing any possible impractical
calculations as shown in Example 2 in the section on “Calculating the Number of Shipping Boxes Required”. You
certainly do not want to confuse your customers and explain the discrepancies over and over again.

Shipping Estimator Display Settings for Shopping Cart  toggles the display of the Shipping Estimator option when
customers view their shopping cart details. The following example screen shots show what customers can expect to
see for the values of Display as Button on Shopping Cart  and Display as Listing on Shopping
Cart Page  respectively. 

No. of shipping boxes Weight per shipping box
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Common Shipping Information

Before we start adding shipping options, you need to know certain common shipping information that will help ease
your configuration later. 

The Shipping Modules Screen

All shipping modules in Zen Cart are configured via the Shipping Modules screen. To access this screen, click on
Modules > Shipping. 

Display as Button 
on Shopping Cart

 Display as Listing 
on Shopping Cart Page

[Logged In Customer]

 Display as Listing 
on Shopping Cart Page

[Non-Logged In Customer]
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122 e-Start Your Web Store with Zen Cart

A shipping module can only be used if it is:
 Installed.
 Enabled.

Therefore, you should automatically perform the above steps if you are asked to configure a shipping module later in
the chapter.

The colors of the buttons under the Sort Order column have the following meanings:
 Red – Shipping Module is not installed.
 Green – Shipping Module is installed and enabled.
 Yellow – Shipping Module is installed but disabled or the Shipping Zone field is enabled only for a

particular zone.

Common Shipping Settings

Certain fields which are common across most of the different shipping modules are highlighted in the following table
so we do not have to explain them again later.

Table 10.2: Explanation of common shipping settings   (continued)

Property Meaning

Tax Class Assigns a tax class to the calculated shipping cost of an order. Refer to
“Understanding How Taxes are Configured” on page 107 if you have forgotten
how taxes work.

Tax Basis Specifies which of the following addresses to use for calculating tax charges - 
Shipping, Billing or Store. Refer to “Basis for Tax Calculation” on page 108 for
more information.

Handling Fee Adds an extra charge to the final shipping cost. For example, if you have to buy
special packaging materials for your goods, you might want to add the cost of
those materials here.

Note: Customers do not like dealing with stores that come up with what are
perceived as hidden charges. So I'd recommend you do not add any charges
here.
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Table 10.2: Explanation of common shipping settings   (continued)

Property Meaning

Shipping Zone For shipping modules that have selected a particular zone definition for this
field, customers will only see the corresponding shipping option if their delivery
addresses fall within the selected zone definition.

Specifying –  none  --   for this field for a particular shipping module will make
the corresponding shipping option appear to all customers.  

For testing purposes, set this field to –  none  --  .

Sort Order Indicates the sequence in which shipping options appear to a customer when
checking out. A shipping option with a lower value will appear above a
shipping option with a higher value.

You can leave this field set to 0 for all shipping modules to let Zen Cart sort the
shipping options automatically when customers view them. 

If you choose to specify a non-zero value for this field, make sure you also
specify a non-zero value for all other shipping modules. In addition, all non-
zero values must be different.

Adding Shipping Options

Flat Rate 

This shipping option adds a fixed charge to a customer's order regardless of the number of items, total weight or total
price of the order. For example, if a customer orders 5 lamps, 2 tables and 3 chairs, you still charge a flat rate of $50
for the whole order.

This type of shipping option is a good choice for stores that sell goods which can be hand-carried by customers. In
such cases, if the customers wish to have the items delivered, then the store will charge a flat rate for any deliveries.
An example would be furniture shops which typically do delivery if customers buy items above a certain amount. 

To configure this module:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Edit the Flat Rate module. If required, install the module first.
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3. In the Shipping Cost field, specify the fixed amount you want to charge for customers who choose this
shipping option.

4. Fill in the rest of the details for the module. Refer to “Common Shipping Settings” on page 122 for
explanations for the rest of the fields.

5. Click update to save your changes into the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test
Product (refer to “Normal Test Product” on page 65 for details) for the purpose of our test. 

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add a “Normal Test Product” product to your cart and check out the item.

3. At the Delivery Information screen, you should see “Flat Rate” appear as a shipping option under the
Shipping Method section.

4. Check that the amount appearing next to the Best Way radio button is correct based on your settings for this
module.

Per Item

This shipping module adds a fixed charge to each item in a customer's order regardless of the number of items, total
weight or total price of the order. For example, if a customer orders 5 lamps, 2 tables and 3 chairs, you decide to
charge a per item rate of $10. Your total shipping cost will work out to be (5 + 2 + 3) x 10 = $100.

This shipping module is a good choice for stores that sell a single item or items that have uniform shipping attributes.
An example would be shops selling DVDs, CDs and books, etc.
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To configure this module:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Edit the Per Item module. If required, install the module first.

3. In the Shipping Cost field, specify the amount you want to charge for each item in a customer's order.

4. Fill in the rest of the details for the module. Refer to “Common Shipping Settings” on page 122 for
explanations for the rest of the fields.

5. Click update to save your changes into the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test
Product (refer to Normal Test Product on page 65 for details) for the purpose of our test. 

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add two or more “Normal Test Product” products to your cart and check out the items. By adding multiple
items, you can better visualize and verify the accuracy of the shipping charges calculation.

3. At the Delivery Information screen, you should see “Per Item” appear as a shipping option under the
Shipping Method screen.

4. Check that the amount appearing next to the Best Way radio button is correct based on your settings for this
module.

Per Unit

This shipping module applies a different charge to each item in a customer's order based on the item's unit weight and
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quantity. The unit weight of an item is the weight you specified when creating a product in the catalog. Essentially, it
provides you a way of specifying different shipping charges based on the products that are being shipped.

Consider this scenario: You decide to sells pots and pans which weigh 0.5 and 0.25 pounds respectively. You have
further decided that the shipping cost is $10 per pound. Therefore, if a  customer orders 2 pots and 3 pans, the total
shipping cost will work out to be (2 x 0.5 x 10) + (3 x 0.25 x 10) = $17.50.

To configure this module:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Edit the Per Unit module. If required, install the module first.

3. In the Shipping Cost per Unit field, specify the amount you want to charge per unit weight for each item in
a customer's order. If you have trouble understanding this field, think of it as how much you would charge
per pound ($/lb) or how much you would charge per kilogram ($/kg), etc.

4. Fill in the rest of the details for the module. Refer to “Common Shipping Settings” on page 122 for
explanations for the rest of the fields.

5. Click update to save your changes into the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test
Product (refer to “Normal Test Product” on page 65 for details) for the purpose of our test. 

Before you test this module, you can turn off tare weight to simplify the interpretation of the test results. Click on
Configuration > Shipping/Packaging and set the following fields to 0:0 .

 Package Tare Small to Medium - added percentage:weight 
 Larger packages - added packaging percentage:weight 

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add two or more “Normal Test Product” products to your cart and check out the items. By adding multiple
items, you can better visualize and verify the accuracy of the shipping charges calculation.

3. At the Delivery Information screen, you should see “Per Unit” appear as a shipping option under the

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


 Chapter 10   Shipping 127

Shipping Method section.

4. Check that the amount appearing next to the Best Way radio button is correct based on your settings for this
module.

Repeat the test with different values for the tare weight to better understand how shipping charges for this shipping
module are calculated by Zen Cart.

Store Pickup

This shipping module gives customers the benefit of picking up their items at your store instead of incurring any
delivery charges. Similarly, it saves store owners the hassle of having to pack and deliver the goods. If you use this
option, do consider defining a shipping Zone Definition that covers your local vicinity so that only customers with
shipping addresses in the vicinity can see this shipping module.

To configure this module:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Edit the Store Pickup module. If required, install the module first.

3. In the Shipping Cost field, specify the amount you would like to charge for customers who choose to pick
up their goods from your store. Usually, this amount is left at 0.00  unless there is some warehousing costs
to the store owner.
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4. Fill in the rest of the details for the module. Refer to “Common Shipping Settings” on page 122 for
explanations for the rest of the fields.

5. Click update to save your changes into the database.

Before you begin to test this shipping module, you need to create a product in your store. We shall use the Normal
Test Product (refer to “Normal Test Product” on page 65 for details) for the purpose of our test. 

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add a “Normal Test Product” product to your cart and check out the item.

3. At the Delivery Information screen, you should see “Store Pickup” appear as a shipping option under the
Shipping Method section.

4. Check that the amount appearing next to the Walk In  radio button is correct based on your settings for this
module.

Table Rates

This shipping module allows you to apply different shipping charges based on either the weight, price or number of
items bands. For example, you can charge $10 for orders above $50 and $2 for orders above $100. Specifying table
rates based on price or number of items is entirely up to how your business operates. To specify table rates by
weight, you can usually obtain a copy of the shipping rates table from your local post office to help you get started.

Understanding the Shipping Table

Before we go any further, you need to understand the syntax of the Shipping Table field which you will encounter
later. 

Example 1: Table Method = Weight

In this example, you have specified that the value of the Shipping Table represents weight. Let us assume that the
total weight of a customer's order is “x” and that the default unit of measure for weight is in “lbs”. If the value of the
Shipping Table field is 25:8.50,50:5.50,1000:0.00 , it essentially means the following:

         x ≤ 25 lbs   : Shipping Rates = $8.50
25 lbs < x ≤ 50 lbs   : Shipping Rates = $5.50
50 lbs < x ≤ 1000 lbs : Shipping Rates = $0.00 i.e. Free Shippi ng for total weight above 50
lbs.

Example 2: Table Method = Price

In this example, you have specified that the value of the Shipping Table represents price. Let us assume that the total
price of a customer's order is “y” and that the default currency is in “$”. If the value of the Shipping Table field is
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25:8.50,50:5.50,1000:0.00 , it essentially means the following:

      y ≤ $25   : Shipping Rates = $8.50
$25 < y ≤ $50   : Shipping Rates = $5.50
$50 < y ≤ $1000 : Shipping Rates = $0.00 i.e. Free Shipping for purchases above $50

Example 3: Table Method = Number of Items

In this example, you have specified that the value of the Shipping Table represents number of items. Let us assume
that the total number of items in a customer's order is “z”. If the value of the Shipping Table field is
25:8.50,50:5.50,1000:0.00 , it essentially means the following:

     z ≤ 25   : Shipping Rates = $8.50
25 < z ≤ 50   : Shipping Rates = $5.50
50 < z ≤ 1000 : Shipping Rates = $0.00 i.e. Free Shipping f or more than 50 items bought

Make sure you understand how the Shipping Table works before you begin configuring this shipping module.

To configure this module:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Edit the Table Rate module. If required, install the module first.

3. Change the value of the Shipping Table field according to your preference and then specify what the
Shipping Table field represents by clicking the appropriate radio button in the Table Method field.

4. Fill in the rest of the details for the module. Refer to “Common Shipping Settings” on page 122 for
explanations for the rest of the fields.

5. Click update to save your changes to the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test
Product (refer to “Normal Test Product” on page 65 for details) for the purpose of our test. 
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The following test uses weight for illustration. You should substitute it with either price or number of items to suit
your own needs. Before you test this module, you can turn off tare weight to simplify the interpretation of the test
results. Click on Configuration > Shipping/Packaging and set the following fields to 0:0 .

 Package Tare Small to Medium - added percentage:weight 
 Larger packages - added packaging percentage:weight 

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add two or more “Normal Test Product” products to your cart and check out the items. By adding multiple
items, you can better visualize and verify the accuracy of the shipping charges calculation.

3. At the Delivery Information screen, you should see “Table Rate” appear as a shipping option under the
Shipping Method section.

If your table method calculation is based on weight, you will see the number of shipping boxes and weight
per box fields next to the “Table Rate” heading

4. Check that the amount appearing next to the Best Way radio button is correct based on your settings for this
module.

Zone Rates

Zone Rates can be considered a superset of Table Rates. Both shipping modules operate on the same underlying
concept using band rates for weight, price or number of items in an order. Whereas the Table Rates shipping module
has only one shipping table for an entire shipping zone, the Zone Rates shipping module provides different shipping
tables for multiple shipping zones. 

To look up the ISO country code for a particular country while configuring this module, go to
http://www.unicode.org/onlinedat/countries.html.

To configure this module:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Edit the Zone Rates module. If required, install the module first.
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3. Select an appropriate value for the Calculation Method field. 

4. If you do not want this shipping option to appear for shipping addresses in specific countries, add the
necessary ISO country codes in the Skip Countries field. 

Customers with shipping addresses in countries not specified in the Skip Countries  field and also not
specified in all the Zone Countries field will see a message displayed under the “Zone Rates” shipping
option as shown in the following screen shot.

5. For each zone, fill in the necessary details for the Zone Countries, Zone Shipping Table and Zone
Handling Fee fields.

6. Fill in the rest of the details for the module. Refer to “Common Shipping Settings” on page 122 for
explanations for the rest of the fields.

7. Click update to save your changes into the database.

We shall use the Normal Test Product (refer to “Normal Test Product” on page 65 for details) for the purpose of our
test. The following test uses weight for illustration. You should substitute it with either price or number of items to
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suit your own needs. 

In addition, we shall use the test customer we created in “Setting Up a Test Customer” on page 62 for our test. Note
that the ISO country code for the test customer's country of France is “FR”.

To simplify the interpretation of test results, you can turn off tare weight for the time being. Click on Configuration
> Shipping/Packaging and set the following fields to 0:0 .

 Package Tare Small to Medium - added percentage:weight 
 Larger packages - added packaging percentage:weight 

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add two or more “Normal Test Product” products to your cart and check out the items. By adding multiple
items, you can better visualize and verify the accuracy of the shipping charges calculation.

3. At the Delivery Information screen, you should see “Zone Rates” appear as a shipping option under the
Shipping Method section.

4. Check that the amount appearing next to the Shipping to radio button is correct based on your settings for
this module.

Free Shipping

This shipping module allows you to offer free shipping to your customers. Note that it is compulsory to enable this
module if you decide to do the following:

 Offer discount coupons which are marked as free shipping. Refer to “Creating Discount Coupons” on page
313 for details

 If you have a product configured for free shipping in your store.
 If you sell downloadable products.

When this shipping option appears in the Delivery Information page during check out, all other shipping options
(except Store Pickup, if enabled) will automatically disappear. To enable free shipping to appear simultaneously with
other shipping options (besides Store Pickup, if enabled) in the Delivery Information page during check out, use the
“Free Shipping Options” module instead.

You can choose from the following list of conditions to trigger the appearance of the Free Shipping option when
customers check out their purchases:

 The total price of a customer's order exceeds a threshold value.
 If a product does not have any unit weight associated with it.
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 If all products in a customer's order are configured for free shipping as follows:
➔ Product is Virtual  field is not set to Yes, Skip Shipping Address .
➔ Always Free Shipping field is set to No, Normal Shipping Rules .

To trigger the appearance of the Free Shipping option when the total price of a customer's order exceeds a threshold
value:

1. Click on Modules > Order Total to access the Order Totals Modules screen.

2. Click on Shipping and edit the item.

3. Specify true  for the Allow Free Shipping field.

4. Set the threshold amount to trigger free shipping in the Free Shipping For Orders Over field.

5. Specify whether free shipping should apply for international  or national  delivery addresses in the
Provide Free Shipping For Orders Made field. Choose both  for testing purposes.

To trigger the appearance of the Free Shipping option when a product does not have any unit weight associated with
it:

1. Click on Configuration > Shipping/Packaging to access the Shipping/Packaging screen.

2. Set the Order Free Shipping 0 Weight Status field to 1. 

To trigger the appearance of the Free Shipping option when all products in a customer's order are configured for free
shipping, you need to first make sure that you have a product that is configured to take advantage of such a scenario
first. To configure such a product:

1. Click on Catalog > Categories/Products to access the Categories/Products screen.

2. Navigate to the the category containing the product you want to configure for free shipping. If you do not
have such a product, you can create one first.

3. Edit the details of the product. Make sure the following fields are set as follows:
 Product is Virtual  field is not set to Yes, Skip Shipping Address .
 Always Free Shipping field is set to No, Normal Shipping Rules .

Now that you understand the conditions that will trigger the appearance of the Free Shipping option during check
out, you can start configuring the Free Shipping module.
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To configure this module:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Edit the FREE SHIPPING!  module. If required, install the module first.

3. In the Free Shipping Cost field, specify the amount to charge customers who choose this option. Specifying
a fee here is discouraged because customers expect Free Shipping to be literally free!

4. Fill in the rest of the details for the module. Refer to “Common Shipping Settings” on page 122 for
explanations for the rest of the fields.

5. Click update to save your changes to the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test
Product (refer to “Normal Test Product” on page 65 for details) for the purpose of our test. 

We shall assume that you have chosen to trigger Free Shipping based on price.

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add a “Normal Test Product” product to your cart and check out the item.

3. At the Delivery Information screen, you should see “Free Shipping” appear as the only shipping option under
the Shipping Method section if your free shipping threshold value is below the order price.

4. Note that the threshold value for free shipping is shown on the screen as well.
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Free Shipping Options

This shipping module allows you to offer free shipping to customers side-by-side with other shipping options. This is
not possible with Free Shipping which causes all other shipping modules (except Store Pickup, if enabled) to
disappear when it appears. Furthermore, you can choose to have this shipping option appear based on the total price,
total weight or total number of items in a customer's order.

To configure this module:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Edit the Free Shipping Options module. If required, install the module first.

3. Carefully read the instructions on the side-panel before you start configuring this module.

4. Specify how Free Shipping Option should be triggered based on the corresponding Total, Weight and Item
Count fields.

5. Avoid entering a value for the Shipping Cost field because customers expect Free Shipping Options to be
literally free!

6. Fill in the rest of the details for the module. Refer to “Common Shipping Settings” on page 122 for
explanations for the rest of the fields.

7. Click update to save your changes into the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test
Product (refer to “Normal Test Product” on page 65 for details) for the purpose of our test. 

We shall assume that you have chosen to trigger Free Shipping based on number of items in an order. Thus, you
should have entered 2 for the Item Count >= field when configuring this module.

To test this module:
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136 e-Start Your Web Store with Zen Cart

1. Log in to your test customer account in your Store Front.

2. Add three or more “Normal Test Product” products to your cart and check out the items. By adding multiple
items, you can better visualize and verify the accuracy of the shipping charges calculation.

3. At the Delivery Information screen, you should see “Free Shipping Options” displayed as a shipping option
under the Shipping Method section.

4. Check that the amount appearing next to the Free Shipping radio button is correct based on your settings for
this module.

Summary

Shipping options are an important aspect of an online store. Finding the best option for your situation will require
some planning and creative experimentation. Make sure you spend some time to understand how the module you
choose actually works. It could save you a lot of embarrassing questions from customers later. 

To keep things simple, we did not discuss any shipping modules that require an account with an external shipper
(United States Postal Service (USPS), United Parcel Service (UPS), etc). Do consider using a third-party shipper if
you require real-time shipping charges to be calculated. You can find more shipping modules catering to external
shippers (DHL, FedEx, etc) in the downloads area at Zen Cart's site. 
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Chapter 11 Payment

Introduction

Zen Cart provides various payment modules to cater to the different ways in which store owners intend to process
customer's payment information. Each payment module that is enabled will then appear as a payment option to
customers based on the billing addresses they select when they check out their items.

Before offering any payment option to your customers, make sure you find out more about the legal and accounting
requirements of your country. For example, in most countries, you need to ensure that customers credit card
information must be transmitted over a secure channel and such credit card information must be stored securely.

Zen Cart comes with a number of default payment modules. However, we will not be covering the Authorize.net,
Authorize.net (AIM) and Linkpoint/YourPay API payment modules. Instead, we will cover the PayPal IPN payment
module as it is the most popular form of online payment at the moment. Once you are familiar with how the PayPal
IPN module works, you should be able to adapt the concept to other payment modules that require access to a third-
party payment processor.

In this chapter, we shall:
 Run through the common payment screen and payment settings.
 Go through each payment option separately.

Default Payment Modules Overview

Before you decide which payment options to offer your customers, you can consult the table below to get an idea of
the various payment modules available by default in Zen Cart. These payment modules are classified according to the
methods they employ to process payments, such as:

 Online – Processing is done in real-time with an external payment processor.
 Offline – Processing is done when information is collected and the store owner has to take action to complete

the payment process.
 Special – This is a special case where no action is taken to process payment.

137
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138 e-Start Your Web Store with Zen Cart

Table 11.1: Default payment options

Modules Method Comments

Cash on Delivery Offline Payment is received on delivery of goods. Not advisable for
global e-commerce!

Check/Money Order Offline Customers will mail in their check or money order separately
after placing their orders.

Credit Card Offline Customers transmit their credit card information to you and you
process the payment with your bank separately.

Authorize.net Online Integrates with Authorize.net payment processor. See
http://www.authorize.net/ for details.

Authorize.net (AIM) Online Same as above but uses Authorize.net’s Advanced Integration
Method (AIM) for integration.

Linkpoint/YourPay
API

Online Integrates to the LinkPoint payment gateway. For more
information on signing up for a merchant account and using this
module, go to http://www.zen-cart.com/partners/linkpoint for
details.

PayPal IPN Online Integrates to PayPal payment processor. To sign up for a PayPal
business account and obtain more information on PayPal, go to
http://www.zen-cart.com/partners/paypal for details.

PayPal Express
Checkout

Online Also integrates to PayPal payment processor but has the added
benefit of shortening the checkout process for customers. For
more information on this payment module, turn to the PayPal
Express Checkout sub-forum on Zen Cart's site.  

The Zen Cart FREE
CHARGE CARD

Special Allows you to specify that customers from a specific zone are
able to buy things from your store for free.

Enabling Network Access to Third-Party Sites

If you have enabled a payment module (e.g. Linkpoint/YourPay API) which requires access to a third-party site to
process payments, you may need to enable cURL support on your server. Refer to “Enabling Network Access to
Third-Party Sites” on page 117 for more details on this issue.

Common Payment Information

Before we start adding payment options, you need to know certain common payment information that will help ease
your configuration later.
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 Chapter 11   Payment 139

The Payment Modules Screen

All payment options in Zen Cart are configured via the Payment Modules screen. To access this screen, click on
Modules > Payment. 

A payment option can only be used if it is:
 Installed.
 Enabled.

Therefore, you should automatically perform the above steps if you are asked to configure a payment option later in
the chapter.

The colors of the buttons under the Sort Order column have the following meanings:
 Red – Payment Module is not installed.
 Green – Payment Module is installed and enabled.
 Yellow – Payment Module is installed but disabled or the Payment Zone field is enabled only for a particular

zone.

Common Payment Settings

Certain fields which are common across most of the different payment options are highlighted in the following table
so we do not have to explain them again later.

Table 11.2: Common payment settings   (continued)

Property Meaning

Payment Zone For payment modules that have selected a particular zone definition for this
field, customers will only see the corresponding payment option if their billing
addresses fall within the selected zone definition.

Specifying –  none  --   for this field for a particular payment module will make
the corresponding payment option appear to all customers.  

For testing purposes, set this field to –  none  --  .
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Table 11.2: Common payment settings   (continued)

Property Meaning

Set Order Status Specifies the status of an order after a customer has made payment. The default
installation of Zen Cart comes with four order statuses defined - Pending,
Processing, Delivered, Updated.

The default  value in the drop-down list box refers to the default order status
defined in Localization > Orders Status. For more details on order statuses,
refer to “Working with Order Statuses” on page 298.

Sort Order of Display Indicates the sequence in which payment options appear to a customer when
checking out. A payment option with a lower value will appear above a
payment option with a higher value.

You can leave this field set to 0 for all payment modules to let Zen Cart sort the
payment options automatically when customers view them. 

If you choose to specify a non-zero value for this field, make sure you also
specify a non-zero value for all other payment modules. In addition, all non-
zero values must be different.

Adding Payment Options

Cash on Delivery

Generally, this method is not recommended for e-commerce. However, if you are just beginning to add an online
presence on top of your current brick-and-mortar shop; and you already have a base of loyal customers, then this
would be an excellent option for you.

To discourage customers from choosing this payment option, you can consider charging customers an extra fee if
they choose this payment option during checkout. Refer to “Cash on Delivery (COD) Fee” on page 238 for more
details.

To configure this module:

1. Click on Modules > Payment to access the Payment Modules screen.

2. Edit the Cash on Delivery module. If required, install the module first.
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 Chapter 11   Payment 141

3. Fill in the details for the module. Refer to “Common Payment Settings” on page 139 for explanations for all
the fields.

4. Click update to save your changes into the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test
Product (refer to “Normal Test Product” on page 65 for details) for the purpose of our test. 

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add a “Normal Test Product” product to your cart and check out the item.

3. At the Delivery Information screen, choose any shipping method and click continue checkout to proceed to
the Payment Information screen.

4. At the Payment Information screen, you should see “Cash on Delivery” appear as a payment option under the
Payment Method section.

Check and Money Order

This method is not recommended for e-commerce because it takes time both for the check or money order to arrive
and for them to clear with the banks. However, it is a safer means of collecting payment as it avoids online fraud. In
any case, certain businesses will always need to have this means of receiving payment, so we shall discuss how this
can be done in Zen Cart.

To configure this module:

1. Click on Modules > Payment to access the Payment Modules screen.

2. Edit the Check/Money Order module. If required, install the module first.
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3. Enter the name of the person or entity that should receive the check or money order in the Make Payable to
field. Do not use the default text displayed in the text box.

4. Fill in the details for the rest of the module. Refer to “Common Payment Settings” on page 139 for
explanations for the rest of the fields.

5. Click update to save your changes into the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test
Product (refer to “Normal Test Product” on page 65 for details) for the purpose of our test.

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add a “Normal Test Product” product to your cart check out the item.

3. At the Delivery Information screen, choose any shipping method and click continue checkout to proceed to
the Payment Information screen.

4. At the Payment Information screen, you should see “Check/Money Order” appear as a payment option under
the Payment Method section.

5. Click the radio button next to Check/Money Order and then click on continue checkout to proceed to the
Order Confirmation screen.
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Free Charge Card

Unlike all other payment modules in Zen Cart, this payment module does not involve any monetary transaction. Its
main purpose is to offer customers a smoother checkout experience. When this payment option appears, all other
payment options will disappear thus speeding up the checkout process because customers do not have to spend time
choosing between different payment options.

This payment option is available only to products that satisfy the following criteria:
 Product price is marked as Free.
 Product comes with Free Shipping.

Note that this payment option will only appear if all items in the customer's shopping cart satisfy the above criteria. 

In addition, if an order happens to qualify for free shipping because a free shipping coupon was redeemed, then this
payment option will appear as well.

You may ask why anyone would offer a free item? Well, you could do this to gain some publicity to your site or
build goodwill among your customers. For example, if your store sells hard-copy magazines; you can offer readers a
free electronic download of a particular magazine's article to entice them to sign up for a subscription to that
magazine. Most customers would also have a better impression of your store since you have given them a “try-
before-you-buy” option.

Before you begin to configure this module, you need to enable the Free Shipping option in Zen Cart:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Click on FREE SHIPPING!  and make sure it is installed and enabled.

3. Make sure both the Free Shipping Cost and Handling Fee fields are set to 0. 

4. You can specify Tax Class, Shipping Zone and Sort Order according to your preferences.

To configure this module:

1. Click on Modules > Payment to access the Payment Modules screen.

2. Edit the The Zen Cart FREE CHARGE CARD module. If required, install the module first.

“Make Payable to” field

Store Contact information. 
To change, click on Configuration > My Store. 

Edit the field “Store Address and Phone”
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3. Fill in the details for the module. Refer to “Common Payment Settings” on page 139 for explanations for the
rest of the fields.

4. Click update to save your changes into the database.

Before you begin to test this module, you need to have a free product that also offers free shipping. Do take note that
the product has to be marked as Product is Free and not just specified as having a price of $0.00! We shall use the
“Free Test Product with Free Shipping” (refer to “Free Test Product with Free Shipping” on page 66 for details)
product for the purpose of our test. 

To test this module:

1. Log in to your test customer account in the Store Front.

2. Add a “Free Test Product with Free Shipping” product to your cart and check out the item.

3. The Delivery Information screen will only appear if you have specified No, Shipping Address
Required  for the Product is Virtual  field when you created your product. Only the Free Shipping and
Store Pickup shipping options will be visible regardless of whether other shipping modules are available.

Choose any shipping option and click continue checkout to go to the Payment Information screen.

4. At the Payment Information screen, you should see “The Zen Cart FREE CHARGE CARD” appear as the
only option under the Payment Method section.

It is recommended that you change the wording “The Zen Cart FREE CHARGE CARD” to avoid confusing
your customers as they are unlikely to know what it means. Before doing that, make sure you go through the
“The Template Override System” on page 270 to learn how to edit files in Zen Cart properly.

To change the relevant wording, look for the file

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


 Chapter 11   Payment 145

<zc-home>/includes/languages/engl ish/modules/payment/freecharger.php  and edit its
contents accordingly.

Credit Card

If you select this option, you must have the means to process credit card payments yourself. In addition, you should
also take note of any legal or commercial requirements as well.

Because credit card information is extremely sensitive, your credit card merchant's terms of service (TOS) will likely
require that you do not store any complete credit card numbers in your database in case your store gets hacked. 

To comply with the TOS of your merchant and to simplify the store owners task of processing credit card numbers,
credit card numbers that are collected by this module are split into two parts. One part will contain only the middle
digits of the credit card number and is sent to an email address of specified by a store owner. The remaining digits of
the credit card number will be stored in the database. Store owners will then be the only ones who are able to retrieve
both sets of numbers and combine them to get a complete credit card number for processing.

Before you enable the credit card processing module, you need to specify which credit cards your online store will
accept. Click on Configuration > Credit Cards to enable the relevant credit card you want to support.

Take note of the Credit Card Enabled – Show on Payment field. It allows you to show your store's accepted credit
cards at the Payment Information screen when customers check out their purchases. 

To configure this module:

1. Click on Modules > Payment to access the Payment Modules screen.

2. Edit the Credit Card  module. If required, install the module first. 
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3. Refer to the following table before you fill in the details for the Collect and store the CVV number and
Split Credit Card E-mail Address fields. 

Property Meaning

Collect and store the CVV
number

This option allows you to specify whether to store the CVV number in your
database. The CVV number stands for “Creditcard Validation Value”. It is a 3
or 4 digit code embossed or imprinted on the reverse side of Visa, MasterCard
and Discover cards and on the front of American Express cards. 

It provides an added layer of fraud prevention for stolen credit card numbers.
If you specify false  for this setting, Zen Cart will not prompt customers to
enter a CVV number when specifying their credit card details. Recommended
setting: true .

Split Credit Card E-mail
Address

The email address you specify here will contain the middle 8 digits of the
credit card number a customer submits.

Note: If you do not specify an email here, no credit card information will be
stored in the database! You will not be able to process any credit card
payments and Zen Cart will send you an email warning you about this
situation.

4. Fill in the details for the rest of the module. Refer to “Common Payment Settings” on page 139 for
explanations for the rest of the fields.

5. Click update to save your changes into the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test
Product (refer to “Normal Test Product”on page 65 for details) for the purpose of our test.

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add a “Normal Test Product” product to your cart and check out the item.

3. At the Delivery Information screen, choose any shipping method and click continue checkout to proceed to
the Payment Information screen.

4. At the Payment Information screen, you should see “Credit Card” appear as a payment option under the
Payment Method section.
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 Chapter 11   Payment 147

If you would like to see the images of your store's accepted credit cards as they appear in the preceding
screen shot, click on Configuration > Credit Cards and edit the Credit Card Enabled - Show on Payment
field accordingly. The images of the credit cards are contained in the directory <zc-

home>/includes/templates/template_default/ images/ icons . Refer to “The Template Override
System” on page 270 to learn how you can change the images properly.

5. Click the Credit Card radio button and use the following test values:
5.1.  Retain the value of the Card Owner's Name or specify a new one if you desire.
5.2.  Enter 4111111111111111  into the Card Number field. Zen Cart will recognize this as a test credit

card number.
5.3.  Specify any valid future date in the Expiration Date field.
5.4.  Enter any number for the CVV Number field. This field will only appear if you have specified True

for the Collect and store the CVV number field while configuring this module.

6. Click on continue checkout to proceed to the Order Confirmation screen. Notice that the middle digits of the
credit card number have been replaced with a sequence of 'X's.

7. Click on confirm the order to complete the checkout process.

If you have specified a valid email address for the Split Credit Card E-mail Address field while you were
configuring this module, open up your email reader and look at the email sent to the aforementioned email address.
You should see the middle eight digits of the credit card number that was previously entered in Step 5.2 above.

To see the rest of the credit card number, click on Customers > Orders to proceed to the Orders screen. Use the
order number you see in the email to help you locate which order in the orders screen you should look at. Click on
the edit button next to the order and you should be presented with the details of the order. The remaining part of the
credit card number will be displayed as shown in the following screen shot.
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PayPal IPN

PayPal is one of the most popular and widely-accepted payment methods on the Internet. It charges merchants a very
low fee for its transactions and comes with an excellent fraud detection service. Furthermore, it does not levy any
extra charge to open an account with them. 

PayPal offers several payment solutions to online merchants for these merchants to process customer payments. The
PayPal IPN module that comes with Zen Cart works with PayPal's “Website Payments Standard” payment solution.
As of Zen Cart version 1.3.7.1, it does not support PayPal's “Website Payments Pro” payment solution.

IPN stands for Instant Payment Notification, and it is the means by which PayPal informs your store that it has
successfully processed your customer's payment. Once your store receives this information from PayPal, Zen Cart
then releases the order for the customer. 

Do spend some time to find out how PayPal works by visiting its web site at http://www.paypal.com. The following
steps will assume you are setting up PayPal IPN for the first time on a remote host.

You should go through the rest of the book and be sufficiently familiar with Zen Cart before attempting to set up the
PayPal IPN payment module in Zen Cart.

There are essentially three things you need to do to get PayPal working with your online store. 
 Set Up PayPal IPN Support in Your Store.
 Set Up Your PayPal Business Account at PayPal’s site. 
 Test Your PayPal Setup.

Set Up PayPal IPN Support in Your Store

1. Go to the Admin Console of your online store. 

2. Click on Modules > Payment to access the Payment Modules screen. 

3. Click on the PayPal IPN module. If this module is not installed, the side-panel should look similar to the
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 Chapter 11   Payment 149

following screen shot.

4. Take note of the following fields in the side-panel as you will need them later.
 Instant Payment Notification Preferences URL.
 Automatic Return URL

Notice that the URLs of the fields in the above screen shot are preceded by “https”. If you have not enabled
SSL support for your store, the URLs will display “http” instead.

5. After you click install, you should see a side-panel similar to the following screen shots.

6. Make sure that Enable PayPal Module is set to True . 

7. Specify an email address for the Business ID field. If you already have a PayPal account, this should be the
Primary Email Address for that account. If not, enter an email address first and then set it as the Primary
Email Address after registering for an account at PayPal's site.

8. Take note of the value for the Mode for PayPal web services field. It should match the one you see in your
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150 e-Start Your Web Store with Zen Cart

PayPal account later.

9. Leave all the other fields at their default values while testing this module. Only change them later after you
are more familiar with how the PayPal module works.

10. Click update to complete your PayPal settings in Zen Cart. 

Set Up Your PayPal Business Account at PayPal’s site

Before we begin, make sure you have signed up for a PayPal Business Account (PBA). If you have not done so, you
can go to http://www.zen-cart.com/partners/paypal to start creating your account.

There are actually three main things you need to configure on PayPal's site.

1. Specify a Primary Email so that PayPal can notify you when payments are made.

2. Set up Instant Payment Notification so that PayPal can send payment notification back to your Zen Cart
store.

3. Set up Website Payment Preferences to allow PayPal to redirect customers back to your site after making
their payments at PayPal's site.

To begin configuring your PBA to accept payments from your store:

1. Log in to your PBA and the top of your screen should look similar to the following screen shot. 

2. Click on the Profile tab, and then click Email under the Account Information  heading. Look for an email
that has its Status set to Primary .  Make sure it is exactly the same as the email you entered previously in
Step 7 of the Set Up PayPal IPN Support in Your Store section.

3. Click on the Profile tab again, and then click Instant Payment Notification Preferences under the Selling
Preferences heading. 
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3.1.  Click the check-box to activate PayPal's Instant Payment Notification (IPN) feature. 

3.2.  Refer to the Instant Payment Notification Preferences URL you obtained in Step 4 of the Set Up
PayPal IPN Support in Your Store section and enter it into the Notification URL  field. Note: Change the
URL to start with “https” instead of “http” if your store has SSL configured already.

4. Click Save to activate the IPN feature in your PayPal account. 

5. Click on the Profile tab, and then click Website Payment Preferences under the Selling Preferences
heading. Only the portion shown in the following screen shot is of interest to us.

5.1.  Set the Auto-Return  radio button to On to activate this feature for your PayPal account.

5.2.  Refer to the Automatic Return URL  you obtained in Step 3 of the Set Up PayPal IPN Support in Your
Store section and enter it into the Return URL field. Note: Change the URL to start with “https” instead
of “http” if your store has SSL configured already.

5.3.Optionally, set the PayPal Account Optional field (not shown in the preceding screen shot) to On. By
doing so, customers without PayPal accounts can still pay using their credit card information.

5.4.  Leave the other fields at their default values for now. You can change them later when you are more
comfortable with how PayPal works.

5.5.  Click Save to commit all your changes.

6.  You can now log out from your PayPal account.
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Test Your PayPal Setup

Before you begin testing your PayPal IPN module:
 Make sure you have created a product in your store with a value of $0.01. This amount minimizes any

monetary loss if unforeseen problems occur with your tests.
 Make sure you use several test customer accounts from different regions to test your PayPal settings.

To begin testing your PayPal IPN module:

1. Log in to your Store Front as a test customer and purchase your test product.

2. Choose PayPal IPN as your payment option in the Payment Information screen.

3. Proceed to the Order Confirmation screen and after you click Confirm the order  in that screen, you will be
redirected to PayPal’s site to complete your payment details. 

4. After you have completed payment at PayPal’s site, you should be redirected back to your online store.
 

5. Log in to your Admin Console.

6. Click on Customers > Orders to see what your order looks like.

7. Click on Customers > Paypal IPN to check that your order has been processed successfully by PayPal and
the customer's order information has indeed been returned to your store. 

8. Log in to your PayPal Business Account.

9. You should see a payment received from your test order if everything goes well.

10. Do a refund for the test product's amount if you are satisfied with your testing.

11. Log in to your Admin Console again.

12. Click on Customers > Paypal IPN to check whether the order status has been updated after your order has
been refunded.

Summary

Do not overwhelm your customers with too many payment options. Research has shown that customers who ponder
too long on a payment option eventually end up not buying at all! Use the following criteria when deciding whether
to offer a particular payment option to your customers:

 Benefit your customers and convenient for them to use.
 Suitable for your business and be easy to administer.

Besides offering your customers suitable payment options, you should also make sure your store uses Secure Sockets
Layer (SSL) when processing payment details from them. Refer to “Secure Sockets Layer (SSL)” on page 368 for
more information on how you can set up SSL for your store.

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


Part 3  Managing Your Store

Catalog

This section discusses how you can add products and services to your store catalog. It also shows
you how to customize your products using product attributes. You will also learn different ways
to manipulate your product catalog to allow you to sell downloadable goods, list your products in
multiple categories, etc.

This section covers the following topics:

● Categories, Product Types and Products

● Product Attributes

● Other Product Manipulation Techniques

● Order Totals, Surcharges and Discounts
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Chapter 12 Categories, Product

Types and Products

Introduction

A store catalog enables visitors to your online store to browse the different goods and services you have for sale. The
Categories side-box is the place where your main store catalog is displayed.

Notice that the store catalog groups different products into distinct categories. Categories are arranged in a tree
hierarchy which allows visitors to quickly get to their desired items. 

In this chapter, we shall:
 Create categories to hold your products and services.
 Understand how product types work and which one to use when creating your products and services.
 Add products and services to your catalog.

Basic Catalog Concepts

Before we discuss Categories, Product Types and Products, we need to have a big picture of how these three entities
are inter-related to avoid any confusion when you need to make use of them later. Let us use a file system on your
computer as an analogy to help us understand the differences between them. 

Think of Categories as the directories you create to hold your files. For example, you can create a “business” and a
“personal” directory to hold different files related to your work or personal life in your computer. Similarly, in an
online store, you use categories to hold different products for users to browse and buy.

Next, think of Product Types as being analogous to the different file types in your computer. For example, you use
“.jpg” files to represent image files and “.pdf” to represent documents you read. Similarly, in an online store, you use
Product Types to represent different types of products. 

Finally, think of Products as the different files that exist in your computer. Each file exists in a directory and is of a
particular file type. Similarly, in an online store, a Product is of a particular product type and is held in a category.

Now that you are clear about the differences between Categories, Product Types and Products, we shall begin
discussing each one separately.

155

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


156 e-Start Your Web Store with Zen Cart

Working with Categories

Categories allow you to group different sub-categories and products together. However, under normal circumstances,
each category can only contain either products or sub-categories but not both at the same time. Therefore, do not
place your products on the top-most level. This is because once you do that, you will not be able to create any
categories!

Zen Cart provides you the flexibility of re-arranging your categories by moving them around. When you move a
category to another category or sub-category, all the products under the category will be moved as well. This feature
allows you to quickly come up with a rough product catalog when you begin experimenting with your store setup and
then you can slowly refine it according to your business requirements.

Furthermore, to help ensure uniformity of products in a category, Zen Cart is also able to restrict products in a
category to a specific product type. 

How Categories Are Displayed

Zen Cart provides several ways for you to display the categories you have created and enabled. You have the option
of displaying your categories in the following manner:

 Categories side-box.
 Categories tab menu.
 Categories pictures on the main page.

The Categories Side-Box

A Categories side-box is shown in the following screen shot below.

There are several properties you can set for the Categories side-box:

 To disable the display of the number of products in each category (the numbers within the brackets), click on
Configuration > My Store and set the field Show Category Counts to false .

 To change other display properties of the Categories side-box, click on Configuration > Layout Settings
and experiment with the following fields:

Categories separator

The no. of products in the category.
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 Chapter 12   Categories, Product Types and Products 157

➔ Categories Separator between links Status
➔ Categories Box - Show Specials Link 
➔ Categories Box - Show Products New Link 
➔ Categories Box - Show Featured Products Link 
➔ Categories Box - Show Products All Link  
➔ Categories Separator between the Category Name and Count 
➔ Categories Separator between the Category Name and Sub Categories 
➔ Categories Count Prefix 
➔ Categories Count Suffix 
➔ Categories SubCategories Indent 
➔ Categories with 0 Products Status 
➔ Categories – Always Open to Show SubCategories 
➔ Main Page – Opens with Category

Most of the above fields are self-explanatory and you can visually inspect their impact by specifying
different values for them. However, there are two fields which you might need to pay more attention to as
explained below.

The meaning of Categories - Always Open to Show SubCategories is not immediately obvious to the eye
when you first enable it. If enabled, it tells Zen Cart to show the sub-category that is holding the currently
displayed product. If it is disabled, you will always see the top-most categories no matter which product you
are currently viewing in a sub-category.

The purpose of Main Page - Opens with Category is to show products from a specific branch of your
catalog to visitors that reach your site for the first time. For example, if you have a category called
“Pineapples” that is under the “Fruits” category as shown in the preceding Categories side-box, you can
make use of the Main Page - Opens with Category field to automatically display all items in the
“Pineapples” category when a visitor reaches your site for the first time.

The Categories Tab Menu

The categories tab menu appears across your store header. To enable this option, click on Configuration > Layout
Settings and set Categories-Tabs Menu ON/OFF to 1. The following screen shot of two example categories (i.e.
Fruits, Drinks) gives you an idea of where the categories tab menu is located in your store header.

Note that only top-level categories will be shown in the tab menu.

Categories Displayed as Images on the Main Page

Categories can also be displayed as images on the main page itself. To enable this option, click on Configuration >
Layout Settings and set Categories - Always Show on Main Page  to 1. The following screen shot of two example
categories (i.e. Fruits, Drinks) gives you an idea of where category images are located in the main page of your store.
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158 e-Start Your Web Store with Zen Cart

Again, only pictures of top-level categories will be shown on the main page.

Adding a Category

To add a category to your store catalog:

1. Click on Catalog > Categories/Products to access the Categories/Products screen. 

If you click on the green tick icon (not shown in the screen shot) next to the Go To field, the screen will be
refreshed and a drop-down list box will appear in place of the green tick icon. The drop-down list box allows
you to quickly navigate to a different part of the store catalog hierarchy.

2. Click on new category to proceed to the category details page. 

Choice of HTML
 or plain-text editor

 when writing 
product/category/metatag 

descriptions

Click on it to quickly
 jump to any category.
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 Chapter 12   Categories, Product Types and Products 159

3. Enter a name for the category in the Category Name field.

4. Enter a description for the category in the Category Description field. 

5. To specify an image for the category, choose one of the following methods below:

  The first method is to upload your image to the server via your browser.
➔ Search an image file from your local computer by clicking the Browse button next to the Category

Image field. For a discussion on image file sizes, refer to “Optimizing Image Sizes” on page 374 for
more information. 

➔ Choose a directory which you want to use to store the image from the Upload to Directory drop-
down list box. The default value of categories  refers to <zc-home>/images/categories

under the web server. The other values in the drop-down list box refer to sub-directories located
under <zc-home>/images . 

  The second method is to upload your image via FTP to your server.
➔ The image you upload via FTP should be placed in the <zc-home>/images directory or its sub-

directory.
➔ After your image is uploaded, type in the name of the file in the filename field. If the file on the

server is <zc-home>/images/beverage.gi f, type the value beverage.gif . If the file on the
server is <zc-home>/images/drinks/beverage.gi f, then type the value
drinks/beverage.gif  instead.

Note that you can type none  into the filename field to remove an image you have uploaded previously.
However, this method does not work with Internet Explorer. 

6. Enter a number for the Sort Order field which specifies the sequence which this category will be displayed
with respect to other categories.

7. Click save to save your information. Your new category will appear in the Categories/Products screen. 
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Restricting Categories Based on Product Types

After you have created a category, you can choose to restrict the product types that the category can hold. In this
way, you reduce errors while adding products to the category. 

For example, if your store sells music CDs. You will likely choose to use the Product-Music product type when
creating a music CD in your store catalog because this is the only product type in Zen Cart that contains the
following fields: music genre, artist and record company. By restricting the category you wish to hold the music CD
to contain only products of Product-Music product type, you will not make the mistake of using another product type
when creating music CDs in that category.

Note that category restrictions based on product types only affects the creation of new products in the affected
categories. Any products created based on other product types currently in the affected categories will not be
affected.

To restrict a category to allow only products of a particular Product Type:

1. Click on Catalog > Categories/Products to access the Categories/Products screen. 

2. Click on the green “e” icon in the row containing the category which you want to set up a restriction. The
category's details screen should appear.

3. Navigate to the bottom of the screen and you should see something similar to the following screen shot.

4. From the Restrict to Product Type drop-down list box, choose the product type you wish to restrict this
category to.

5. Click on Add include SubCategories if you want the restriction to apply to all sub-categories under this
category. Click on Add without SubCategories if you want the restriction to apply only to the immediate
sub-category instead of subsequent sub-categories after the immediate sub-category. All additions are
immediately saved in the database. 

Note that sub-categories created after restrictions have been applied to the parent categories will not inherit
the restrictions of the parent categories.

6. Repeat Steps 4 and 5 to restrict this category to other Product Types.

Note that there is no visual cue to indicate that a category contains restrictions. You should check the parent category
whenever you do not see a full list of product types available to you when creating a product. Furthermore, there is
no way you can tell whether a category contains restrictions via Add include SubCategories or Add without
SubCategories. Therefore, it is always a good idea to write down your changes and keep a manual record.

Moving Categories

Zen Cart allows you the flexibility of moving categories around the catalog. All products and sub-categories under
the particular category to be moved will also be moved automatically.
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 Chapter 12   Categories, Product Types and Products 161

To move a category:

1. Click on Catalog > Categories/Products to access the Categories/Products screen. 

2. Click on the purple “m” icon in the row containing the category which you want to move. You should see a
screen similar to the following screen shot.

3. Choose the destination category to move to from the drop-down list box.

4. Click on move to move the category to the destination category.

Working with Product Types

All products created in Zen Cart belong to a particular Product Type. Product types define the default properties of a
product and whether these properties are shown to a customer. Furthermore, different product types might be handled
differently by Zen Cart. The main reason for the use of Product Types stems from the fact that different product types
will need to be displayed differently. For example, a song is different from a car because songs need properties like
artist, recording company, etc, whereas a car will be more concerned with the manufacturer and model. 

Do not be confused between Product Types and Categories since products need to belong to both of them. Categories
only affect how your products are arranged your store's online catalog whereas Product Types control the properties
(model, manufacturer, etc) that are associated with your product.

There are currently five product types in Zen Cart:
 Product-General 
 Product-Music 
 Product-Free Shipping 
 Document-General 
 Document-Product 

Editing a Product Type

Each Product Type has two sets of properties:
 Definition properties.
 Layout properties.
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162 e-Start Your Web Store with Zen Cart

Editing Definition Properties 

Definition properties specify the characteristics of a product type. It is of interest mainly to people who want to
customize a product type or to create new product types in Zen Cart. As there is seldom any need to edit the
definition properties of a Product Type unless you are a programmer, we shall only go through the meanings of the
fields for those who are curious.

To edit the definition properties of a particular Product Type:

1. Click on Catalog > Product Types to access the Product Types screen. 

2. Choose a product type and click on edit to bring up a side-panel similar to the following screen shot.

Most of the fields are self-explanatory except the following:
 Handler Page - This field is used to indicate which PHP program should be used to process this

particular product type. Do not edit this field unless you are very sure you know what you are doing! 

 Product Type Default Image – If you upload an image here, Zen Cart will use this default image if
you do not specify an image when creating products belonging to this Product Type. It is reserved for
future use, therefore, do not specify anything here.

 Upload to Directory – This option is useful only if you have specified something for the Product
Type Default Image field. 

 This Product can be added to cart – If unchecked, it means users cannot purchase this product
because they cannot add it to the shopping cart. 

3. Click on save if you have made any changes. 
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Editing Layout Properties 

Layout properties affect the display of certain product-related properties either in the Store Front or Admin Console.
Different product types might even have different sets of product-related properties. For example, the Product-Music
product type has a unique “recording company” property which is non-existent in other product types. The
Product-General product type has a “manufacturer” property not found in the Product-Music product type.

To edit layout properties of a particular Product Type:

1. Click on Catalog > Product Types to access the Product Types screen. 

2. Choose a product type and click on edit layout to access the layout properties screen. A sample screen shot
of what you will see for a Product-General product type is shown below.

The Product Free Shipping Image Status - Catalog field and properties beginning with “Show” affect the
display of a product's properties in the Store Front. Other properties relate to the default status of certain
fields in a product when you start customizing the product in the Admin Console.

3. Select any field you wish to change and then click edit when the corresponding side-panel appears.

4. If you have made any changes to a field, click on update in the side-panel to effect your changes. 

Creating Products and Services

Before you add a product to your store, you must first determine what product type you want the product to belong
to. As we have discussed in Product Types, you will need to choose between the five different product types. 

Under normal circumstances, you will usually choose to have products belong to either the Product-General,
Product-Music or Document-Product product types. This is because a product that belongs to the Document-General
product type cannot be added to a shopping cart and thus customers cannot buy the product. You will usually not
offer free shipping for your products (Product-Free Shipping) unless they are downloadable goods because free
shipping (especially international) can erase a substantial amount of your revenue.

After going through how to add products and services to your catalog in this chapter, you will find the process very
tedious and repetitive if your products have similar attributes and values. You can alleviate this problem and save
time for yourself by duplicating products you have created. We shall discuss the techniques to accomplish this in
“Duplicating Products” on page 218 in a later chapter.
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Product Manufacturers

Before we discuss how to add products of each of the product types to your store catalog, let us take a slight detour
and look at the process of creating a manufacturer for a product. This is because a manufacturer needs to be created
first before you can select it as a value when creating your product. A manufacturer field is available for products
belonging to the following product types: Product-General, Document-Product and Product-Free Shipping.

There are two side-boxes that cater specifically to manufacturers as shown in the following screen shots.

If a product has a value specified for its manufacturer field, Zen Cart will place a Manufacturers side-box in your
Store Front. By clicking a hyperlink in the Manufacturers side-box, a list of products belonging to the same
manufacturer will be displayed. Thus, customers can quickly locate a product they are interested in based on
information they have on the name of the manufacturer.

For example, if your store sells mobile phones and accessories, you might decide to place your products into two
separate categories: Phones and Accessories. However, most people are loyal customers of a particular brand and
will only purchase accessories and phones of a common brand due to interoperability issues. For these customers,
getting to their choice of products is easier via the Manufacturers side-box rather than browsing the Categories side-
box.

The Manufacturer Info side-box appears only when you are at the Product Info page of a product. By clicking on the
Other products hyperlink in this side-box, you will also be shown a list of products that come from the same
manufacturer.

To create manufacturers in Zen Cart:

1. Click on Catalog > Manufacturers to access the Manufacturers screen.

Notice that there is a number next to the words Products underneath the product image. This indicates the
number of products that are linked to this manufacturer. If the value is zero, this manufacturer will not be
shown in the Manufacturers side-box.

2. Click on insert to access the manufacturer detail screen.
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 Chapter 12   Categories, Product Types and Products 165

3. Enter the name of a manufacturer into the Manufacturers Name field.

4. To specify an image for the manufacturer, follow the same instructions as you did on page 159 when you
specified an image for a category. The difference this time is the default directory where files are uploaded is
manufacturers , which corresponds to the <zc-home>/images/manufacturers  directory on the
server.

5. Specify the web address of the manufacturer in the Manufacturers URL  field; e.g. http://www.clubs-
handphones-technologies.com

6. Click on save to save your changes.

Creating a General Product

Most products that you create will usually belong to the Product-General product type. This product type has the
most number of fields and many of those fields also appear in other product types as well. Therefore, we shall make
use of it to help explain and point out the differences between it and other product types.

Before you begin to create a General product:

1. Click on Catalog > Categories/Products to access the Categories/Products screen.
 

2. Navigate to the category within which you want to create your product. Create one if you have not done so.

To create a General product:

1. Click on the select box at the bottom of the screen and choose Product  -  General   to create products of this
type. 

2. Click on new product to access the Product screen. 
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166 e-Start Your Web Store with Zen Cart

3. To correctly specify the details for your product, refer to the following table for an explanation of the
different fields.

4. After you have entered your desired values, click on preview to upload any images and see whether there are
any warnings or errors in your entries. 
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 Chapter 12   Categories, Product Types and Products 167

5. Click on insert to save your changes in the database. 

The following table explains the meanings of all the different fields for the Product screen of a product belonging to
the Product-General product type. Most of the fields can be used as a reference for other product types as well.

Table 12.1: Explanation of Product-General settings   (continued)

Field Comments

Products Status If a product is marked as Out of Stock  the product will not appear in your store. 

Each time a product is sold, the value in the Products Quantity field will be
decremented. When the Products Quantity field reaches zero, this field will
automatically switch to Out of Stock . 

For further discussion on how Out of Stock settings can be customized, refer to
“Configuring Stock Settings” on page 306.

Date Available If the product is already in stock, leave this field empty.

If you specify a future date, a customer is still able to view and purchase the product.
The product will be displayed in the “Upcoming Products” list in your Store Front and
the product's Product Info page will also highlight the date that the product will be in
stock. 

Products Manufacturer Allows you to specify the manufacturer of a product; e.g. if you sell cars, you can have
Ford, Toyota, etc as the manufacturers.

You need to enter the list of manufacturers first before you can see any of your choices.
Refer to “Product Manufacturers” on page 164 for details.

Products Name This is the name of the product that customers see.

Product is Free Marking Yes will override all prices and discounts you have applied for the product
and cause the product to be free! The customer will still see whatever discounts that
were applied but will not be charged anything for the product during the checkout
process.

Try not to specify a value for Products Price (Net) field if you do not want to confuse
your customers when you set this field to Yes. This feature is good for occasions when
you want to give away product samples to customers for them to try before they buy.
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Table 12.1: Explanation of Product-General settings   (continued)

Field Comments

Product is Call for
Price

Behaves similarly to “Product is Free” except that the product will have a “call for
price” image instead. Customers also cannot add the product to cart.

Try not to specify a value for Products Price (Net) field if you do not want to confuse
your customers if you set this field to Yes .

Product Priced by
Attributes

You will see in the next chapter that you can add extra, self-defined attributes to your
products. If you choose to price your products based on attributes (color, size, etc), you
can make use of this field to decide how you want to display your product prices.

Let us take the case where you sell a PC at a base price of $1000 with a default of
256MB RAM. You want to allow your customers to be able to add extra RAM via
options to have 512MB (add $100) or 1GB (add $200).

If you set this option to No. Your product details will appear to your customers as
follows.

Products Price $1000
256MB
512MB (+$100)
1GB (+$200)

If you set this option to Yes . Your product details will appear to your customers as
follows.

Products Price starting at $1000
256MB ($1000)
512MB ($1100)
1GB ($1200)

Essentially, what this attribute does when set to Yes is to show the total price of a
product with the prices of the attributes added; whereas if it were set to No, then prices
are seen to be incremental. Which option you choose is entirely up to aesthetics and
how you want to present your product pricing.

Tax Class Allows you to automatically calculate the Products Price (Gross) value using the
value you specify for the Products Price (Net) field. Refer to “Adding a Tax Class”
on page 111 for details on setting up a tax class.

The default tax class can be specified in the Product Price Tax Class Default -
When adding new products? field under the layout properties of this product type in
Configuration > Product Types.

Products Price (Net) This is the base price of your product. It is usually your selling price.
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 Chapter 12   Categories, Product Types and Products 169

Table 12.1: Explanation of Product-General settings   (continued)

Field Comments

Products Price (Gross)This is the price of your product after applying the tax rate specified in the Tax Class
field. If you find that your value looks strange, check whether it has to do with multiple
tax rates by referring to “Compounding or Adding Different Tax Rates” on page 113.

Product is Virtual Normally you would specify No, Shipping Address Required  if you need to
ship any physical goods to your customers. However, if your store offers professional
services (accounting, law consultation, etc) to your customers and you do not need to
ship any physical products, then you can specify Yes, Skip Shipping
Address . 

If you specify Yes, Skip Shipping Address  for this field, you are implying
Always Free Shipping is marked Yes, Always Free Shipping , even if you
set it to No, Normal Shipping Rules ! 

Special, Product/Download Combo Requires a Shipping
Address  is used only if you want to provide both a downloadable product and a
physical product to be sent to your customers.

The default virtual status can be specified in the Product Virtual Default Status -
Skip Shipping Address - When adding new products? field under the layout
properties of this product type in Configuration > Product Types.

Always Free Shipping Indicates whether you want to offer Free Shipping for this product. If you set it to No,
Normal Shipping Rules , then all the rules you specified in your shipping
modules will kick in.

Note: If you specified Product is Virtual  to be Yes, Skip Shipping
Address , then this field is automatically assumed to be Yes, Always Free
Shipping  regardless of what you specify for it.

The default free shipping status can be specified in the Product Free Shipping
Default Status - Normal Shipping Rules - When adding new products? field
under the layout properties of this product type in Configuration > Product Types.
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Table 12.1: Explanation of Product-General settings   (continued)

Field Comments

Products Quantity Box
Shows

If set to Yes, Show Quantity Box , the customer sees:

If set to No, Do not show Quantity Box ,  the customer sees:

In the second case, each customer is restricted to purchasing the quantity specified in
the Product Qty Minimum  field. This feature comes in handy if you offer digital
downloads for sale. Customers will only need one copy of a digital download because
they can easily make extra copies themselves. Thus, you can save customers the trouble
of entering the number of items they want to purchase by specifying Product Qty
Minimum  as 1 in this case.

Product Qty Minimum Indicates the minimum number of items of a product a customer must buy. It is also
commonly known as the “minimum order quantity” in layman terms.

If a customer enters less than the minimum quantity allowed, the system will display an
error message prompting the customer to  adjust the quantity.

This option is useful when you are offering an extremely low priced product which will
only turn in a profit if a minimum number of items are sold.

Product Qty Maximum Indicates the maximum number of items of a product a customer is allowed to buy.

If a customer enters more than the maximum quantity allowed, the system will
automatically adjust the quantity to be equal to the maximum allowed quantity. This
option is useful when you have products that are in high demand and you want to avoid
angering your customers if one of them buys a large amount at one go thus depriving
other customers of a chance to buy the product.
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Table 12.1: Explanation of Product-General settings   (continued)

Field Comments

Product Qty Units This option limits customers to purchasing in fixed quantities. For example, if you
specify the value to be 5, then customers can only order in quantities of 5, 10, 15, etc. 

The wording to potential customers may not be very intuitive though. You can see this
in the screen shot below where it states “Units: 5” which limits your customers to
purchasing in quantities of 5. 

This option is useful when you have goods already packed neatly in fixed quantities. By
not taking out the goods and selling separately, you can save yourself any leftover
goods and maybe help your shipping costs as well. 

Product Qty Min/Unit
Mix

If you have defined custom attributes for a product, you can make use of this field to
control what quantities of a product (based on attributes) customers are allowed to buy
from your store.

Let's say you sell canned tuna and have defined an attribute “flavor” with three possible
values: curry sauce, tomato sauce and olive oil. Assume you have set up the following
fields as follows:
Product Qty Minimum  = 4
Product Qty Maximum  = 12
Product Qty Units = 1

The above quantity settings mean the customers can only buy the canned tuna in
quantities of: 4, 5, 6, 7, 8, 9, 10, 11 or 12.

If Product Qty Min/Unit Mix  is No. Besides adhering to the above quantity settings,
customers are also limited to ordering tuna packed in one of the flavors only. 

If Product Qty Min/Unit Mix  is Yes . Although they still have to adhere to  the
above quantity settings, they are now allowed to mix-and-match the different flavors of
tuna in different quantities e.g. 2 cans in curry sauce, 3 cans in tomato sauce and 7 cans
in olive oil.
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Table 12.1: Explanation of Product-General settings   (continued)

Field Comments

Products Description Enter the description for your product here. Use the HTMLarea to enter and format
your text to make your descriptions really stand out. Use the Plain Text editor if you
plan to enter raw HTML source code or you just want to enter some text without any
fancy formatting.

Products Quantity Indicates the amount of stock you have for the particular product. If you do not specify
a value, it defaults to 0. 

If a customer places an order (e.g. 4 units) for a product that has limited stock available
(e.g. 1 unit left), a warning message will be displayed in the Shopping Cart page as
shown in the following screen shot.

If all your units are sold, then Zen Cart automatically marks the Product Status as
Out of Stock  and disables the product.

The customer will not be able to see the product in your product catalog or anywhere in
your Store Front if it is disabled.

If you enable the product by toggling the red button in the Categories/Products screen
but still leave its Product Status as Out of Stock , then the customer will see a
Sold Out sign instead of the usual Add to Cart button when viewing the product. An
example of what the Sold Out sign looks like is shown in the following screen shot.

Either way, customers will not be able to make any purchases once a product is out of
stock.

For further discussion on how Out of Stock settings can be customized, refer to
“Configuring Stock Settings” on page 306.
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Table 12.1: Explanation of Product-General settings   (continued)

Field Comments

Products Model Used to specify a model for your product. Customers can perform a search in your store
based on a product's model. 

Products Image To specify an image for the product, follow the same instructions as you did on page
159 when you specified an image for a category. Note the existence of two extra
options for a product image compared to a category image.

For the Delete Image option:
 Set to Yes if you want to disassociate the current image with the product. No

new product image will be uploaded.
 Set to No if you want to use another image with the product.

For the Overwrite Existing Image on Server option:
 Set to Yes if you need to upload an image which has changed but still

maintain the previous name or you simply want to upload a new image after
clicking the Browse button.

 Set to No if want to use an image which has already been uploaded via FTP to
the desired directory on your server. You can type the name of the uploaded
file in the filename field.

Products URL Used to point a customer to another web site which might contain more information for
the product. For example, you can type in a URL in the following form:
www.greatphones.com/pico.html .

If a value is entered for this field, the following line will appear under a product in the
Product Info page in your Store Front. 

Note that the words “webpage” is a hyperlink and it points to the URL you specified for
this field.

Products Weight Allows you to specify a weight. The default weight is 0 if you leave this field blank.
The default unit of measurement is pounds (lbs). 

If weight is 0, you might accidentally cause shipping to be free if you have enabled
Order Free Shipping 0 Weight Status under Configuration >
Shipping/Packaging. Therefore, make sure you check that setting if you intend to set
this field to 0 or leave it blank.

Sort Order Specifies the sequence in which this product should be displayed. Default is 0.

By default, all quantities specified in the Product page must be in whole units. To allow customers to buy products in
fractional units, click on Configuration > Stock and change the Product Quantity Decimals field accordingly. For
information on other stock settings, turn to page 306 for more details.
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Creating a Music Product

Zen Cart provides explicit support for music-related products via the Product-Music product type. Products that are
of Product-Music product type will have an additional three fields available to them.

 Recording Artist
 Record Company
 Music Genre

To see these three fields appearing in the Product Info page in the Store Front, make sure that the layout properties of
the Product-Music type under Catalog > Product Types has the following fields enabled:

 Show Artist
 Show Music Genre
 Show Record Company

The Record Companies and Music Genre fields give rise to the following two side-boxes. The Record Artist field
currently has no effect but a side-box might be added in future.

To specify the information for the Record Artists, Record Companies and Music Genre fields, look into the
screens accessible by clicking the following menu entries.

 Extras > Record Artists
 Extras > Record Companies
 Extras > Music Genre

To create Music products, follow the same steps as you did when creating a General product. The fields you see will
depend on what you have enabled on the layout properties of the Product-Music type under Catalog > Product
Types.  

Before you begin to create a Music product:

1. Specify the information you want to relate to your Music product in the respective screens below:
 Extras > Record Artists
 Extras > Record Companies
 Extras > Music Genre

Because the above screens are self-explanatory, we shall not go through the screen shots here.

2. Click on Catalog > Categories/Products to access the Categories/Products screen.
 

3. Navigate to the category within which you want to create your product. Create one if you have not done so.

To create a Music product:

1. Click on the select box at the bottom of the screen and choose Product  -  Music   to create products of this
type. 
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2. Click on new product to access the Product screen. The screen is exactly the same as the one you have when
creating a General product. The only difference is the emergence of the music-related fields which replaces
the Manufacturer  field in the General product screen.

3. Enter the details for your product. Refer to the table under the “Creating a General Product” section for an
explanation of those non-music related fields.

4. After you have entered your desired values, click on preview to upload any images and see whether there are
any warnings or errors in your entries. 

5. Click on insert to save your changes in the database. 

If you would like to add sample clips or other materials to your Music product, you can refer to “Providing Music
Samples” on page 207. If you would like to offer your Music products as downloads, refer to “Selling Downloadable
Products” on page 210 for details on how to create downloadable products.

Creating a Document

To create documents in your store, you can make use of either the Document-General or Document-Product product
types. Products that belong to the Document-General product type cannot be purchased by customers. You can use
such products to offer free information to your customers: FAQs, free articles, brochures, etc. On the other hand,
products that belong to the Document-Product product type act like normal products which can be sold at a price.

Only products that belong to the Document-General and Document-Product product types can be displayed in a
separate Documents side-box in your Store Front. This allows your customers to easily separate normal products
(displayed in the Categories side-box) from document products in your store. 

Before you begin to create a Document product:

1. Check that you have enabled the Split Categories Box field under Configuration > Layout Settings to
separate the display of products based on their Product Type definitions.

2. Check that the Documents side-box can be displayed by enabling the sideboxes/document_categories.php
field via Tools > Layout Boxes Controller.

3. Click on Catalog > Categories/Products to access the Categories/Products screen.
 

4. Navigate to the category within which you want to create your product. Create one if you have not done so.

5. Make sure that you restrict the category to contain at least the following types.
 Document-General 
 Document-Product
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Only categories that contain a restriction on the Document-General product type will be displayed in the
Documents side-box. However, products of Document-General type cannot be purchased as they cannot be
added to cart. Therefore, you will also need to specify an additional Document-Product type restriction to the
category so that the document products you create can be sold.

To learn how to restrict categories to contain only products that belong to specific product types, refer to
“Restricting Categories Based on Product Types” on page 160 for details.

To create a Document product:

1. Click on the select box at the bottom of the screen and choose either Document  -  Product   if you want to be
able to sell your documents or choose Document  -  General   if you only want to showcase a document
(perhaps an article you find interesting). 

2. Click on new product to access the Product screen. If you chose Document  -  Product   when creating this
product, your screen will be identical to the one you saw when creating a General product. If you chose
Document  -  General   when creating this product, you will be presented with a screen similar to the one in
the following screen shot.

3. All the fields for the Document-General product (as seen in the preceding screen shot) are self-explanatory so
we shall not discuss them further. If you have chosen Document-Product when creating this product, you can
refer to “Creating a General Product” on page 165 for the steps to configure your product because the
meaning of the fields are similar. 

4. After you have entered your desired values, click on preview to upload any images and see whether there are
any warnings or errors in your entries. 

5. Click on insert to save your changes in the database. 

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


 Chapter 12   Categories, Product Types and Products 177

Creating a Service

What if your store sells services (accounting, legal or insurance, etc) instead of physical products which need to be
delivered? Well, one way is to treat a Service as a General product and set its Product is Virtual  field to Yes,
Always Free Shipping . If all items in a customer's shopping cart are virtual products and you have enabled the
Free Shipping shipping module, Zen Cart will automatically skip the Delivery Information page and bring the
customer to the Payment Information page.

Another way is to use the Product-Free Shipping product type when creating your service. By default, products that
belong to this product type do not have their weights displayed in the Store Front and are set to free shipping. Most
services do not require any physical delivery of goods, so you will also want to consider turning off the display of the
Free Shipping icon when displaying products of this product type. 

To disable the display of the Free Shipping icon in the Store Front for products of Product-Free Shipping product
type:

1. Click on Catalog > Product Types to access the Product Types screen.

2. Click Product-Free Shipping under the Product Types column and concentrate on the side-panel.

3. Click the edit layout button on the side-panel to proceed to a screen containing definition properties for this
product type.

4. Edit the Product Free Shipping Image Status – Catalog field and set the value to No.

5. Click update to save your changes.

Summary

We have covered the basic building blocks that make up your store catalog. You have seen how categories can be
created and manipulated. You have also learned about the different product types available in Zen Cart and which
product type to use when creating your products or services. You should be able to easily create and manipulate
items in your store catalog.
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Chapter 13 Product Attributes

Introduction

You may need to specify custom attributes when you starting adding products to your store. For example, if your
store sells shoes, you’ll most likely want customers to be able to choose what size and material they want. You can
even attach price and weight information to each custom attribute. 

In this chapter, we shall:
 Familiarize you with the general steps to adding a product attribute.
 Learn how the Attribute Controller screen works and its different attribute flags.
 Learn about attribute images, attribute pricing and attribute weighting.
 Know how to copy/add/delete attributes affecting individual products or several products at once.
 Learn how to sort product attributes.

Adding Attributes to a Product

Zen Cart allows you to create attributes for all Product Types. Each attribute is defined by an option name and
several option values. Because the addition of other attribute properties (pricing, images, etc) can be very confusing,
we shall start off with how to create a product attribute first. Once you are familiar with this step, you will be more
confident in tackling the topics on attribute properties.

Before you begin adding a product attribute, make sure you have already created the product to which you want to
add an attribute.

There are essentially three steps to creating an attribute for a product.
1. Create option name.
2. Create option value(s).
3. Link attribute to product.

Step 1 of 3: Create Option Name

1. Click on Catalog > Option Name Manager to access the Product Options screen. 

2. To simplify the look of this screen, choose Display Global Features – OFF  from the drop-down list
box as shown in the following screen shot.

179
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180 e-Start Your Web Store with Zen Cart

3.  Concentrate on the following part of the screen to begin configuring your option name.

4. Specify the following details for your attribute: 
 en – Your attribute name in English. 
 Order – The sequence in which your attribute will be arranged next to other attributes. By default, a

lower value will make your attribute appear before any attributes with a higher value. 
 Option Type – Determines how your option values can be selected. Refer to the following table for

the appearance of your option based on your selection.

Option
Type

Example of how option values
appear in the Store Front

Comments

Dropdown Customers will need to choose one of the choices
listed.

Text Customers specify their own words. No choices
will be provided even if they are defined. 

We shall use the terms “text-field” and “text-area”
to refer to the two screen shots on the left. A “text-
field” only allows a single line for text input while
a “text-area” allows multiple lines for text input.

Note: If this attribute is compulsory and you want
to force your customers to enter something before
allowing them to add products to the cart, enable
the Attribute Required for Text  field when we
talk about Attribute Flags later in this chapter.

Radio Customers can choose only one of the choices
listed. 

Note: Once a radio button is selected, none of the
radio buttons can be de-selected.

Checkbox Customers can choose zero or more choices. 
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Option
Type

Example of how option values
appear in the Store Front

Comments

File Customers can specify a file on their local
computers to upload to your store. 

Two conditions need to be satisfied before users
can have their files uploaded successfully. Click on
Configuration > Maximum Values to specify
these conditions. The Allowed Filename
Extensions for uploading ensures that only files
with the specified extensions can be uploaded. The
Maximum File Upload Size places an upper
limit on the file sizes users can upload.

The file will be uploaded into the <zc-

home>/images/uploads directory on the web
server and be renamed into a number with the
original file extension; 1.pdf, 2.pdf , 3.jpg, 4.bmp,
etc. However, users will not notice this because the
original filenames will still be presented to them in
the Store Front.

Read Only Customers can only view the available choices but
they are not allowed to choose. This option is
usually used to inform customers of something
instead of telling them to take a specific action.

5. Click on insert to create your option name. The screen should be refreshed with your option name saved in
the database. 

6. To set additional properties for the option name you just created, click on the corresponding edit button.

7. If you have specified the Option Type to be Text , you can specify a non-zero value for the Rows field and
a “text-area” will appear to the customer instead of the default “text-field”. The Display Size controls the
number of visible character columns whereas the Maximum Length limits the amount of text a customer
can enter. 

8. Make any other changes you require and click on update to save your settings.
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182 e-Start Your Web Store with Zen Cart

Step 2 of 3: Create Option Value(s)

If you have chosen File  or Text  for the Option Type field of your attribute name in the Option Names screen, you
will not need to specify an option value. For all other option types, use the following steps to create your option
value(s).

1. Click on Catalog > Option Value Manager to access the Option Values screen.

2. To simplify the look of this screen, choose Display Global Features – OFF  from the drop-down list
box as shown in the following screen shot. 

3. Concentrate on the following part of the screen to begin configuring your option value(s).

4. Select the option name to which you want to add your option value from the drop-down list box under the
Option Name column. Specify the option value name and sort order in the respective Option Value and
Default Order columns.

5. Click on insert to associate the option value with the option name. Your screen should be refreshed with
your option name and option value saved in the database.

6. Repeat Steps 4 and 5 if you need to add another option value to your option name. 

Step 3 of 3: Link Attribute with Product

1. Click on Catalog > Attributes Controller  to access the Attributes Controller screen. 

2. Select a category from the drop-down list box which contains the product to which you want to add an
attribute. 

3. Choose your desired product from the product list and click display. 

4. Concentrate on the portion which allows you to associate the option name you created previously with the
product you want. 
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5. Click your choice of Option Name and Option Value to associate with the product. Note: You must choose
both an option name and an option value. Many people make the mistake of choosing either an option name
or an option value only.

If the value you selected in the Option Name list is of File or Text type, you should only choose TEXT
[RESERVED FOR TEXT/FILES ONLY ATTRIBUTES]  in the Option Value list.

6. Click on insert to save the association between the attribute and the product. 

7. Repeat Steps 5 and 6 to add another attribute option names and/or option values to the product.

Understanding How Attribute Flags Work

After having gone through the Attributes Controller Screen, you may have noticed some attribute flags appearing in a
multi-colored row as shown in the following screen shot. These flags control further properties of each attribute so it
is important that you do not overlook them.

 
You can change the default values for these flags by clicking on edit layout for the respective product types under
Catalog > Product Types. Using a sample layout setting from the Product-General product type, you can see that the
settings match the attribute flag's default settings exactly.

The meaning of the individual attribute flags are explained in the following table.
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Table 13.1: Meaning of individual attribute flags   (continued)

Attribute Flag Meaning

Used for Display Purposes
Only

Indicates that this attribute is meant for informational purposes only.

For example, if this attribute is part of a group of options (Dropdown,
RadioButton, Checkbox), and its flag is set to Yes, when customers
click on the attribute choice and then select Add to Cart, an error
message will be shown indicating that the attribute cannot be chosen.
Other attributes, however, can be chosen.

If this attribute is a Text or File, then nothing should be entered into the
respective fields or a similar error message will appear when
attempting to add the product to a cart.

This flag has no effect on attributes that are of ReadOnly type.

Attribute is Free When Product
is Free

If you have specified a price for an attribute but marked your product
as free, you can specify whether that makes the whole product free or
whether you still want to charge your customers based on the price of
the attributes alone.

For example, you sell old tower clocks and you have specified that they
come with attributes like gold or silver needles which each cost money.
If you decide to make your old tower clocks free, you should then
decide whether you should charge your customers extra if they choose
the gold or silver needles.

Default Attribute to be Marked
Selected

Applicable only if your attribute is of option type Dropdown, Radio or
Checkbox. This will automatically set this option value as the default
option selected from the list of option values.

For example, if you have option values of “white”, “red”, “blue” and
“green” for a T-shirt. You can set the option value of “white” to be the
default selected attribute by setting this field to Yes.

Apply Discounts Used by
Product Special/Sale
 

Indicates whether the same discount percentage should be applied to
this attribute as it applies to a product. Refer to “Order Totals,
Surcharges and Discounts” on page 225 for details on Specials and
Sales.

For example, if the price of a product is $30 and a sale of 50% is given.
That means the product costs $15. If an attribute is originally priced at
$5, then if this flag is set to Yes, the attribute price after discount
would be $2.50.

However, if this flag is set to No, then the attribute price will remain at
$5 although the product is at the discounted price of $15.
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Table 13.1: Meaning of individual attribute flags   (continued)

Attribute Flag Meaning

Include in Base Price When
Priced by Attributes 

This flag is only effective when a product has its Product Priced By
Attributes  field in the Product page of the Admin Console marked as
Yes. Refer to page 168 for more details on that field.

It takes the smallest amount in a group of option values and adds it to
the product's base price to come up with a starting price which the
customer sees.

Let's use an example to illustrate how this option works when all option
values have this flag set to Yes.

Suppose you have a “size” attribute with three options priced at $5,
$10, $25 for “small”, “medium” and “large” sizes respectively. The
product cost price is set at $30. Thus, a customer in the Product Info
page of your Store Front will see a price tag of “Starting at $35” instead
of “$30”. 

Attribute Required for Text If your attribute is of option type Text, you can make it into a
compulsory field. Users will be forced to enter some text before they
are allowed to add the product or service to the cart. 

An example would be the wordings on a cake.  You can force users to
enter the wordings they want on the cake by setting this option to Yes.

You should now have no problems when we discuss how you can specify additional price and weight information for
your attributes later in this chapter.

Attribute Images

You can specify different images for your attributes to help your customers better visualize the end-product or
service. For example, you can have a different color T-Shirt represent your T-Shirt's color attribute as shown in the
following screen shot. 
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186 e-Start Your Web Store with Zen Cart

Before you specify images to represent your product or service:
 Make sure you have created the product and its required option names and option values.
 Make sure that Enable Attribute Images is set to true  under Configuration > Attribute Settings.

To specify an image to represent each attribute:

1. Click on Catalog > Attributes Controller  to access the Attributes Controller screen.

2. Choose the appropriate category from the drop-down list box and your screen will be refreshed with products
from the previously selected category. Note: The (*) next to certain categories in the drop-down list box
indicates that they contain products.

3. Choose the appropriate product and attribute from the respective boxes and then concentrate on the following
area in your screen. The fields in this portion of the screen behaves similarly to the screen used for creating a
product so we shall not waste time explaining the fields again.

4. Upload the appropriate image to your store by specifying the required values and then click the insert button.

If you go to your Store Front and look at your product, you might not be satisfied with the way the attributes are laid
out on the screen. There are several layout options open to you as well. You can take a look at a few of them in the
following screen shots.
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 Chapter 13   Product Attributes 187

Before you change the layout of your image attributes:

1. Click on Configuration > Product Info  to access the Product Info screen.

2. Check the value of Product Info - Show Option Values Name Below Attributes Image. This field will
cause the text to disappear if the text appears below an image. For example, if the text “Blue” appears below
the blue square, then the text “Blue” will disappear if this option is disabled.

To change the layout of the image attributes:

1. Click on Catalog > Option Name Manager to access the Product Options screen.

2. Click edit for the option name you used for your image attribute previously.

3. Concentrate on the following portion of the screen which specifies how the attribute should be laid out.

4. Edit the Attribute Images per Row and Attribute Style for Radio Buttons/Checkbox fields accordingly.

5. Click update to effect your changes.

6. Go to your Store Front to see whether the attribute layout suits your preference.

Attribute Pricing

Zen Cart provides you the ability to price your products by attributes. For example, if you sell computers, you can set
a base price and then increment the price for each separate accessory or component that is added. If you sell T-shirts,
you can specify different color options and tag a separate price for each color.

While you are going through this section, take note of the effects the following attribute flags might have on your
pricing options:

 Attribute is Free When Product is Free
 Apply Discounts Used by Product Special/Sale 
 Include in Base Price When Priced by Attributes 

Also keep in mind that although we are going through the attribute properties (price, weight, etc) individually, these
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188 e-Start Your Web Store with Zen Cart

attribute properties can actually be combined to yield the desired effect for your products.

By Absolute Value 

The simplest way to price your attributes is to specify a price for selecting the attribute and indicating whether the
price should be incremented or decremented for each product that is bought. The following example screen shot
shows a hotel charging different rates based on the room type specified by a customer.

Before you specify the pricing for an attribute:

 Make sure you have created the product and its required option names and option values. 

 Click the edit layout button of the product type that is linked to this attribute and look at the PRODUCT
Attribute Price Prefix - Default  field. This field specifies whether the attribute price should be incremented
or decremented by default.

To specify a price for an attribute:

1. Click on Catalog > Attributes Controller  to access the Attributes Controller screen.

2. Choose the appropriate category from the drop-down list box and your screen will be refreshed with products
from the previously selected category. 

3. Choose the appropriate product and attribute from the respective boxes and then concentrate on the following
area in your screen.
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 Chapter 13   Product Attributes 189

4. To add the attribute price from the product price, specify a “+” or a blank space in the first box under the
Price field. To subtract the attribute price from the product price, specify a “-” in the box instead.

5. Enter your desired price in the empty box under the Price field.

6. If you want your attribute price to be charged only once regardless of how many items of the product a
customer buys, enter a value in the One Time field. 

7. Enter a number into the Order  field. This field indicates the sequence in which the attributes will be
displayed to a customer. For example, if you have three attributes X, Y, Z in their original sequence of 1, 2, 3
and you change the sequence to 3, 1, 2. Then the attributes will be displayed in this order to the customer Z,
X, Y.

8. Click insert to save your changes to the database.

One Time Charges

The One-Time field which you saw in Step 6 of the previous section allows you to charge a customer only once for a
product attribute when several items of a product are bought. An example is provided below to help you understand
its use.

If you have a product that retails for $20 and a si ngle attribute that adds $1 to the product.
You have also specified that this attribute has a one-time charge of $5. 

Then if the customer buys a total of 3 of your prod ucts with the same attribute, the total
price charged to the customer will be: ($20 + $1 + $5) + ($20 + $1) + ($20 + $1)  = $68

This option is usually applied to one-time setup charges. For example, when you first sign up for a web hosting
account with a web hosting provider, they usually charge you a one-time setup fee and not for subsequent renewals
for the hosting plan.

By Percentage

This pricing mechanism works similarly to attribute pricing by numbers except that it is based on percentage rather
than numbers. It makes use of the concept of price factor and offset to achieve a percentage-based attribute pricing
scheme. Nevertheless, the attribute prices that are displayed are in absolute numbers instead of percentages. The
following example screen shot shows a poster of Einstein which is priced by size and color.
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190 e-Start Your Web Store with Zen Cart

To price your attributes by percentage:

1. Click on Catalog > Attributes Controller  to access the Attributes Controller screen.

2. Choose the appropriate category from the drop-down list box and your screen will be refreshed with products
from the previously selected category. 

3. Choose the appropriate product and attribute from the respective boxes and then concentrate on the following
area in your screen.

To understand the meanings and syntax for the above fields, refer to the section after these steps.

4. To add the attribute price to the product price, specify a “+” or a blank space in the first box under the Price
field. To subtract the attribute price from the product price, specify a “-” instead.

5. To specify a constant price factor and offset for your attribute, enter your desired values in the first two
boxes of the left column under the Price Factor and Offset headings.

6. To specify a one-time price factor and offset for your attribute, enter your desired values in the last two
boxes of the left column under the One Time Factor and Offset headings.

7. Commit all your changes to the database by clicking the insert button.

Price Factor, One Time Factor and Offset

The Price Factor and Offset pricing mechanism calculates the attribute price based on a percentage of the product
price. The formula is as follows:

Attribute Price = (Price Factor – Offset) x Product  Price

The above formula can optionally be combined with the Price field as follows:

Attribute Price = Price + [(Price Factor – Offset) x Product Price ]
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 Chapter 13   Product Attributes 191

The Offset field is a bit of an abstract concept and thus is not quickly understood without some explanation. We shall
use an example to show why this is so. For example, you might want to add 1% (i.e. 0.01) to the price of a car if a
customer chooses a custom paint attribute. 

Car Price = $30,000
Price Factor = 0.02
Offset = 0.01

Attribute price: (0.02 - 0.01) x $30,000 = $300

However, you could achieve the same result using a Price Factor of 0.01 and Offset of 0. This seems to be the easier
and logical way and is shown below.

Car Price = $30,000
Price Factor = 0.01
Offset = 0

Attribute price: (0.01) x $30,000 = $300

So what is the purpose of the Offset field when you can accomplish the same pricing strategy with or without it?
Well, the answer boils down to personal preference. The Offset field is provided to certain store owners who prefer
to enter their attribute pricing according to a “fixed pattern”. 

For example, take the screen shot of the poster of Einstein that was shown initially in this section. If your store sells
posters that come in various sizes and color, then you can implement an attribute pricing strategy based on the pattern
shown below. Notice that there are two main variables that decide the pricing strategy – Print Size and Print Color.

Print Size  Price Factor   Print Color    Offset
 8” x 10”   0.4            B/W            0.2
11” x 14”   0.6            Color          0.1
16” x 20”   0.8

Now that you understand the Price Factor and Offset fields, we shall move on to discuss the One Time Factor
field. The difference between the Price Factor and One Time Factor fields is in how the final product price is
arrived at for product quantities greater than 1. Take a look at the following examples to understand their differences.

Quantity   Product Price  Price Factor   Attribute Price  Total Product Price 
1          10             0.2            2                (10 + 2) = 12
3          10             0.2            2                (10 + 2) x 3 = 23

Quantity   Product Price  One Time Factor  Attribut e Price  Total Product Price 
1          10             0.2              2                (10 + 2) = 12
3          10             0.2              2                (10 x 3) + 2 = 32

By Quantity

Quantity discounts for a product attribute can also be specified in Zen Cart. Once a product attribute contains a
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192 e-Start Your Web Store with Zen Cart

quantity discount, Zen Cart will show a hyperlink on the Product Info page in the Store Front.  The pop-up window
which appears on clicking the hyperlink allows a customer to see the bulk discounts that apply for the product. An
example of an optical mouse with a bulk discount for each type of connector chosen is shown in the following screen
shots.

Before you specify bulk discounts for your attribute:

 Make sure you have created the product and its required option names and option values.

 Make sure that Enable Qty Price Discount is set to true  under Configuration > Attribute Settings .

To specify bulk discounts for an attribute:

1. Click on Catalog > Attributes Controller  to access the Attributes Controller screen.

2. Choose the appropriate category from the drop-down list box and your screen will be refreshed with products
from the previously selected category. 

3. Choose the appropriate product and attribute from the respective boxes and then concentrate on the following
area on your screen.

To understand the meanings and syntax for these two fields, refer to the section after these steps.

4. To specify a constant quantity discount for your attribute, enter your desired values in the Attributes Qty
Price Discount field.

5. To specify a one-time quantity discount for your attribute, enter your desired values in the Onetime
Attributes Qty Price Discount field.

6. Commit all your changes to the database by clicking the insert button.

Click to open pop-up window.
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 Chapter 13   Product Attributes 193

Attributes Qty Discount and Onetime Attributes Qty Discount

The Attributes Qty Discount field allows you to specify bulk discounts for a particular attribute. For simplicity's
sake, we shall assume that this attribute has no other prices attached to it. Consider the case where your store sells an
optical mouse at a price of $29 and a customer chooses only the USB Connector attribute. 

You can specify the bulk discounts for the optical mice with the USB Connector option value as follows:

1:1.00,3:0.75,5:0.50

Customers at the Product Info page in your Store Front can click on a Quantity Discount hyperlink which opens a
pop-up window showing a Quantity Discount Table as follows:

QTY        1       2-3     4+ 
PRICE      $1.00   $0.75   $0.50 

The above table values translate into the following scenarios based on the number of optical mice a customer buys
assuming only the USB Connector attribute is selected.

No. of Optical Mouse bought = 1,   Total Price: ($2 9 + $1.00) x 1 = $30.00
No. of Optical Mouse bought = 2,   Total Price: ($2 9 + $0.75) x 2 = $59.50
No. of Optical Mouse bought = 3,   Total Price: ($2 9 + $0.75) x 3 = $89.25
No. of Optical Mouse bought = 4,   Total Price: ($2 9 + $0.50) x 4 = $118.00
No. of Optical Mouse bought = 5,   Total Price: ($2 9 + $0.50) x 5 = $147.50
No. of Optical Mouse bought = 6,   Total Price: ($2 9 + $0.50) x 6 = $177.00

The Onetime Attributes Qty Discount field allows you to specify bulk discounts for a particular attribute but the
calculation is slightly different from the Attributes Qty Discount field. For comparison sake, we shall use the same
example above but with the values entered into the Onetime Attributes Qty Discount field instead of the Attributes
Qty Discount field.

Customers at the Product Info page of your Store Front can click on a Quantity Discount hyperlink which opens a
pop-up window showing a Quantity Discount Table as follows:

QTY        1       3       5 
PRICE      $1.00   $0.75   $0.50 

The above table values translate into the following scenarios based on the number of optical mice a customer buys,
assuming the USB connector attribute is selected.

No. of Optical Mouse bought = 1,   Total Price: (1 x $29) + 1.00 = $30.00
No. of Optical Mouse bought = 2,   Total Price: (2 x $29) + 0.75 = $58.75
No. of Optical Mouse bought = 3,   Total Price: (3 x $29) + 0.75 = $87.75
No. of Optical Mouse bought = 4,   Total Price: (4 x $29) + 0.50 = $116.50
No. of Optical Mouse bought = 5,   Total Price: (5 x $29) + 0.50 = $145.50
No. of Optical Mouse bought = 6,   Total Price: (6 x $29) + 0.50 = $174.50

By Words or Letters

This pricing mechanism is applicable only to attributes that are of the Text option type. It allows you to price your
text attribute according to the number of letters or words that a customer specifies. An example of a cake which
allows customers to specify the wordings they want on the cake and a corresponding greeting card is shown in the
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following screen shot to give you an idea of the use of this pricing mechanism.

Before you specify the pricing for words or letters in your attribute:

 Make sure you have created the product and its required option names and option values. The option name
must be of option type – Text.

 You can restrict the Text box layout configurations by clicking on the edit button of the option value in the
Option Values screen.

 You can also force the customer to key in the text area before adding the product to a cart by checking the
Attribute Required for Text  flag in the Attributes Controller screen.

 Make sure that Enable Text Pricing by word or letter and Text Pricing - Spaces are Free are set to true
under Configuration > Attribute Settings.

To specify a price for the number of words or letters in each attribute:

1. Click on Catalog > Attributes Controller  to access the Attributes Controller screen.

2. Choose the appropriate category from the drop-down list box and your screen will be refreshed with products
from the previously selected category. 

3. Choose the appropriate product and attribute from the respective boxes and then concentrate on the following
area on your screen.

4. To price an attribute based on words, enter your desired values in the Price Per Word and Free Words
headings.

5. To price an attribute based on letters, enter your desired values in the Price Per Letter and Free Letters
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headings.

6. Commit all your changes to the database by clicking the insert button.

Attribute Weighting

If your shipping charges are affected by the weight that your product attributes introduce, you can optionally choose
to increase the product weight based on the attribute instead. An example would be if your store sells gym
equipment. A customer can choose to buy a set of basic dumbbells and add more weight to the dumbbells by using
weight plates. This example is shown in the following screen shot.

Before you specify weight to represent your product or service:

 Make sure you have created the product and its required option names and option values.

 Click the edit layout button of the product type that is linked to this attribute and take note of the
PRODUCT Attribute Weight Prefix - Default  field. This field specifies whether the attribute weight
should be incremented or decremented by default. In addition, make sure the following fields in the screen
are enabled:

➔ Show Weight 
➔ Show Attribute Weight 

To specify a weight to represent each attribute:

1. Click on Catalog > Attributes Controller  to access the Attributes Controller screen.

2. Choose the appropriate category from the drop-down list box and your screen will be refreshed with products
from the previously selected category. 

3. Choose the appropriate product and attribute from the respective boxes and then concentrate on the following
area in your screen.

4. To add the attribute weight to the product weight, specify a “+” or a blank space in the first box under the
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Weight field. To subtract the attribute weight from the product weight, specify a “-” instead.

5. Type in a value for the second box under the Weight field to specify how much weight should be added or
subtracted from the product's weight.

6. Enter a number into the Order  field. This field indicates the sequence in which the attributes will be
displayed to a customer. For example, if you have three attributes X, Y, Z in their original sequence of 1, 2, 3
and you change the sequence to 3, 1, 2. Then the attributes will be displayed in this order to the customer Z,
X, Y.

7. Optionally, you can enter values into the Price and One Time fields if you want to specify prices along with
your weights. Note that the One Time field applies only to price and not weight!

8. Commit all your changes to the database by clicking the insert button.

Manipulating Multiple Attributes Simultaneously

We shall now talk about how to copy attributes across different products. If you intend to perform all these
operations, remember the two following principles:

 Create and price all your attributes beforehand to save you the trouble of propagating the changes afterwards.
 Back up your database to prevent accidental replacement of your data. Refer to “Database Back Up” on page

364 for details on doing this properly.

Enabling Mass Attribute Copy, Add and Delete

To copy or move attributes you have created, you need to turn on the appropriate feature in Zen Cart. You can either
set this as a default for your store or on a per-page basis.

To enable copying and moving of attributes on a default basis:

 Click on Configuration > Layout Settings and set Option Names and Values Global Add, Copy and
Delete Features Status and set the value to 1 to enable it. 

Note: Although three options are explained in the side-panel, only two options are actually available. The
third option, “2 = Products Model” is reserved for future use.

To enable copying and moving of attributes on a per-page basis:

 Go to either the Product Options screen or the Option Value Manager screen and select  Display Global
Features – ON   from the drop-down list box near the top of the screen.
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Copying Attributes to Other Products

Some situations require that you copy a set of attributes for one product across to all the products you have in a
specific category. For example, suppose your shop sells children's clothing. You can set up an option name “shirt
size” with the following values “small”, “medium” and “large”. You can then copy all these option values to another
option name “cap size” easily.

As explained earlier, an attribute is made up of an option name and one or more option values. Therefore, there are
two possible ways by which you can copy attributes to other products. 

 Copy option values from one option name to another option name
 Copy option name with associated values from one product to other products in a category.

To copy all option values from one option name to another option name:

1. Click on Catalog > Option Name Manager to access the Product Options screen.

2. Concentrate on the following portion of the screen.

3. Choose the source option name containing the required option values to copy from the Copy from Option
Name select box.

4. Choose the destination option name for the values you wish to copy to from the Copy All Option Values to
Option Name field.

5. Click on update to complete the copy operation.

To copy selected option values to other products by matching “option name and value”:

1. Click on Catalog > Option Value Manager to access the Option Values screen and concentrate on the
following portion of the screen.
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2. To copy to products that contain a certain distinct attribute option name and option value, choose the
matching option name and option value from the first column of select boxes; i.e. Option Name to match
and Option Values to match.

3. Select the option name and option value you wish to copy from by choosing from the select boxes in the
second column; i.e. Option Name to add and Option Value to add.

4. In Step 3, you chose products that contain a matching attribute which will be affected by the copy operation.
You can optionally specify whether these matching products should be restricted to a certain category by
specifying the Category ID in the third column. 

5. Click on insert to start the copy operation. A success message will appear at the top of your screen if
everything is successful.

To copy selected option values to other products by matching “option name”:

1. Click on Catalog > Option Value Manager to access the Option Values screen and concentrate on the
following portion of the screen.

2. Select the option name and option value you wish to copy from by choosing from the select boxes in the first
column; i.e. Option Name to add and Option Value to add.

3. Optionally, you can enter a Product ID into the blank text box on the left-most column for a source product
which already has its default values.

Target Source

TargetSource
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For example, you may have many different products with the same attribute but one of them has its option
value price and weight set to a specific value already. You can choose to have this specific product's default
option value and settings copied over to the new product.

4. To copy to products that contain a certain distinct attribute option name only, choose the matching option
name from the second column of select boxes; i.e. Option Name to add to.

5. In Step 4, you chose products that contain a matching attribute which will be affected by the copy operation.
You can optionally specify whether these matching products should be restricted to a certain category by
specifying the Category ID in the third column's text box. 

6. If you do not want to continue adding an attribute if the target product already contains the attribute you are
trying to add, you should check the Ignore existing attributes and add only new attributes radio button.

7. If you want to update the target attribute with the source attribute values (most likely already changed from
the last time it was added), you can check the Update existing attributes with new settings/prices option
instead. This setting will have an effect only when both the source and target attribute values are the same
but the attribute pricing, weight and other settings are different.

8. Click on insert to start the copy operation. A success message will appear at the top of your screen if
everything is successful.

Adding Attributes to Other Products

You can create an attribute and choose to have it added to other products. The target products (which must have at
least one option value defined) can be restricted to the following types.

 All products.
 A single product.
 A category of products.

To access these options, click on Catalog > Option Name Manager and scroll to the following portion of the
screen.

You should have no problems going about adding your own attributes to other products since the fields are self-
explanatory and you have already covered how to copy attributes in the above sections.
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200 e-Start Your Web Store with Zen Cart

Deleting Attributes from a Selection of Products

Zen Cart also allows you to do a mass delete of attributes from a selection of products if the need arises. All the steps
taken and screen options are similar to those in the adding and copying of attributes section. Thus, we shall not be
going through them.

To delete a matching option value from all products or a category of products, click on Catalog > Option Values
Manager and manipulate the following portion of the screen.

You can also choose to delete an attribute from products by matching an option name only. These products can be
restricted to the following types.

 All products.
 A single product.
 A category of products.

To do so, click on Configuration > Option Name Manager and manipulate the following portion of the screen.

Sorting Product Attributes

Zen Cart provides several options for you to manipulate the ordering of product attributes. 

To change the sorting preferences for your attributes:

1. Click on Configuration > Product Info  to access the Product Info screen.

2. Change the sort order for your option names and values by looking at the following fields:
 Products Info - Products Option Name Sort Order 
 Products Info - Product Option Value of Attributes Sort Order 
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To rearrange the sort order of option names or option values, click on Catalog > Option Name Sorter or Catalog >
Option Value Sorter respectively.

Summary

After going through this chapter, you should be comfortable manipulating product attributes. Product attributes is one
of the most powerful features of Zen Cart although few people utilize its flexibility or power because it requires a bit
of time and effort and some experimentation to understand. Do not worry if you spend a bit more time on this chapter
than the rest of the book because once you master the power of attributes, your imagination will allow you to
configure almost any product the way you intended.
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Chapter 14 Other Product

Manipulation Techniques

Introduction

This chapter makes use of the knowledge you have gained in the previous two chapters to further customize other
aspects of your online catalog.

In this chapter, we shall:
 Specify multiple images for a single product.
 Add product samples to music products.
 Set up downloadable products for sale.
 List products across multiple categories.
 Specify the function of your online store.

Providing Multiple Images for a Product

There are two scenarios where you might want to provide multiple images for a product:
 To showcase a single product using different images
 To use your custom-sized images instead of using Zen Cart's image auto-scaling feature.

Using Different Images for a Product

There are probably various occasions when you want to display multiple images for a product. For example, a zoom-
in of a specific product detail like the neck-line of a dress or to provide several views (plan, elevation, etc) of a
machine. Refer to the following screen shot to get an idea of how different images for a single product can be
displayed.

203
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204 e-Start Your Web Store with Zen Cart

Before you add any additional images to your product, you need to understand how Zen Cart  recognizes and handles
additional images for a product.

Understanding How Additional Images are Recognized

Zen Cart uses a base name to distinguish the main picture of a product from other additional pictures of the same
product. For example, the main picture of a laptop will usually be the front view. The side and back views might
make up the other pictures for the laptop. In this case, the image names could be named as follows:

 laptop.jpg
 laptop_backview.jpg
 laptop_sideview.jpg

Typically, an underscore is used to represent additional product images linked to a base name. You could easily have
used “laptopa.jpg”, “laptop123.jpg”, “laptoplaptop.jpg”, etc. However, the latter naming schemes are difficult to
comprehend and can lead to a maintenance nightmare if you have many products using images with similar names.

For simplicity's sake, we shall assume that all additional product images referred to in this book use the underscore
as the separator to distinguish them from the base name of the product's main picture. Thus, from the list of sample
laptop pictures listed above, the base picture is the one without an underscore (i.e. laptop.jpg). The base picture is
usually uploaded when you create a new product in the Admin Console. For the other pictures, they will need to be
manually sent to the server via FTP.

Before we go further, take note of a potential problem that can occur if you are not careful in naming your additional
product images. Consider the following scenario where you have set up two laptops in your store catalog.

Product X: Custom Desktop Computer
  Base picture: desktop.jpg
  Other picture: desktop_side.jpg
  Other picture: desktop_01.jpg

Product Y: NorthStar Desktop Computer
  Base picture : desktop_northstar.jpg
  Other picture: desktop_northstar_back.jpg
  Other picture: desktop_northstar_01.jpg

If customers view Product Y, they will see it normally, with a base image and two additional images for the other
views. If customers view Product X, there will be a problem because all six images are displayed! The problem is due
to the fact that all six images have a base name of “desktop”. After this example, you should be conscious to avoid
having different images with the same name.
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 Chapter 14   Other Product Manipulation Techniques 205

The names of a product's additional images are sorted alphabetically before their corresponding images are
displayed. Therefore, you should append a number or a letter behind the names of additional product images in order
to display them in your desired sequence. 

Adding Additional Images to a Product

Before you can show additional images for your products, you need to enable this feature for your particular product
type:

1. Click on Catalog > Product Types to access the Product Types screen. 

2. Choose the product type for which you want to have multiple images displayed and click on the edit layout
button on the side-panel.

3. Make sure that the Show Product Additional Images field is enabled.

To add an additional image to a product:

1. Make sure your additional image contains an underscore (i.e. “_”) after the base name of the main product
image you have already uploaded. For example, if a product's main image is “aaa.jpg”, then the base name is
simply “aaa”. A possible name for the product's additional image might be “aaa_side.jpg”.

Recall that the underscore is the naming convention we are using for this book to identify the additional
images of a product.

2. Upload the additional image via FTP to the same directory where the base product image is located on the
server.

To change the layout for the additional product images of a product:

1. Click on Configuration > Images to access the Images screen.

2. Specify the required value in the Product Info - Number of Additional Images per Row field.

Providing Pre-Scaled Images for a Product

We shall now learn how you can use pre-scaled images with your products. Before we proceed, make sure you have
gone through the “Understanding How Additional Images are Recognized” section on page 204 as we will be making
use of some of the concepts discussed there.

Providing Companion Medium and Large Images Without Using Auto-Scaling

There are essentially three possible image sizes (small, medium and large) for product images in Zen Cart. As you
probably know by now, Zen Cart automatically scales your images to the correct size if you only supply one image
per product. 

Auto-scaling of images can result in images with less than optimum file sizes and thus consume precious bandwidth.
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206 e-Start Your Web Store with Zen Cart

To alleviate this problem, you can use your own pre-sized images to bypass the auto-scaling process to minimize
wasted download capacity and improve page loading times for your customers. With pre-sized images, you also exert
greater control over the exact resolution and size of the images that you want your customers to see.

Let us take a look at where you can see images of the three different sizes in your Store Front. This will give you a
better idea of what you need to supply to Zen Cart for each image size. Below is a list of pages in your Store Front
where different image sizes can be seen:

 Product Listing - small versions of your product images or rather the scaled down versions of your product
images if they are quite large. 

 Product Info - medium sized images are displayed by default.
 Product Info - large sized images are displayed in pop-up windows when customers click on the hyperlinked

medium sized images.

Whatever the case, if you want Zen Cart to show your images with the relevant image sizes, you need to provide
additional information to Zen Cart. Zen Cart recognizes the large and medium images by their suffixes of “_LRG” or
“_MED” respectively.

The default suffixes can be changed in Configuration > Images by editing the following fields:
 Product Info - Image Medium Suffix 
 Product Info - Image Large Suffix 

In addition to the above file naming conventions, you need to put your custom images into the respective directories
for the size desired. These directories should already be on your server and are located immediately underneath the
<zc-home>/images directory with the names of large and medium  respectively.

Therefore, to provide your custom medium and large size images for your base and additional images, you could
name your images as follows (assuming your base and additional images are originally located under the <zc-

home>/images directory):
 images/laptop.jpg
 images/laptop_sideview.jpg
 images/laptop_backview.jpg

 images/medium/laptop_MED.jpg

 images/large/laptop_LRG.jpg
 images/large/laptop_sideview_LRG.jpg
 images/large/laptop_backview_LRG.jpg

Notice that only one medium size image for a product (i.e. laptop_MED.jpg) is required regardless of how many
additional images are used to represent a product. The name of the medium size image must also be derived from the
base name of the product's main image instead of the names of any additional images. 

Adding Pre-Scaled Images to a Product

To specify medium and large images for your base and additional product images:

1. Make sure the relevant images have the correct suffix before the file extension.
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2. Upload the files via FTP to their respective directories on the server. For example,  <zc-

home>/images/ large and <zc-home>/images/medium .

Providing Music Samples

For products of Product-Music product type, Zen Cart allows you to specify music samples for free download to
users. For example, if your store sells music CDs, you can provide sample music clips for each song in the CD. An
example screen shot of a music CD with sample song clips is shown below for you to visualize how sample clips can
appear with a product. The comments on the screen shot will be obvious when you learn to configure product
samples later in this section.

Music product samples are implemented using the concepts of media type and media manager. A media type
specifies the file type that a product sample belongs to. For example, media types of music clips can be in mp3 or
wma file formats while media types of song lyrics can be in txt or pdf file formats. A media manager contains several
files of possibly different media types, that are assigned to a particular product. For example, you can create a media
collection of song clips and lyrics and assign the media collection to a music CD in your online store.

The general steps to configuring product samples can be summarized below: 
1. Configure Media Type for Product Sample.
2. Create a Media Collection to Hold Product Samples.
3. Assign the Media Collection to a Music Product.

Let us now go through the above steps in greater detail.

Step 1 of 3: Configure Media Type for Product Sample

To define the media types for your product samples:

1. Click on Extras > Media Types to access the Media Types screen.

Media Type Name
= MP3

Collection Name

Media Clips
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208 e-Start Your Web Store with Zen Cart

2. Click on insert to begin creating a media type for your product sample.

3. Specify a name whose meaning will be obvious to your customers in the Media Type Name field. This field
is displayed to your visitors telling them the file format of the sample.

4. Specify a file extension in the Media Type Extension field which corresponds to the product sample file you
will be uploading later. Examples include wma, pdf , mp4 etc.

5. Click on save to create the media type in your database.

Step 2 of 3: Create a Media Collection to Hold Product Samples

To create a media collection of product samples:

1. Click on Extras > Media Manager to access the Media Manager screen.

2. Click on insert to begin creating a new media collection.

3. Type a suitable name into the Media Collection Name field and click save to save this media collection into
the database. Your Media Manager screen will be refreshed.

4. Select the media collection you just created and click on edit to begin specifying the different files that you
wish to associate with the media collection.
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5. If you wish to change the name of the media collection you just created, edit the Media Collection Name
field and click save. 

6. For each file that you wish to associate with this media collection, click the Browse button next to the Add
Media Clip field and select a file from your local computer's hard drive. This file should end with a file
extension which you have defined in the Extras > Media Types screen.

7. Choose a directory from the Upload to Media Directory drop-down list box to indicate where you want
your uploaded file to be placed on the server. The default value of  Main Directory  points to the <zc-

home>/media directory on the server.

Avoid uploading files with special characters (quotes, exclamation marks, etc) or spaces in their file names to
avoid download problems for your customers. These problems can arise due to how different web browsers
work.

8. Choose the appropriate file extension from the Media Clip Type field for the product sample file you intend
to upload. The file extension for the file you upload must match a file extension defined in the Media Types
screen. If both file extensions do not match, Zen Cart will just ignore the product sample you uploaded and
thus not display the product sample in the media collection of the product.

9. Click Add to upload and associate the sample file to your media collection. 

10. Repeat from Step 4 to add another product sample to the media collection.
.

Step 3 of 3: Assign the Media Collection to a Music Product

To assign the media collection you have created to a music product:

1. Click on Extras > Media Manager to access the Media Manager screen.

2. Choose the required media collection and click on assign to product to begin assigning the media collection
to your desired music products.
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210 e-Start Your Web Store with Zen Cart

3. Choose the product category from the top drop-down list box and the product from the bottom drop-down
list box for the product that should be assigned the media collection. 

4. Click Add to assign the required media collection to the product. 

5. Repeat from Step 3 to add the same media collection to another product.

Selling Downloadable Products

Digital downloads are one of the hottest ways of doing business on the Internet nowadays. There is no inventory to
hold and customers get to enjoy their products sooner.

Zen Cart allows you to easily set up downloadable products for sale in your online store via the use of product
attributes. For example, you can sell individual songs contained in a song album by using a product attribute to
represent each song. Customers can then choose which songs they want to buy and pay only for those songs.

Deciding How Download Options Are Structured

The steps to creating a downloadable product are fairly straightforward. The difficult part is in deciding how you
want to “structure” your download options as shown in the following screen shots.
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The figure on the left shows an encyclopedia with several downloadable parts. All the downloadable parts are
presented as radio buttons which have already been pre-selected. Therefore, when customers buy the encyclopedia,
they will be able to download all four parts of the encyclopedia separately. Breaking up large files into smaller parts
for download allow users with limited bandwidth to schedule their downloads according to their own free time. 

All three download attributes are implemented using a pair of option name and option value. All option values also
have their Default Attribute to be Marked Selected attribute flag in the Attributes Controller screen set to Yes. By
doing so, customers do not have to explicitly click on each radio button to indicate they want to purchase that
particular download.

The figure on the right shows an instructional manual and the corresponding training videos for download. Here,
customers are given a choice of what they want to download. For the Video attribute, they can choose from any of
the four videos. For the Manual attribute, they will need to choose between the PDF or Word file format. In either
case, each option name has more than one option value attached to it. The price of the final purchase will also depend
on the number of downloads that a customer chooses.

Having seen two examples of how download attributes can be structured, you should be able to utilize the concept
when creating your own downloadable products.

Configuring a Downloadable Product

The general steps to configuring your downloadable product properly can be summarized below:
1. Enable Download Functionality in Zen Cart.
2. FTP Downloadable Files to the Server.
3. Configure Download Attributes.
4. Specify When Downloads Are Made Available.
5. Test Your Product Download Configuration.

Before you begin to configure your downloadable product:

 Create a product based on the product type that best matches the downloadable product you want to sell. Due
to the nature of downloadable products, you should pay careful attention to the fields in the following table
when creating your product.

Property Recommended Setting and Explanation

Product is Virtual Set to No, Shipping Address Required . Zen Cart will
not reduce the stock level automatically in this case; which is
logical for a downloadable product. 

Always Free Shipping Set to No, Normal Shipping Rules  if your product is
offered purely as a downloadable file. Zen Cart automatically
skips the Shipping Information page if all items in a customer's
shopping cart are downloadable files.

Set to Special, Product/Download Combo Requires
a Shipping Address  if your product is offered both as a
downloadable file and a physical good to be delivered to
customers.
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212 e-Start Your Web Store with Zen Cart

Property Recommended Setting and Explanation

Products Quantity Box
Shows

Set to No, Do not show Quantity Box  and set the
Product Qty Minimum  field to 1 if your product is offered
purely as a downloadable file. This setting makes sense for
products offered purely as download files because customers only
need one copy of the product and can easily duplicate multiple
copies themselves.

Refer to Table 12.1 under the “Creating a General Product” section on page 165 if you need to refresh your
memory on the meanings of the other fields in the Product screen.

 Prepare the files you want customers to download. Try to zip your downloadable files into a compressed
format to save space and speed up the download. For compressed files, most web browsers will open up a
dialog box prompting users to save the files to their local computers.

If your downloadable files are uncompressed and happen to belong to the type that can automatically be
"opened" by a web browser (.jpg, .gif, .pdf, etc), your customers will not have a chance to choose where they
want to save the files and may even have trouble opening the files properly. Therefore, save yourself the
trouble of having to answer support calls by compressing your downloadable files.

To configure your downloadable product, follow the steps outlined below:

Step 1 of 5: Enable Download Functionality in Zen Cart

1. Click on Configuration > Attribute Settings  to access the Attribute Settings screen. 

2. Ensure that the Enable Downloads field has a value of true . This will allow Zen Cart to process
downloads. 

3. Edit the Download by Redirect field to bring up the following side-panel. Choose true  if your Zen Cart is
running on a Unix/Linux/Mac operating system. Choose false  if your Zen Cart is running on a Windows
operating system. Click update to save your changes.
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4. The Download by streaming field allows your customers to download their files in smaller chunks from the
server. This is helpful if you have set Download by Redirect to false  and the PHP memory limit on your
server has been set to 8MB or less. 

Remember to make sure the <zc-home>/pub directory on your server has the correct file permission (i.e. chmod
755) if you have specified true  for the Download by Redirect field and your Zen Cart store is hosted on a
Unix/Linux operating system. If your Zen Cart store is running on a Windows server, you can ignore the <zc-

home>/pub directory as it is not used.

Step 2 of 5: FTP Downloadable Files to the Server

Now we need to FTP some files to the server which we want users to be able to download.

1. Start your FTP client software and connect to the server hosting your Zen Cart store. 

2. Make sure that the <zc-home>/download  directory exists on the server.  If you do not see the directory,
check the following line in your <zc-home>/includes/configure.php file to see which directory your
downloadable file should be located in.

define(‘DIR_FS_DOWNLOAD’, DIR_FS_CATALOG . ‘downloa d/’);

3. Upload the required file to the <zc-home>/download  directory or the directory specified in the
previously mentioned configure.php  file. Note that you cannot upload to a sub-directory of this directory!
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Step 3 of 5: Configure Download Attributes

Different file formats are required for different types of product downloads. For example, if you sell e-books, your
download format might be “.pdf” or “.doc”. If you sell music, your download format might be “.mp3” or “.wma”.
Whatever the case may be, you need to tell Zen Cart what the attribute used for download is.

Before you begin to configure your download attribute:

 Create the attribute you want for a product to allow a specific download. For example, if you are offering e-
books as downloadable files, you can create an attribute with an option name of “File Format” and option
values of “pdf” and “doc” respectively.

 Choose either one of the following values for the Option Type field when creating your download attribute's
option name:

➔ Radio  
➔ Dropdown  

To configure your download attribute:

1. Click on Catalog > Attributes Controller  to access the Attributes Controller screen. 

2. Navigate to the product which you want to associate a download attribute with.

3. Choose the option name and option value to be associated with a specific download file. Concentrate on the
following portion of the screen.

4. In the Filename field, type the name of the file which you have transferred to the server via FTP. Note that
the file name is case-sensitive! 

5. Enter a value for the Expiry days field to specify the download validity period for the download. You can
change the default value for this field by clicking on Configuration > Attribute Settings and changing the
value of the Download Expiration (Number of Days) field.

6. Enter a value for the Maximum download count field to specify a limit on how many times a customer can
download the same file. You can change the default value for this field by clicking on Configuration >
Attribute Settings and changing the value of the Number of Downloads Allowed - Per Product field.

7. Click on insert to link the downloadable file with the product attribute. 

8. Repeat from Step 3 if you want to associate another attribute with another file download. 

Step 4 of 5: Specify When Downloads Are Made Available

Finally, you need to tell Zen Cart whether the customer is entitled to an immediate download or a delayed download.
This decision is based on the order status of the customer purchase. The default order statuses available in Zen Cart
are as follows:

 Pending [1]
 Processing [2]
 Delivered [3]
 Update [4]
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Refer to “Working with Order Statuses” on page 298 if you want to find out more about order statuses.

Click on Configuration > Attribute Settings  and concentrate on the following fields which dictate what order
statuses will affect when your products are available for download.

 Downloads Controller Update Status Value – The order status value here resets the download days and
maximum download counts for a particular download. This is helpful if your customer's download period has
expired and you want to enable them to re-download a particular file. The default value is 4 which represents
an order status of “Update [4]”.

 Downloads Controller Order Status Value >= lower value – The lower bound of order statuses that will
make a download available to customers. The default value is 2, which represents an order status of
“Processing [2]”.

 Downloads Controller Order Status Value <= upper value – The upper bound of order statuses that will
make a download available to customers. The default value is 4, which represents an order status of “Update
[4]”.

Based on the above three fields in the Attribute Settings screen, we can conclude that an order that has an order status
of “Processing [2]” or “Delivered [3]” will mean that file(s) are available for download. An order of “Pending [1]”
will mean that file(s) are not available for download yet. An order of “Update [4]” not only makes a download
available, it resets the download days and maximum download counts too.

Now that you understand how order statuses affect the availability of your downloads to customers, you will need to
specify when you want files to be available for download to customers after they have paid up.

To configure when customers can download a particular file after paying for your goods:

1. Click on Modules > Payment to access the Payment Modules screen. 

2. Choose and edit a payment option available to your customers and concentrate on the following portion of
the screen.

3. Choose a value for your Set Order Status field as discussed earlier on this page:
 For delayed downloads, you need to set the order status to Pending [1] . 
 For immediate downloads, you need to set order status to Processing [2]  or Delivered [3] .

Step 5 of 5: Test Your Product Download Configuration

Using a test customer account, go to your Store Front and purchase the downloadable product which you have just
created. Make sure you choose a payment option that allows you to check whether it allows immediate or delayed
download. 

If a file is available for immediate download, the test customer will be able to see and download the files
immediately on the Checkout Success page as shown in the following screen shot.
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216 e-Start Your Web Store with Zen Cart

Optionally, you can log in to the test customer account to check whether files are available for download. To give
you an idea of how files that are available for download will appear in a test customer's account, you can refer to the
following sample screen shots.

Checking and Changing Download Statuses

After a purchase is made by a customer, you can check the availability of your downloadable products to that
customer.  This allows you to check on customer complaints regarding download failures or simply to manually
reactivate the downloads of a particular customer's order. 

To check and/or change the download status of your customer orders:
 

1. Click on Customers > Orders to access the Orders screen.

2. Choose the order which contains purchased downloads and click the edit button on the side-panel.
Concentrate on the following portion of the screen.

Click “view”
to go to next screen

to begin
download.

Status is“Processing”
i.e. Download available.
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3. To change the download status of a particular file, click on the respective button under the Status column.

4. To change the status of an order so as to control when files are available for download, choose a suitable
order status from the Status drop-down list box and click the update button.

Managing Downloadable Products Centrally

You can easily lose track of which attributes are tied to which downloadable files if your online store sells a lot of
downloadable products. To alleviate this problem, Zen Cart provides a screen which allows you to manage all your
download-specific information from one place. This screen is available via Catalog > Downloads Manager as
shown in the following sample screen shot.

Color of button 
denotes availability

 of download

Change from 
“Pending [1]” to “Processing [2]”

 to allow customer to 
perform download.

Click “edit” to change 
to this side-panel.
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218 e-Start Your Web Store with Zen Cart

Duplicating Products

By duplicating your products, you save time and effort because you only need to customize selected portions of the
copied product instead of having to create a new product each time. Duplicating products work best when your
products have fairly generic properties with few differences. 

For example, T-shirts have a limited selection of sizes and mostly differ in terms of color, pictures and wordings.
Therefore, you can easily create a skeletal product of your T-shirt with some generic attributes like color and size
attached to it. By duplicating this skeletal product within the same category or to other categories, and customizing
only those properties (description, images, etc) that change, you can save yourself a lot of time and repetitive effort.

To duplicate a product within a category or to another category:

1. Click on Catalog > Categories/Products to access the Categories/Products screen.

2. Click on the blue “C” button next to the product you wish to duplicate. This product shall be referred to as
the source product because it is used to create other duplicated products.

3. A side-panel should appear as shown in the following screen shot.

4. Choose the target category you want the duplicated product to reside in from the Categories drop-down box.

5. Choose Duplicate product  for the Copy Method field.

6. Choose Yes for the Copy Product Attributes to Duplicate field if you have product attributes which you
wish to copy to the duplicated product. This field only appears if your source product has attributes attached
to it.

7. Choose Yes for the Copy Product Discounts to Duplicate field if you have any discounts tied to this
product that you wish to copy to the duplicated product. This field only appears if your source product has
discounts attached to it.

8. Click on copy to begin duplicating the product. You should be redirected to the target category you specified
in Step 4 once product duplication completes. 

9. By default, your duplicated product is disabled to allow you to make changes. This is shown by a red button
icon appearing under the Status column of the duplicated product in the Categories/Products screen.

10. Make any required changes to your duplicated product and then enable it so that it is available for sale in
your online catalog.

Copy Product Attributes?

Copy Product Discounts?
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Listing Products in Multiple Categories

Product linking allows you display a product in multiple categories. You also get the benefit of greater product
exposure with only a single copy to maintain. For example, if you have a medicinal pill that has the ability to act as a
sleeping pill and a pain killer, you can list that pill under both the “sleeping pills” and “pain killers” categories. 

The important thing to remember about linked products is this: Although they appear in multiple categories, there is
always only one product. This is a great maintenance advantage because you only have to make changes to your
linked product in one place and all the changes will appear concurrently in all the categories it is displayed in.

Linked products are easily identified in the Categories/Products screen via a yellow button icon (on the right of the
green icon) under the Status column as shown in the following sample screen shot. 

This yellow button icon also appears next to any categories that contain linked products. For example, if your
product originally resides in Category A and is then linked to Category B, you should see the yellow button icons
appearing next to both Category A and Category B in the Categories/Products listing screen.

Master Category

Whenever you deal with products that are linked, you will come across the term Master Category. The purpose of a
Master Category is to allow your product to take advantage of any pricing mechanisms you have tied to a category. 

For example, if you have created a 10% sale for all products in the Christmas Sale category. By linking a Product X
under another category to the “Christmas Sale” category and making the “Christmas Sale” category the Master
Category, Product X will automatically be subjected to a 10% discount as well.

So how do you know what Master Category a linked product belongs to? Well, you can edit any linked product
which has the yellow button icon next to it in the Categories/Products page. You will notice a Product Master
Category field appearing on top of the Product page as shown in the sample screen shot below. 

Notice from the preceding screen shot that the Master Category of the product is the “Computers” category but we
are viewing the product from within the “Test” category. 

In essence, when a product is linked, take note of the following points:
 Only one copy of the product actually exists in the database regardless of how many categories the linked

product appears under.
 Only one Master Category exists for a linked product regardless of how many categories the linked product

appears under.

There are two ways to configure product linking in Zen Cart:
 Simple product linking – only one category can be linked to at any time.
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 Advanced product linking – many categories can be linked to at any time, bulk copy/delete operations, etc,
can be performed from a single location

Simple Product Linking

To list a product under different categories by using the simple product linking approach:

1. Click on Catalog > Categories/Products to access the Categories/Products screen.

2. Click on the blue “C” button next to the product you wish to link from. This product shall be referred to as
the master product because it is under the master category. 

3. A side-panel should appear as shown in the following screen shot.

4. Choose the target category you wish to link to from the Categories drop-down list box. This category must
be different from the current product's category.

5. Choose Link product  for the Copy Method field. 

6. Ignore the Copy Product Attributes to Duplicate field if it appears. 

7. Ignore the Copy Product Discounts to Duplicate field if it appears. 

8. Click on copy to create a linked product. You should be redirected to the target category you specified in
Step 4 once product linking completes.  

9. If you go to both the target category and the master category, you will notice both a green button icon and a
yellow button icon appearing next to your linked product. Furthermore, any category that contains a linked
product will also have the green and yellow button icons displayed next to them.

Advanced Product Linking 

Besides the simple linking you have just seen in the above section, you can employ another technique that is even
faster and more powerful using the Multiple Categories Link Manager screen. This screen allows you to immediately
link a product to multiple categories and perform bulk manipulation of linked products across categories.

Ignore this setting.
Works for Duplicate Products only.

Ignore this setting.
Works for Duplicate Products only.
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Note that the Multiple Categories Link Manager screen is not immediately accessible via any menu options in the
Admin Console. You can only reach the screen via the following two methods:

 Click on the Multiple Categories Link Manager button that appears at the bottom of a Copy To side-panel
of a product when you click on the blue “C” button of a product in the Categories/Products screen.

 Click on the Multiple Categories Link Manager hyperlink appearing near the top of any Attributes
Controller screen of a product.

There is a lot of information contained in the Multiple Categories Link Manager screen. To help you understand this
screen and simplify your configuration approach, think of the screen as being broken up into the following sections:

 Product Selection
 Product Linking
 Mass Operation

Product Selection

This portion of the screen allows you to navigate to the product which you want to link to several categories. You
should be familiar with how this portion of the screen works since it behaves similarly to what you saw in the
Attributes Controller screen.

Product Linking

This portion of the screen allows you to change the Master Category of a linked product by choosing from the
Product Master Category drop-down list box. You can also link a product to multiple categories simultaneously by
selecting the desired check-boxes and then clicking the Update Category Links button.
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Mass Operation

This portion of the screen allows you to perform bulk copying/deleting/resetting for product linking purposes.
Instructions on how to perform these operations are displayed prominently on the screen. Make sure you read and
understand them before performing any operations as these operations can affect many products simultaneously.

Limiting Catalog Information and Store Function

After configuring your products, you can decide how your store should behave with regards to customer shopping.
For example, do you only want your store to showcase products and not show any price or do you want it to run as a
normal online store where customers can browse and purchase your goods.

There are three ways to control the shopping functions in your store:
 Store-Wide shopping function.
 Customer Login-based shopping function.
 Customer Authorization-based shopping function.

Based on Store Status

To specify the shopping function of your store on a store-wide basis:

1. Click on Configuration > My Store to access the My Store screen.

2. Edit the Store Status field and concentrate on the side-panel.
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3. Explanations for the different values are as follows:
 Under normal circumstances, you will choose the value 0. This means your store functions as a normal

online store where users can browse and purchase your goods.

 If you choose option 1, your store will function as a product showcase. Visitors to your site will only see
your products without the prices and not be able to make any purchase. Only a Contact Us hyperlink
which leads to the Contact Us page is shown in place of a Add to Cart button. Visitors will also not be
able to create an account with your store because the log in hyperlink at the top of the Store Front will
not be displayed.

 If you choose option 2, your store will function as if you chose option 1. The only difference being that
prices are displayed to visitors in this case.

Based on Customer Logged In Status

To control your store shopping function based on the login status of your customers:

1. Click on Configuration > Customer Details to access the Customer Details screen.

2. Edit the Customer Shop Status - View Shop and Prices field and concentrate on the side-panel.

3. Explanation for the different values are as follows:
 Not required   – The store functions normally. Users are able to view products and their prices

and also to make purchases.

 Must login to browse   – Visitors to your site who are not logged in will only see the Log In
screen with both side columns disabled. Upon log in, the store functions normally.

 May browse but no prices unless logged in   – Visitors to your store who are not
logged in will still see your products. However, no prices will be displayed and a “Login for price”
message will be displayed in place of the Add to Cart button. Upon login, the store functions
normally.

 Showroom Only   – Regardless of the login status of customers, a “Show Room Only” message will
be displayed in place of the Add to Cart button. Customers will still be able to see the products and
prices in your store but will not be able to make any purchases.

4. Click on update to if you have made any changes.
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Based on Customer Authorization Status

Customers to your store can have different authorization statuses assigned to them as we shall see when we discuss
this in “Individual Customer Settings” on page 292. To control your store shopping function based on the
authorization status of your customers:

1. Click on Configuration > Customer Details to access the Customer Details screen.

2. Edit the Customer Approval Status - Authorization Pending field and concentrate on the side-panel.

3. The effects of the above fields in the side-panel are similar to Customer Login-Based Shopping Function.
The difference being that one depends on the login status while the other depends on the authorization status.

4. Click on update if you have made any changes.

Summary

This chapter has covered the less commonly used operations in product and catalog manipulation. By making use of
catalog manipulation techniques like linking and copying, you will save time and effort creating products, discounts
and product attributes. You have learned the different ways of showcasing your products using multiple images and
sample clips to aid your customers in purchasing your products. Finally, you also learned how to restrict the display
of your product catalog based on either the store status or a specific customer status.
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Chapter 15 Order Totals,

Surcharges and Discounts

Introduction

An array of pricing mechanisms exist in Zen Cart to help store owners meet their business objectives. Discounts
allow excess stock to be cleared or to increase revenue by enticing customers to buy in greater volume. On the other
hand, surcharges allow businesses to control their costs by charging customers more for extra services. Finally, order
totals allow a store owner to specify how the final price of an order should be derived during the checkout process.

As you go through the chapter, do take note of the difference between product pricing and order pricing. Product
pricing only affects products; e.g. discounts. Order pricing affects the total amount of the order which includes the
prices of the products; taxes, surcharges, discounts, etc.

In this chapter, we shall:
 Configure how customer order prices are calculated via the Order Totals modules.
 Add surcharges to customer orders.
 Implement different discounts schemes.

Understanding Order Totals

The final price charged to customers is known as the order total in Zen Cart. This amount appears in the final step of
the checkout process as shown in the following sample screen shot.

Notice from the sample screen shot that a series of calculations are performed before the final order total ($225.00) is
displayed to a customer. Zen Cart gives you the flexibility to configure the sequence in which these calculations are
performed and also some of the logic within each step of a calculation.

225
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226 e-Start Your Web Store with Zen Cart

The Order Total Modules Screen

The Order Total Modules screen allows you to configure how different modules work together to affect an order
total. To access the Order Total Modules screen, click on Modules > Order Total.

 There are two important things to note about this screen:

 Each module under the Modules column is used to apply a particular business logic to a calculation. For
example, the Tax module is used to determine whether a customer is liable for tax; and then to apply that tax
to the order if the customer is liable for tax.

 Each value under Sort Order column is used to determine the sequence in which the corresponding module
is applied to a calculation. The smallest number being the one which is applied first. If nothing appears under
the Sort Order column, it means the module has been disabled and will not have an effect on an order's
pricing. 

The value which appears under the Sort Order column is especially important and can have unexpected results on an
order total's amount. Look at the following two examples which show the difference in order total amounts just by
switching the sequence in which the Shipping and Tax modules are applied in their calculations.

Example 1: Sort Order: Sub-Total, Shipping, Tax, Total = 1, 2, 3, 4

Product A                          = $ 5.00
Product B                          = $15.00
Sub-Total                          = $( 5 + 15)     = $20.00
Add Shipping (@ Flat Rate of $10)  = $(20 + 10)     = $30.00
Add Tax      (@ 5%)                = (5% x 30) + 30  = $31.50
Total                              = $ 31.50

Example 2: Sort Order: Sub-Total, Shipping, Tax, Total = 1, 3, 2, 4

Product A                          = $ 5.00
Product B                          = $15.00
Sub-Total                          = $( 5 + 15)      = $20.00
Add Tax      (@ 5%)                = (5% x 20) + 20   = $21.00
Add Shipping (@ Flat Rate of $10 ) = $(21 + 10)      = $31.00
Total                               = $ 31.00

One important point to remember when testing your order total settings is to use multiple items in your shopping cart.
This method aids in your understanding of different order total modules by allowing you to scrutinize their
calculations more closely.
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Core Modules

Although any order total module can be uninstalled, you should leave some of the “core” modules as always
installed. If you uninstall these “core” modules, order total calculations may not make sense and the orders might not
even be processed by Zen Cart after payment is made!

Modules which are optional (Gift Certificates, Discount Coupons, etc) will be discussed in their respective sections
later in the book.

Before we go on, let us arrange all the modules in their default order assuming they were all enabled. This gives you
a better idea of how the core modules act together to impact the prices of your order total.

Table 15.1: Default sort order of each order total module

Order Modules Core Modules

100 Sub-Total Yes

200 Shipping Yes

280 Discount Coupon No

290 Group Discount No

300 Tax Yes

400 Low Order Fee No

840 Gift Certificates No

950 COD Fee No

999 Total Yes

Explanations of the core modules are as follows:

Sub-Total – Calculates the total prices of all items in a customer's shopping cart.

Shipping – Applies a shipping charge to a customer's order based on the shipping module that the customer has
selected when performing the checkout process.

Tax – Adds up all the taxes that apply to the items in a customer's shopping cart. Whether a product is liable for tax
depends on your tax configuration and also whether you have specified a tax class when creating that product.

Total – Displays the total amount of the order. If you disable this module, customer orders will not be processed by
Zen Cart.

For a discussion on the rest of the non-core order total modules, refer to the following sections:
 “Discount Coupons” on page 311.
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 “Customer Group Discounts” on page 235.
 “Cash on Delivery (COD) Fee” on page 238.
 “Gift Certificates” on page 322.
 “Low Order Fee” on page 237.

Giving Discounts

Discounts are a widely-used technique employed by retail businesses to increase sales or to clear unwanted stock.
When a product has a discount applied to it, the discounted price of the product will be shown in red while the
original price will be crossed out in the Store Front. 

To change the way your discounts are displayed in the Store Front, click on Configuration > Product Info  and edit
the following fields:

 Product Info - Show Sales Discount Savings Status 
 Product Info - Show Sales Discount Savings Dollars or Percentage 
 Product Info - Show Sales Discount Savings Percentage Decimals 

Choosing a Discount Type

Before we discuss how to configure the various discount techniques, take a look at the following table to help you
decide on which discount type you want to apply for your store.

Table 15.2: Comparison of different discount types   (continued)

Discount Type Entitlement Comments

Product Specials Single Product Applies a percentage or fixed price discount
to a product. Optionally, an expiry date can
be specified.

Product Quantity Discounts Single Product Applies a price discount based on the
quantity of a product bought. 

Product Sale Multiple Products Applies product price discounts to the entire
store or to specific categories of products.

Attribute Quantity Discounts Per Product Attribute Discount on attribute price based on quantity
of a product bought.

Refer to “By Quantity” on page 191 for more
details.
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Table 15.2: Comparison of different discount types   (continued)

Discount Type Entitlement Comments

Customer Group Discounts Multiple Customers Entitles selected customers to an order total
discount.

Discount Coupons Single/Multiple Customers and
Single/Multiple Products

Discount coupons can be applied both to an
order total or a selection of products.

Refer to “Discount Coupons” on page 311 for
further details on how discount coupons
work.

The important thing to note is that Group Discount calculations are applied to order totals instead of products. On the
other hand, Discount Coupon calculations can be applied to both order totals and certain selected products depending
on how the order total module is configured. Make sure you are very clear on the difference between order total
discounts and product price discounts before choosing a discount type you want to configure. 

Order total discounts apply to the charges (i.e. sub-total, taxes, shipping, etc) that a customer incurs during the
checkout process. Product price discounts apply only to product prices that are configured during the product
creation process.

Product Specials

Specials allow you to specify a product discount either by percentage or by an exact price. You also have the option
of specifying an expiry date for the discount. When a product is on Special, Zen Cart will increase the exposure of
the product via the various layout components in the Store Front as shown in the following screen shots.

Note that the product which appears in the Specials side-box is chosen randomly by Zen Cart. You can control the
number of products that are randomly displayed by editing the Random Products On Special For Box field via
Configuration > Maximum Values. 

Click on “Specials”
 hyperlink to go to 

next screen

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


230 e-Start Your Web Store with Zen Cart

To put a product on Special:

1. Click on Catalog > Specials to access the Specials screen. 

2. Click on new product to bring up the Specials details screen.

3. Choose the product you want to place on Special from the Product field.

4. Enter a percentage (e.g. 10%) to discount from the product or an absolute number for the new price of the
product (e.g. 10.00 ) for the Special Price field. 

5. Optionally, choose a date for the Available Date field by clicking on the dark icon next to the field to bring
up a pop-up calendar. If no value is specified in the field, the discount takes effect immediately after
creation. If a future date is specified, the product will automatically appear as a Special in the Store Front
when the future date arrives. 

6. Optionally, choose a value for the Expiry Date field by clicking on the dark icon next to the field to bring up
a pop-up calendar. The discount will run indefinitely unless a value is specified for the Expiry Date field.

7. Click insert to place the product on Special.

To view statistics for products that are on Special, click on Admin Home on the navigation menu to reach your
home page. Look at the Specials Expired and Specials Active fields under the Statistics table as shown in the
following screen shot.
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Product Quantity Discounts

Quantity discounts allow store owners to give discounts for bulk purchases of a product. A product that has a
quantity discount attached to it will be displayed with a discount table in the Product Info page of the Store Front as
shown in the following screen shot. 

To customize how the discount table is displayed, click on Configuration > Layout Settings and edit the Product
Discount Quantities - Display how many per row? field accordingly.

To create a quantity discount for a product:

1. Click on Catalog > Products Price Manager to access the Products Price Manager screen. There is a lot of
information contained in the screen. To help you understand and manipulate the settings on the screen more
confidently, we shall only show the relevant portions of the screen as we go through the configuration steps.

2. Choose a product to which you want to apply a quantity discount by referring to the following portion of the
screen.

2.1.  From the drop-down list box between the previous and next buttons, choose a category that contains
your desired product.

2.2.  After your screen refreshes, select your desired product from the list box beside the display button. 

2.3.  Click display and the details of your desired product will be displayed in the following portion of your
screen.
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3. To apply a quantity discount to the product you have chosen:

3.1.  Click on any of the two edit buttons on the Products Price manager screen. After your screen is
refreshed, concentrate on the following portion of the screen. 

3.2.  Click on add blank discounts and you should see a discount table as shown in the following screen
shot. 

To change the default number of blank discounts displayed whenever the add blank discounts
button is clicked, click on Configuration > Layout Settings and edit the Product Discount
Quantities - Add how many blank discounts? field.

3.3.  If your product has attributes defined, select how you want your quantity discount to be applied via the
Discount Qty Applies to Mixed Attributes field. If you choose Yes, product attributes will be ignored
and only the number of products bought will be used to trigger a quantity discount. If you choose No, all
product attributes must match (e.g. T-shirt with color attribute “Blue” and size attribute “Large”) before
the total number of the products will be used to trigger a discount.

3.4.  Do not click the add blank discounts button again unless you wish to create an additional 5 blank
discounts.

3.5.  Select how you want your discount to be applied for the product by choosing a value from the Discount
Type drop-down list box. Explanations for the various possible values are as follows:

 Percentage   – Applies a percentage discount. 
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 Actual Price   – Specifying a new price 
 Amount Off   – Subtracting an amount from the product price 

3.6.  Select the price basis from which your new product price should be derived from the Discounted Price
from field. Choose Price  if you want the discount to be applied to the product price. Choose Special
if you want the discount to be applied to an already discounted price of a product on Special.

3.7.  Enter the quantity of products bought that will qualify for a bulk discount together with the
corresponding discount rates into the respective Minimum Qty  and Discount Value fields.

4. Click on update once you are satisfied with your settings. Your screen will refresh and Zen Cart will display
the automatically calculated discounted prices in a table as shown in the following screen shot.

Product Sale

Zen Cart uses the concept of a “sale” to apply discounts to an entire store catalog or to certain product categories.
Unlike products on Special and products with quantity discounts, Zen Cart does not display the discounted products
with other visual cues other than showing the discounted price in red.

To create a discount for the entire store catalog or to specific product categories:

1. Click on Catalog > SaleMaker to access the SaleMaker screen.

2. Click on new sale to access the SaleMaker details screen.
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3. Before you configure anything, click on the Click here for Salemaker Usage Tips hyperlink near the top of
the screen. A pop-up window (as shown in the following screen shot) appears with instructions on how to
configure Salemaker properly.

4. Enter the name you want to assign to this sale in the SaleName field.

5. Enter a positive number into the Deduction field.

6. Select how you want your new discounted price to be derived from the Type field. 

7. If you want discounts to be applied only to products within a certain price range. Enter your desired values in
the Products Pricerange and To fields.

8. If your product is already on Special, you can decide how your new sale price will be affected by choosing a
value from the If a product is a Special field.

9. If you want the sale to take place immediately, leave the Start Date field empty. If your sale should be
automatically activated on a future date, choose a suitable date from the dark icon next to the Start Date
field.
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10. If you do not want your sale to expire, leave the End Date field empty. If your sale should automatically
expire on a future date, choose a suitable date from the dark icon next to the End Date field.

11. Choose whether you want your discount to be applied to the entire catalog or to selected categories by
checking the relevant check-boxes. If you check both the Entire catalog field and any other categories, the
sale will still be applied to the entire catalog!

12. Click on insert to create your new sale. 

13. After your screen is refreshed, your new sale will be displayed. Note that your sale will only be active if the
button in the Status column is green.

To view statistics for products that are on Sale, click on Admin Home on the navigation menu to reach your home
page. Look at the Sales Expired and Sales Active fields under the Statistics table:

Customer Group Discounts

Sometimes, you may want to offer discounts only to a selected group of customers. For example, if you have a group
of loyal customers who are your main purchasers, you can opt to give them a group discount to recognize their
loyalty and to encourage them to continue doing business with you.

Customer group discounts are only applicable to order totals in Zen Cart. They cannot be restricted to apply only to
certain products in your store. Furthermore, customers will not see any discounted prices based on their discount
groups while shopping. Group discounts are only shown during the checkout process. 

The following screen shot shows the details of a shopping cart with a 10% Group Discount applied. 

Before you can can create customer group discounts, you need to enable and configure the necessary order total
module.

1. Click on Modules > Order Total to access the Order Total Modules screen.

2. Edit the Group Discount module. Install it if required. The following side-panel will appear.
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3. Enter a suitable value for the Sort Order field. Refer to “The Order Total Modules Screen” on page 226 if
you have forgotten the purpose of this field.

4. Specify true  for the Include Shipping field if you want shipping charges to be covered by a customer
group discount.

5. Specify true  for the Include Tax field if you want taxes to be covered by a customer group discount. 

6. Choose a suitable value for the Re-calculate Tax field. Usually, you should leave this as none . If you
choose Standard  or Credit Note  , you will need to play around with different test orders to see whether
they suit your needs.

7. If you have chosen Credit Note  for the Re-calculate Tax field, you should choose a suitable option from
the Tax Class drop-down list box.

8. Click update to finish configuration of your Group Discount order total module.

You should play around with the Sort Order field for all the order total modules if you encounter erroneous or
illogical calculations. If that does not help, your last resort is to refer to the PHP code contained in the <zc-home>/

includes/modules/order_total/ot_group_pricing.php file.

We shall now look at how we can create group discounts for your customers. There are two main steps to creating
discounts for customers:

 Create a discount group specifying the discount value.
 Specify which customers belong to a specific discount group.

To create a discount group:

1. Click on Customers > Group Pricing to access the Group Pricing screen.

2. Click on insert and concentrate on the side-panel. 
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3. Enter a name for the group discount you want to create in the Group Name field.

4. Enter a positive value into the Percentage Discount field.

5. Click save to create the discount group.

To attach a discount group to a customer:

1. Click on Customers > Customers to access the Customers screen. Note that the orders button will only
appear if the customer has purchased a product from your store before.

2. Choose a customer to whom you want to assign a discount group and click edit. 

3. Select the discount pricing you want to apply to the customer from the Discount Pricing Group drop-down
list box as shown in the following screen shot.

4. Click update to assign the customer to the Discount Group.

Adding Surcharges

Surcharges allow you to add an additional fee to the order total prices. Zen Cart allows you to impose surcharges for
orders that are below a certain amount or when customers choose the Cash-On-Delivery payment method.

Low Order Fee

A Low Order Fee allows you to charge customers an extra amount of money for orders that are below a certain
threshold amount. This feature is helpful for stores that sell products with very narrow profit margins.

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


238 e-Start Your Web Store with Zen Cart

If you intend to set up a low order fee for your store, try to display a message clearly in your Store Front informing
customers about this policy. As the low order fee will only be shown in the final step of the checkout process,
customers might feel your business is out to cheat them and discontinue visiting your store.

To add a surcharge for orders falling below a certain threshold amount:

1. Click on Modules > Order Total to access the Order Total Modules screen.

2. Edit the Low Order Fee module. Install it if required.

3. Make sure the Allow Low Order Fee field is set to true .

4. All fields are self-explanatory so we shall not go through them here.

5. Click on update to save your changes to the database.

Cash on Delivery (COD) Fee

The Cash On Delivery (COD) payment method is not encouraged for online business. This is because there is a
higher risk that you might not get the payment you want. Customers can always regret their purchases and refuse to
pay when you show up at the door or deny the transaction ever took place. 

Therefore, to discourage customers from choosing this option and to provide yourself some insurance, you can
impose a charge on customer orders if they choose to pay via the COD payment method in Step 2 of the checkout
process. Note that the wording in red (i.e. COD Fees may apply) will only appear if the COD fees order total module
has been enabled.
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COD Fees that are applicable will only be shown in the final step of the checkout process as shown in the screen
show below.

To impose surcharges for customers who choose to pay via the COD payment method:

1. Click on Modules > Order Total to access the Order Total Modules screen.

2. Edit the COD Fee module and concentrate on the side-panel.

3. Make sure the Display COD field is set to true .

4. As you can see, you can specify different COD fees for different shipping modules. As all the fields are self-
explanatory, we shall not discuss them further.

5. Click on update to save your changes to the database.
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Summary

In this chapter, you have learned to manipulate your product prices and order prices by using the different discounts
and surcharges available in Zen Cart. You have also taken a look at how your order totals can impact the final order
price that is charged to customers.
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Part 4  Customizing Your

Store

Unlike the previous sections which teach you how to configure the business logic in your store,
this section deals mainly with how to customize the look-and-feel of your store. You will learn the
different layout elements that make up a Zen Cart store, how to make your store support multiple
languages, etc. 

This section covers the following topics:

● Simple Customization

● Advanced Customization
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Chapter 16 Simple Customization

Introduction

Most of the customizations in this chapter are related to the visual elements of your Store Front and can be performed
from within your Admin Console alone. Thus, it is suitable for everyone, regardless of whether you are well-versed
in different web technologies like HTML, CSS, Javascript, PHP, etc.

In this chapter, we shall:
 Understand the different layout components.
 Learn how to customize product-related layout components and pages.
 Learn to create your own custom web pages.
 Enable the display of shipping and privacy information to adhere to local regulations.
 Learn where to change default maximum and minimum values for your settings.

Common Layout Elements

From Figure 16.1, you can see that a typical screen in your Store Front is actually broken up into five major display
blocks. Each major display block acts as a container for other layout elements (side-boxes, center-boxes, template

Figure   16.1  : Structural Layout Elements  

Center
Column

Left
Column

Right
Column

Header

Footer
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text, etc). These child layout elements each hold a specific piece of information. This modular design of layout
elements allows you to quickly and easily manage the display of information by turning on/off or editing certain
settings within the Admin Console.

Header

From the preceding screen shot, you can see that the Header can be divided into four main areas:
 Navigation Bar – Provides links for users to perform functions like log in, check out, manage account etc. 
 Header Main Bar – Usually the place to locate your company logo and put across your sales message. 
 EZ-Pages Header Bar – For placing links to EZ-Pages. EZ-Pages are custom web pages you create for

specific purposes; company press releases, news articles, etc. We will touch on them in the later part of this
chapter.

 Categories Tabs Menu Bar – For placing your top-level category entries.

The Header can only be turned off from the Admin Console under special conditions (e.g. during web site
maintenance). However, the display status of the elements contained within the Header can be altered easily from the
Admin Console.

To turn off the Search box on the Navigation Bar, click on Tools > Layout Boxes Controller and edit the sideboxes/
search_header.php field. Make sure you set both the Left/Right Column Status and Single Column Status fields
to OFF.

To turn off the Categories Tabs Menu Bar, click on Configuration > Layout Settings and set the Categories-Tabs
Menu ON/OFF field to 0.

To turn off the EZ-Pages Header Bar, click on Configuration > EZ-Pages Settings and set the EZ-Pages Display
Status – HeaderBar field to 0.   

Footer

The Footer contains the following elements:
 The top half contains the Home hyperlink and possibly some hyperlinks to the EZ-Pages you have created.
 The bottom half contains the IP address of a site visitor accessing your store and the copyright message from

Zen Cart.

To turn off the display of EZ-Pages hyperlinks, click on Configuration > EZ-Pages Settings and set the EZ-Pages
Display Status – FooterBar field to 0. 

Categories Tab Menu

Header Main Bar

EZ-Pages Header Bar

Navigation Bar
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To turn off the display of IP address of your site visitor, click on Configuration > Layout Settings and set the
Footer - Show IP Address status field to 0.

The copyright text cannot be turned off in the Admin Console. To alter the copyright text, open up the <zc-home>/

includes/ languages/english.php file and edit the text next to the “FOOTER_TEXT_BODY” field. Remember
to perform the edit using the override system which is covered in “The Template Override System” on page 270.

Columns

As you have seen when we discussed structural layout elements, there are three columns defined for each screen in
Zen Cart. These columns are referred to as the left column, right column and center column.  

The center column is always visible and cannot be turned off. Neither can its display properties be edited from the
Admin Console alone. It is used to hold important pieces of information in the form of template text, product
information, search results, etc. The left and right columns act purely as containers for side-boxes and they do allow
their display properties to be set via the Admin Console.

To change the properties of the left and right columns:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. To turn off the relevant columns, set the value of the following fields to 0:
 Column Left Status – Global 
 Column Right Status – Global 

3. To alter the width of the relevant columns, edit the following fields:
 Column Width – Left  
 Column Width – Right 
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Breadcrumbs

Breadcrumbs are navigational links that provide customers with a visual cue as to their current location in your store.
They are located on the top-left corner of the center column.

To alter the appearance of the breadcrumb:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. Edit the the following fields accordingly:
 Define Breadcrumb Status
 Bread Crumbs Navigation Separator 

While editing the Bread Crumbs Navigation Separator, you might encounter the character sequence “&nbsp;”.
This character sequence represents a white space in HTML. It is required because HTML interprets any number of
normal white spaces which you type as a single white space.

For example, if you type “Thank     You” with five white spaces in between the words in an HTML document, you
will only see “Thank You” with only one white space between the words in your browser. To force the five spaces to
appear in a web browser, you need to type as follows: “Thank&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;You”.

Side-Boxes

Side-boxes are rectangular blocks that appear on the left and right columns of your Store Front. Each side-box
provides a specific functionality. For example, the Categories side-box functions as an online catalog for visitors to
browse your products. The Currencies side-box allows your site visitors to view your products in a currency of their
choice. 

To change the width of all side-boxes:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. To specify the width of the relevant side-boxes, edit the following fields:
 Column Width – Left Boxes
 Column Width – Right Boxes

To change the display properties (excluding width) of individual side-boxes:

1. Click on Tools > Layout Boxes Controller to access the Column Boxes Classic screen. The text “Classic” is
the name of a template. You will learn more about templates in the next chapter.
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 Chapter 16   Simple Customization 247

Notice that the list of side-boxes in the screen is split into two halves. The top-half represents side-boxes that
are located on the left column of your Store Front whereas the bottom-half represents side-boxes that are
located on the right column. 

2. To edit the display properties of any side-box, click on its adjacent green “e” icon and concentrate on the
corresponding side-panel.

3. To turn on/off the display of a side-box, edit the Left/Right Column Status field. 

4. The Single Column Status field is ignored by Zen Cart except for the Search box setting mentioned in the
“Header” section on page 244. 

5. To place a side-box either on the right or left column, edit the Location: (Single Column ignores this
setting) field.

6. To specify the order in which side-boxes should appear next to each other in a column, edit the Left/Right
Column Sort Order field.

7. Note that the Single Column Sort Order field is currently ignored by Zen Cart. Do not waste time setting
any values for it.

Banners

Banners usually appear in the form of advertising blocks that appear at various locations in your Store Front (side-
boxes, headers and footers). They will be covered fully in “Banners” on page 344. 
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248 e-Start Your Web Store with Zen Cart

Multi-Product Layout Elements

How products are displayed plays an important role in the buying decisions of customers. Therefore, we need to look
closely at the different product layout elements that can appear in your Store Front. To help you with your CSS
customizations (which you will learn in the next chapter), the product layout elements we are about to discuss will be
grouped according to their appearance. 

Before we begin, take note that most of the product layout elements we will discuss require that some of your
products meet certain conditions (Featured Product, Specials, etc) before you will see them in your Store Front:

 Featured Products will be discussed in “Featured Products” on page 357. 
 Product Specials were discussed in “Product Specials” on page 229. 
 New Products will be shown depending on the elapsed time since they were added to your catalog. You can

configure the elapsed time setting by editing the New Product Listing - Limited to field under
Configuration > Maximum Values. 

 Upcoming Products are products that have their Date Available fields in their respective Product screens set
to a future date.

New, All and Featured Product Listings

Depending on whether your products meet certain conditions, you may find the following hyperlinks at the bottom of
the Categories side-box.

 New Products.
 Featured Products.
 All Products.

On clicking each of the hyperlinks in the above list, you will be redirected to product listings similar to the following
screen shots. 
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 Chapter 16   Simple Customization 249

To turn off any of the aforementioned links in the Categories side-box, click on Configuration > Layout Settings
and turn off the relevant fields:

 Categories Box - Show Products New Link 
 Categories Box - Show Featured Products Link 
 Categories Box - Show Products All Link 

To limit the number of products appearing in any of the above product listings:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. Edit the relevant field for your desired product listing:
 New Products Listing- Number Per Page 
 Maximum Display of Featured Products Page 
 Maximum Display of Products All Page 

To configure the appearance of individual product listings, you can do the following:
 For New Products listing, click on Configuration > New Listing.
 For Featured Products listing, click on Configuration > Featured Listing.
 For All Products listing, click on Configuration > All Listing .

We have chosen to discuss these three product listings together because their configuration fields are the same
although they are located in different screens in the Admin Console. The meanings of the fields are mostly self-
explanatory but their syntax can be quite confusing. To help you understand the syntax better, we shall use the
Display Product Name field under Configuration > All Listing  as an example.
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250 e-Start Your Web Store with Zen Cart

From the preceding screen shot, the default value for Display Product Name has 4 digits and is shown as 2101 . The
explanation for the individual digits is shown below:

The first digit specifies the location of the product name as shown in the following illustrations. Notice that the
product name will only be displayed if you specified either “1” or “2” as the value for the first digit.

The second and third digits are taken together to represent the order in which different pieces of information are
displayed next to each other.  Let us take a look at the second and third digits of Display Product Price (middle 2
digits = “40”) and Display Product Name (middle 2 digits = “10”) and see what happens if we swap the values as
shown in the following illustrations.

The fourth digit indicates how much “clearance” or white space will separate one displayed field from another
displayed field. Look at the following illustrations to better appreciate the visual impact of this setting.

1st digit = “0”
or any other value .

Display Product Name = “10”
Display Product Price  = “40”

Display Product Name = “40”
Display Product Price  = “10”

1st digit = “2”1st digit = “1”
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 Chapter 16   Simple Customization 251

Search and Category Product Listings

A Search product listing appears when a customer performs a search in any of the search boxes in your store. A
Category product listing appears under the following conditions:

 When a category or sub-category with several products is chosen from the Categories side-box.
 When a customer is on a Product Info page and clicks on the listing button which is between the previous

and next buttons.
Both Search and Category product listings are shown in the following screen shots.

The main difference between the Search and Category product listings is the lack of category information in the
Search product listings. The drop-down list box for manufacturers will only appear for the Category product listing if
there are two or more manufacturers associated with the entire list of products in the category.

Nevertheless, the configuration for the appearance of both these product listings (other than the above differences)
are done via the same screen in the Admin Console. Therefore, we have chosen to group them together in our
discussion.

4th digit = “4”4th  digi t = “1”
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252 e-Start Your Web Store with Zen Cart

To change the display of both the Search and Category product listings simultaneously:

1. Click on Configuration > Product Listing  to access the Product Listing screen.

2. Click on a field you would like to change and follow the instruction in the corresponding side-panel to make
your changes.

3. If you have edited any property, click on update to save your changes.

To change the number of items to display in the Category product listing:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. Edit the Products Listing- Number Per Page field and click update to save your changes.

Product Center-Boxes

Product center-boxes have the ability to appear across several places in your Store Front as shown in the following
screen shots.
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 Chapter 16   Simple Customization 253

The screen shots on the left are product center-boxes that appear in the Home page of your Store. The middle screen
shot shows a product center-box appearing in a category with child categories defined while the one on the right
shows a product center-box appearing under a Product Listing. There is also an Also Purchased product center-box
but we will discuss that in a later chapter.

Note that there is another center-box which contains upcoming products to your store. We will cover that center-box
in the “Upcoming Products Summary-List” section on page 256 because it looks totally different from the center-
boxes you see in the preceding screen shots.

The following table summarizes some general characteristics of product center-boxes.

Table 16.1: Characteristics of different product center-boxes

Location in Store Front Type of Center-Box Products Displayed

Home page (also known as
Index page or Main page)

New Products, Featured Products,
Specials

All eligible products in the store
can be displayed here.

Category page with sub-
categories.

New Products, Featured Products,
Specials

Only eligible products from sub-
categories will be displayed.

Product Listing page New Products, Featured Products,
Specials

All eligible products within the
parent category.

Product Info page Also Purchased Products Will be discussed in “Also
Purchased Products” on page 355.

With the exception of the Product Info page which will be discussed in another chapter, we shall now discuss how
we can configure the different product center-boxes in your store.

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


254 e-Start Your Web Store with Zen Cart

To turn on/off or specify the sort order of a particular product center-box in your Home page:

1. Click on Configuration >Layout Settings to access the Layout Settings screen.

2. Note down the value of the Categories - Always Show on Main Page field. This field is primarily used to
control whether category images should be displayed in your main page or not. However, its value can affect
the configuration of product center-boxes in your Home page as well. 

3. Click on Configuration > Index Listing  to access the Index Listing screen.

4. If the value you obtained in Step 2 is 1, then edit the following fields accordingly.
 Show New Products on Main Page - Category with SubCategories 
 Show Featured Products on Main Page - Category with SubCategories 
 Show Special Products on Main Page - Category with SubCategories 

5. If the value you obtained in Step 2 is 0, then edit the following fields accordingly.
 Show New Products on Main Page 
 Show Featured Products on Main Page 
 Show Special Products on Main Page 

To turn on/off or specify the sort order of a particular product center-box in your Category with sub-categories page:

1. Click on Configuration > Index Listing  to access the Index Listing screen.

2. Edit the respective field for your desired product center-box:
 Show New Products on Main Page - Category with SubCategories 
 Show Featured Products on Main Page - Category with SubCategories 
 Show Special Products on Main Page - Category with SubCategories 

To turn on/off or specify the sort order of a particular product center-box in a Product Listing page:

1. Click on Configuration > Index Listing  to access the Index Listing screen.
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 Chapter 16   Simple Customization 255

2. Edit the respective field for your desired product center-box:
 Show New Products - below Product Listing 
 Show Featured Products - below Product Listing 
 Show Special Products - below Product Listing 

To simultaneously control the number of products appearing in each product center-box for all pages:

1. Click on Configuration > Maximum Values to access the Maximum Values settings screen.

2. Specify the number of products you wish to display for a particular product center-box by editing the
relevant fields.

 New Products Module 
 Maximum Display of Featured Products - Main Page 
 Maximum Display of Specials Products - Main Page 

Note: The Maximum Display of Featured Products Page field applies to Product Listings and not product center-
boxes.

To control the number of columns appearing in each product center-box for all pages:

1. Click on Configuration > Index Listing  to access the Index Listing screen.

2. Edit the respective field for your desired product center-box:
 New Products Columns per Row 
 Featured Products Columns per Row 
 Special Products Columns per Row 

Note: The Special Products Columns per Row setting also affects the Product Specials Grid, which we
shall talk about in the next section.

 

Product Specials Grid

Besides appearing in product center-boxes, products on Special can also appear in a grid layout as shown in the
preceding screen shot. We shall refer to this layout as the Product Specials Grid. The Product Specials Grid only
appears when a customer clicks on Specials in the Categories side-box.

To control the number of products appearing in the Product Specials Grid:

1. Click on Configuration > Maximum Values to access the Maximum Values screen

2. Edit the Products on Special field.

Note: Do not confuse this setting with the one in the Specials product center-box.
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256 e-Start Your Web Store with Zen Cart

To change the number of columns for the Product Specials Grid:

1. Click on Configuration > Index Listing  to access the Index Listing screen.

2. Specify a value for the Special Products Columns per Row field.

Note: The Special Products Columns per Row setting also affects the Specials product center-box.

Upcoming Products Summary-List

Whenever the Date Available field in a Product page is set to the future, the affected product will be displayed in the
Upcoming Products summary-list in Zen Cart.

Although the appearance of the Upcoming Products summary-list is different from that of the product center-boxes,
its configuration is similar to that of the product center-boxes. Therefore, refer to “Product Center-Boxes” on page
252 for details on how to configure your Upcoming Products summary-list.

Important Shopping Pages

The Product Info and the Shopping Cart pages both play an integral part in a customer's shopping experience. As
such, store owners usually want to customize these pages to enhance their customers' shopping experience.

The Product Info Page

This is the most important page in your entire store because it contains detailed product information; and customers
usually base their purchasing decisions on it. Therefore, most store owners would want to customize this page to
highlight relevant information to their customers. 
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 Chapter 16   Simple Customization 257

To alter the display of certain fields in the Product Info page:

1. Click on Catalog > Product Types to access the Product Types screen.

2. Select the Product Type that the product belongs to and click edit layout to access a list of product details for
the Product Type.

3. Choose a field you wish to change and click edit to bring up the relevant side-panel.

4. After making your changes, click update to save your changes. Note that this change affects all products
belonging to the same product type.

To alter other visual aspects of the Product Info screen:

1. Click on Configuration > Product Info  to access the Product Info screen.

2. Experiment with the settings on this screen. Ignore the last four fields for now because we will touch on them
in a later chapter. The rest of the fields are self-explanatory so we shall not discuss them further.
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258 e-Start Your Web Store with Zen Cart

The Shopping Cart Page

The Shopping Cart page displays all the items that a customer intends to purchase. Prices are added to allow
customers to decide whether they should proceed to check out or whether they should alter their shopping list to meet
their budget constraints.

To turn edit the template text appearing under the words “Your Shopping Cart Contents”, edit the <zc-

home>/includes/ languages/engl ish/shopping_cart.php file. Make sure you use the Override System to
perform your edit. The Override System is covered in “The Template Override System” on page 270.

To customize the display of the update and delete buttons on the page:

1. Click on Configuration > Stock to access the Stock screen.

2. Edit the following fields accordingly:
 Show Shopping Cart - Delete Checkboxes or Delete Button 
 Show Shopping Cart - Update Cart Button Location 

To customize how the item count, weight and amount at the top of the table are displayed:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. Edit the Shopping Cart - Show Totals field accordingly.

To customize the look of the product images displayed on the page:

1. Click on Configuration > Images to access the Images screen.

2. Edit the following fields accordingly:
 Image - Shopping Cart Status 
 Image - Shopping Cart Width
 Image - Shopping Cart Height

 
To change the display of the shipping estimator button:

1. Click on Configuration > Shipping/Packaging to access the Shipping/Packaging screen.
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 Chapter 16   Simple Customization 259

2. Edit the Shipping Estimator Display Settings for Shopping Cart  field accordingly. To see the effects of
changing this setting, refer to the screen shots on page 120.

Creating Custom Web Pages

Besides the standard web pages you have seen in the Store Front, you can also create entirely new custom web pages
to suit your particular needs. For example, if you want to display your company financial statements in a separate
part your store or you want to add a page to explain to customers how your company ensures product quality by
going through a rigorous manufacturing process, etc.

There are essentially two methods you can use to create your custom web pages. 
 Define Pages
 EZ-Pages

Define Pages is good for creating a few simple web pages which do not necessarily have any relationships between
them. They are located at specific locations in your online store. EZ-Pages is better suited for situations which
require a greater number of custom web pages. Furthermore, EZ-Pages allow you to define relationships between
pages and gives you greater control over how and where you want to place them in your store.

Define Pages

A Define Page refers to the template text on a screen which store owners may want to override or turn off. Define
Pages are accessed via hyperlinks in the Information and More Information side-boxes as shown in the preceding
screen shots.

To turn on/off a portion or an entire Define Page:

1. Click on Configuration > Define Page Status to access the Define Page Status screen.
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260 e-Start Your Web Store with Zen Cart

Notice that the names of the different Define Pages are mapped to the hyperlinks in the Information and
More Information side-boxes in your Store Front.

2. Edit any field and you will see a side-panel similar to the preceding screen shot. Choose your desired choice
out of the four possible combinations of Link and Define Text options.

The meaning of the Link and Define Text options are as follows:
 The display of a hyperlink in the relevant side-box is controlled by setting Link to either ON or OFF.
 The display of template text in a Define Page is controlled by setting Define Text to either ON or

OFF.

3. Click update if you have made changes to a field.

To change the template text displayed in a Define Page:

1. Click on Tools > Define Pages Editor to access the Define Pages Editor screen.

2. Select the Define Page you wish to change from the ENGLISH  drop-down list box and choose an
appropriate value for the TEXT EDITOR  field as shown in the following screen shot.

3. Make your desired changes to the template text in the text-area. 

4. Click on save to save all your changes.
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 Chapter 16   Simple Customization 261

If you have enabled and changed the text for your Define Page 2, Define Page 3 and Define Page 4 pages, you will
want to change the title of those pages and how their hyperlinks appear in the More Information  side-box as well.
For example, you might have replaced the previous pages with About Us, User Agreement and Product Guarantee
pages in your store instead. 

To change the title of the hyperlinks in the More Information side-box for the Define Page 2, Define Page 3 and
Define Page 4 pages, edit the following contents in your <zc-home>/includes/languages/english.php file.

define('BOX_HEADING_MORE_INFORMATION', 'More Inform ation');
define('BOX_INFORMATION_PAGE_2', 'Page 2');
define('BOX_INFORMATION_PAGE_3', 'Page 3');
define('BOX_INFORMATION_PAGE_4', 'Page 4');

To change the titles appearing on the top-left corner of the Define Page 2, Define Page 3 and Define Page 4 pages,
edit the following files instead.

  <zc-home>/includes/ languages/engl ish/2.php

  <zc-home>/includes/ languages/engl ish/3.php

  <zc-home>/includes/ languages/engl ish/4.php

Although it is extremely easy to edit the contents of Define Pages from the Admin Console, you might want to wait
till you learn more about the Override System in the next chapter before doing so. Refer to “Changing Static Text”
on page 275 if you want to steal a quick peek.

EZ-Pages

EZ-Pages allows you to create additional pages from within the Admin Console alone. There is no need to manually
edit, create or edit any files. Instead, the contents of all EZ-Pages you author are stored in the database. EZ-Pages
boasts the following features:

 Links to EZ-Pages can be displayed in any of the following areas: 
➔ In the EZ-Pages hyperlinks bar of the Header. Refer to the screen shot on page 244.
➔ As part of the hyperlinks lining the Footer. Refer to the screen shot on page 244.
➔ In the Important Links side-box.

 You can specify the HTML content yourself, link to an external site (http://www.yahoo.com) or link to an
internal page (Privacy Notice page).

 You can define relationships between EZ-Pages by separating them into groups and organizing them into a
hierarchical structure; e.g. a top page containing links to sub-pages.

The following illustration should give you an idea how EZ-pages can be structured. It shows three EZ-Pages
hyperlinks (Forbes Business News, MSN Money and Yahoo Finance) in the Important Links side-box that, when
clicked, will redirect users to third-party sites. The remaining hyperlink at the bottom of the side-box points to a
collection of EZ-Pages that are part of the store. In this case, the EZ-Pages are structured as part of a collection of
related pages. However, you can choose to have EZ-Pages presented as separate pages.
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262 e-Start Your Web Store with Zen Cart

To enable the display of the Important Links side-box (which holds your EZ-Pages hyperlinks):

1. Click on Tools > Layout Controller Boxes to access the Column Boxes screen.

2. Edit the sideboxes/ezpages.php field accordingly. 

3. Also check that the EZ-Pages Display Status – Sidebox field under Configuration > EZ-Pages Settings is
enabled. 

To control other display properties of EZ-Pages in your Store Front:

1. Click on Configuration > EZ-Pages Settings to access the EZ-Pages Settings screen.

2. Click on a setting you want to change and read the instructions on the side-panel before making any changes.
All settings are self-explanatory so we shall not go through them here.

3. After you finish editing a setting, click on update to save your changes.

To create and edit your EZ-Pages:

1. Click on Tools > EZ Pages to access the EZ-Pages screen.

Note: The default number of EZ-Pages you see listed on your screen can be changed. Click on
Configuration > Maximum Values and edit the Maximum Display EZ-Pages field.
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 Chapter 16   Simple Customization 263

2. Familiarize yourself with the meanings of the column headers in the preceding screen shot by referring to the
following table.

Table Header Meaning

ID A unique number automatically generated by Zen Cart for every EZ-Page created.

Page Title This is the title of the page you want to use for your EZ-Page. It is also the name
of the hyperlink that customers will see in your Store Front.

Open New Window With this field set to Yes , a customer who clicks on an EZ-Page hyperlink will
see a new browser window open to display the contents of the EZ-Page.

Page is SSL With this field set to Yes , an EZ-Page will be displayed to a customer with an
“https” instead of an “http” in the web browser's URL. It is useful for cases where
your EZ-Page contains sensitive information and you want customers to view the
contents securely. This setting does not apply to pages which are external links.

Header Specifies the sequence that different EZ-Pages will appear in the header of your
Store Front. To appear in the header, the corresponding Order field in the EZ-
Page detail screen must be set to a value greater than 0 and the button must be
“green”.

Sidebox Similar to preceding Header discussion, but applies to the hyperlinks in the
Important Links side-box instead.

Footer Similar to preceding Header discussion, but applies to the footer of your Store
Front instead.

Chapter Allows you to group related EZ-Pages together. A Table of Contents will
automatically be generated for related pages and navigational links will then
appear on the selected EZ-Pages in the group. 

To group EZ-Pages together, make sure they have the same Chapter number.

Note: This setting has no effect on external EZ-Pages links.

TOC Used in conjunction with Chapters to specify the order within a grouping of EZ-
Pages.

3. Click on new file to access the EZ-Page detail screen.
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4. Note that specifying a blank or 0 in any of the Order fields will cause the EZ-Page hyperlink not to appear
in your Store Front.

5. To specify the contents of an EZ-Page, you can only choose either one of these three fields:
 HTML Content  – Type something in this field if you are specifying your own content to display to your

users. For example, if you are writing your own press release.
 Internal Link URL  – Type the portion of the URL that links to a page that currently exists in your

online store. For example, you would like the Privacy Notice page to be displayed when users click on
this EZ-Page hyperlink in your Store Front.

 External Link URL  – Type the URL of an external hyperlink which a customer will be redirected to
once they click this EZ-Page hyperlink. For example, if you sell Samsung handphones, you could display
Samsung's online registration site to users when they click on this EZ-Page hyperlink in your Store
Front.

6. Fill in the rest of  the details by referring to the table in Step 2.

7. Click on insert to save your changes and you will be redirected back to the  EZ-Pages management screen.

As you can see, this module is very powerful due to its flexibility. You can create articles, news releases, external site
references, etc. The only drawback in EZ-Pages currently is the lack of support for content rendered in multiple
languages unless the language pack supports this feature. This drawback will be clearer to you when you learn how
to add additional language support to your Zen Cart store. 

Altering the Shopping Flow

The standard shopping flow that comes with Zen Cart can be altered to help you meet with local regulatory
requirements or to suit your store's display preferences.
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Complying with Local Regulations

In certain countries, customers need to explicitly agree to privacy statements before they sign up for an account with
your online store. In other instances, it is also a legal requirement that customers be shown the shipping regulations
before they are directed to buy any product from you. 

Both the above scenarios are not the default way Zen Cart is configured to work. Implementing the above scenarios
can be done by simply enabling the relevant fields in the Regulations screen which you can access by clicking on
Configuration > Regulations.

Delaying the Display of the Shopping Cart

The standard shopping flow in Zen Cart displays the shopping cart whenever an item is added to it. Sometimes, this
may not be the behavior you want. For example, you have already customized your site to display that information in
another part of the store. 

You can change the standard behavior by making Zen Cart display a success message instead of showing the
shopping cart's contents whenever an item is added to the shopping cart.

To disable the display of the shopping cart after an item is added to it:

1. Click on Configuration > My Store to access the My Store screen.

2. Set the Display Cart After Adding Product  field to false .

If you choose not to display the contents of the shopping cart after customers add items to them, you should plan to
enable the Shopping Cart side-box. The Shopping Cart side-box displays the items currently in the customer's
shopping cart and also the total amount for all the items. Clicking on the “Shopping Cart [more]” hyperlink will bring
customers to the Shopping Cart page.
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To enable the display of the Shopping Cart side-box:

1. Click on Tools > Layout Boxes Controller to access the Column Boxes screen.

2. Edit the sideboxes/shopping_cart.php field accordingly.

Besides enabling the Shopping Cart side-box, you may want to decide when it should appear. To configure when the
Shopping Cart side-box should appear:

1. Click on Configuration > Layout Settings to access your Layout Settings screen.

2. Edit the Shopping Cart Box Status field accordingly.

  

Using Split Login/Sign-Up Screens

The default screen that is displayed when a customer clicks the Log In hyperlink in your Store Front allows the
customer to either sign up for an account or to log in to his or her own account using that screen alone. You should
be familiar with that screen since you have already set up several test customer accounts already. 

If you prefer to split the sign-up and login information of that screen into two screens instead, you can do so via a
switch in the Admin Console. After enabling the display of sign-up and login information in different screens,
customers who click the Log In hyperlink in your Store Front will encounter the following screen instead.

To split the display of sign-up and login information into different screens:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. Set the Use split-login page field to True .
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Adjusting Maximum and Minimum Values

An often overlooked feature of Zen Cart is the ability for you to specify different maximum and minimum values for
various fields in your Admin Console or Store Front. For example, you can specify the minimum length of a
company name that a customer should enter when creating an account with your store or the maximum number of
products that should be displayed in a product center-box.

You can change the maximum or minimum values of most fields in Zen Cart by clicking on Configuration >
Maximum Values and Configuration > Minimum Values and editing the respective settings. You should be
familiar with some of those settings as we have mentioned them previously. 

Managing Images Centrally

Although images are scattered throughout your store, you can manage their dimensions and other aspects centrally
within the Images screen by clicking on Configuration > Images.

You should be familiar with some of these settings since we have gone through them when configuring our products.
Most of the other fields are self-explanatory so we shall not touch on them further.
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Summary

In this chapter, you have gone through the various settings in the Admin Console that can help you customize the
layout elements in Zen Cart. The vast number of options available for configuration makes it impractical to cover
every single setting in this chapter. Nevertheless, you can refer to the screen shots to browse through the available
settings.
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Chapter 17 Advanced

Customization

Introduction

We shall now go into the guts of Zen Cart to learn how to properly customize your store's look and functionality with
minimum impact on future upgrades. This will mean having to deal with HTML, CSS and a little bit of PHP along
the way.

Do not be disheartened if you do not have the necessary knowledge. Online tutorials on HTML and CSS are freely
and easily available on the Internet. PHP and Javascript knowledge take more time to master but are usually not
required unless you need to overhaul a large part of the business logic in a certain module.

In this chapter, we shall:
 Go over some characters that have special meaning to HTML and PHP.
 Understand the Template Override System.
 Customize your store using CSS, HTML, Javascript, etc.
 Add support for multiple languages using language packs.

Characters with Special Meanings in HTML and PHP

For readers who are unfamiliar with HTML or PHP, there are several characters you need to pay attention to while
editing some of the files mentioned in the rest of this chapter. 

Handling Special Characters in HTML Code

For HTML code, some characters need to be escaped with HTML character entities to prevent browsers from failing
to display the affected web pages properly.

As an example, take a look at the snippet of HTML code that appears in <zc-

home>/includes/ languages/engl ish/html_includes/define_contact_us.php. The code prints the header
of the Contact Us page as Contact Us Sample Text .... 

<p><strong>Contact Us Sample Text ...</strong></p>

To change the text to Contact John & Jerry , the code would look like the following snippet instead. Notice that the
HTML character entity (&amp;) character is used to replace the ampersand sign (&) instead.

<p><strong>Contact John &amp; Jerry</strong></p>

269
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270 e-Start Your Web Store with Zen Cart

A collection of commonly used HTML character entities is shown in the following table. For a detailed list of HTML
character entities, refer to http://www.w3schools.com/tags/ref_entities.asp.

Table 17.1: Commonly used HTML character entities

Character HTML Character Entities

< &lt;

> &gt;

& &amp;

" &quot;

Handling Special Characters in PHP Code

For PHP code, text with a single quote (') or double quotes (") that appear between other quotes may need to be
escaped with a preceding backslash (\) character. The rules governing the use of these special characters can be quite
complex so interested readers are advised to turn to http://www.php.net/types.string for more information.

To simplify our discussion, we shall only look at how to escape single and double quotes (either ' or ") that appear
between single quotes (') because this is the most common scenario you will encounter when editing PHP files in Zen
Cart. 

As an example, take a look at the snippet of PHP code that appears in <zc-

home>/includes/ languages/engl ish/contact_us.php. The code prints the title of the Contact Us page as
Contact Us.

define('HEADING_TITLE', 'Contact Us');

To change the title to Shop's Contact, the code would look like the following snippet instead. Notice that a
backslash (\) character precedes the single quote which will be displayed to your customers.

define('HEADING_TITLE', 'Shop\'s Contact');

To change the title to “Contact Us”, the code would look like the following snippet instead. Notice that the double
quotes are replaced with the HTML character entity (&quot;) instead of a backslash character (\). 

define('HEADING_TITLE', '&quot;Contact Us&quot;');

The Template Override System

Zen Cart provides a mechanism called a Template Override System which serves the following purposes:
 Use templates to control the look and functionality of your store.
 Ease maintenance and upgrading efforts by not touching user-defined template files.

The Template Override System consists of three parts:
 Database settings.
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 Automatically included files.
 Override System.

We shall only discuss the Override System and how it relates to the look-and-feel of your store. The other two topics
are too technical and are more suited for developers looking to enhance Zen Cart's functionality.

How the Override System Works

The Override System allows you to modify the look-and-feel, and specify new language interpretations for your store
in a way that does not require you to make direct changes to the default core files in Zen Cart. This system greatly
eases any future Zen Cart upgrade woes because you only need to back up the template override directories you
created. 

The Override System can only be applied to directories that contain either of the following sub-directories:
 classic 
 template_default  

The “template_default ” directory contains all the files related to your store’s look-and-feel.

The “classic ” directory serves 3 purposes. 
 It is the default template used by Zen Cart. 
 This template modifies the look-and-feel of your store by altering the functionality of certain files in the

“template_default” directory. 
 It is used as an indicator that a folder can be overridden. 

The Override System works by looking at files in a specific sub-directory that have been earmarked as a template via
the Admin Console. When Zen Cart encounters a file residing in an override directory, it will read that file instead of
the default file that it usually reads; thus changing the store's functionality or look-and-feel.

A brief outline of how a template directory is created is shown below:

1. To determine whether files in a directory can be overridden, look for a directory which contains either
template_default  or classic.

2. Create your override directory according to the following rules. 

2.1.Your override directory name should preferably not contain any spaces or strange characters to avoid
experiencing conflicts in different operating systems.

 
2.2. If a directory contains a template_default  sub-directory, your override directory should be at the

same-level as the file you want to override. An example is shown below.

Default path:
<zc-home>/includes/templates/template_default/s ideboxes/tpl_languages.php
Override path:
<zc-home>/includes/templates/<your-template-name>/sideboxes/tpl_languages.php

If a directory contains only the classic sub-directory, your override directory should be one-level below the
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files you want to override as shown in the following example.

Default path: 
<zc-home>/includes/ languages/engl ish/header.php
Override path: 
<zc-home>/includes/ languages/engl ish/<your-template-name>/header.php

3. Copy any sub-folder or file you wish to override from the default path to your override path.

4. Make any changes you require to the file in your override path.

The above steps give you a general idea of how a template directory is created and the rules you need to follow. The
next section will show you how to actually implement a proper override system.

Identifying Directories to Override

Before we can start our customization, we need to first understand what the different directories do in Zen Cart.
There are three main directories located under the <zc-home>  directory that will help you decide what you need to
override.

 includes/templates – To change the colors, fonts and images used on your site. For example, the color of
your side-boxes.

 includes/ languages – To change the text that is displayed in your web pages. For example, the title of
your side-boxes 

 includes/modules – To change the logic or display structure of certain modules. Currently, you cannot
override logic that is included in the sub-directories: order_total , pages , payment , shipping  and
debug_blocks.

Specifying Template Information

In order for Zen Cart to recognize your override directory as a template, you need to provide details of your template
in a specific file under a particular directory.
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To provide details of your template to Zen Cart:

1. Copy and rename the includes/templates/classic  directory to includes/templates/magic. 

Note: We can also create our magic override directory by copying the same files from the
template_default directory individually. However, copying everything from the classic directory saves
time and effort since we won't need to alter all the files contained in the template_default directory.

2. Edit the file template_info.php under the magic  directory. You can use the sample code below for
testing purposes. 

<?php
$template_name = 'Magic Template';
$template_version = 'Version 1.0';
$template_author = 'Store Owner – Claude Blanc';
$template_description = 'Custom template for testin g purposes.';
$template_screenshot = 'scr_template_default.jpg';
?>

Note that the “$template_screenshot” field refers to a file which should preferably be a screen shot of how
your store looks with the new look-and-feel implemented by the new template. This file should be placed in
your override directory's images  sub-directory; i.e. includes/templates/magic/ images . Since we
have not finished creating our new look-and-feel for the store, we leave it pointing to the old image.

Switching Templates

For Zen Cart to make use of the files contained in an override directory, you will need to tell Zen Cart to switch to
your desired template as follows:

1. Click on Tools > Template Selection to access the Template Selection screen.

2. If you want your custom template to be applied for all languages used in the store, click the row with
Template Language set as Default (All) .
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3. If you want your custom template to be used only for a particular language, click on new language.

3.1.  Choose your custom template from the Template Name drop-down list box and associate it with your
desired language by choosing from the Language Name drop-down list box. 

3.2.  Click insert to save your changes.

4. Click on edit to access the template details page if you have chosen Step 2 instead of Step 3 above.

4.1.  Choose your desired template from the Template Name drop-down list.

4.2.  Click on update to save your changes.

Now that we understand how to create and select a new template in Zen Cart, we can safely begin our
customizations. Anytime you are unhappy with your new modifications or feel you have overridden something
wrongly, just switch back to the “Classic” template which is the default template used by Zen Cart.

Changing How Your Store Looks

There are many possible ways to customize your store's look-and-feel. However, most customizations can be
accomplished by just editing the following two entities in Zen Cart:

 Stylesheets that control the colors, borders and placement of HTML elements.
 Language files that define all the words you see in your Store Front; “Login”, “My Account”, etc.

Modifying Stylesheets

Zen Cart employs the power of Cascading Style Sheets (CSS) to specify the properties of fonts, colors and images for
the different elements in your online store. This approach gives your store a consistent look and allows changes to be
easily implemented.

Furthermore, different stylesheets can be specified on a site-wide, page-specific and/or language-specific scale. We
shall only discuss the site-wide approach in this book because once you get the hang of it, you can easily move on to
the other approaches.

Before we begin, it is assumed that you have already created and switched to your custom template with the template
name of “magic”.

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


 Chapter 17   Advanced Customization 275

To change your store's look-and-feel using CSS:

1. Navigate to your magic/css directory.

2. If you are interested in performing language-specific and page-specific overrides, read the
CSS_read_me.txt file.

3. To give you an idea of how stylesheets can change your store's look, edit the stylesheet.css  file and
change the following lines accordingly:

BODY {
background-color: #e5edf5;

       background-color: #00000;

.leftBoxHeading, .centerBoxHeading, .rightBoxHeadin g {
  margin: 0em;
  background-color: #abbbd3;
  background-color: #000000;
  background-image: url(../images/tile_back.gif);
  padding: 0.5em 0.2em;
}

The above stylesheet changes transforms your store's background color and side-box header colors to black.

4. Go to your Store Front and refresh your page to see the effects of your changes to the stylesheet.css file. 

Now that you have seen the ease with which you can change your store's look-and-feel, you can easily implement
your own changes by modifying the relevant stylesheets accordingly. If you are altering the CSS setting for a specific
multi-product layout element, you should refer to the various screen shots in the “Multi-Product Layout Elements”
section starting from page 248 to assess the impact of your change on other similar multi-product layout elements.

Changing Static Text

A common task many store owners need to perform is to change the text appearing in different parts of a store. For
example, changing the the title of the Categories side-box from “Categories” to “Store Catalog”. This task is easily
performed in Zen Cart by looking for the required file containing the original text to change and then using the
Override System to edit its contents.
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Before we begin, it is assumed that you have already created and switched to your custom template with a template
name of “magic”.

To override any text in your Zen Cart store:

1. Determine the language in which the text is displayed. We shall assume you are using the default “english”
language.

2. Proceed to the includes/ languages directory.

2.1.  The engl ish.php  file that resides directly under the includes/ languages directory contains most of
the text that appears across many pages in your store and also some of the emails sent from your store.

2.2.  If you want to change some text belonging to a specific page, you will have to traverse down the
includes/ languages/english directory to look for the particular page where the text appears. For
example, the text that appears in your Store Front after installation: “Congratulations! You have
successfully installed your Zen Cart™ E-Commerce Solution.” appears in the
includes/ languages/english/ index.php file.

3. Find the file with the text you want to change and copy it to your override directory. For example, if you
want to override some text in the engl ish.php file, copy it to the  includes/ languages/magic

directory.

4. Make your changes in the overriding file and reload your page in your Store Front to see the effect of your
changes.

In the previous chapter, you learned how to change the text in a Define Page using the Define Pages Editor in your
Admin Console. We shall now use the Override System to perform the changes instead.

To change the text in a Define Page:

1. Copy the relevant file from includes/ languages/html_includes  to the respective sub-directory under
your override directory (e.g. includes/ languages/html_includes/magic).

2. Change the text in the file under your override sub-directory. The following example shows the contents of
the define_privacy.php  file being changed.

<p><strong>Privacy Sample Text  ...</strong></p>
<p><strong>Our Store Privacy Policy</strong></p>

3. Go to your Store Front and proceed to your Privacy Policy page. A comparison of the text in that page before
and after modification is shown in the following illustration.
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You can easily apply the above technique to change any text appearing in other languages you may have added to
your store.

Supporting Multiple Languages 

Although Zen Cart is written in English, it has the capability to support additional languages. This is accomplished
through the help of language packs which can be downloaded from Zen Cart’s site. 

If you do not find the language you require, you can even create your own language pack. However, this is not an
easy task because you would need to be familiar with all the words that need to be translated. To learn how you can
create your own language pack, you can refer to Zen Cart's site for instructions.

The handful of language packs currently available vary in terms of their coverage for different areas of your store.
Some language packs cover both the Store Front and Admin Console whereas other language packs may only cover
the Store Front or Admin Console. As these language packs are developed by volunteers and not Zen Cart's
developers, the quality of each translation will vary. If you spot any mistakes, just let the maintainers (i.e. volunteers)
of those language packs know.

Understanding ISO Language Codes and Language Encodings

Before you begin adding a language pack, you need to know about language codes and language encodings. These
two topics allow you to configure Zen Cart to support additional languages and also for your web browser to display
other languages properly.

A language code is a 2-letter ISO 639-1 code or 3-letter ISO 639-2 code used to represent a language name. Zen Cart
only supports the 2-letter ISO 639-1 at the time of writing of this book. For example, “ja” is used to represent
Japanese and “en” is used to represent English. You can access a list of codes for your language from the following
website - http://www.loc.gov/standards/iso639-2/php/code_list.php.

A language encoding is a binary representation of a language's character set. A character set is a grouping of several
characters that represent a language. For example, you can think of the English alphabet as a character set consisting

Default Text Overriden Text
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of 52 upper and lower-case letters. A language encoding allows a computer program to translate a set of bytes into
the correct character. However, to display the character properly on a system, the appropriate fonts must also be
installed. 

Web Browser Language Preferences

Most modern graphical web browsers have the ability to let users configure the languages used to display web pages.
It is important to know where this setting is if you intend to test a new language that you have added to Zen Cart. 

We shall use the free and open source Mozilla Firefox web browser in our examples to show you how to go about
configuring your browser languages. There are two ways to specify language preferences in Firefox and we shall
highlight both ways.

 Static Language Preferences – This configuration lists the languages that are supported by a web browser.
The list of supported languages can automatically be detected by programs like PHP, Java, CGI etc. Zen Cart
is written in PHP so it uses this setting to determine a customer's default language preferences.

 Dynamic Language Preferences – This configuration allows a user to change the web browser language
currently being used to render a web page. If you see gibberish being displayed in your web browser when
viewing web pages authored in foreign languages, you should experiment with this configuration.

Static Language Preferences

This configuration provides programs running on web servers with a way of automatically detecting what languages
are supported by a user's web browser.

To edit the language preferences of your web browser:

1. Start up Mozilla Firefox if you have it installed on your system.

2. Click on Tools > Options to bring up a dialog box and navigate to the specified area as shown in the
following screen shot.

3. Click on Choose and you will be able to add any language preferences in the ensuing dialog box.
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Note: The “us” behind the language “en-us” is referred to as a language variant. It is used to represent
differences in how a language is used in different locations. For example, “color” in the United States is
spelled as “colour” in the United Kingdom.

4. To add a language that your browser supports, choose one from the drop-down list box, then click Add.

5. To specify your default language, make sure it is the top-most entry in the Languages in order of
preference list box.

6. Click on OK  to confirm your changes.

Dynamic Language Preferences

This configuration changes the language encoding of a web page currently being displayed in your web browser.
Unlike the configuration mentioned in the “Static Language Preferences” section, this setting changes how your web
browser interprets a web page already sent by a web server. It does not send this setting to the web server.

To change the current language used by your web browser to render a web page:

1. Start up Mozilla Firefox if you have it installed on your system.

2. On the main menu bar, click on View > Character Encoding > Auto-Detect to display a list of languages.

3. Choose and click a language you wish to use to render a page you are currently viewing.
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280 e-Start Your Web Store with Zen Cart

You can now view any web page dynamically with your desired language encoding instead of the static default
language which might be read by web applications and rendered to you.

Adding a Language Pack

A language pack is a collection of files that contain translations of different fields in Zen Cart in a specific language
(French, Spanish, etc). The language pack can either be for the Store Front only, Admin Console only, or for both
interfaces.

Before you begin adding a language pack:

1. Click on Configuration > My Store and edit the Language Selector field to specify how your browser will
switch to another language.

 Default   - Indicates that a visitor will see a site rendered according to the language you set for your
store. For testing purposes, you might like to set this as the option first.

 Browser   - Indicates that your store will automatically switch to a language based on the language
preferences in a visitor's browser. Refer to “Static Language Preferences” on page 278 for an example
showing how supported languages are configured in a web browser.

2. Click on Configuration > Maximum Values and edit the Maximum Display of Language Flags in
Language Side Box field. As the name implies, this field specifies the number of languages (represented by
flags) to display in your Languages side-box in your Store Front.

We shall use the example of a Simplified Chinese Language Pack for Zen Cart version 1.3.7.1 as an example on how
to add a language pack to Zen Cart. You can then modify the steps to install your own language pack. 

Download and Install a New Language Pack

Before you begin adding your language pack, make sure you back up your <zc-home>  directory. Refer to “File
System Back Up” on page 364 for details on how to back up this directory properly.

To begin installing a language pack:

1. Obtain a language pack: 
1.1.  Go to Zen Cart's home page and click the downloads hyperlink on the top menu. 
1.2.  Click on the Language Packs hyperlink to see a list of language packs available for Zen Cart.
1.3.  Check the version of Zen Cart that is supported for the desired language pack.
1.4.  Download the required language pack to your machine. For our example, this file is named

“simplified_chinese_language_pack_1.3.7.zip”

Note: If a language pack you want is not available in the downloads section, click on the International
Support hyperlink located near the bottom of Zen Cart's web site. This will lead you to other Zen Cart sites
which might contain the language pack you need.
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2. Expand your language pack into a separate folder and you should see the directory structure of a
decompressed Chinese language pack as shown in the following screen shot.

Note that this language pack does not contain any documentation. Other language packs may have additional
documentation which teaches you how to use or install their language packs properly.

3. Copy the relevant files and directories under the uncompressed language pack directory into the
corresponding directories under your <zc-home>  directory.

4. Log in to your Admin Console.

5. Click on Localization > Languages to bring up the Languages screen.

6. Click on new language to provide details of your new language pack to Zen Cart. The following screen shot
shows the details we will specify for our example Chinese language pack.

7. Enter a name for your language pack in the Name field. E.g. Simplified Chinese .

8. Enter the two-letter ISO 639-1 code which represents the language in the Code field. Although Simplified
Chinese is used in both Mainland China and Singapore, it is customary to use China as the country code to
represent Simplified Chinese. Therefore, enter the country code for China as cn .
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282 e-Start Your Web Store with Zen Cart

9. The default icon.gif  in the Image field is an image that is provided by your language pack. Most likely, it
is the flag of a specific country synonymous with that language; e.g. the flag of China to represent the
Simplified Chinese language.

10. Enter the directory which holds all your language-specific files in the Directory  field. You should be able to
derive this value via the following directory path of your language pack - <language-pack-

directory>/includes/ languages/<directory-path> . If you refer to the figure in Step 2, you will
understand how we obtained the value of schinese  for our language pack.

11. Optionally, check the Set as Default check box if you intend to make this the default language that your
store uses. For testing purposes, do not set this field for now.

12. Optionally, if you would like to associate a specific template to this language.
12.1. Click on Tools > Template Selection to bring up the Template Selection screen.
12.2. Click on new language to specify what template should be used for your new language.
12.3. Specify the necessary details and click insert.

While testing, it is best to leave the template set to the default Classic Template. This helps to confirm your
language pack is installed properly first before you do additional tweaking to your language settings.

Associate Currency in New Language Pack with a Currency in the Currencies Screen

Depending on your language pack, you may need to add the currency code associated with your language pack to
Zen Cart after your language pack is installed. If you do not perform this step, your order totals will not add up when
switching you switch the store to use the newly installed language.

Since we are using the Chinese language pack for our example, we will need to add a new currency (Chinese Yuan)
to your store as it is not in the list of currencies that comes with a default installation of Zen Cart.

To add the new currency associated with the new language pack:

1. Open up the <zc-home>/includes/ languages/<your_language>.php  file and check the field
containing the words “LANGUAGE_CURRENCY”. For the Chinese language pack, you should see
something as follows. 

define('LANGUAGE_CURRENCY', 'CNY');

2. Log in to your Admin Console.

3. Click on Localization > Currencies to access the Currencies screen.

4. Click on new currency and concentrate on the side-panel.

5. Use the currency code you saw in Step 1 and enter into the Code field for the currency. For example, enter
CNY for the Code field if you are using the Chinese language pack.

6. For the rest of the fields, enter the values according to those shown on the following screen shot if you are
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 Chapter 17   Advanced Customization 283

using the Chinese language pack. If you have a problem entering the Chinese character for the Symbol Right
field, enter &#20803;  instead.

7. Click on insert to save your changes.

To learn more about default currency display in Zen Cart, refer to “Configuring the Displayed Default Currency” on
page 100 for more details.

Test the New Language Pack Integration

Before you begin testing, we shall assume you have set the Language Selector field to Default  under
Configuration > My Store. The test shall be performed for both the Store Front and the Admin Console separately.

To test whether your language pack is working for your Store Front:

1. Start your web browser and proceed to your Store Front.

2. From the Languages side-box, click on the relevant flag representing the language you want to view the store
in.

3. You screen should be refreshed and displayed in the chosen language. Adjust your browser language setting
dynamically if you see gibberish. Refer to “Dynamic Language Preferences” on page 279 for details if you
have forgotten how to set your browser's language dynamically.

An example screen shot of your store displayed in Chinese is shown in the following screen shot. 
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284 e-Start Your Web Store with Zen Cart

Make sure you test out all the necessary screens by entering an order in your system to check whether all the
functionality and calculations are correct! The following screen shot of a shopping cart with order calculations
displayed is to help remind you to perform these checks.

To test whether your language pack is working for your Admin Console (Note: Works only if your language pack
has support for Admin Console):

1. Start your web browser and log in to your Admin Console.

2. You should be able to switch your language according to the drop-down list box located underneath the Zen
Cart logo as shown in the following screen shot.
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 Chapter 17   Advanced Customization 285

3. Choose your desired language from the drop-down list box and your entire Admin Console will now be
rendered in your selected language. The following example screen shot shows the home page of the Admin
Console rendered in Simplified Chinese.

With our example of adding a Chinese language pack as a reference, you should now be able to easily add your own
language pack. Different language packs require different settings and may require you to perform certain manual
steps. Therefore, always read the instructions (if available) that come with each language pack before you begin
installing it.

Provide Translations for Different Parts of Your Store

After you are sure your new language pack is installed properly, you can begin updating all your product and
category details in the new language. Also do not forget to update all your define pages like Shipping and Returns
Policy page, Privacy Notice pages, etc.

Third-Party Contributions

Although Zen Cart is already very powerful, it can never fully anticipate the changes or requirements of the business
world. To cater for unique scenarios and requirements, Zen Cart allows volunteers to contribute code (side-boxes,
payment modules, shipping modules, etc) for use by the community. 

To access the list of contributions from volunteers, go to Zen Cart's site and click on downloads at the top of the
page. If you do not find what you are looking for, try asking around in the forums. 

Before downloading and testing out a new contribution, check that the contribution is actually suitable for the
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286 e-Start Your Web Store with Zen Cart

version of Zen Cart you are currently running. Since each contribution is different in purpose and configuration, read
the accompanying instructions contained within the files after downloading the files. It is also wise to test
contributions on a test copy of your site and never on your 'live' site.

Summary

In this chapter, you have learned how to make use of the Override System to modify your files to simplify any Zen
Cart upgrades you need to perform in future. This should be the approach you use whenever you need to make
changes to your store. You have also seen how language packs and changes in CSS files can drastically change the
look-and-feel of your store. Although it is fun and exciting to change things around, try to write down your changes
in case you make a mistake in your configuration and need to roll back your store's look-and-feel to a previous state.
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Part 5  Managing Your Store

This section discusses the activities you need to carry out once your store goes 'live' and starts
accepting customer purchases. You will learn to manage customers, configure stock settings  and
process orders. Different marketing techniques are also presented to help you attract customers,
boost sales and maintain rapport. Finally, you will learn to deal with system administration
duties to make sure your store runs smoothly.

This section covers the following topics:

● Managing Customers

● Managing Orders

● Managing Stock

● Marketing

● System Administration
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Chapter 18 Managing Customers

Introduction

Zen Cart provides a simple customer management interface for you to keep track of customer orders and to email
them if necessary. You also have the ability to specify a custom authorization status for customers, restricting their
purchasing actions in your store. 

In this chapter, we shall:
 Manage common customer details.
 Manage individual customer details.
 Understand the impact of deleting customers.
 View the total number of customers in your store.

Common Customer Settings

Common customer settings affect all customers. It is closely related to the sign-up screen of your online store as we
shall see later.

To edit settings common to all customers:

1. Click on Configuration > Customer Details to access the common Customer Details screen.

Many of the fields in the above screen are related to the sign-up portion of the Log In screen in your Store
Front as shown in the following screen shot.
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290 e-Start Your Web Store with Zen Cart

Note that you can also specify the minimum length of the fields appearing in the sign-up portion of your Log
In screen. To do this, click on Configuration > Minimum Values  and edit the relevant fields.

2. Comparing the preceding two screens, you will find that you can easily enable/disable the display of certain
fields in the sign-up portion of the Log In screen by editing the following fields in the Customer Details
screen:

 Email Salutation
 Date of Birth
 Company
 Address Line 2
 State
 Create Account Default Country ID
 Fax Number
 Show Newsletter Checkbox
 Customer Default Email Preference

3. The State - Always display as pulldown? field alters how the State/Province field in the Log In screen of
your Store Front works. When set to true , a drop-down list box will be displayed for the State/Province
field instead of an input box. The entries in the drop-down list box are populated based on the currently
selected entry in the corresponding Country field of the Log In screen.

The entries in the State/Province field are actually taken from the settings you have configured via
Locations/Taxes > Zones in the Admin Console. Various possible appearances of the State/Province field in
the Store Front can be seen in the following screen shots.
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 Chapter 18   Managing Customers 291

4. If you do not want customers to see a product notification prompt after the checkout process as shown in the
following screen shot, disable the Customer Product Notification Status field. 

5. The Customer Shop Status - View Shop and Prices and Customer Approval Status - Authorization
Pending fields are related to the shopping functions of your store. Refer to “Limiting Catalog Information
and Store Function” on Page 222 for details.

6. Do not edit the Customer Authorization: filename unless you are absolutely sure you know what you are
doing! This field specifies the name of the PHP file in Zen Cart that controls how customer authorization
works.

7. Other fields related to how you want your store to be displayed, depending on the approval status of your
customers, are shown below: 

 Customer Authorization: Hide Header 
 Customer Authorization: Hide Column Left  
 Customer Authorization: Hide Column Right 
 Customer Authorization: Hide Footer 
 Customer Authorization: Hide Prices 

8. The Customers Referral Status field is related to how you want to use Discount Coupons to set up a
referral system in Zen Cart. Refer to “Implementing a Customer Referral Scheme via Discount Coupons” on
page 318 for details on implementing a customer referral scheme.

Text box disabled
 if State/Province 
contains entries.

Text box enabled
if State/Province 

does not
 contain any entries.

State – Always display 
as pulldown? 

= false.

State – Always display 
as pulldown? 

= true.

State – Always display 
as pulldown? 

= true.
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292 e-Start Your Web Store with Zen Cart

Another thing worth mentioning is to specify whether you want to receive a notification email if a new customer
creates an account with your store. If you would like to receive an email when a new customer signs up, you can
click on Configuration > E-Mail Options  and set the following fields accordingly.

 Send Copy of Create Account Emails To - Status 
 Send Copy of Create Account Emails To

Individual Customer Settings

The Customers Screen

The selection of individual customers and their respective configuration and functions are accomplished through the
Customers screen by clicking on Customers > Customers.

Editing a Customer's Details

To edit individual customer details:

1. Select a customer from the Customers screen and concentrate on the side-panel.

2. Click on edit to access the customer's details screen.

“orders” button will only appear if the 
customer has ordered something before.
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 Chapter 18   Managing Customers 293

Most fields contain information captured when the customer signed up for an account with your store so we
shall not discuss them further. You will probably not need to make any changes to these fields because
customers can change their personal information anytime by logging into their own accounts. 

3. The Customer Authorization Status allows you to control how the shopping function in your store should
appear to a particular customer. Refer to “Limiting Catalog Information and Store Function” on page 222 for
various options on how your store's shopping function can be configured.

4. The Discount Pricing Group field allows you to assign a discount group to a customer. This field was
discussed when we talked about “Customer Group Discounts” on page 235.

5. The Customer Referral 1st Discount Coupon field will be discussed later when we talk about
“Implementing a Customer Referral Scheme via Discount Coupons” on page 318.

Sending Emails to Selected Customers

To send emails to selected customers:

1. Select a customer from the Customers screen and concentrate on the side-panel.

2. Click on email to access the screen for you to start composing your email message.
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294 e-Start Your Web Store with Zen Cart

The Rich Text Message text area allows you to send HTML-formatted email messages to your customers. It
will only appear if you set Use MIME HTML When Sending Emails to true  when you click on
Configuration > E-Mail Options . The layout of the Rich Text Message text area will in turn depend on the
setting of the Text Editor  field as shown in the preceding screen shot.

3. Choose your customer or customers from the drop-down list box in the Customer field. There is a wide
choice of customers you can choose from as detailed below:

 All customers.
 All newsletters subscribers. 
 Customers who have been dormant for more than 3 months and are also newsletter subscribers.
 Active customers in the past 3 months who are also newsletter subscribers.
 Active customers in the past 3 months regardless of whether they are newsletter subscribers.
 Any individual customer, regardless of subscription status.

4. The From field for sending out emails is automatically populated. 

To change to another email address to automatically appear next time, click on Configuration > E-Mail
Options and change the value of the Email Address (sent FROM) field. However, this is not recommended
because it affects all emails sent from your store.

5. Enter the subject line for your email message in the Subject field.

6. Enter your message in the Rich Text Message field for customers who prefer to receive HTML formatted
emails. 

7. Enter your message in the Text-Only Message field for customers who prefer to receive their emails in plain
text. 

8. Click on preview to proceed to the next screen to preview your email message.

9. Click on send mail to begin sending your email.

10. A success message will appear at the top of the screen if the email was sent successfully.

Affects the display of 
“Rich Text Message”

 text area.

Text Editor = HTMLarea

Text Editor = -- none --
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 Chapter 18   Managing Customers 295

Viewing a Customer's Order History

This function is available only to customers who have purchased products from your store.

To manage individual customer orders:

1. Select a customer from the Customers screen and concentrate on the side-panel.

2. Click on order to access the Orders screen showing a list of orders previously made by the selected
customer.

3. We will discuss the individual functions available in the Orders screen in the following chapter.

Deleting Customers

To delete a customer, go to the Customers screen and click the delete button in the side-panel next to the selected
customer. Before you do that, take note of the following point. 

Therefore, instead of deleting customers, you might want to set the Customers Authorization Status of the
customer to one of the pending statuses instead.

Determining How Many Customers You Have 

To view the total number of customers you have, click on Admin Home on the navigation menu to reach your home
page. Look at the Customers field under the Statistics table. 

Order ID

Reset
Order ID
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296 e-Start Your Web Store with Zen Cart

Sometimes, the above figure may not be what you want because you have disabled several accounts by setting their
authorization status to one of the Pending Approval statuses. In that case, you should subtract the number of non-
approved customers from the above statistic to get a true view of the number of customers you have.

To check the number of non-approved customers you have:

1. Click on Customers > Customers to access the Customers screen. 

2. Click on the Asc or Desc hyperlink under the Authorized table column to sort customers via their approval
status. Note that non-approved customers are represented by a a red button icon in the Authorized  table
column.

3. Count the number of non-approved customers based on the number of red button icons in the Authorized
column.

   

Summary

In this chapter, you have learned how to manage both common and individual customer settings in Zen Cart. Mainly,
you were shown how to manage customer details, send email to customers and also to view an individual customer's
order history.
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Chapter 19 Managing Orders

Introduction

Once a customer purchases goods from your store, orders are generated and saved into Zen Cart's database. Based on
these orders, statistics can be generated which allow you to gain an insight into how your store sales are faring. With
each order, you will also be able to generate the corresponding invoices and packing slips which will be attached to
your goods shipment for delivery to customers.

In this chapter, we shall:
 Understand the different order statuses.
 Go through order statistics.
 Look at invoices and packing slips auto-generated by Zen Cart.
 Learn how to reset order IDs.

The Orders Screen

Most functions pertaining to order management in Zen Cart are performed in the Orders screen. The two ways you
can access the Orders screen are as follows:

 To access the Orders screen for all customers, click on Customers > Orders. 
 To access the Orders screen for individual customers, click on Customers > Customers and then click on

orders.

The following sample screen shot shows an Orders screen for all customers.

A subtle difference that exists between the Orders screens for individual customers and all customers is the existence
of a reset button on the individual customer Orders screen. By clicking on that button in the individual customer
Orders screen, your screen will refresh to show an Orders screen for all customers.
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298 e-Start Your Web Store with Zen Cart

Make a mental note of the Orders screen as we shall be referring to it throughout this chapter.

Working with Order Statuses

Each stage of the order fulfillment process can be reflected using an order status. Customers who log in to their
accounts can then track their orders themselves without having to call you. The following two screen shots show the
different order statuses appearing in different pages of a customer's account.

Another use for order statuses is to control whether digital downloads purchased from your store are entitled to
immediate or delayed downloads. Refer to “Selling Downloadable Products” on page 210 if you have forgotten how
downloads are configured.

Order Statuses and Their Meanings

By default, there are four order statuses defined in Zen Cart. These four statuses and their meanings are shown in the
following table.

Click to go to the the 
Order History screen
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 Chapter 19   Managing Orders 299

Table 19.1: Meaning of different order statuses

Status Meaning

Pending The default status defined in Zen Cart to assign to an order after a customer completes
the checkout process. Note: You can re-assign the default status to another order status.

Processing You acknowledge the receipt of an order and inform customers that you are currently
looking into their orders and taking the necessary steps to prepare the goods before
delivering to them.

This usually denotes that payment has been received and is therefore the status typically
used for payment modules which process credit card payments in real-time. Note that
the default Credit Card payment module in Zen Cart does not process credit card
payments in real-time.

Delivered Indicates that goods which customers have ordered have been shipped. This step usually
signals that the order fulfillment process has been completed.

Update Usually used only for exceptional cases in the order fulfillment process. For example,
customers receive their goods but complain that the goods are faulty. You can then set
the order status to “Update” for you to conduct further investigation into the matter
before deciding whether to grant a full or partial refund to the customer.

Another special case is the resetting of download properties for downloadable products
in a customer's order as mentioned on page 215.

The above order statuses and their meanings are based on the common order management work flow of most online
businesses. There is no “hard-wiring” of order statuses to meanings and so you can  alter their meanings to suit your
business needs. 

For example, if your online store sells rental space for a block of flats, you have nothing to deliver, so the Delivered
status becomes meaningless. Instead, you can think of the Delivered status as a Rented status. We shall take a look at
how to create new order statuses or edit them later in the chapter.

Updating Customer Order Statuses

Each time you perform a task in your order fulfillment process, you can update the status of an order. Order statuses
which have been updated will be reflected when customers log in to their accounts to view their order history.
Optionally, you can choose to send an email to customers upon updating their order statuses.

To update a customer order status:

1. Go to the Orders screen.

2. Choose an order from the screen and click edit to reach the orders detail screen.
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3. Add any remarks you have regarding the updated order status in the Comments field. 

4. Choose the new order status from the Status drop-down list box.

5. Check the Notify Customer check-box if you want an email to be sent to the customer informing the
customer of the change in order status.

6. Check the Append Comments field if you want the remarks you entered in the Comments field to be
included in the email sent to the customer. 

7. Click on update to confirm the change in order status.

A sample plain-text email sent to a customer is shown in the following screen shot. 

If you want to receive copies of the order confirmation emails sent to customers, click on Configuration > E-Mail
Options and set the relevant email addresses in the Send Copy of Order Confirmation Emails To field. 
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Customizing Order Statuses

As mentioned previously, your business needs might require that you have additional order statuses to cater for your
order fulfillment work flow. For example, if your store offers refunds for faulty goods shipped to customers, you can
choose to create an additional “Pending Goods Return” status to indicate you are waiting for your customer to return
the faulty goods before refunding them the amount for the purchase.

To customize your order statuses, click on Localization > Orders Status to access your Orders Status screen. 

 To change the name of an order status or to set it as the default order status, choose the order status and then
click on edit.

 To create an additional order status, click on insert.

 To remove an existing order status, click on delete. You should only do this for order statuses that you have
created.  Avoid deleting the default order statuses that come with Zen Cart as they are used in several parts of
your store. For example, when configuring whether customers are entitled to immediate or delayed product
downloads.

Viewing Order Statistics

Zen Cart provides an easy way for you to view the following statistics for your orders:
 Total number of orders for each order status.
 Quick view of new orders received.

To access your order statistics:

1. Click on the Admin Home hyperlink near the top of your Admin Console.

2. Statistics relating to your customer orders are found in the New orders and Orders tables.
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Generating Invoices from Orders

Whenever you deliver a product to a customer, you will need an invoice to accompany the delivery. Zen Cart
simplifies this process for you by allowing you to generate an invoice directly from an order.

To generate an invoice from an order:

1. Go to the Orders screen.

2. Choose an order from the screen and click the invoice button. 

3. A new window appears showing the invoice generated by Zen Cart.

4. Examine the information contained in the invoice carefully. If your invoice includes tax information, the
prices displayed may be different. Refer to “Display of Tax Information” on page 109 for more information
on how taxes are displayed.

To change the store information displayed on the top-left corner of the invoice, click on Configuration > My Store
and edit the Store Address and Phone field.

You can use the following methods to change the image on the top-right corner of the invoice:
 Replace the image <zc-home>/admin/ images/ logo.gi f with another image of the same name and

dimension.
 Adjust the following settings in the <zc-home>/admin/ includes/ languages/engl ish.php file to suit

the dimensions and name of your custom image.

define('HEADER_LOGO_WIDTH', '200px');
define('HEADER_LOGO_HEIGHT', '70px');
define('HEADER_LOGO_IMAGE', 'logo.gif');

Note that the same image is also used in the top-left corner of the Admin Console and any packing slips generated by
Zen Cart.

Generating Packing Slips from Orders

If you need to ship physical goods to your customers, you will likely need to have a packing slip accompany the
shipment. Again, you can generate a packing slip directly from an order.
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To generate a packing slip from an order:

1. Go to the Orders screen.

2. Choose an order from the screen and click the packing slip button. 

3. A new window appears showing the packing slip generated by Zen Cart. 

4. Examine the information contained in the packing slip carefully. Unlike an invoice, there is no payment
information associated with a packing slip.

To change the store information or image displayed on the packing slip, follow the instructions on page 302.

Resetting Order IDs

If you have been testing your store setup, you will have undoubtedly created several test orders. Before your Zen
Cart goes 'live' and starts accepting real customer orders, you might want to reset the order ID. For example, if your
test orders end at the order ID of “123”. You might want to reset the order ID to “1000” instead. This helps you
differentiate your test orders from your real orders.

To reset your order IDs:

1. Click on Tools > Store Manager to access the Store Manager screen. 

2. Concentrate on the portion of the screen as shown in the following screen shot. 

3. Read the instructions displayed below the Reset Current Order ID field carefully.

4. Follow the instructions on the screen and update the Old Order ID  and New Order ID fields accordingly.

5. Click the reset button next to the Reset Current Order ID field to use the new order ID on the next
customer order.

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


304 e-Start Your Web Store with Zen Cart

Summary

In this chapter, you have learned about the characteristics of different order statuses and how to define your own
custom order statuses. You have also gone through the different order-related statistics which can help you assess
how well your business is doing. To help with goods delivery, you also learned to generate packing slips and
invoices directly from individual orders. Finally, you saw how you can reset your order IDs before accepting real-
world orders.
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Chapter 20 Managing Stock

Introduction

The proper management of stock levels plays an important part in any business. Zen Cart currently provides a basic
stock management system for you to view different stock-related information and to help you meet customer demand
for your goods.

In this chapter, we shall:
 View stock information.
 Configure stock settings.
 Specify low stock email notification.

Checking Stock Information

Stock information allows you to quickly see which products need replenishment or which products have yet to reach
your store for sale.

Current Stock Levels

To check current stock levels:

1. Click on Reports > Products Low Stock to access the Product Stock Report screen. 

Notice that products with the lowest stock levels are listed first.

2. The figures displayed under the Quantity  column are taken from the Products Quantity fields of the
corresponding products in their respective Product screens. Products that have their Products Status field
marked as Out of Stock  in their respective Product screens will still be displayed in this screen. 

To control the number of products that are displayed in each page of the Product Stock Report screen, click on
Configuration > Maximum Values and edit the Maximum Display of Products on Reports field.
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306 e-Start Your Web Store with Zen Cart

Future Stock Expected

Another report of interest to you when assessing your stock level is the products that you have ordered but have yet
to arrive in your store. Currently, this report only displays the names of the products and not the quantity. 

To check the products that have yet to arrive:

1. Click on Catalog > Products Expected to access the Products Expected screen.

2. The dates displayed under the Date Expected column are taken from the Date Available fields of the
corresponding products in their respective Product screens. 

3. To view or change the product's details including its availability date and quantity, click on edit to access the
product's Product screen.

Configuring Stock Settings

Besides generating reports on stock-related information, Zen Cart allows you to configure how your stock levels are
controlled and how you want your stock-related information to be displayed to customers.

To configure your stock settings:

1. Click on Configuration > Stock to access your Stock screen.

2. Refer to the following table to learn how you can configure the various stock-related fields in the Stock
screen.
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Field Comments

Check stock level Indicates whether a warning message will be displayed when the number of
items for a particular product added to a shopping cart exceeds the actual
quantity of the product. Consider the case when you set this field to true .

If you have specified that the quantity of a product is “1” and a customer adds
“3” items of the same product to the shopping cart, an error message will be
displayed indicating there is insufficient stock for the customer to purchase.

Subtract Stock Indicates whether to automatically decrease the stock level by an amount
equivalent to that which the customer purchased. Consider the case when you
set this field to true .

If you have specified that the quantity of a product is “10” and a customer adds
“4” items of the same product to the shopping cart. The quantity of the product
in your store will automatically be set to “6” after the customer completes the
checkout process.

Allow Checkout Indicates whether to prompt a customer to change the number of items in the
shopping cart if the number of items exceed the product quantity. 

If you set this value to true , you run the risk of over-selling and if your
suppliers cannot meet your sudden demand, your reputation with customers will
suffer. Therefore, the recommended value is false .

Mark product out of
stock

Sets the display characters that should be displayed to indicate that a product is
out of stock. An example screen shot of the default value “***” appearing in a
shopping cart is shown below. 

Stock re-order level Specifies the level of stock that you want to use as an indicator for you to begin
ordering more supplies. 

This field will come in handy if you intend to receive email alerts for products
that are out of stock.

Products status in
Catalog when out of
stock should be set to

If you have set the Subtract Stock field to true ; when the stock level reaches
zero or a negative number, the Products Status field of the product in the
Product page will be updated according to the setting in this field.

If this field is set to 0, the Products Status field in the product's Product page
will be set to Out of Stock  and the product will not be displayed in the
Store Front. If this field is set to 1, the Products Status field will be set to In
Stock  instead.
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Field Comments

Show Sold Out Image
in place of Add to Cart

If this value is set to 1, an image with the words “Sold Out” will be displayed
on the Product Info page in the Store Front instead of the usual “Add This To
My Cart” button and the check box to specify the number of items to order.

Product Quantity
Decimals

Allows you to sell products that do not come in whole units. For example, if you
sell fabric by the yard, customers can enter 1.25 yards when adding the product
to the cart.

Remember to adjust the product's quantity-related fields in the Product screen if
you intend to support fractional quantity values in your store.

3. The remaining fields on the Stock screen (as listed below) relate more to the display of the customer's
shopping cart contents in the Store Front than to stock-related information. Thus, we will not discuss them
here. 

 Show Shopping Cart - Delete Checkboxes or Delete Button 
 Show Shopping Cart - Update Cart Button Location 
 Show New Products on empty Shopping Cart Page 
 Show Featured Products on empty Shopping Cart Page  
 Show Special Products on empty Shopping Cart Page 
 Show Upcoming Products on empty Shopping Cart Page 

Receiving Low Stock Email Notifications

Zen Cart has the ability to send email alerts to you when the stock reaches the re-order level you specified in the
preceding Stock screen. 

Note that an email alert will not be sent if you manually alter the product quantity to reach a level below the re-order
level. Only re-order levels that have been reached via the system subtracting the product's quantity by an equivalent
number of purchased items will trigger the email alert.

To receive emails for stocks that have reached the re-order level:

1. Click on Configuration > E-Mail Options  to access your Email-Options screen.

2. Edit the following fields accordingly: 
 Send Low Stock Emails 
 Send Low Stock Emails to 

Summary

In this chapter, you have learned to view stock-related information and how to configure your desired stock settings.
You have also seen how you can configure email alerts for products that have reached a predetermined low stock
level, thus eliminating the need for you to constantly log in to your store to check your stock levels.
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Chapter 21 Marketing

Introduction

Besides having great products and services, one of the keys to profitability is how you market your online store and
products. The marketing aims you can achieve with the techniques presented in this chapter are as follows:

 Direct customers to visit your store.
 Build long-term relationships with your customers in order to increase the likelihood of repeat sales.
 Promote other products which customers may not be looking to buy when they visit your store.

In this chapter, to help you achieve the above marketing aims, we shall:
 View statistics which will help you in your marketing decisions.
 Go through the following marketing techniques:

➔ Discount Coupons 
➔ Gift Certificates 
➔ Featured Products 
➔ Newsletters 
➔ Product Reviews 
➔ Tell-a-Friend 
➔ Banners 
➔ Search Engines 
➔ Other Product Promotion Features

Note that you can also use the sales techniques presented in “Giving Discounts” on page 228 to achieve some of the
marketing aims.

Be warned that this chapter is very long. So if you are short of time, you should just read the following section,
“Gathering Useful Statistics”, and then jump to any marketing technique you want to use.

Gathering Useful Statistics

Before deciding on a marketing technique to use, you should gather some statistics to understand current customer
spending and viewing behavior in your store. You can then measure the effectiveness of each marketing technique by
comparing the before and after results of these statistics. These statistics can also be used to target high-value
customers because repeat business from these customers will have a higher impact on your profits.

Products Viewed and Products Purchased

Statistics generated from products viewed and products purchased from your store allow you to tailor your marketing
campaign in a product-centric manner. For example, if you realize a product is commonly viewed but not usually
purchased by customers, you can create and send a newsletter to your customers telling them the benefits of the
product thus creating the impetus for them to buy.
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310 e-Start Your Web Store with Zen Cart

To view statistics for products viewed, click on Reports > Products Viewed to access the Best Viewed Products
screen.

To view statistics for products purchased, click on Reports > Products Purchased to access the Best Products
Purchased screen.

You may want to reset the statistics for the above screens if you wish to begin a new marketing campaign. In this
way, the effectiveness of your marketing campaign will be more easily determined, as you do not have to take into
account any old values when viewing the statistics. 

To reset the statistics for the preceding screens: 

1. Click on Tools > Store Manager and concentrate on the following portion of the screen. 

2. To reset the statistics for the Best Viewed Products screen, click on the reset button next to the Reset ALL
Products Viewed field.

3. To reset the statistics for the Best Products Purchased screen, click on the reset button next to the Reset ALL
Products Ordered field

Total Order Values Per Customer

Statistics generated from the relationship between customers and their total order values allow you to tailor your
marketing campaign in a customer-centric manner. For example, you can use this information to identify high-value
customers and use Discount Coupons or Gift Certificates to reward them and breed long-term customer loyalty.

To view statistics relating customers to total order values, click on Reports > Customer Orders-Total to access the
Best Customer Orders-Total screen.
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Discount Coupons 

Discount coupons are used by customers to purchase products at a discounted value. The discounted value can either
be a percentage off a product's price or an absolute dollar amount. Discount coupons can also be applied to customer
orders to give free shipping if a minimum order value is reached.

They have proven to be very popular with customers and can be used as a low-cost way of introducing your product
or service to the marketplace. For example, you can give out discount coupons to loyal customers to try your new
products at a discounted rate. Over time, your products will gain the recognition of customers as they keep coming
back to buy more products from you.

As discount coupons can eat into your profits, you should exercise discretion when using them. Zen Cart can help
you in this aspect by restricting the use of discount coupons to certain categories of products only.

How Discount Coupons Work

The way Discount Coupons work is outlined below: 

1. Discount coupons are created by store owners and sent to customers either during account creation or
selectively via email from the Admin Console. Alternatively, discount coupon codes can be advertised in
newspapers and magazines or disseminated through salespersons if you want to implement a customer
referral scheme.

2. Store owners can choose to restrict the usage of discount coupons to certain categories and products. Coupon
usage can also be restricted based on the billing addresses of customers.

3. Customers can make use of their discount coupons when they are prompted to enter a discount coupon code
on the Payment Information screen during the checkout process.

Configuring the Discount Coupon Module

Before you can start using Discount Coupons in your store, you need to enable and configure the Discount Coupon
order total module as follows:

1. Click on Modules > Order Total to access the Order Total Modules screen.

2. Edit the Discount Coupon module. Install it if required. 
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3. Enter a suitable value for the Sort Order field. Refer to “The Order Total Modules Screen” on page 226 if
you have forgotten the purpose of this field.

4. Specify true  for the Include Shipping field if you want shipping charges to be covered by a discount
coupon.

5. Specify true  for the Include Tax field if you want taxes to be covered by a discount coupon. 

6. Choose a suitable value for the Re-calculate Tax field. Usually, you should leave this as none . If you
choose Standard  or Credit Note  , you will need to play around with different test orders to see whether
they suit your needs.

7. If you have chosen Credit Note  for the Re-calculate Tax field, you should choose a suitable option from
the Tax Class drop-down list box.

8. Click update to finish configuration of your Discount Coupon order total module.

You should play around with the Sort Order field for all the order total modules if you encounter erroneous or
illogical calculations. If that does not help, your last resort is to refer to the PHP code contained in the <zc-home>/

includes/modules/order_total/ot_coupon.php file.

After a Discount Coupon module is enabled, a Discount Coupons hyperlink will appear in the Information side-box.
Upon clicking this hyperlink, visitors can type in a discount code to view the details associated with that particular
discount code. The following screen shots illustrate the process.
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Creating Discount Coupons

To create a discount coupon:

1. Click on Gift Certificates/Coupons > Coupon Admin to access the Discount Coupons screen. 

2. Click on insert to access the coupon details screen. 
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3. All fields on the screen have corresponding explanations next to them so you should not have any problems
entering the correct values. However, before entering the relevant details into the screen, take note of the
following points: 

 Coupon Amount and Free Shipping are mutually exclusive! You should only specify one or the
other; but not both at the same time. The system will not show any errors but you will have problems
later when customers start using their coupons. Also make sure the Free Shipping module is enabled
if you enable the Free Shipping check-box.

 It is a good idea to leave the Coupon Code field empty to allow Zen Cart to generate a unique code
for you. This is because humans tend to specify coupon numbers in sequence and clever customers
might just make use of this loophole to use the coupon codes of other customers!

 What you specify for the Uses per Coupon field will depend on how you structure your coupon
marketing campaign. The following two scenarios should help you decide what value to enter for the
field:

If you advertise a 10% discount coupon in the newspapers for a laptop your store sells, you are
limited to a single discount coupon code for that advertisement. Thus, you would have to leave the
Uses per Coupon field blank because you want as many people as possible to use the same discount
code to purchase the laptop from your store. 

If you send unique discount coupons to customers on their birthdays, then you might want to restrict
them to use the coupon for one time purchases only. In this case, you should specify 1 for the Uses
per Coupon field. 

 The Uses per Customer field allows you to limit the use of a discount coupon on a per-customer
basis. 

There might be some confusion with the Uses per Coupon field if you happen to specify both at the
same time. 
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For example, if you specified Uses per Coupon to be 50 and Uses per Customer to be 1, then how
many times can each customer use a particular coupon? The answer is each customer can use a
particular coupon only once. However, if the same coupon is given to another 60 customers, then
only the next 49 customers can use the same coupon code and each of those 49 customers can use the
coupon once also. 

 You are strongly advised to set the Start Date and End Date fields to limit the validity period for
your discount vouchers. There are two benefits to this approach:

➔ Customers will tend to make their purchase decisions faster with a looming expiry deadline
for their discount coupons. 

➔ It limits the possibilities of customers turning up with old discount coupons with rates you
offered long ago, which are no longer profitable for you to continue offering now.

 You can restrict coupon usage to only be eligible if customers billing addresses falls within the
specified zone definition in the Coupon Zone Restriction drop-down list box.

4. After entering all the relevant coupon details, click preview to proceed to the next screen to have a look at
your changes. 

5. Once you are satisfied with your changes, click confirm to create the coupon.

Restricting Coupon Usage by Category or Product

It is a good idea to restrict the use of your coupons to certain categories of products in your store. This allows you to
better control the cost of running your discount coupon campaign as you can work out which products you can afford
to offer at discount, and with what percentage or value, without eating into your profits significantly. 

To limit the use of discount coupons to certain categories or products:

1. Select the discount coupon to which you want to apply a restriction from the Discount Coupons screen.

2. Click on restrictions to bring up a screen for you to restrict the use of the discount coupon to certain
categories and/or products. 

3. To restrict your coupon usage to specific categories, choose from the relevant drop-down list boxes under
the Category Restrictions heading. After making your choice, click Add to confirm the restriction. Repeat
this step for all other categories you wish to restrict.

4. To restrict your coupon usage to specific products, choose from the relevant drop-down list boxes under the
Product Restrictions heading. Choose the different products you want to allow or deny and click Add.
Repeat this step for all other products you wish to restrict.
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5. Once you are satisfied with your choice, click back to return to the Discount Coupons screen.

The use of your discount coupon should now be limited only to the specific categories and/or products you have
allowed or denied. If you face problems configuring your product restrictions, try setting Deny on the Top category
before setting Allow  on individual products.

Delivering Discount Coupons to Customers Electronically

There are two ways which discount coupons can be sent to customers electronically:
 Selectively email discount coupons to customers manually via the Admin Console.
 Send discount coupons automatically to customers upon account creation.

Manually Email Discount Coupons to Customers

To receive copies of discount coupon emails sent manually via the Admin Console, click on Configuration > E-
Mail Options  and enable the following fields:

 Send Copy of Admin Discount Coupon Mail Emails To – Status
 Send Copy of Customer Admin Discount Coupon Mail Emails To 

To send discount coupons to customers directly via the Admin Console:

1. Click on Gift Certificate/Coupons > Coupon Admin to access the Discount Coupons screen.

2. If you want a HTML toolbar to help you compose HTML email messages, choose HTMLarea from the Text
Editor  field.

3. Select the discount coupon you want to mail to your customers and click email on the side-panel to bring up
the email details page. 

You will see two text areas for you to enter your email message if you have enabled Use MIME HTML
When Sending Emails in Configuration > E-Mail Options .

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


 Chapter 21   Marketing 317

4. Enter the relevant details and click send mail to bring up another screen for you to preview your email
message.

 
5. Click on send mail in that screen to send your discount coupons to the relevant parties. 

A sample discount coupon plain-text email sent to a customer via the Admin Console is shown in the following
screen shot.

Automatically Send a Discount Coupon on Account Creation

To receive copies of discount coupon emails sent automatically to customers on account creation, click on
Configuration > E-Mail Options  and enable the following fields:

 Send Copy of Create Account Emails To – Status
 Send Copy of Create Account Emails To 

To enable selected discount coupons to be sent on account creation:

1. Click on Configuration > GV Coupons to access the GV Coupons screen.
 

2. Click on New Signup Discount Coupon ID# and concentrate on the side-panel. 

3. Choose a discount coupon you have previously created from the drop-down list box and click update. The
selected discount coupon will be sent to the next customer who signs up for an account with your store.

4. If you want to change the generated discount coupon code length, edit the Length of the redeem code field.

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


318 e-Start Your Web Store with Zen Cart

For example, if you specify this length to be 10, then the redeem code generated by Zen Cart may look like
9e47daba3b . 

If you had previously specified your own value instead of leaving the code generation to Zen Cart for the
Coupon Code field when creating the discount coupon, then this field will have no effect. Furthermore, note
that a change to this field will also affect the length of the redeem codes for gift certificates! 

5. If you want to change the order status for an order total balance of zero after applying your discount coupon,
you can edit the Default Order Status For Zero Balance Orders field.

A sample discount coupon plain-text email received by a customer on account sign-up is shown in the following
screen shot.

Implementing a Customer Referral Scheme via Discount Coupons

A Customer Referral scheme allows you to expand your customer base and assess how effective your marketing
campaign is by tracking how effective your different channels of marketing (salespersons, advertisements, etc) are
performing. 

For example, if you have a team of salespersons, you can give each of them a unique discount code. Your
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salespersons will give out their individual discount codes to each new customer they find for your business. When
these new customers sign up for an account with your store, they will use the unique discount code of the salesperson
who introduced them to your business. In this way, you can track the performance of each salesperson by looking at
the number of new customers who sign up with your store using the unique discount code of a salesperson.

How Customer Referrals Work

The term referral code appears constantly when discussing referrals. It is actually a discount coupon code which has
been “tagged” to specific customers to identify how they arrive at your store. It can only be used once per customer
and is used to find out how customers come to know about your site.

For example, when a customer signs up with your store using a discount code they acquired from a magazine, radio
or TV advertisement. That discount code is then known as a referral code because that customer was “referred” to
your store by that magazine advertisement.

Here is how referrals works in Zen Cart:

1. Discount coupons are created. 

2. Discount coupons are then disseminated through different channels accordingly; salespersons,
advertisements, parties, etc. 

3. Customers learn of your online store through one of your referrers (salespersons, advertisements, etc). 

4. Customers sign up with your store using the discount code you handed out in Step 2. Optionally, customers
can enter the discount code handed out in Step 2 when they check out their purchases.

5. Zen Cart associates each discount code with the referrer and calls it a referral code.

6. Store owner views a report of how the different referrers and referral schemes have performed. 

Track Customer Referrals

There are two methods to track customers who were referred to your site: 

 When customers sign up for a new account, they can enter the referral discount coupon code on the sign-up
form of the Log In screen. 

In this case, Zen Cart is able to determine the referrer immediately after the account creation process
completes successfully.

 When customers enter their referral discount coupons in the Payment Information screen during checkout.  
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320 e-Start Your Web Store with Zen Cart

In this case, Zen Cart stores the first discount coupon code used by the customer during checkout in order to
identify the referral source.

To configure which method you would like to use to track customer referrals: 

1. Click on Configuration > Customer Details to access the Customer Details screen. 

2. Click on Customer's Referral Status field and concentrate on the side-panel. 

 Choose 0 if you do not want to use the Customer Referral feature. 

 Choose 1 if you want to track customers by noting the first time a discount coupon is redeemed by them. 

 Choose 2 if you want to track customers by asking them how they were referred to your store from the
sign-up portion of the Log In screen or when customers edit the referral source in their My Account area
if the referral source has not already been set. 

3. Click on update to effect your changes. 

Once a referral code has been attached to a customer, only the store owner can change the referral code. To see where
the referral code for a customer is stored:

1. Click on Customers > Customers to access the Customers screen.

2. Select your desired customer and click the edit button on the side-panel.

3. The referral code for a customer is shown in the Customer Referral 1st Discount Coupon field as shown in
the following screen shot.
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View Report on Customer Referrals

To view the performance of your referrers and referral schemes:

1. Click on Reports > Customers Referral to access the Customers Referral Report screen. 

2. Choose a referral coupon code from the drop-down list box at the top of the screen. 

3. Specify which period of the report you would like to view by entering the appropriate dates into the Start
Date and End Date fields.

4. Click display and a list of orders using the particular referral coupon you specified in Step 2 will be
displayed. A sample screen shot is shown below.

Viewing Discount Coupon Usage Statistics

To view the usage statistics for individual discount coupons:

1. Click on Gift Certificate/Coupons > Coupon Admin to access the Discount Coupons screen.

2. Select a discount coupon and click Report to bring up the discount coupon usage details screen.
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Gift Certificates

Gift certificates are commonly used as a marketing tool for businesses as they offer the following advantages:
 Convenient for people who do not know what gifts to buy. 
 Provide immediate cash to the business without having to supply a product or service until a later date. Thus,

they behave similarly to an interest-free loan. 
 Inexpensive way to widen your customer base.

There are some important concepts to take note of before you start offering gift certificates in your store:
 Unlike discount coupons for which you can specify an expiration date, gift certificates represent real money

and do not expire.
 Gift certificates can be purchased by customers like ordinary products, sent by store owners to customers or

transferred between customers. 
 Discounts cannot be applied to gift certificates.
 A unique code is associated with each gift certificate.
 Gift certificate values are transferable. For example, if a customer has a $100 gift certificate, he is able to

transfer $20 to his relative and his account will be left with $80 
 They cannot be restricted to different categories like discount coupons.

How Gift Certificates Work

The way Gift Certificates work is briefly outlined below: 

1. Gift certificates are created as products and sold; or they are created by the store owner and sent to customers
either during account creation or selectively via email from the Admin Console.

2. Customers who purchase gift certificates will have the amount credited into their gift certificate accounts in
your store. Customers who receive their gift certificates via email will have to redeem them at your store
using the gift certificate code in their emails. After a gift certificate is redeemed, the gift certificate amount
will be credited into the gift certificate account of the redeemer.

3. To prevent cases of fraud, the store owner can configure whether gift certificates need to be approved before
they can be used in your store.

4. The value contained in gift certificates can then be used when purchasing goods from your store. The
customer will be prompted to enter a gift certificate code on the Payment Information screen during the
checkout process.

To give you a more complete picture of the workings of gift certificates, we shall cover the following areas in greater
detail.

 How customers receive their gift certificates.
 How gift certificates are displayed on customer account screens.
 How gift certificates are used for purchase and transfer.
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How Customers Receive Their Gift Certificates

There are actually several ways by which customers can receive their gift certificates.

 Customers can buy them from your store if you have created your gift certificates as products. 
 Store owners can create gift certificates and send them to selected customers manually via email.

Alternatively, gift certificates can be automatically sent via email on account creation.
 Customers can also receive their gift certificates from other customers. If the receiving parties are not

currently customers of your store, they will be prompted to sign up for an account before their gift certificate
values can be redeemed.

Gift certificates which are not bought as products from your store will have to be redeemed. Details required to
redeem a gift certificate are contained in emails sent to customers. A sample gift certificate email sent to a customer
by a store owner is shown in the following screen shot.

Redemption of Gift Certificate Values

There are two ways customers can go about redeeming the values in their gift certificates as shown in the gift
certificate emails sent to them:

 By clicking on the hyperlink which contains a gift certificate code in the gift certificate email sent to them,
the customer will be redirected to your online store. After logging in or creating a new account if the
customer does not have an account yet, the gift certificate value will automatically be redeemed. A success
message indicating the value of the gift certificate redeemed will be shown to the customer as seen in the
following sample screen shot.

 By entering the gift certificate code contained in the gift certificate email in the Redemption Code field of the
Payment Information screen during the checkout process. 

Value of Gift Certificate

Unique 
Gift Certificate number 
generated by Zen Cart
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324 e-Start Your Web Store with Zen Cart

A success message indicating the value of the gift certificate redeemed will be shown to the customer only
when proceeding to the next screen. A sample success message when a $50.00 gift certificate is redeemed is
shown in the following screen shot.

The Gift Certificate Account Balance

Customers can check their gift certificate balance when they log in to view their account details. A gift certificate
balance displayed in a customer's account is shown in the following sample screen shot.

Alternatively, if a customer is logged in, the gift certificate balance will be displayed in the Shopping Cart side-box
as shown in the following screen shot.

 

How Gift Certificates Can Be Used

Customers can choose to use their gift certificates for the following purposes:
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 Chapter 21   Marketing 325

 Purchase of products in your store using the balance in their gift certificate account.
 Transfer the value (either wholly or partially) to someone else.

To purchase products using the balance in their gift certificate accounts:

 At the Payment Information screen during the checkout process, customers can make full or partial use of the
money currently in their gift certificate accounts for their purchase by entering a suitable value in the Apply
Amount field.

Alternatively, if customers want to redeem and use the value in a gift certificate at the same time, they can
enter the redeem code into the Redemption Code field instead.

To transfer the values within their gift certificate account balances:

 Customers can click on the Send a gift certificate hyperlink in their Account Information screen and the
following screen will appear 

After they are done filling in the details in the screen, they can click send to transfer a portion of their gift
certificate account balance as a gift certificate to another person.

When customers transfer the gift certificate amounts in their accounts to other customers, you can also be notified via
email. To set up this email notification, go to Configuration > E-Mail Options  and set the following fields
accordingly. 

 Send Copy of Customer GV Send Emails To - Status 
 Send Copy of Customer GV Send Emails To
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Configuring the Gift Certificates Module

Before you can start using gift certificates in your store, you need to enable and configure the Gift Certificates order
total module as follows:

1. Click on Modules > Order Total to access the Order Total Modules screen.

2. Edit the Gift Certificates  module. Install it if required.

3. Enter a suitable value for the Sort Order field. Refer to “The Order Total Modules Screen” on page 226 if
you have forgotten the purpose of this field.

4. The Queue Purchases field is only relevant for gift certificates that are purchased as products from your
store. This field has no effect for gift certificates that are emailed to customers.

Choose false  for the Queue Purchases field if you want the amount in a gift certificate to be credited
automatically into a customer's gift certificate account after purchase. If Queue Purchases is set to true ,
you will have to manually credit the amount to the customer's gift certificate account. 

Recommended value is true  if you want to avoid the possibility of fraud. For example, consider the case
where you set this value to false  and customers pay for a gift certificate via credit card. If the gift
certificate amount is immediately credited into their accounts, they can use it to purchase goods or services
from your store immediately. After they know your goods are being shipped to them, they then cancel their
credit card payment.

However, you might choose to set this value to true  if it becomes impractical for you to manually approve
gift certificates because too many people are buying them. In that case, make sure you use a payment method
that would reduce the possibility of fraud (i.e. PayPal).

5. Specify true  for the Include Shipping field if you want shipping charges to be covered by a gift certificate.

6. Specify true  for the Include Tax field if you want taxes to be covered by a gift certificate.

7. Choose a suitable value for the Re-calculate Tax field. Usually, you should leave this as none . If you
choose Standard  or Credit Note  , you will need to play around with different test orders to see whether
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they suit your needs.

8. If you have chosen Credit Note  for the Re-calculate Tax field, you should choose a suitable option from
the Tax Class drop-down list box.

9. The Credit Including Tax  field is only relevant for gift certificates which you have created as taxable
products. For example, suppose you have created a gift certificate as a product for sale and applied a tax rate
of 10% to it. If the gift voucher is priced at $10.00, the customer will be charged $11.00 on checkout due to
product tax. 

Now how much should go into the customers gift certificate account balance? If this option is set to true ,
then customers will receive $11.00 in their gift certificate account balance. If this option is set to false ,
then customers will get $10.00 in their gift certificate account balance instead.

10. Choose an order status to associate to an order from the Set Order Status field if a gift certificate covers the
full amount of an order. 

11. Click update to finish configuration of your Gift Certificates order total module.

You should play around with the Sort Order field for all the order total modules if you encounter erroneous or
illogical calculations. If that does not help, your last resort is to refer to the PHP code contained in the <zc-home>/

includes/modules/order_total/ot_gv.php file.

If a Gift Certificate module is enabled, a Gift Certificate FAQ hyperlink will appear in the Information side-box.
Upon clicking this hyperlink, a customer can redeem a gift certificate or find out more about the use of gift
certificates by clicking the relevant hyperlinks under the “Gift Certificate FAQ” text. The entire process is illustrated
in the following screen shots.

Selling Gift Certificates as Products

Unlike discount coupons, you can sell gift certificates as products. Since gift certificates are commonly displayed
with their values, you may want to consider creating the relevant gift certificate images before you start creating your
gift certificate product.

If you have a local copy of Zen Cart installed, you can refer to the directory <zc-

home>/images/gi ft_cert i f icates to take a look at some of the sample Gift Certificate images available.
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328 e-Start Your Web Store with Zen Cart

To create gift certificates as products in your store:

1. Navigate to the Categories/Products screen and create a product of “Product-General” type under your
desired category.

2. In the Product screen of the product, pay extra attention to the fields shown in the following table while
creating your product.

Field Value Explanation

Product is Virtual Yes, Skip Shipping Address Since this is an electronic Gift
Certificate, no delivery of the Gift
Certificate is required.

Always Free Shipping Yes, Always Free Since a cash amount equivalent to the
value of the Gift Certificate is stored in
the customer's account, there is nothing
to physically ship to a customer.

Products Model GIFT-XXX This field must begin with “GIFT” and
with capitals. Consider marking this field
as “GIFT-10” or “GIFT-100” to
differentiate between different gift
certificates.

Do not mis-configure this step!

Products Shipping Weight 0 Since an electronic Gift Certificate has
no weight.

3. Use your discretion to specify the values for the other fields on the screen. 

4. Click on save to create the gift certificate as a product.

Approving Gift Certificates

Note that a gift certificate purchased as a product by a customer may not have its value credited into a customer's
account immediately. An optional approval process may need to be performed by the store owner before the gift
certificate value is released into the customer's gift certificate account balance as a precaution against possible fraud.
This additional approval process does not apply to gift certificates that are sent via email from Zen Cart to customers
or between customers themselves.

To ensure that gift certificates are approved by the store owner before their values are released into customer
accounts:

1. Click on Modules > Order Total to access the Order Total Modules screen.

2. Edit the Gift Certificates  module.

3. Make sure that the Queue Purchases field is set to true .
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To approve a gift certificate:

1. Look for the GIFT Queue button that appears at the top of your Admin Console as shown in the following
screen shot.

2. Alternatively, click on Customers > Orders to access the Orders screen and then run through each
individual order to see which are the orders that have a GIFT Queue button displayed in their side-panels as
shown in the following sample screen shot.

3. Either way, by clicking on a GIFT Queue button, you will reach the Gift Certificate Release Queue screen.
Another way to reach the Gift Certificate Release Queue screen is to simply click Gift Certificate/Coupons
> Gift Certificates Queue. 

This screen contains a list of gift certificates that are waiting for approval before their amounts are credited
into the relevant customer's gift certificate account.

4. Choose the gift certificate you wish to approve and click on Release GIFT to bring up a side-panel
prompting you to confirm your decision.

5. Click on Confirm  to release the value of the gift certificate to a customer's gift certificate account balance. 
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Delivering Gift Certificates to Customers

There are two ways which gift certificates can be sent to customers electronically:
 Selectively email gift certificates to customers manually via the Admin Console.
 Send gift certificates automatically to customers upon account creation.

Manually Email Gift Certificates to Customers

To receive copies of gift certificate emails manually sent to customers from the Admin Console, click on
Configuration > E-Mail Options  and edit the following fields accordingly:

 Send Copy of Admin GV Mail Emails To - Status 
 Send Copy of Customer Admin GV Mail Emails To

To send gift certificates to customers manually via the Admin Console:

1. Click on Gift Certificate/Coupons > Mail Gift Certificate  to access the Send Gift Certificate To
Customers screen.

You should be able to see two text areas for you to enter your email message if you have enabled Use MIME
HTML When Sending Emails under Configuration > E-Mail Options .

2. Specify the recipient(s) of the gift certificate by choosing from the Customer drop-down list box or entering
an email into the Email To field. 

3. The From field is automatically populated with the value from the Email Address (sent FROM) field of the
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E-Mail Options screen. 

4. Enter some text for the Subject field which will appear in customer emails.

5. Specify the value of the gift certificate you wish to send to customers by entering a number into the Amount
field. Do not specify the currency symbol as Zen Cart automatically appends the symbol of the default
currency to this amount when sending out the email. 

6. Enter any other text that you might want to send to your customers in the Rich Text Message and Text-Only
Message fields. These fields correspond to emails that are formatted in HTML and plain-text respectively.

7. Click on send mail to bring up another screen to preview the email message and message recipients. 

8. Click on send mail in that screen to send the gift certificate.

A sample plain-text gift certificate email sent to a customer from the Admin Console is shown in the following
screen shot.

Automatically Send a Gift Certificate on Account Creation

To receive copies of gift certificate emails sent automatically to customers on account creation, click on
Configuration > E-Mail Options  and enable the following fields:

 Send Copy of Create Account Emails To – Status
 Send Copy of Create Account Emails To 

To enable Gift Certificates to be automatically created and sent on account creation:

1. Click on Configuration > GV Coupons to access the GV Coupons screen.
 

2. Click on New Signup Gift Voucher Amount and concentrate on the side-panel. 
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3. Enter the gift certificate amount into the text box and click update. 

4. If you want to change the gift certificate code length, edit the Length of the redeem code field. For
example, if you specify this length to be 10 , then the redeem code generated by Zen Cart for the gift
certificate may look like 9e47daba3b . (Warning: This field also affects the length of a redeem code for
discount coupons!) 

6. If you want to change the order status for an order total balance of zero after applying your gift certificate,
you can edit the Default Order Status For Zero Balance Orders field.

A sample plain-text gift certificate email received by a customer on account sign up is shown below. Note that only
the gift certificate portion of the email is shown.

Track Gift Certificates Sent

To track all the gift certificates you have sent to customers or those that customers send between themselves, click on
Gift Certificate/Coupons > Gift Certificates sent to access the Gift Voucher's Sent screen as shown in the
following sample screen shot.
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Newsletters

Newsletters allow customers to stay informed of new happenings in your store. They are delivered via email and
provide an excellent means of building relationships with your customers.

Zen Cart provides two types of newsletters:
 General newsletters – for promotional purposes and general store news. 
 Product newsletters – these are divided into product-specific and all-products newsletters. 

How Newsletters Work

The way Newsletters work is outlined below:

1. Customers opt in to receive a particular newsletter. There are several ways this can be done. 

 During account creation, customers can opt in to receive General newsletters.

 After account creation, customers can log in to their accounts to opt in to receive General newsletters
or Product newsletters.

 Anytime customers are viewing a product's details, they can opt in to receive a Product-specific
newsletter by clicking in the Notifications side-box.

2. Store owners compose and send the relevant newsletters to interested customers. 
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3. Customers can choose to unsubscribe from any newsletter anytime. Again, there are several ways to do this. 

 By clicking on the Newsletter Unsubscribe hyperlink in the Information side-box. This will allow
customers to unsubscribe from the General newsletter. Customers will be prompted to log in if they
have not done so.

To check whether the Newsletter Unsubscribe hyperlink is available in your Information side-box,
click on Configuration > E-Mail Options  and check that the Display "Newsletter Unsubscribe"
Link?  is enabled.

 Customers can log in to their accounts and unsubscribe from the General or Product newsletters.

Enabling Newsletter Sign-Up on Account Creation

This feature applies only to General newsletters where users can be informed of the latest promotion or news from
your store. 

To allow customers to opt in to receive newsletters during account creation:

1. Click on Configuration > Customers Details to access the Customer Details screen.
. 

2. Make sure the Show Newsletter Checkbox field is enabled. 
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Your customers should now see the newsletter subscription option when they sign up for an account with your store
as shown in the following screen shot.

Creating Newsletters

We shall now look at the process of creating the relevant General and Product email newsletters for your customers.

To create and send newsletters to your customers:

1. Click on Tools > Newsletter Manager and Product Notifications Manager to access the Newsletter and
Product Notification Manager screen. 

2. To create a new newsletter, click on new newsletter to proceed to the newsletter details screen. 

3. In the Module field, choose newsletter  if you wish to create a General newsletter and
product_notification  if you wish to create a Product newsletter.

4. Enter a name for your newsletter in the Subject field. This name will also be displayed in the subject line of
emails that customers receive.

5. Recall that users have the option of choosing whether they want to receive their emails in HTML or plain
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text when they sign up for a newsletter. Therefore, enter your newsletter details into both the Rich-Text
Content and Plain-Text Content areas to cater for both sets of users. 

6. Enter all relevant details and click save to effect your changes. Your newly created newsletter will be
displayed in the Newsletter and Product Notification Manager screen. 

7. To send your newly created newsletter, click on your desired newsletter in the Newsletter and Product
Notification Manager screen.

8. Click on send to begin sending your newsletter. What screen you see next will depend on what you entered
for your Module field in Step 3. 

 If you specified newsletter , you will be prompted to select your newsletter recipients.

Choose your desired newsletter subscribers from the drop-down list box and then click on select.
You will be shown a preview of your message and the number of recipients for the newsletter. Click
on send mail in that screen to send your newsletter.

 If you specified product_notification , you should see the following screen.

If your newsletter is general enough to encompass all products, click Global. If your newsletter is
meant for users who have signed up for specific products only, you need to choose the relevant
products from the Products list and move them to the Selected Products list by clicking on >>>.

Once you have completed your selections, click on Submit. You should see a screen saying how
many subscribers will receive the Product newsletter. Click on send in that screen to send your
newsletter.

9. You can check whether your newsletter is sent by looking for a green tick icon under the Sent column of the
Newsletter and Product Notification Manager screen.
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Viewing the Number of Newsletter Subscribers You Have

To view the number of newsletter subscribers you have, click on the Admin Home hyperlink near the top of the
Admin Console. Look at the Newsletter subscribers field under the Statistics table as shown in the following screen
shot.

 

Product Reviews

Product reviews increase the likelihood that customers will return to your site, either to write a review of the items
they bought or to see what other customers think of a product they want to buy. You also stand to benefit because
you can learn from customer preferences, thus adjusting your product offerings and directing your marketing efforts
more effectively.

Although product reviews are useful, they can be susceptible to abuse. For example, an unscrupulous competitor
could sign up for an account with your store and write bad reviews about your products or store. To overcome this
problem, Zen Cart allows you the option of moderating all reviews before they are posted on your site for everyone
to see. Furthermore, customers have to sign up for an account first before they are allowed to write any reviews.
There is no option to allow anonymous users to write reviews.

How Product Reviews Work

The way Product Reviews work is outlined below:

1. Customers select a product and proceed to the Product Info page as shown in the following screen shot. 

2. Customers clicks on “write a review” to proceed to a page where a review of the product can be written as
shown in the following screen shot. Zen Cart will prompt customers to log in if they have not done so.
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338 e-Start Your Web Store with Zen Cart

3. Customers choose a rating for the product by clicking on any of the radio buttons with stars displayed next to
them.

4. Reviews are entered into the text area on the screen. The minimum number of characters that customers
should type before Zen Cart allows a product review to be submitted is configured via the Product Review
Text field under Configuration > Minimum Values.

5. After the product review is completed, customers click on submit to send their reviews for the store owner to
moderate and approve. Note: Moderation is optional.

6. Once reviews are approved, they will appear in the Reviews side-box randomly.

Store owners can control the number of product reviews that are randomly displayed by editing the Random
Product Reviews For Box field in the Configuration > Maximum Values screen.

7. To see a list of all product reviews in your store, customers can click on the the product image or the
“Reviews [more]” hyperlink  at the top of the side-box. A list of sample reviews are shown in the following
screen shot.  
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Enabling Product Reviews

Product reviews are limited to selected product types only; they cannot be enabled on a per-product basis currently.
Before users can write product reviews, you need to enable it first.

To allow users to write reviews:

1. Click on Catalog > Product Types to access a list of product types in your store. 

2. Choose a product type you want users to be able to write reviews on and then click on edit layout. 

3. Make sure the Show Product Reviews Button field is enabled. 

4. Optionally, you can decide whether to display the number of reviews for a particular product (which appears
underneath the “write a review” button) by editing the Show Product Reviews Count field.

Moderating Product Reviews

It is a good idea to moderate reviews to check that the comments are genuine and legal. For example, you do not
want comments that praise your products but criticize other companies because you could end up with a legal case on
your hands.

Product reviews submitted by customers may be subjected to moderation by store owners. A store owner is then able
to edit the contents of a product review before approving it for display to all visitors.

Enable Moderation for Product Reviews

To enable a product review to be moderated:

1. Click on Configuration > Product Info  to access the Product Info screen. 

2. Make sure the Product Reviews Require Approval field is enabled. 

Receive Emails for Products Pending Reviews

If you would like to receive email alerts informing you of product reviews ready for moderation, click on
Configuration > E-Mail Options  and configure the following fields accordingly.

 Send Notice of Pending Reviews Emails To – Status
 Send Notice of Pending Reviews Emails To

This is a good idea if you want to save yourself the effort of constantly logging into your Admin Console to check for
product reviews to moderate and approve.

Moderate a Product Review

To moderate a review:

1. Click on Catalog > Reviews to access the Reviews screen as shown in the following screen shot.
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Alternatively, you can reach the same screen by clicking on the Admin Home hyperlink near the top of the
Admin Console, and then clicking on Reviews Pending Approval in the Statistics table. 

2. If you wish to view and edit the contents of a product review written by a customer, click on edit to bring up
the product review details page as shown in the following screen shot.

2.1.  Make any changes and preview your changes in another screen by clicking preview.

2.2.  Click on update in the new screen once you are satisfied with your changes. You should be redirected
back to the Reviews screen after the update completes.

3. To approve a product review, simply click the respective red button under the Status column to change its
color to green. 

Viewing Product Review Statistics

To view statistics for Product Reviews in your store, click on Admin Home on the navigation menu to reach your
Admin Console's home page. Look at the following fields under the Statistics table as shown in the screen shot
below.

 Reviews 
 Reviews Pending Approval
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Tell-a-Friend

This feature allows your customers to send emails to their acquaintances about a product in your store. The term
“Word-of-Mouth” is commonly used to describe this form of marketing activity. Research has shown that this form
of marketing is very powerful as people tend to respond better to recommendations by friends and relatives compared
to direct marketing messages from companies. 

Keep in mind that this feature can also be easily abused by email spammers and unscrupulous competitors.
Therefore, Zen Cart allows you to configure whether users should be logged in before they are allowed to  utilize this
feature. Furthermore, to allow you to weigh the pros and cons of enabling this feature, Zen Cart allows you to track
messages sent from your online store to see the usage patterns of your site visitors.

How Tell-a-Friend Works

The way Tell-a-Friend works is outlined below:

1. Customers select a product and proceed to the Product Info screen. 

2. Customers either click on the “tell a friend about us” button or the email icon in the “Tell a Friend” side-box
to proceed to another screen where they can enter the details of their recommendation. Depending on the
store owner's configuration, they might be prompted to log in first. If customers are already logged in, the
Your Name and Your Email  fields will be populated automatically. 

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


342 e-Start Your Web Store with Zen Cart

3. After filling in the rest of the details, customers click on send to submit their recommendations to Zen Cart.
Zen Cart then routes the recommendations to the respective email recipients of the recommending customers.

A sample Tell-a-Friend email that a customer's acquaintance received is shown in the following screen shot. 

Enabling Tell-a-Friend

Before users can make use of the Tell-a-Friend feature, you need to enable it.

To allow users to use the Tell-a-Friend feature:

1. Click on Catalog > Product Types to access the Product Types screen. 

2. Choose a product type you want users to be able to utilize the Tell-a-Friend feature, and click on edit layout.

3. Make sure that the Show Product Tell a Friend button field is enabled. 

To configure whether users should be logged in before using the Tell-a-Friend feature, click on  Configuration > E-
mail Options and set the Allow Guest To Tell A Friend field accordingly.
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Tracking Tell-a-Friend Email Messages

You may have noticed that the customer is warned that: “… all emails sent via this web site are logged and the
contents available to the store owner …” just before the customer clicks on the send button in the Tell-a-Friend
screen. In actual fact, the store owner has to actively enable certain options to track the messages.

There are two ways to track Tell-a-Friend email messages that are sent from your store.
 Enable email archiving
 Cc Tell-a-Friend emails

Enable Email Archiving

When email archiving is enabled, all emails (not just Tell-a-Friend emails) are stored in your database. This feature
does lead to more maintenance effort and costs because of the additional space and care required when dealing with
archived emails. 

To go through the different email messages and sift out the ones that are related to “Tell-a-Friend” can be technically
challenging as users need to be familiar with database languages like Structured Query Language (SQL) or a
particular database administrator tool. 

Nevertheless, you are still strongly encouraged to turn on this feature even if you are technically unsound. You can
always turn to experts to retrieve the required data if necessary. For example, if you receive complaints that your
store is sending out spam to users you are not familiar with, you can always turn over your database records to allow
experts to help you identify the offending users.

To enable email archiving:

1. Click on Configuration > E-mail Options to access the E-Mail Options screen. 

2. Make sure that the Email Archiving Active  field is enabled. 

Receive Copies of Tell-a-Friend Emails

Another way to track Tell-a-Friend emails would be to configure Zen Cart to send copies of such emails to you.
Usual patterns of malicious behavior can then be narrowed down quite efficiently. For example, if you have a lot of
emails originating from a single email address for all your Tell-a-Friend emails, you would have strong reason to
believe someone is using your store to send spam emails.

To ask Zen Cart to send copies of Tell-a-Friend emails to you:

1. Click on Configuration > E-mail Options to access your E-Mail Options screen.

2. Make sure that the following fields are enabled and configured properly.
 Send Copy of Tell a Friend Emails To – Status
 Send Copy of Tell a Friend Emails To
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Banners

Besides using banners as a form of advertising to generate income for your store, you can also make use of banners
to implement a simple affiliates program as part of a cross-promotion marketing campaign with another site. For
example, if you sell cars, you can exchange banners with a magazine that covers the car industry. In this way, both
sites stand to gain exposure to their products without using any money for advertising.

How Banners Work

The way Banners work is outlined below:

1. Store owners create different banners and position them at specific locations in their Store Fronts.

2. Site visitors click on any of the banners.

3. Zen Cart records each banner click and re-directs visitors to the sites associated with the respective banners.

4. Store owners check banner statistics generated by Zen Cart to determine the effectiveness of their banner
marketing campaign.

Banner Display Concepts

There are some important concepts you need to know before you can properly configure the display of banners in
your Store Front.

Firstly, each banner you create should belong to a banner group. By default, there are three types of banner groups,
namely:

 Sidebox-Banners
 Wide-Banners
 BannersAll

Banners belonging to the groups Sidebox-Banners and Wide-Banners are displayed dynamically. Only one banner in
the group will be displayed at any time. Each refresh of a web page will result in a different banner in the respective
group being shown. Banners belonging to the BannersAll group are displayed statically. All banners in this group
will be displayed at the same time and will not change regardless of any page refreshes.

Furthermore, banners designed for the Sidebox-Banners group should be small enough to fit into a side-box in your
Store Front. Banners designed for the Wide-Banners group can be larger as they are commonly placed across the
width of the screen. 

Secondly, you need to consider where you want to position a particular banner group in your Store Front. You have a
choice of placing them in selected side-boxes, page headers or page footers as shown in the following screen shot.
The names used to identify the different positions are also provided on the screen shot as a quick reference when you
configure your banners.
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After you are familiar with the banner display concept, you can start configuring how you want your banners to be
displayed. You can make use of Figure 21.1 as a guide when positioning your banners.

To enable the display of banners in side-boxes, turn on the respective side-boxes as follows:

1. Click on Tools > Layout Boxes Controller to access the Column Boxes screen.

2. Enable the respective fields accordingly: 
 sideboxes/banner_box.php
 sideboxes/banner_box2.php
 sideboxes/banner_box_all.php

To specify where your banners should be positioned:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. The locations where banners can appear in your store are controlled by the following fields.
 Banner Display Groups - Header Position 1 
 Banner Display Groups - Header Position 2
 Banner Display Groups - Header Position 3 
 Banner Display Groups - Footer Position 1 
 Banner Display Groups - Footer Position 2 
 Banner Display Groups - Footer Position 3 
 Banner Display Groups - Side Box banner_box 
 Banner Display Groups - Side Box banner_box2 
 Banner Display Group - Side Box banner_box_all 

3. To enable a banner group to be displayed in a certain position, select a desired field from the list in Step 2. A
side-panel should appear as shown in the following screen shot.

Figure   21.1  : Locations of different banners in the Store Front  

Header Position 3

Footer Position 3

banner_box_all

banner_box_2

Footer Position 2

Footer Position 1

Header Position 2

Header Position 1

banner_box
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346 e-Start Your Web Store with Zen Cart

 Read the instructions and enter the one or more of the banner group names below into the text box.
➔ Wide-Banners  
➔ Sidebox-Banners  
➔ BannersAll  

 Click on update to save your changes.

Creating a Banner

To create a banner:

1. Click on Tools > Banner Manager to access the Banner Manager screen. 

Make sure you do not overlook the statistics shown under the Displays/Clicks column. These statistics allow
you to measure the effectiveness of a banner advertisement by showing you how many clicks were recorded
for the number of times a banner is displayed.

2. To add a new banner, click new banner to bring up the banner manager details screen. To save space, only
the top half-of the screen is shown. 
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Read the instructions displayed prominently below the buttons (shown in the following screen shot) to
understand some of the rules governing the use of different fields in this screen.

3. Set the Banner Status field as Active  if you want your banner to be displayed. Disregard this field if you
have configured values for Scheduled At and Expires On as the banner status will be managed
automatically by Zen Cart once those fields are set. 

4. Set the Banner New Window field to Yes  if you want a new window to appear when a customer clicks on
the banner. The new window will display the site that is associated with this banner.

5. Set the Banner on SSL field to Yes  if you want your banner to be displayed correctly if your store's URL
switches from “http” to “https”. 

If this field is set to No, then on SSL pages, your banner will not appear. This is useful if your banner
references graphics or content external to your site and would throw security alerts on SSL pages. 

6. Enter a name for your banner in the Banner Title field. This name will be displayed in the Banner Manager
screen. 
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7. Choose a banner group that your banner should belong to in the Banner Group field.

8. The next part is a bit tricky, you have a choice of specifying whether you want a normal or HTML Text
banner. 

With normal banners, you just specify a banner image and a URL that users should be redirected to when
they click on the banner. With HTML Text banners, you can have banners using Flash, Java Applets, etc.
However, you will need to know HTML to properly configure this type of banners.

 To configure a normal banner:
➔ In the Banner URL field, enter the web address of the site to which users will be redirected when

they click on the banner. 
➔ Follow the on-screen instructions to specify the banner image in the Image field. 

 To configure an HTML Text banner:
➔ Enter your customized HTML code into the HTML Text  field. For example, you can enter <a

href="http://www.yahoo.com">Yahoo Site</a>  into this field to show a hyperlink which
will redirect users to Yahoo's site if they click on it.

9. If you have specified BannersAll  for the BannerGroup field previously, you can specify the sequence in
which your banner will be displayed among all the banners in the group by entering a value into the Sort
Order - banner_box_all field.

10. If you would like your banner to be displayed starting from a certain date, enter a value in the Scheduled At
field by choosing from the calendar that is displayed when clicking on the dark button next to the field.
Leave this field blank if the banner is to be displayed immediately. 

11. You have a choice of disabling your banner display either on a certain date or based on the number of times
that the banner has been displayed by entering suitable values into the relevant input box of the Expires On
field. Leave this field blank if your banner is to be displayed forever.

12. Click on insert to create your banner. You will be redirected to the Banner Manager screen once the banner
is created.

13. At the Banner Manager screen, make sure the Status button of the banner you just created is green or your
banner will not be displayed in the Store Front. 

Search Engine Optimization (SEO)

One of the most important things to do after getting your site online is to get it listed on search engines. By doing so,
you are able to drive a greater amount of traffic to your site and subsequently increase your sales. 

To get listed on a search engine you will need to submit the URL of your site and some personal details to the
relevant search engine. Submission rules vary among different search engines so you will need to do some research.
Since the rules on site submission to different search engines are updated constantly, we shall not show the steps here
as they are likely to become obsolete soon after this book is published. 

Once your application is approved, the search engine will send a little program called a “web-bot” , “robot” or
“spider” to crawl and index your site pages. The robot then sends back the relevant data it has obtained from your site
to the search engine and the algorithms in each search engine will decide how your site ranks when someone
performs a search in that particular search engine.
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Because robots are computer programs, they cannot “see” the pages like human beings. Instead, they can only see the
source code that is used to render your web page in web browsers. To help these robots understand your site and
content better, Zen Cart provides the following features to aid in their indexing work:

 Site Map
 Meta Tags

We shall use the term Search Engine Optimization (SEO) to describe the above features as they help make your site
easier to understand to robots. Most people use the term to describe the methods used to make a site appear on top of
page rankings instead. Getting on top of page rankings is a big deal for any online business because it increases the
exposure of the business to customers and hence drives greater traffic to the site compared to sites that do not rank as
high.

The two SEO methods described above are legal and widely-accepted by search engines as long as you do not abuse
them. Other SEO methods might be targeted more for specific search engines. Regardless of which SEO method you
use, do check that the method has not been outlawed by a search engine before using it. Search engines tend to
change their rules periodically to prevent anyone from using a specific method to get listed on top of page rankings.

Robots and Security

Session IDs are unique sequences of characters generated by web applications to keep track of users actions. Session
IDs generated by Zen Cart are preceded by a “zenid” character. An example of a session ID appearing in a store's
URL is shown below:

http://www.example.com/store/index.php?main_page=in dex&zenid= af40be3714c3b6e70c83e958c1f6e1f6

Session IDs appearing in search engine results can lead to some strange problems with your store. When multiple
users click on the search engine result hyperlink with your session ID embedded in the URL, they could potentially
see each others' carts and account details giving rise to security and privacy issues.

Besides the online risks of exposing your session IDs, you should also avoid exposing your store session IDs when
displaying your store's URL in magazines, email signatures or other advertising material.

To turn off session ID indexing by robots:

1. Click on Configuration > Sessions to access your Sessions screen.

2. Make sure the Prevent Spider Sessions field is set to True .
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Site Map

When users click on the Site Map hyperlink in the Information side-box in your Store Front, they will be redirected
to a page that shows the different products available in your store and how your store is organized. All this
information is automatically generated by Zen Cart, and is clearly useful to visitors who might otherwise get lost in
your store if you have a lot of content.

Besides being useful to humans, the site map is also beneficial for robots. This is because all the relevant pages in
your store are conveniently located in a single place which eases the robot's task of crawling and indexing your site.
Furthermore, robots are also able to derive useful relationships between the different products in your store as the
structure of your site makes it easier to understand for them. 

As a site map is automatically enabled and generated by Zen Cart, the only concern you may have with the site map
is the privacy issues it can raise when robots start crawling your site. To address this concern, you should make sure
that Zen Cart does not generate My Account hyperlinks in the site map so that robots do not have a chance of
crawling them. This is because My Account pages contain sensitive information that should only belong to individual
customers and not be indexed as part of your site's content. 

To turn off  the display of My Account links in a generated Site Map:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. Click on the Site Map - include My Account Links? field and concentrate on the side-panel.

Define Text
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3. Make sure the field is set to No before you click update to effect your changes.

To customize the look of your site map:

1. Click on Configuration > Define Page Status to access the Define Page Status screen.

2. Click on the Define Site Map Status field and concentrate on the right-panel.

3. Select your desired setting and click update to effect your changes.

To change the wordings of the template text in your site map, use the Template Override System to override the
<zc-home>/includes/ languages/engl ish/html_includes/define_site_map.php file.

Meta Tags

Meta tags are special HTML tags that communicate information to web browsers and robots. They are not meant for
human viewing and you can only see them when you view the HTML source code of a web page from within your
web browser. 

If you are using Mozilla Firefox, you can right-click on a web page and then click View Page Source on the pop-up
menu to see the HTML source code associated with that page. Similarly, if you are using Internet Explorer, you can
right-click on a web page and click View Source on the pop-up menu instead.

Any tag that contains the word “meta” is a meta tag; e.g. <meta name="keywords">. 

Generally, there are two types of meta tags. The first type of meta tags are meant for web browsers. The following
example meta tag tells your web browser what format and language the web page is encoded in so that your web
browser knows how to display it properly.
 
<meta http-equiv= "Content Type " content= "text/html; charset=iso_8859_1 " /> 

The other type of meta tags are meant for robots as they provide details of the contents in your store and help the
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352 e-Start Your Web Store with Zen Cart

robots index your store pages according to your input. These are the meta tags that we will concentrate on and talk
about for the rest of this chapter. The following example meta tag may be read by robots to understand the contents
of your store better.

<meta name= "keywords " content= "fruits, grocery, apples, oranges, grapes ">

Note that nowadays, the influence of meta tags on search engine results has been drastically reduced as other
parameters are used by search engines to index and rank web sites.

Information you define for meta tags can be divided into the following categories:
 General Information
 Category and Product Information

General Store Information

If you wish to have general information about your store appear in meta tags generated by Zen Cart, you will need to
edit the <zc-home>/includes/languages/english/meta_tags.php file. The following sample contents are
taken from the file.

// page title
define('TITLE', 'Zen Cart!');

// Site Tagline
define('SITE_TAGLINE', 'The Art of E-commerce');

// Custom Keywords
define('CUSTOM_KEYWORDS', 'ecommerce, open source, shop, online shopping');

// Review Page can have a lead in:
define('META_TAGS_REVIEW', 'Reviews: ');

// separators for meta tag definitions
// Define Primary Section Output
  define('PRIMARY_SECTION', ' : ');

// Define Secondary Section Output
  define('SECONDARY_SECTION', ' - ');

// Define Tertiary Section Output
  define('TERTIARY_SECTION', ', ');

The information contained in this file will be included in other meta tags in some other pages that appear in your
store. Remember to use the Template Override System if you want to make changes to the file.

Category and Product Information

To add category and product information to your meta tags, you will need to configure each individual category and
product separately.
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To create meta tags for a category:

1. Click on Catalog > Categories/Products to access your Categories/Products screen. 

2. Navigate to your desired category and click on the “biohazard” button; i.e. the button with black and white
quadrants. 

3. Enter the name of the web page for the Title  field. This name will be shown on the web browser title bar
when a customer goes to the category page by clicking on the category hyperlink in the Categories side-box.

4. Enter the keywords you want to associate with the category in the Keywords field. For example, if you
specify test, experiment  for this field, your meta tag will show up as <meta name="keywords"
content="test, experiment">. 

5. Enter the description you want to associate with the category in the Description field. For example, if you
specify testing purpose  for this field, your meta tag will show up as <meta name="description"
content="testing purpose">.

6. Click save to save your changes into the database.

To specify meta tags for a product:

1. Click on Catalog > Categories/Products to access your Categories/Products screen. 

2. Navigate to your desired product and click on the “biohazard” button; i.e. the button with 4 black and white
quadrants. 
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354 e-Start Your Web Store with Zen Cart

3. Click the relevant radio buttons under the Mark What the Product's Meta Tag Title Should Include table
heading to specify which piece of product information should appear in the title bar of a customer's web
browser when the customer reaches the Product Info page in your Store Front.

To change the default values for the radio buttons, click on Catalog > Product Types to access the Product
Types screen. Select a product type and click edit layout and then customize the following fields
accordingly.

 Show Metatags Title Default - Product Title
 Show Metatags Title Default - Product Name
 Show Metatags Title Default - Product Model
 Show Metatags Title Default - Product Price
 Show Metatags Title Default - Product Tagline

4. Enter the name of the web page for the Meta Tag Title field. Depending on the settings of the radio buttons,
this name might be shown on the web browser title bar together with other product information when a
customer goes to the Product Info page in your Store Front. Note that other general keywords might also
appear in the meta tag. Refer to “General Store Information” on page 352 for more information.

5. Enter the keywords you want to associate with the product in the Meta Tag Keywords field. For example, if
you specify test, experiment  for this field, your meta tag will show up as <meta name="keywords"
content="test, experiment">. Again other general keywords might also appear in the meta tag.

6. Enter the description you want to associate with the product in the Meta Tag Description field. For example,
if you specify testing purpose  for this field, your meta tag will show up as <meta name="description"
content="testing purpose">.

7. Click preview to proceed to the next screen which summarizes your product meta tag configuration.

8. Click update in that screen to confirm your changes.

Customizing Meta-Tag Appearances

To further configure meta tag appearances in the Product Info page of your Store Front:

1. Click on Configuration > Product Info  to access the Product Info screen.

2. Edit the following fields accordingly:
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 Meta Tags - Include Product Model in Title
 Meta Tags - Include Product Price in Title 
 Meta Tags Generated Description Maximum Length? 

Other Product Promotion Features

We shall now talk about some marketing features that are seldom noticed or used by store owners. Two of these
features (Also Purchased Products and Best Sellers) are automatically enabled in Zen Cart while the third (Featured
Products) needs to be configured.

Also Purchased Products

The Also Purchased Products feature is automatically available in Zen Cart. This feature is similar to a familiar
marketing technique called “Cross-Selling” which aims to sell other related products to a customer when the
customer is viewing a particular product. An example would be recommending nails when a customer is looking at a
hammer in your store.

The Also Purchased Products feature works like this: When a visitor views a product in the Product Info page,  Zen
Cart will analyze whether the currently viewed product has ever been ordered together with other products by other
customers. If the analysis is positive, those other products that were purchased by other customers will appear in the
“Customers who bought this product also purchased...” center-box at the bottom of the Product Info page. The
following screen shot gives you an idea of how things look.

Note that the recommended products appear randomly in the center-box. There is no way to specify which specific
products should be recommended based on the currently displayed product.

To change the appearance of the “Customers who bought this product also purchased...” center-box:

1. Click on Configuration > Product Info  to access the Product Info page.

2. Edit the Also Purchased Products Columns per Row field accordingly.

To specify how many eligible recommended products should be available before the center-box is shown:
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356 e-Start Your Web Store with Zen Cart

1. Click on Configuration > Minimum Values  to access the Minimum Values screen.

2. Edit the Also Purchased Products field accordingly. Hint: If you do not want the center-box to ever appear,
specify a very high value for this field.

To limit the maximum number of eligible products displayed in the center-box:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. Edit the Also Purchased Products field accordingly. 

Best Sellers

The Best Sellers feature displays a list of products that have made the most sales in your store. It takes advantage of
the curiosity factor in humans which wants to find out what and why others are buying. This is especially so if
customers are looking for goods that are “safe-bets” as gifts for loved ones.

If you do not see the Bestsellers side-box in your store, click on Tools > Layout Boxes Controller and then edit the
sideboxes/best_sellers.php field.

To set the minimum number of eligible best sellers before the Bestsellers side-box will be displayed:

1. Click on Configuration > Minimum Values  to access the Minimum Values screen.

2. Edit the Best Sellers field accordingly.

To set the maximum number of best sellers that should be displayed in the Bestsellers side-box:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. Edit the Best Sellers For Box field accordingly.

To configure other Bestsellers side-box settings:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. Edit the following fields accordingly.
 Bestsellers - Number Padding 
 Bestsellers - Truncate Product Names 
 Bestsellers - Truncate Product Names followed by ... 
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Featured Products

Featured Products allow you to showcase certain products distinctively across several areas of your store as shown in
the following screen shots.

There are many reasons why stores might want to put products in a designated “feature” area. For example, if a store
has the rights to sell a very limited edition of a branded game console, the store could market the console as a
featured product to build up interest and bring in pre-orders before the actual launch of the product. 

Take note of the following differences between Specials (discussed on page 229) and Featured Products:
 Specials always include a discount whereas Featured Products have the option of not having a discount. 
 Specials can also be positioned as Featured Products too.

To create a featured product:

1. Click on Catalog > Featured Products to access the Featured Products screen. 

2. Click on new product to access the Featured Products details screen. 

3. Choose a product from the Product field.

4. Optionally, choose a future date for the Available Date field by clicking on the dark button next to the field
to pop up a calendar, if you want the product to be placed on Featured on the future date. Leave the field
blank if you want the product to be placed on Featured immediately.

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


358 e-Start Your Web Store with Zen Cart

5. Optionally, choose a future date for the Expiry Date field by clicking on the dark button next to the field to
pop up a calendar, if you want the product to be removed from the Featured Product areas on that date. Leave
the field blank if you want the product to be placed on Featured forever.

6. Click insert to create the Featured Product. 

To view statistics for Featured Products in your store, click on the Admin Home hyperlink near the top of your
Admin Console. Look at the following fields under the Statistics table.

 Featured Products Expired
 Featured Products Active

Summary

As you have seen, Zen Cart provides a wide variety of techniques to help you achieve your marketing aims.
Experiment with those marketing features that interest you and assess their effectiveness by examining the relevant
statistics. With imagination and hard work, you should be able to tune your marketing strategies to generate profits
for your business. 
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Chapter 22 System Administration

Introduction

Proper system administration ensures that your online store stays secure and performs reasonably when users visit
your store. System administration may not be directly related to your business logic but it can affect the smooth
operation of your online store.

In this chapter, we shall:
 Examine general system administration tasks.
 Learn to properly back up files and database.
 Consider important security settings.
 Look at factors that contribute to site performance bottlenecks.
 Look at how you would upgrade your Zen Cart to a newer version.

General Tasks 

We shall now discuss some of the general system maintenance tasks that you may need to perform from time to time.

Changing Administrator Details

Zen Cart provides a simple interface for managing administrator accounts. All administrator accounts have full
access to the store so you should consider carefully before assigning an administrator account to another person.  

To add an administrator or change an administrator's details:

1. Click on Tools > Admin Settings to access the Admin Settings screen.

2. To reset an administrator's password:

2.1.  Click on reset pwd and concentrate on the side-panel.

359
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360 e-Start Your Web Store with Zen Cart

2.2.  Type in the new password you want to use in both the Password and Confirm Password fields. Note
that passwords in Zen Cart are case-sensitive and must exceed 5 characters in length by default.

2.3.  Click save to update your new administrator password.

3. To edit the details of an existing administrator:

3.1.  Click on edit and concentrate on the side-panel.

3.2.  Change the details of the administrator by typing in values for the fields Admins Name and Email. 
3.3.  Click save to update your administrator details.

4. If you would like to add another administrator, just click on insert to begin the process. All fields on the
corresponding side-panel are self-explanatory and will not be explained here. 

Checking Server Time

If your site is hosted on a remote server, it is important to know whether there is any difference between the server
time and your local time. Knowing this time difference allows you to better understand when payments are received
and also when orders are issued. All your orders and log files are recorded in server time. Therefore, you should
translate from server time to the local times of your customers when answering customer queries regarding their
orders or shipping dates. 

To check the time on your server:

1. Click on Tools > Server/Version Info to access the Server Information screen. A portion of that screen is
shown in the following screen shot.
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 Chapter 22   System Administration 361

2. The server time is found in the following two fields. 
 Server Date
 Database Date

If you notice a significant difference between the two fields, you should immediately alert your web hosting
provider and find out the reason.

Website Maintenance

There will be times when you need to close your online store for a short period of time. You could use this time to do
a stock take, do a Zen Cart version upgrade or simply to back up all your data. You can inform customers about an
impending service disruption by placing your site in maintenance mode.

When your store is placed in maintenance mode, customers can still reach your website. However, they will see a
message indicating that your store is undergoing maintenance and will not be able to perform any transactions. A
sample screen shot of what a customer may see for a store placed under maintenance mode is shown in the following
screen shot.

Although a web site can be placed in maintenance mode immediately, most web sites will inform customers a few
days or weeks ahead before doing so. This leaves a better impression on users because they will not begin to suspect
that you had to place your site under maintenance to handle an emergency (e.g. hackers). 

When configuring settings for web site maintenance, always specify the time values in server time instead of your
local computer time. Furthermore, try to set the time in GMT or another timezone format to cater to international
users.

To place your store in maintenance mode:
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362 e-Start Your Web Store with Zen Cart

1. Click on Configuration > Website Maintenance to access the Website Maintenance screen. 

2. To put your store in maintenance mode immediately, set the Down for Maintenance: ON/OFF field to
true .

3. If your store is already in maintenance mode; i.e. Down for Maintenance: ON/OFF is set to true .

3.1.  Set the Display when web master has enabled maintenance field to true  if you want to inform users
when your site was placed under maintenance. 

3.2.  Set the Display website maintenance period field to true  if you want to display the value specified
for the Website maintenance period field. Preferably, leave this option as false  because you do not
want to pressurize yourself and disappoint your customers if you cannot complete your maintenance on
time. 

3.3.  Enter a value for the Website maintenance period field to inform visitors how long you expect the site
to be down for maintenance.

3.4.  Set the Down For Maintenance (exclude this IP-Address) field with a list of IP addresses that will
still be able to access all the normal store functions like buying products and checking out. 
 This setting is good for cases where you have set up a store but would like to do further testing on

normal store functions before allowing access to real-world customers.
 The IP address of a store owner can be seen on the Admin Console's menu bar next to the date. You

can copy that IP address and paste it into this field if you intend to access your store normally when
your site is under maintenance and may require updating each time you go into maintenance mode.

3.5.  Modify the following fields accordingly to specify how your store should look when visitors reach your
site while it is under maintenance:

 Down for Maintenance: Hide Header
 Down for Maintenance: Hide Column Left
 Down for Maintenance: Hide Column Right
 Down for Maintenance: Hide Footer
 Down for Maintenance: Hide Prices

4. If your store is not in maintenance mode; i.e. Down for Maintenance: ON/OFF is set to false .

4.1.  Set the NOTICE PUBLIC Before going Down for Maintenance: ON/OFF field to true  if you want
the value in the Date and hours for notice before maintenance field to be displayed in your Store
Front. Note that if the Down for Maintenance: ON/OFF field has been set to true , the NOTICE
PUBLIC Before going Down for Maintenance: ON/OFF field will be ignored and no maintenance
notification will be displayed.
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 Chapter 22   System Administration 363

4.2.  Enter the desired time for the beginning of your website maintenance in the Date and hours for notice
before maintenance field. You store will not be placed in maintenance mode automatically when this
date is reached.

5. Leave the Down for Maintenance: filename field alone. This field specifies which program file in Zen Cart
should handle the programming logic behind the website maintenance module.

To enable EZ-Pages to be viewed by store owners accessing the store from IP addresses specified in the Down For
Maintenance (exclude this IP-Address) field of the Website Maintenance screen:

1. Click on Configuration > EZ-Pages Settings to access the EZ-Pages Settings screen.

2. Set your desired field to a value of 2.
 EZ-Pages Display Status – HeaderBar
 EZ-Pages Display Status – FooterBar
 EZ-Pages Display Status – Sidebox

Viewing Who's Online Information

Both site visitors and administrators are able to view information regarding other visitors who are currently accessing
an online store. However, a customer's view and an administrator's view of information pertaining to other visitors is
different.

The Customer's View

The Who's Online side-box allows a customer to see the total numbers of users currently browsing the same online
store. No detail on individual customers are provided. 

This feature is not very useful unless you have a community-driven site where users can reach out to each other in
real-time and communicate. To disable this side-box, click on Tools > Layout Boxes Controller and edit the
sideboxes/whos_online.php field under Box File Name accordingly.

The Administrator's View

Store owners can see more information relating to the customers visiting their store. They can use this information to
ascertain which pages are the most popular, where most of the customers come from, etc. This information can also
be used for system maintenance purposes. For example, you can check that you do not have any users before you
bring your site down for maintenance. 

To see information regarding who is currently online:

1. Click on Tools > Who’s Online to access the Who's Online screen. A list of users currently using your
system will be displayed.
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364 e-Start Your Web Store with Zen Cart

2. Click on the REFRESH LIST hyperlink to see the latest statistics. 

You can learn a lot of interesting stuff about your site visitors using this screen, so make sure you read through the
legend and other statistics in smaller print.

Backing Up Your Store's Data

Make sure you back up your data routinely. This point cannot be overstated enough because your business depends
on it. Imagine if your database gets corrupted for some reason, how are you going to deliver your goods to customers
who have already paid up? Your reputation is at stake and you may even end up in court to face legal proceedings.

Before performing your backup, make sure that there are no users online and your site has been placed under
maintenance mode. 

There are essentially two things you need to back up.
 File system.
 Database.

File System Back Up

If your site is hosted remotely, you can copy all the files you want to back up into your local machine via an FTP
program.

If you prefer to do a minimum back up, you just need to back up the following files:
 All the files you have changed. 
 All the images and modules you have uploaded 

If you are paranoid, you can perform a full backup by copying all files from the <zc-home>  directory of your
remote web host to your local computer.

Database Back Up

This is the most important backup because most of your system settings and all your customer, payment and order
data, etc, are stored here. If anything goes wrong or you feel that your database is corrupted, you can always recover
your database via a database backup file.

If your site is hosted remotely, you will most likely be supplied with phpMyAdmin to back up your database. If you
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 Chapter 22   System Administration 365

do not have phpMyAdmin installed, check with your web host on how you can back up your database.

To familiarize yourself with the database back up procedure, we shall use the phpMyAdmin that comes with XAMPP
to perform a back up of the online store on your local machine. Note that there might be slight interface differences
between the version of phpMyAdmin that comes with XAMPP and the one provided by your web hosting provider.

To back up your database using the phpMyAdmin that comes with XAMPP:

1. Access the phpMyAdmin web interface (http://www.example.com/phpmyadmin). 

2. Select the database which you used to set up Zen Cart during your installation from the drop-down list box
on the left-panel. 

3. You should see all the tables in your store's database listed on the right-panel of your screen. 

4. Click on the Export  tab near the top of the screen to go to the next screen where you can specify your details
on how to export data from your database. 

5. Click the Select All hyperlink under the Export  section to select all the tables in your store for export. Make
sure the radio button is set to SQL.
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366 e-Start Your Web Store with Zen Cart

6. Use the settings displayed in the following screen shot for the SQL options section on your screen. Only
check the Add DROP TABLE  option if you want to be able to use the backed-up data to override an
existing database!

7. Check the Save as file check-box and enter a filename in the File name template field. This will allow you
to save the backup as a normal text file. Click the Compression radio button of your choice. Note: Do not
check the remember template check-box. 

8. Click Go to begin the backup process. 

9. After the backup process completes, your browser will prompt you to save the backup file in your local
machine. 

To recover your database using the backup file:

1. Repeat Steps 1 – 3 above. 

2. Click on the SQL button on the top row of tabs and a screen will appear with details on how you can import
data into your database. 
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3. Choose the backup file you saved previously in Step 9 above by clicking the Browse button.

4. Click on the Go button next to the character set of the file drop-down list box to begin your database
recovery process. If errors occur during the recovery process, unzip the backup file on your local computer
and then repeat from Step 3 using the unzippped file. 

5. After your backup process completes, log in to your Admin Console and Store Front and run some test
transactions to make sure everything is recovered properly.

Addressing Security Concerns

Security is a big and intimidating topic in all IT-related systems and a whole book will be required to write about all
aspects of this topic. Therefore, to reduce the scope of security coverage, we will only be touching on issues specific
to your Zen Cart web site in this book

Before we begin, if you have a local copy of Zen Cart installed, you can open up  <zc-

home>/docs/important_site_security_recommendations.html in your web browser to run through a list
of things you can do to make your site more secure.

File Permissions

Misconfigured file permissions allow hackers to easily gain unauthorized access to your system. Therefore, you
should pay careful attention to the permissions you set for certain Zen Cart directories when your site is hosted on a
remote server.

Before we continue, make sure you understand how file permissions are specified for your operating system. For
example, Linux and Unix file permissions come in read, write and execute modes which is represented using three
numbers; i.e. chmod 777. Windows permissions, on the other hand, are less complicated and less powerful.

Because most web hosts use Linux-based or Unix-based servers, we shall use Unix-style permissions to explain how
file permissions should be set for certain directories in your Zen Cart directories. For files hosted on a remote server,
you can use a GUI-based FTP program to alter file permissions directly. For more details of FTP programs, refer to
Appendix A, “Utility Software”.

The following directories under <zc-home>  should be set to writable and readable  in Linux/Unix environments
after installation. After your store has been set up properly, their permissions should be tightened again.

 /cache 
 /pub  
 / images 
 / includes/ languages/engl ish/html_includes

 /admin/backups
 /admin/ images/graphs

All these files under <zc-home>  must be set to user-executable only (i.e. chmod 444 or 644 in Linux/Unix).
 / includes/configure.php

 /admin/ includes/configure.php

If your site is hosted on Windows or Mac, please check with your site administrator as to how you can achieve the
same effect as the preceding permission levels for the relevant files and directories.
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368 e-Start Your Web Store with Zen Cart

Secure Sockets Layer (SSL)

Secure Sockets Layer (SSL) ensures that the traffic between users’ browsers and your server is secure and not open
to sniffing by hackers. SSL capability is achieved by placing a digital certificate on your web server. 

Although many web hosts provide you with a shared certificate for free, it is recommended that you fork out some
money and get yourself a dedicated certificate instead. A dedicated certificate ensures that the certificate is uniquely
identified with your domain. With shared certificates, web browsers usually pop up a dialog box warning users that
the site they are dealing with is not who they claim to be. The latter scenario looks unprofessional and users might
decide to leave when they encounter the pop-up warning; thus abandoning their carts altogether.

Although you can configure SSL for your entire site, this is not advisable. SSL requires intensive computing
resources because of the encryption and decryption processes and thus slows down your site tremendously.

Instead, SSL is usually configured only for certain areas of your site where information confidentiality is of utmost
importance. Some areas on your site which will benefit from the use of SSL are:

 Customer login/sign-up page 
 Customer checkout page 
 Admin login page
 Admin catalog modification page

Configure SSL Support for Your Store

There are essentially two files in Zen Cart you need to edit for SSL support:

 <zc-home>/includes/configure.php 

➔ Changes to this file affects SSL access to your Store Front. Zen Cart will automatically redirect
customers to a secure checkout process via SSL. Customers will also be automatically redirected to a
SSL page during sign up or log in.

 <zc-home>/admin/ includes/configure.php 

➔ Changes to this file affects SSL access to your Admin Console. Zen Cart will automatically redirect the
store owner to an SSL page when a login to the Admin Console is performed.

Make sure you have a valid SSL certificate installed on your web host before proceeding to configure your site. Your
web host will be the one to install the certificate on the server. Once you have SSL configured properly, users who
access SSL-enabled pages on your site should see a “lock” icon appearing at the bottom of the their browser
windows as shown below.

If you cannot get SSL to work properly on your site, you will need to check with your web hosting provider.

Test Out SSL Configuration on the Store in Your Local Computer

Since XAMPP already comes with a certificate installed and you have created a sample domain

Browser:
Mozilla Firefox

Browser:
Internet Explorer
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(http://www.example.com/store) on your local computer, you can have some hands-on practice in configuring SSL
for the store in your local computer before you do it on your remote server.

To set up Zen Cart to automatically switch to SSL during a customer login or account checkout, edit the file
includes/configure.php and change the following lines accordingly.

  define('HTTP_SERVER', 'http://www.example.com');
  define('HTTPS_SERVER', 'https://www.example.com') ;

  define('ENABLE_SSL', 'true');

  define('DIR_WS_CATALOG', '/store/');
  define('DIR_WS_HTTPS_CATALOG', '/store/');

To set up Zen Cart to automatically switch to SSL for an administrator during log in and catalog manipulation, edit
the file admin/ includes/configure.php and change the following lines accordingly

  define('HTTP_SERVER', 'http://www.example.com');
  define('HTTPS_SERVER', 'https://www.example.com') ;
  define('HTTP_CATALOG_SERVER', 'http://www.example .com');
  define('HTTPS_CATALOG_SERVER', 'https://www.examp le.com');

  define('ENABLE_SSL_CATALOG', 'true');
  define('ENABLE_SSL_ADMIN', 'true');

  define('DIR_WS_ADMIN', '/store/admin/');
  define('DIR_WS_CATALOG', '/store/');
  define('DIR_WS_HTTPS_ADMIN', '/store/admin/');
  define('DIR_WS_HTTPS_CATALOG', '/store/');

Perform the following checks to verify that SSL has been configured properly for your store.

1. To check that admin login will automatically switch to SSL:
 Enter http://www.example.com/store/admin into your web browser URL location. Ignore any warnings

from your web browser if it complains that it does not recognize the SSL certificate or that it has expired.
You will automatically be redirected to a SSL-secured site with the following URL -
https://www.example.com/admin/store/login.php.

2. To check that customer login or sign-up will automatically switch to SSL:
 Go to your Store Front and click on the Login hyperlink. You will automatically be redirected to a

secure page to enter your login credentials. After you have logged in, you will be redirected back to a
non-secure page.

3. To check that customer checkout will automatically switch to SSL:
 Go to your Store Front and purchase a test product. Once you initiate a checkout, you will automatically

be redirected to a SSL page to complete the transaction.

Sessions

Sessions are your server’s way of keeping track of who you are. There are a number of ways your server can do this,
most notably using cookies. 

Zen Cart allows you to configure how sessions are controlled. The default settings are sufficient in most cases, so
unless you are a developer, you are unlikely to change any settings here. Nevertheless, it is always good to know
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370 e-Start Your Web Store with Zen Cart

there is such a feature in case you need to use it.

General Session Settings

Click on Configuration > Sessions to access the Sessions screen. 

The default values should work well for most servers. Do not make any changes here unless you are absolutely sure
you know their consequences. Most of these settings will only make sense to advanced users with web programming
knowledge, so do not worry too much if you are lost.

Admin Session Setting

There is an additional setting that controls how long a logged in administrator is allowed to remain inactive before
Zen Cart automatically logs out the administrator. The default value is 3600 seconds; i.e. 60 minutes. 

To change the duration of inactivity for a administrator in the Admin Console, click on Configuration > My Store
and set your desired value for the Admin Session Time Out in Seconds field.

Viewing Customer's Session History

Zen Cart provides a convenient view of your customer's session history in a Counter History table. This table can be
accessed by clicking on Admin Home in the navigation menu of your Admin Console.

The information displayed in the table shows you the statistics for each day - the unique number of session hits to
your site and the total session hits to your site. In layman terms, this means how many unique visitors came to your
site, and the total number of pages viewed by all visitors. For example, if a customer visits your store once that day
and moves around 5 pages before leaving, you will see a statistic of “1 – 5”. If another customer came that day and
viewed 10 pages, you will see a statistic of “2-15”. 
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Log Files

If your online store is hosted on a remote server, your web hosting provider will likely have log files configured to
record information about your online store. These server log files are an important source for troubleshooting your
application or identifying hacking attempts. 

Although these files can be a bit unwieldy to read and understand for non-technical people, you should still find out
from your web host where they are located and then download them periodically. If you encounter any problems with
your online store (fraud, hacking attempts, etc), you can then turn over these log files to experts for analysis.

The main server log files you should have access to are listed below:
 Apache web server log file.
 MySQL database log file.

Improving Site Performance

Performance issues are usually the most frustrating to resolve because complaints are usually based on perceived
experiences. For example, a customer can call you to say your online store is behaving slowly today compared to
yesterday. But your question will be how slow is the site? This is because you know that sometimes the server will be
slightly slower if there are too many users accessing it at the same time.  

We will restrict our performance discussions strictly to what you can achieve with Zen Cart instead of topics like
hardware upgrades, network selection, etc. This helps sharpen our focus and allows you to concentrate only on tasks
that are directly within your control.

Gathering Performance Statistics

Always be objective and gather useful statistics for your server before deciding whether to look into how to improve
your server performance. Indeed, such statistics will also be the reference point which you use to conclude whether
your performance tuning has yielded any measurable results.

Page Parse Time

For each page that is dynamically generated, Zen Cart is able to log the amount of time required to process that page.
The page parse time can either be displayed in real-time in your Store Front or be recorded in a separate log file on
your server which can be downloaded for off-line analysis.

To analyze your page processing performance:

1. Click on Configuration > Logging to access your Logging screen.

2. If you want to have a separate log file generated for off-line analysis, set the following fields.
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372 e-Start Your Web Store with Zen Cart

2.1.  Set the Store Page Parse Time field to true  to enable logging to a server file.

2.2.  Set the name of an existing file in the Log Destination field to store the page parse time data. For
example, if you are on Windows, you can set this value to D:\test.txt  for testing purposes.

2.3.  If you want to change the display format of the entries in the log file, you can enter the appropriate value
in the Log Date Format field. 

2.4.  If you are running PHP 4, you have the option of storing database queries in the log file by setting the
Store Database Queries field to true .  

The following screen shot of a sample off-line file that is generated by Zen Cart is shown to give you an idea
of how the contents of a log file might look like.

3. If you also want to have real-time logging statistics displayed in the Store Front, set the Display The Page
Parse Time to true .  A screen shot of how the page parse time will be displayed at the bottom of your Store
Front is shown below.

Remember to turn off page parsing after you feel you have have gathered enough data to help you troubleshoot your
performance problem. If page parsing is left enabled, it can also be a performance drain on your server since it
requires more processing for each page to load. 

User Load

User load refers to the number of page hits to your online store. This is usually the number of page views by your site
visitors but it can also include indexing activities by a search engine robot. For the purpose of our discussion, we
shall not discuss search engine indexing activities as they do not play a big part in the statistics related to user load.

When we spoke about customer session history on page 370, we came across the Counter History table. You can use
the statistic in that table to quickly identify the user load on your site for a particular day. If a sudden spike in user
load is detected, you should not be surprised if your site behaves slower than normal.

Another use for the Counter History table is to determine the average number of visitors to your site over a period of
time by performing a manual calculation. With this information, you can then decide what a reasonable response
time for your web site performance is. Thus, if your customer complains that a page is taking too long to load, you
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 Chapter 22   System Administration 373

can refer to your desired response time and provide an appropriate reply.

To identify the user load on your site over a period of time, you should refer to the Hit Counter statistic found under
the Statistics table in your Admin Home page. 

To reset the value in the Hit Counter field, click on Tools > Store Manager and edit the Update Counter field
accordingly before clicking reset.  Note that the Hit Counter Started field in the Statistics table will not be updated to
the latest date.

Checking Server Uptime

Server uptime shows how long your server has been running since the last system restart. If a system is restarted,
your Zen Cart customers may perceive a disruption in their shopping experience. 

Before we continue, note that some web hosts might not allow the server uptime information to be made available via
the Zen Cart Admin Console. In that case, you will have to check with your web host.

To enable Zen Cart to check how long your server has been running.

1. Click on Configuration > My Store to access the My Store screen. 

2. Make sure the Server Uptime field is enabled. 

To check how long your server has been up and running:

1. Click on Tools > Server/Version Info to access the Server Information screen.

2. The uptime is found in the Server Up Time field.

Check with your web host if you find that your server has been constantly restarted (i.e. uptime is always a few
days). This might explain why your site is performing slowly because they might just be performing upgrades to the
server while your store is still running.

Enabling GZip Compression

GZip compression enables the faster display of web page contents in a web browser. If GZip compression is enabled,
the server first compresses the contents of a web page before delivering to a customer's web page. When the page
reaches the customer's end, the web browser will automatically uncompress and display the contents to the customer. 

If GZip compression has been enabled, you will notice that your browser window goes blank for a while before the
actual page you requested is displayed.
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374 e-Start Your Web Store with Zen Cart

Note that some web hosting providers turn on PHP Output Buffering and GZip compression by default. In such
cases, you should not turn on GZip compression in Zen Cart as you will be recompressing already-compressed
content, thus slowing things down rather than gaining speed.

You can ask your web hosting provider whether GZip compression is on by default in their PHP configuration; or
you can click on Tools > Server/Version Info and check the value for the output_buffering  field. If GZip
compression is on, the value of the output_buffering  field will show as either On or 1.

To turn on GZip compression in Zen Cart:

1. Click on Configuration > GZip Compression to access the GZip Compression screen. 

2. Set the Enable GZip Compression field to 1.

Although this feature can minimize your CPU and bandwidth loads tremendously, some older browsers do not
support it. Use your own discretion to decide whether you want to enable this feature.

Optimizing Image Sizes

Image size is usually the main cause of why web pages load slowly and it is also the main consumer of bandwidth on
your site. Therefore, you should always optimize your images by reducing their file sizes if you find your site is
loading slowly.

As a general guideline, you can reduce the size of your product images to 30 kilobytes each. Icon images are usually
small enough in size so you can ignore them when optimizing your images. For other images, you will need to decide
for yourself as you need to balance the need for visual clarity and appeal against speed.

For store owners, the file size limit for images they upload is indicated by the upload_max_filesize field under Tools
> Server Info. If an image exceeding this limit is uploaded, the file will not be uploaded and no warning messages
will be displayed. 

Reducing Database Reads

One of the most common and effective ways to improve your site performance is to reduce the number of database
read operations. One of the biggest culprits of excessive database reads is the category count that you see next to
your catalog entries in your Categories side-box. 

To remove the category count from your catalog:

1. Click on Configuration > My Store to access your My Store screen. 

2. Make sure you set Show Category Counts to false . 

As most side-boxes and feature listings may also involve a lot of database reads, try to turn off all those that are not
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essential to your customers; manufacturer's side-box, who's online, etc.
   

Optimizing Your Store's Database

Another technique to improve database performance is to delete unwanted records that have been deleted by the Zen
Cart program but are still present in the database. This action should be performed periodically and preferably at a
time when your store does not have many customers as it will impact the database performance during that time.

To optimize your database:

1. Click on Tools > Store Manager to access your Store Manager screen.

2. Go to the bottom of the screen and you will see a section similar to the following screen shot.

3. Click on confirm  to begin optimizing your database.

4. After the cleanup is completed, a message indicating how many database tables were affected will be
displayed.

Upgrading Your Zen Cart Installation

From time to time, you will have to perform upgrades to your Zen Cart installation. This could be because you want
to utilize features in a more recent version or you need to upgrade to higher versions to patch security loopholes.

Checking Your Zen Cart Version

To check for available updates to your Zen Cart store, click on Configuration > My Store and enable the Show if
version update available field. To check whether you are running the latest version of Zen Cart, click on the Check
for Updates button at the top-right corner of your Admin Console as shown in the following screen shot. 

Obtaining the Latest Upgrade Instructions

Whenever a new version of Zen Cart is available, an announcement will be posted in Zen Cart's forum. Details on
how to perform an upgrade are also posted there. As upgrade instructions may vary from version to version, we shall
not cover them here. 
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376 e-Start Your Web Store with Zen Cart

Summary

After completing this chapter, you should be able to identify areas that makes your online store perform better and
more securely. You have also seen how to perform proper backups of your important data and guidelines to
upgrading your Zen Cart installation. Although the techniques here are not directly related to your business
objectives, do not ignore them as they play an important part in the smooth operation of your online store.
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Appendix A Utility Software

Introduction

Besides the standard web browser (Internet Explorer, Mozilla Firefox, etc), email clients (Microsoft Outlook, Mozilla
Thunderbird, etc) and file compression tools (WinZip, WinRAR, etc), you will need additional utility software to
customize Zen Cart properly.

Because similar programs are easily available for the Unix/Linux platforms, we will only highlight those available
for the Windows platform. You can find more of such programs by running a search at http://www.download.com.

Each software category will highlight the desirable features that should exist in a program before recommending a
free-ware version and a share-ware version that supports those features. Which one you decide to use will depend
purely on your personal preference.

Text Editors

To customize any Zen Cart installation properly, you will need to edit some of the text files (HTML, CSS and PHP
files, etc). Do not use word processors (e.g. Microsoft Word) to edit the text files as they will add invisible characters
to those files. These invisible characters can cause problems either for Zen Cart or for web browsers.

Before you settle on a text editor, make sure it has the following features:

 Supports syntax highlighting for HTML, CSS, Javascript and PHP. 
➔ Helps you to code and debug faster by visually separating the different elements of the file. For example,

such a text editor might highlight PHP code in blue and HTML code in red.

 Automatic error highlighting for HTML, CSS, Javascript and PHP.
➔ Helps you catch errors in your programs while you are writing your code before these errors are detected

when you run your program in Zen Cart.  For example, if you fail to specify a closing tag for your
HTML code, the editor uses a red underline to highlight the offending HTML tag.

Crimson Editor

Web Address: http://www.crimsoneditor.com/

This is a simple and free program with a built-in spell checker. 

EditPlus

Web Address: http://www.editplus.com/

This is a very powerful program that even boasts a built-in web browser. You can download it for a free trial of 30
days before deciding whether to buy it.
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380 e-Start Your Web Store with Zen Cart

FTP Software

To transfer files between a remote server and your local computer, you will need to use an FTP client software.
Although the standard FTP command line commands are available for both the Windows and Unix/Linux platforms,
it is advisable to look for one that has an intuitive Graphical User Interface (GUI). 

Before settling on an FTP client program, make sure it has the following features:

 Ability to transfer many files reliably. 
➔ Some FTP clients are known to corrupt files if too many files are transferred at one go to the server. Do

some research on your choice of FTP program to avoid this problem.

 Automatically switch between text and binary modes when transferring multiple files.
➔ To prevent corruption of files, the FTP protocol requires binary files (images, compressed archives, etc)

to be transferred in binary mode and text-based files (HTML, CSS, PHP, etc) to be transferred in text
mode.

 Ability to change file permissions directly from within the GUI.
➔ If your FTP client can change permissions directly, it will save you the trouble of having to log in to your

server and manually changing the file permissions. A screen shot is provided below to give you an idea
how file permissions can be changed directly from within an FTP program. The program featured in the
screen shot is FileZilla.

FileZilla

Web Address: http://filezilla.sourceforge.net/

This is the same software that is used by XAMPP to run as an FTP server. You can also use it as an FTP
client. If you are not confused by having two versions of FileZilla on your machine (one running as a server
and the other as a client), you can go ahead and install this free program. 

Right-click on any file or 
folder to open a context 
menu. Then choose “File 
Attributes” to open the 
above dialog box.

File Permissions
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Appendix A Utility Software 381

WS_FTP Home 2007

Web Address: http://www.ipswitch.com/

This program has a long history and is very popular. It has a wide user base and the program is very stable. You can
download it for a free trial of 30 days before deciding whether to buy it.

An online tutorial on how to use the program is available at
http://www.ipswitch.com/support/ws_ftp/tutorials/tours/index.asp.

File Comparison Software

File comparison software allows you to compare differences between two or more files visually. It is an
indispensable tool when upgrading Zen Cart as it is used to determine which files have changed between different
versions and therefore need to be updated. It is also used commonly in program debugging to understand changes
between different versions of a software.

WinMerge

Web Address: http://winmerge.sourceforge.net/

This free program has the ability to compare more than two files at once. File differences are highlighted using
different colors. It also has the ability to compare entire folder/subfolder structures via simple drag-and-drop.

Beyond Compare

Web Address: http://www.scootersoftware.com/

This program has the ability to compare directories in addition to comparing files. It supports many other advanced
features so you will need to spend more time learning how to use it. You can download it for a free trial of 30 days
before deciding whether to buy it.
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Appendix B Setting Up Shop on the

Internet

Introduction

Once you are familiar with running Zen Cart on your local computer, you can begin to set up your store on the web.
To get your store to run on the Internet, you will need to perform the following steps:

 Choose a domain name. 
 Register the domain name.
 Choose a web hosting provider.
 Install Zen Cart on the remote machine.

To give you a better picture of why you need to perform the above steps, refer to the following diagram which
illustrates the series of events which takes place when users type your store's URL into their web browsers. 

Once you understand the above diagram, you will appreciate the steps that are required for your store to be hosted on
the Internet.

The first thing you need to need to do is to come up with a domain name for your website (e.g. wildsales.com). This
domain name will be used by users to access your online store. Because domain names are unique across the Internet,
you will need to register it to prevent other people from using the same domain name. 

The second thing you need to do is to find a web hosting provider that will provide you the infrastructure (hardware,
network, etc) and software (Apache, PHP, etc) necessary for you to run a Zen Cart store online. Your hosting
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384 e-Start Your Web Store with Zen Cart

provider will also let you know what the IP address (e.g. 191.0.34.43) of the machine hosting your website is.

Finally, you will need to make the association between your domain name and IP address known to one or more
DNS servers across the Internet. 

The above steps are just a logical view of how things are done. For practical purposes, you will usually just choose a
domain name and sign up for a hosting plan with a web hosting provider. The web hosting provider will then perform
all the necessary steps to get your site hosted on the Internet.

Choosing a Domain Name

Your first task before setting up shop on the Internet is to choose a domain name for your online store. For example,
if you choose “www.pets-r-us.com” as the URL for your store, the domain name will be “pets-r-us.com”. 

When choosing a domain name, look out for the following criteria:

 For stores engaged in commercial activities, try to choose a domain name which ends with “.com” or “ .biz”.
Other top-level domains (TLDs) such as “.net”, “ .org”, “. info”, etc are also available.

 Avoid domain names which end with a country code. For example, “.com.sg”, “ .biz.my”, etc, unless your
business activities are limited to a specific locale (e.g. pizza delivery business). The purpose of using the
Internet to conduct business is to gain maximum exposure for your business and to serve a large pool of
customers regardless of geography.

 Choose a domain name that is short and easy to remember. Most people have problems remembering long
names, let alone typing them out error-free. 

 Avoid the use of numbers in your domain name to minimize problems with users typing the URL incorrectly.
For example, if you tell customers your web address is “www.numberonecakes.com”. They may accidentally
type “www.number1cakes.com”into their web browser instead.

 Use words with their proper English spelling when coming up with your domain name to minimize human
errors when typing your URL into a web browser. For example, using “kar-tiuns.com” instead of “car-
tunes.com”. 

Registering a Domain Name

After you have found an available domain name, you should have it registered to prevent other people from laying
claim to it. There are two ways you can go about doing this:

 Register your domain name yourself.
 Register your domain name through a web hosting provider when you sign up for a hosting plan with them. 

Usually, a small fee will need to be paid to secure your rights to a domain name for a period of time (e.g. one year).
Thereafter, it will need to be renewed annually. Therefore, practice due diligence to check that your domain name
never expires by paying your fees on time. You do not want to lose all the hard work you have done in building up a
brand name for your online store only to lose it to someone else just because your domain name needs to be changed!
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Appendix B Setting Up Shop on the Internet 385

If you choose to register your domain name yourself, you can go to http://www.godaddy.com. There are many other
companies who can do the same job, so you might want to try running a search on your favorite search engine. 

Most web hosting providers can also provide domain name registration on your behalf. However, you need to be
careful when dealing with them. Some unscrupulous web hosting providers will register your domain name under
their company name instead of your name. If you decide to migrate your online store to another web hosting provider
later, they will demand a huge fee from you if you want to use back the same domain name they registered on your
behalf. Therefore, it is best to sign up with reputable and well-established web hosting providers and not those which
simply offer the cheapest prices.

Choosing a Web Hosting Provider

A web hosting provider provides the infrastructure that determines whether your online business runs smoothly and
reliably. An online store that is constantly inaccessible or performs sluggishly will hurt your image and your sales.
Therefore, do as much research as possible when deciding on a suitable web hosting provider. 

Some things you will need to look out for when evaluating a web hosting provider are summarized in the following
table.

Table A-1: Criteria for evaluating web hosting providers   (continued)

Criteria Explanation

Operating System and
Software

Try to pick a host that offers a Unix/Linux-based web hosting plan. This is because
Apache has a long history of working with Unix/Linux rather than Windows-based
operating systems and is consequently more stable on Unix/Linux.

Also make sure that the web hosting provider supports PHP and MySQL versions
that are compatible with Zen Cart.

Email Because you are running an online store, you need to make sure that your web
hosting provider allows you to have email accounts setup with them. These email
accounts must be for both inbound and outbound usage.

Price Price should never be the deciding factor when choosing a web hosting provider.
The market is very competitive for web hosting and most hosting plans vary by a
few dollars. Ultimately, what matters more to an online store is speed and
reliability. 

Technical Support Provides different means (e.g. by phone, by email or online only) to reach the web
hosting provider when you face problems with your account or setup. Most web
hosting providers will advertise how good their support is. Do not take their word
for it. Try to find out more information about their claims from online forums or
people you know to determine whether they are really performing up to task and the
level of support they actually provide. 

A poor supporting staff or system can cripple your online business for long periods
if they cannot quickly and reliably solve your problems. 
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386 e-Start Your Web Store with Zen Cart

Table A-1: Criteria for evaluating web hosting providers   (continued)

Criteria Explanation

Uptime Refers to the time that your site will remain accessible. No web hosting provider
can guarantee your site will be up 100% of the time but most will likely quote a
figure of 99.5% or more.

Bandwidth Refers to the amount of data (in bytes) that is transferred from your site to visitors.
If your store sells digital goods for download, you will need to sign up for a plan
which permits a higher bandwidth.

Some sites state that they offer unlimited bandwidth, remember to read the fine
print. Ultimately, web hosting providers need to pay for bandwidth and they will
not allow you to constantly exceed that bandwidth at their expense.

Disk Space Refers to the amount of storage space allocated to your site. Make sure there is
enough space to include an entire Zen Cart installation including any images or files
you are likely to upload.

Again, be wary of sites that offer unlimited disk space for the same reason as they
offer unlimited bandwidth.

Web-Based Control
Panel

This feature gives you the convenience and power of managing certain aspects of
your web account from the comfort of your desk without having to go through
technical support every time. You will be able to view server logs, create user
accounts, create email and FTP accounts, etc. Common control panels you might
encounter include CPanel, Plesk and Ensim.

SSL Installation No proper online store is complete without a SSL certificate to encrypt sensitive
parts of the store's website. Make sure your host has the ability to provide a SSL
certificate to meet your business requirements. 

To make your store appear more professional and legitimate to your users, pay for a
dedicated SSL certificate instead of using a shared SSL certificate. Also make sure
that the SSL certificate you purchase offers at least 128-bit of encryption.

A Recommended Solution – Zen Cart Certified Hosting Providers

If you have trouble deciding on a suitable web hosting provider for your online store, there is good news. Just click
the hosting hyperlink at the top of Zen Cart's web site to see a list of Zen Cart certified web hosting providers .

These web hosting providers have met the rigorous requirements of the Zen Cart team for hosting Zen Cart sites so
you can be sure about their work quality. They are very experienced and knowledgeable in the workings of Zen Cart
and will thus be able to provide good technical support if you encounter problems with your store configuration.
They even offer free installation of Zen Cart on your site.

It is highly recommended that you sign up with one of them if you are just starting a new Zen Cart store. The latest
list of Zen Cart certified web hosting providers can be found at http://www.zen-cart.com/partners/certified_hosts. Go
through their plans and send them an email if you have any questions regarding their hosting packages.
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Appendix B Setting Up Shop on the Internet 387

Migrating Your Local Zen Cart Store to a Remote Server

You might be tempted to migrate your local Zen Cart store setup (catalog, images, settings, etc) to your remote server
once it is set up. This is definitely possible but will require a lot of work. Furthermore, there are several factors which
will affect how your migration should be carried out. For an up-to-date reference on how to do this, take a look at
http://tutorials.zen-cart.com/index.php?article=99.
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Appendix C Test Account

Information

Introduction

When running your Zen Cart store, you will need to create several email and store accounts both for the store owner
and the test customers. This section consolidates all such account information used in this book to help you avoid the
confusion of looking up which account should be used for testing and also as a precaution against forgetting any
login passwords.

The information contained here assumes you are running Zen Cart on your local machine. 

Account Information

Email Accounts

These accounts allow you to read emails sent from Zen Cart to you (store owner) or test customers. They can also be
used to simulate customers sending emails among themselves. For example, when a customer sends a gift certificate
to another customer.

Table C-1: Email account credentials for store owner, administrator and test customers

Username Personal Name Mail Password Purpose

storekeeper Claud Blanc password Store Owner Email Account.

webmaster Store Administrator password Store Administrator Email Account

alan Alan Smith password Customer Test Account

christine Christine Summers password Customer Test Account

jacques Jacques Pires password Customer Test Account

nicole Nicole Bellamont password Customer Test Account

389
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390 e-Start Your Web Store with Zen Cart

Zen Cart Administrator Account

This is the login account to the Admin Console for the store owner (i.e. you). Note that you can configure this
administrator account to be accessed via SSL only. In that case, change “http” to “https” in your URL.

Table C-2: Administrator login account to Admin Console

Admin Console URL Username Password Email

http://www.example.com/store/admin/login.php admin password webmaster@example.com

Zen Cart Customer Test Accounts

These are the login accounts to your Store Front for your test customers. To reduce the strain of typing and
remembering so many accounts, we shall use the same usernames as those you set up in your test email accounts. 

However, you need to be clear about the differences between these two account types. The test email accounts are for
you to simulate customers logging into their email servers to read emails sent to them from your store. The Zen Cart
test customer account is for you to simulate customers interacting with your online store.

Test customers should preferably be from different countries so that you can test the different shipping, payment and
taxation options available in your store.

Table C-3: Customer login accounts to Store Front with selected personal particulars

Customer UserID Password Gender Country ( Choice is up to you )

alan@example.com abcdef Male United States

christine@example.com abcdef Female United States

jacques@example.com abcdef Male France

nicole@example.com abcdef Female France

Database Account

This information is useful when you need to access your database using phpMyAdmin. It is extracted from the file
<zc-home>/admin/ includes/configure.php.

Table C-4: Zen Cart database login account with selected database settings

Database Name Prefix UserID Password

zencart zen_ root <empty field>
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Admin console............................................................63
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free test product with free shipping....................66
normal test product...........................................65

Administration, see System administration................359

Administrative rights.......................................................
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Administrator..................................................................
changing details...........................................359, 360
Zen Cart Administrator account............................390

Also Purchased products..........................................355

Apache Web Server........................................................
configuring.............................................................37
installation requirements...................................29, 30

applying..........................................................................
Bug fixes................................................................52
customer group discounts.............................235-237

Archiving........................................................................
email.....................................................................78

Attribute flags.................................................................
understanding...............................................183-185

Attribute images.............................................................
configuring....................................................185-187

Attribute pricing..............................................................
configuring.....................................187-189, 191, 193

Audience-select count display.....................................79

Auto-scaling...................................................................
providing companion medium and large images
without using................................................205, 206

B

Backups...................................................................364
database back up.................................................364
file system back up..............................................364

Banners....................................................................344
creating........................................................346, 348
display of banner boxes................................344, 345
layout elements....................................................247

use of..................................................................344

Best Sellers..............................................................356

Beyond Compare......................................................381

Breadcrumbs..................................................................
layout elements....................................................246

C

Cash on delivery.............................................................
cash on delivery fee.....................................238, 239
payment options...........................................140, 141

Categories......................................................................
adding..........................................................158, 159
categories display................................................156

categories displayed as images on main page. 157
categories side-box.........................................156
categories tab menu........................................157

listing products in multiple....................................219
advanced product linking..........................220-222
master category..............................................219
simple product linking......................................220

moving.................................................................160
restricting discount coupon usage........................315
restricting to certain product types........................160

Category product listings...................................251, 252

Check.............................................................................
payment options............................................141-143

Columns.........................................................................
layout elements....................................................245

Contact us......................................................................
email dropdown list................................................79
show store name and address................................79
store contact information..................................92, 93

Core modules.................................................................
order total modules, and.......................................227

Countries........................................................................
address format.......................................................86
location, and..........................................................84

address format.............................................84-86
ISO Country Codes...........................................85

Credit Card.....................................................................
payment options............................................145-148

Crimson Editor..........................................................379

Currency........................................................................
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adding new......................................................98, 99
associating new with new language pack......282, 283
configuring displayed default currency..................100
convert for text emails............................................79
currencies screen.............................................97, 98
updating exchange rates in real-time......................99

currency conversion ratio..................................99

Current stock levels..................................................305

Custom web pages.........................................................
define pages.................................................259-261
EZ-Pages......................................................261-264

Customer authorization-based store function.............224

Customer details.............................................................
edit...............................................................292, 293

Customer login-based store function.........................223

Customer settings...........................................................
editing common.............................................289-292

Customer test account...................................62, 63, 390

Customers......................................................................
deleting................................................................295
determining how many customers.................295, 296
order statuses..............................................299, 300
sending emails to.........................................293, 294

Customers Screen....................................................292

Customization.................................................................
adjusting maximum and minimum values.............267
altering the shopping flow.....................................264

complying with local regulations......................265
delaying display of shopping cart.............265, 266
using split login/sign-up screen................266, 267

changing how your store looks.............................274
changing static text..................................275-277
modifying stylesheets..............................274, 275

characters with special meaning in HTML and PHP
............................................................................269

HTML Code.............................................269, 270
PHP Code.......................................................270

managing images centrally...................................267
supporting multiple languages..............................277

dynamic language preferences........................278
ISO language codes................................277, 278
language encoding..................................277, 278
language pack, adding.............................280-282
static language preferences.............................278
web browser language preferences.................278

third-party contributions........................................285

D

Database........................................................................
back up.........................................................364-367
creating your store's database................................39
database account.................................................390
optimizing............................................................375
reducing database reads..............................374, 375

Default currency.............................................................
configuring...................................................100, 101

Define Pages.....................................................259-261

Definition properties........................................................
product types.......................................................162

Discount coupons...........................................................
configure discount coupon module................311-313
creating.........................................................313-315
delivering to customers electronically...................316

email.......................................................316, 317
on account creation.................................317, 318

implementing customer referral scheme via..........318
customer referral scheme................................319
track customer referrals...........................319, 320
view report on.................................................321

restricting usage by category or product...............315
use of..................................................................311
viewing usage statistics........................................321

Discounts.......................................................................
choosing discount type.................................228, 229
customer group discounts.............................235-237
product quantity discounts.............................231-233
product sale..................................................233-235
product specials...........................................229, 230

DNS Server................................................................32
Verify email addresses through..............................78

Document product.............................................175, 176

Domain name.................................................................
choosing..............................................................384
registering....................................................384, 385

Downloadable products..................................................
checking and changing download statuses. . .216, 217
configuring...........................................................211

download attributes.........................................214
enabling download functionality...............212, 213
FTP files.........................................................213
specifying when downloads are available.214, 215
test product download..............................215, 216

managing centrally...............................................217
structuring download options........................210, 211

This PDF has been licensed for use to:                             
joey tanker <joeytanker@gmail.com>

Book available for purchase from http://www.cucumbermedia.com

   
   

   
  jo

ey
 ta

nk
er

<jo
ey

ta
nk

er
@

gm
ail

.co
m

>

http://www.cucumbermedia.com


Duplicating products.................................................218

E

EditPlus....................................................................379

Email..............................................................................
admin format..........................................................78
allow guest to tell a friend.......................................79
audience-select count display................................79
contact us..............................................................79
convert currencies..................................................79
customizing email messages..................................79

changing text in email..................................81, 82
how email messages are formed.................80, 81

e-mail line feeds.....................................................77
email archiving.......................................................78
email friendly errors...............................................78
email options screen..............................................71
enabling email sending..........................................72
gift certificates...............................................330-332
low stock email notifications.................................308
mail server settings...........................................72-74
message recipients...........................................74-77
MIME HTML..........................................................78
sending to customers...................................293, 294
sent from known domain........................................78
store contact information........................................79
tell-a-friend email messages.................................343
test accounts.........................................................40

email accounts................................................389
verify email address...............................................78
"Contact Us" dropdown list.....................................79
"newsletter unsubscribe" link..................................79

Email client.....................................................................
configuring.................................................42, 44, 45

Exchange rates..............................................................
updating in real-time..............................................99

currency conversion ratio...........................99, 100

EZ-Pages..........................................................261-264

F

Featured products.............................................357, 358

Featured products listing....................................248-251

File comparison software..........................................381

File permissions.............................................................
security, and........................................................367

File system back up..................................................364

FileZilla.....................................................................380

Firewall...........................................................................
installation, and......................................................31

Footer............................................................................
layout components...............................................244

Free charge card............................................................
payment options............................................143-145

Free shipping.....................................................132-134

Free shipping options........................................135, 136

FTP files.........................................................................
downloadable products, and.................................213

FTP software....................................................380, 381

Future stock expected...............................................306

G

Gift certificates................................................................
approving......................................................328-330
configuring gift certificates module................326, 327
delivering to customers........................................330

email.......................................................330, 331
send on account creation.........................331, 332
track gift certificates sent.................................332

selling as products........................................327, 328
use of..................................................................322

gift certificate account balance.........................324
how customers receive....................................323
redemption..............................................323, 324
using gift certificates................................324, 325

Gnu General Public License........................................25

GZip Compression..........................................................
enabling.......................................................373, 374

H

Handling.........................................................................
HTML code..................................................269, 270

Hardware requirements...............................................29

Header...........................................................................
layout elements....................................................244

I

Images...........................................................................
managing centrally...............................................267
optimizing image sizes.........................................374
providing multiple images for a product.................203

adding additional images.................................205
adding pre-scaled images...............................206
providing companion medium and large images
without using auto-scaling........................205, 206
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understanding how additional images are
recognized..............................................204, 205

Installation......................................................................
installation setup, understanding............................31

DNS Servers.....................................................31
local setup........................................................32
remote setup.....................................................32

local domain, setting up.........................................36
Apache, configuring..........................................37
Mercury, configuring....................................38, 39

pre-installation requirements..................................29
administrative rights..........................................31
Apache Web Server..........................................30
firewall..............................................................31
hardware requirements.....................................29
Mercury Mail Server..........................................30
MySQL Database..............................................30
PHP..................................................................30
software requirements.......................................29
utility software...................................................31

XAMPP, a pre-packaged solution...........................32
installing......................................................33-36
obtaining XAMPP..............................................33

XAMPP, preparing for Zen Cart installation.............39
database, creating............................................39
test email accounts...........................................40

Zen Cart, installing.................................................45
applying bug fixes.............................................52
checking installation..........................................52
installation....................................................46-51
post-installation.................................................52
pre-installation.............................................45, 46

Invoice...........................................................................
generating from orders.........................................302
store contact information........................................93

ISO Country Codes.....................................................85

ISO Language Codes........................................277, 278

L

Language packs.............................................................
adding..........................................................280, 282
associate new currency with.........................282, 283
installing new................................................280-282
testing new...................................................283-285

Layout elements.............................................................
common...............................................................243

banners..........................................................247
breadcrumbs...................................................246
columns..........................................................245

common..........................................................247
footer..............................................................244
header............................................................244
side-boxes...............................................246, 247

product......................................................................
new, all and featured product listings...............248
product center-boxes................................252-255
product specials grid................................255, 256
search and category product listings........251, 252
upcoming products summary list.....................256

Layout properties............................................................
product types.......................................................163

Linefeeds.......................................................................
e-mail....................................................................77

Local Domain.................................................................
setting up.........................................................36, 37

Location.........................................................................
countries................................................................84

address format............................................85, 86
ISO Country Codes...........................................85

specifying store location...................................89, 90
use of location information................................83, 84
zone definitions......................................................88

adding.........................................................88, 89
purpose of.........................................................88

zones....................................................................86
adding.........................................................87, 88
purpose of.........................................................86

Log files....................................................................371

Low order fee....................................................237, 238

Low stock.......................................................................
email notification..................................................308

M

Mail server......................................................................
settings.............................................................72-74

Maintenance...................................................................
website.........................................................361-363

Managing customers......................................................
common customer settings............................289-292
deleting customers...............................................295
determining how many customers.................295, 296
individual customer settings.................................292

customers screen............................................292
edit customer details................................292, 293
sending emails to customers....................293, 294
view order history............................................295
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Manufacturers................................................................
creating for products.....................................164, 165

Marketing.......................................................................
also purchased products...............................355, 356
best sellers..........................................................356
featured products.........................................357, 358
gathering useful statistics.....................................309

products purchased.........................................309
products viewed..............................................309
total order values per customer.......................310

Master category........................................................219

Maximum and minimum values.......................................
adjusting..............................................................267

Media collection..............................................................
creating........................................................208, 209

Media type......................................................................
product sample, of........................................207, 208

Mercury Mail Server........................................................
configuring.......................................................38, 39
installation requirements........................................30

Message recipients.........................................................
email, and.........................................................74-77

MIME HTML...............................................................78

Moderation.....................................................................
product reviews, of.......................................339, 340

Money order...................................................................
payment options............................................141-143

Music products..................................................174, 175

Music samples................................................................
configuring product samples.................................207

assigning media collection to music product. . .209,
210
create media collection............................208, 209
media type..............................................207, 208

providing..............................................................207

MySQL Database...........................................................
installation requirements........................................30

N

Newsletters...............................................................333
creating........................................................335, 336
enable newsletter sign-up on account creation. . . .334,
335
use of...........................................................333, 334
viewing number of subscribers.............................337

O

One Time Charges.........................................................
product attributes, and.........................................189

One Time Factor.............................................................
product attributes, and..................................190, 191

Order confirmation screen...........................................93

Order confirmation screen...............................................
check/money order option......................................93

store contact information...................................93

Order history..................................................................
viewing................................................................295

Order IDs.......................................................................
resetting...............................................................303

Order totals...............................................................225
core modules.......................................................227
order total modules screen...................................226

examples........................................................226

Orders............................................................................
generating invoices from......................................302
generating packing slips from.......................302, 303
order statuses......................................................298

customizing.....................................................301
meanings, and................................................298
updating..................................................299, 300

orders screen...............................................297, 298
resetting order IDs...............................................303
viewing order statistics.........................................301

Orders screen...................................................297, 298

osCommerce..............................................................26

P

Packaging......................................................................
shipping and packaging details.....................119, 120

Packing Slip...................................................................
generating from orders.................................302, 303
store contact information........................................93

Page parse time................................................371, 372

Payment.........................................................................
adding payment options.......................................140

cash on delivery......................................140, 141
check.......................................................141-143
credit card................................................145-147
free charge card.......................................143-145
money order.............................................141-143

common payment information..............................138
common payment settings.......................139, 140
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payment modules screen................................139
default payment modules overview...............137, 138

Payment modules...........................................................
overview.......................................................137, 138

Payment modules screen..........................................139

Paypal............................................................................
meaning...............................................................148
set up in Zen Cart.........................................148, 150
setting up PayPal business account..............150, 151
test PayPal setup.................................................152

Per Item.........................................................................
shipping options...........................................124, 125

Per Unit..........................................................................
shipping options............................................125-127

PHP...............................................................................
handling PHP code..............................................270
installation requirements........................................30

Price Factor....................................................................
product attributes, and..................................190, 191

Product attributes...........................................................
adding.................................................................179

create option name..................................179-181
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